17:00:29 <colindixon> #startmeeting tsc
17:00:29 <odl_meetbot> Meeting started Thu Nov  3 17:00:29 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:29 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:35 <colindixon> #topic agenda bashing and roll call
17:00:37 <abhijitkumbhare> yes audio buttons greyed out
17:00:55 <colindixon> adetalhouet, abhijitkumbhare, phrobb, CaseyODL, do we have any idea what's up?
17:00:58 <rovarga> webex is screwed, the meeting nr is not accepted by the bridge on dial-in
17:01:00 <ChrisPriceAB> #info Chris Price
17:01:06 <rovarga> #info rovarga fro jmedved
17:01:12 <adetalhouet> #info adetalhouet
17:01:12 <abhijitkumbhare> #info abhijitkumbhare
17:01:20 <adetalhouet> yep, I can't connect to the audio
17:01:26 <dfarrell07> +1 to webex not working
17:01:35 <dfarrell07> #info Daniel Farrell
17:01:44 <abhijitkumbhare> will connect using the phone
17:01:53 <colindixon> #info colindixon
17:02:01 * dfarrell07 is trying to connect using phone, "meeting not valid or not started"
17:02:04 <edwarnicke> #info edwarnicke
17:02:06 <rovarga> I tried that, not working
17:02:11 * edwarnicke can't connect via audio
17:02:17 * edwarnicke does his best mime impression
17:02:21 * ChrisPriceAB subscribes to the school of thought - let's make colin type more for an hour
17:02:27 <adetalhouet> yep phone doesn't work either
17:02:28 <colindixon> :-)
17:02:30 <colindixon> we can do that
17:02:40 <colindixon> I can set up a phone bridge pretty quickly
17:02:46 <colindixon> but we won't get recording
17:02:50 <colindixon> I think that phrobb is in China
17:02:57 <colindixon> so, it's 1a
17:02:57 <rovarga> I can get a webex meeting, I guess
17:03:03 * edwarnicke Mime-type: humman/ed
17:03:27 * ChrisPriceAB facepalms
17:03:31 <dfarrell07> I don't think recording is a prio, any bridge is fine imho
17:03:43 <colindixon> Dial in: +1-408-333-7373
17:03:44 <colindixon> or find a local number here: https://join.brocade.com/dialin
17:03:45 <colindixon> Conference ID: 78981340
17:03:46 <colindixon> Optional Meeting URL: https://join.brocade.com/meet/cdixon/VV1KBYJZ
17:03:46 <colindixon> let's use that
17:04:12 <anipbu> Having trouble dialing in to webex call
17:04:17 <colindixon> chat isn't working on webex either
17:04:19 <colindixon> anipbu: everyone is
17:04:20 * adetalhouet agrees
17:04:21 <abhijitkumbhare> can CaseyODL reset the meeting?
17:04:21 <abhijitkumbhare> I mean can he reset the webex?
17:05:01 <adetalhouet> colindixon: I'm getting the leader hasn't join yet the meeting
17:05:34 <colindixon> adetalhouet: that shold be fixed now
17:05:37 <adetalhouet> it is
17:06:01 * dfarrell07 is called in to colindixon's call
17:06:14 <colindixon> I think CaseyODL and phrobb are not in the country
17:06:58 <skitt> ah I just got the audio on the webex
17:07:13 <colindixon> colin fixed the webex
17:07:19 <adetalhouet> yey
17:07:39 * dfarrell07 is now in the proper webex
17:07:58 <colindixon> the webex is now fixed
17:08:01 <rovarga> woo-hoo
17:08:06 <colindixon> #info colindixon
17:08:25 <LuisGomez> #info LuisGomez for anilvishnoi
17:08:47 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-10-27-17.00.html last week's meeting minutes
17:09:01 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=51634#Agenda the agenda for today
17:09:08 <colindixon> #link colindixon added a type field to the project facts template https://lists.opendaylight.org/pipermail/tsc/2016-November/006219.html
17:09:09 <colindixon> #info centinel merged their blocking patch for stable/boron
17:09:27 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:09:28 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
17:09:29 <colindixon> #action dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
17:09:30 <colindixon> #action phrobb to work on getting us better control of the events page to make his life less painful
17:09:31 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
17:09:41 <colindixon> #undo
17:09:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2903ad0>
17:09:43 <colindixon> #unod
17:09:46 <colindixon> #undo
17:09:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2903290>
17:10:02 <colindixon> #action phrobb to work on getting us better control of the events and downloads page to make his life less painful
17:10:15 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
17:12:20 * ChrisPriceAB wonders what it means for the project itself to not have an active committer?
17:12:44 <colindixon> #info colindixon says that if we can't find active committers for atrium, we will remove them from autorelease for now and carbon in the long run
17:12:46 <tykeal> we're already past Halloween, no zombies!
17:14:13 <colindixon> #info ChrisPriceAB asks if we have a previosu policy on how to deal with projects that have no active committers
17:15:52 <colindixon> #info anipbu says that in the past, we've sent kind reminders and eventually things have been pushed either in or out of the release
17:17:28 <colindixon> #info ChrisPriceAB asks about projects in general, colindixon says that projects can be unilaterally archived by the TSC after 18 months of inactivity
17:17:55 <colindixon> #info rovarga suggests that we provide a way to publicly flag projects without active committers as being at risk of being unilaterally archived
17:18:31 <rovarga> edwarnicke: +1
17:19:31 <colindixon> #info colindixon notes that this is related to the action item above about active projects
17:22:11 <colindixon> #info w.r.t. to sdninterfaceapp, the problem is that we have people who are interested in being committers, but there's no current committers to help
17:22:36 <rovarga> what is this 'outside world' concept?!
17:22:38 <colindixon> #action colindixon to send a mail about projects with no active committers and how to manage them
17:22:52 <colindixon> #topic updates
17:23:15 <colindixon> #topic events
17:23:20 <colindixon> #link https://www.opendaylight.org/global-events
17:23:41 <colindixon> #info ODL forum india on 11/16
17:23:53 <colindixon> #info OPNFV plugfest week of 12/5
17:24:12 <colindixon> #topic Boron
17:24:17 <colindixon> #chair anipbu
17:24:17 <odl_meetbot> Current chairs: anipbu colindixon
17:24:33 <anipbu> #info Boron SR1 Build 20161030 is ready to be presented to the TSC for approval. Blocking bugs have been resolved and test issues have been signed off as OKAY to release.
17:24:37 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR1/Status   <--- Status Page
17:24:44 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1058465710   <--- All projects with test issues have signed off as OKAY to release
17:25:13 <colindixon> #startvote shall the TSC release the 20161030 build of Boron-SR1? -1,0,+1
17:25:13 <odl_meetbot> Begin voting on: shall the TSC release the 20161030 build of Boron-SR1? Valid vote options are -1, 0, +1.
17:25:13 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:25:15 <adetalhouet> #vote +1
17:25:17 <dfarrell07> #vote +1
17:25:18 <colindixon> #vote +1
17:25:18 <ChrisPriceAB> #vote +1
17:25:20 <edwarnicke> #vote +1
17:25:21 <rovarga> #vote +1
17:25:26 <abhijitkumbhare> #vote +1
17:25:36 <colindixon> #endvote
17:25:36 <odl_meetbot> Voted on "shall the TSC release the 20161030 build of Boron-SR1?" Results are
17:25:36 <odl_meetbot> +1 (7): dfarrell07, rovarga, adetalhouet, ChrisPriceAB, edwarnicke, colindixon, abhijitkumbhare
17:25:37 <LuisGomez> #info +1
17:25:41 <tykeal> hehe
17:25:46 <LuisGomez> #vote +1
17:25:55 <colindixon> #agreed Boron-SR1 is released
17:26:14 <colindixon> #topic carbon
17:26:35 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-November/008666.html   <--- Carbon M1 Offset 2 Status is due on today 11/3
17:26:35 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-October/008457.html   <--- Bump SFC versions and remove incorrect parent versions
17:26:36 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/47001/   <--- Original patch merging in SFC
17:26:44 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:sfc0.5.0   <--- List of projects affected and relevant patches
17:27:31 <colindixon> #action cardinal, faas, and groupbasedpolicy need to merge their patches for the sfc version bump
17:28:47 <colindixon> #info rovarga notes that the old versions have expired from nexus so things are failing in autorelease
17:28:52 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:move-karaf-parent+status:open+NOT+project:controller   <--- Switch to use odlparent's karaf-parent.  blocking ODLPARENT ability to remove the controller karaf-parent artifact
17:29:00 * colindixon looks at edwarnicke to hunt people on GBP
17:30:36 <adetalhouet> make sense to me
17:31:08 <tykeal> doesn't grant +2 rights, only the final "submit" which is what we block
17:31:18 <ChrisPriceAB> +1 ^^
17:31:44 <adetalhouet> Right, I agree with Ed's point.
17:31:45 <rovarga> +1 as long as long it's not grating the +2 powers ;-)
17:31:51 <zxiiro> actually we also grant +2 CR and +1 verify for the release team so that they can merge version bump patches
17:32:08 <zxiiro> so there is that to consider
17:32:08 <colindixon> #info anipbu notes that it's frustrating how hard it is to get patches merged even when projects just need to click +2 and submit for pre-prepared patches
17:32:09 <anipbu> rovarga: I would need +2 abilities
17:32:09 <tykeal> hmm... you're correct zxiiro forgot about that
17:32:09 <rovarga> +2 specifically for version bumps only
17:32:39 <rovarga> and those need to be communicated before major release, there was a versioning problem with yangtools going from 0.8 to 1.0
17:32:48 <tykeal> rovarga: you're correct that the +2 was granted specifically for version bumps
17:33:04 <zxiiro> yes the understanding is that +2 CR and +1 Verified is used only for version bump patches specifically. All other patches the Release Team needs to be aware that they can only click the submit button if a committer has already +2'd the patch
17:33:07 <colindixon> #info colindixon brings up the the topic that it seems to make sense that the release manager should be able to click submit for projects while branches are intentionally blocked during releases
17:33:20 <colindixon> #info note that this requires a committer on the project to have already +2ed it
17:34:18 <tykeal> anipbu: don't like being in a gray area? ;)
17:34:38 <edwarnicke> tykeal: anipbu is definitely a white hat, not a grey hat ;)
17:34:38 <colindixon> #info edwarnicke brings up how do we identify the release manager, colindixon says the obvious solution is to have the release manager be a position and privilege appointed by the TSC and serving at the discretion of the TSC
17:38:42 <rovarga> release managers tend to be per release (from my experience)
17:39:05 <colindixon> rovarga: releases are so intertwined here that I don't see how that works
17:39:21 <rovarga> colindixon: we can take it offline
17:39:31 <rovarga> colindixon: but it allows better focus
17:39:46 <adetalhouet> +1 to take this online
17:39:49 <adetalhouet> offline
17:41:40 <adetalhouet> No doubt about anipbu being our Release Manager :)
17:41:46 <abhijitkumbhare> +1
17:42:07 <colindixon> #startvote shall the TSC confirm that in their eyes anipbu is the release manager? -1,0,+1
17:42:07 <odl_meetbot> Begin voting on: shall the TSC confirm that in their eyes anipbu is the release manager? Valid vote options are -1, 0, +1.
17:42:07 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:42:22 <adetalhouet> #vote +1
17:42:23 <colindixon> #vote +1
17:42:24 <LuisGomez> #vote +1
17:42:24 <abhijitkumbhare> #vote +1
17:42:31 <rovarga> #vote +1
17:42:33 <ChrisPriceAB> #vote +1
17:42:44 <dfarrell07> #vote +1
17:42:49 <edwarnicke> #vote +1
17:42:51 <colindixon> #endvote
17:42:51 <odl_meetbot> Voted on "shall the TSC confirm that in their eyes anipbu is the release manager?" Results are
17:42:51 <odl_meetbot> +1 (8): rovarga, adetalhouet, LuisGomez, ChrisPriceAB, dfarrell07, edwarnicke, colindixon, abhijitkumbhare
17:42:57 * ChrisPriceAB wonders about the term obvious majority...
17:43:13 <edwarnicke> ChrisPriceAB: "obvious" not "oblivious" ;)
17:43:19 <colindixon> #topic system integration and test
17:43:23 <colindixon> #info nothing today
17:43:28 <colindixon> #topic infrastructure
17:43:29 <ChrisPriceAB> I am part of the oblivious majority edwarnicke
17:43:35 <colindixon> #Info nothing today
17:43:45 <colindixon> #topic BIER project creation review
17:43:46 <edwarnicke> ChrisPriceAB: We should make t-shirts :)
17:44:02 <jamoluhrsen> lol.  me too.
17:44:06 <tykeal> do they get a special brew?
17:44:17 <tykeal> not that I drink beer... or bier but still ;)
17:44:20 <colindixon> #info this project is another one where the TSC meeting time is prohibitive for having a live revew
17:44:42 <edwarnicke> tykeal: you are going to want bier :)
17:44:43 <abhijitkumbhare> Isn’t beer called bier in German? I will drink to that :)
17:44:59 <abhijitkumbhare> bierhaus
17:45:45 <colindixon> #startvote could you make a 7:30a pacific TSC meeting on 11/10 to do a live review of the BIER project? yes,no
17:45:45 <odl_meetbot> Begin voting on: could you make a 7:30a pacific TSC meeting on 11/10 to do a live review of the BIER project? Valid vote options are yes, no.
17:45:45 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:45:48 <colindixon> #vote yes
17:45:50 <ChrisPriceAB> #vote yes
17:45:52 <dfarrell07> #vote yes
17:45:54 <edwarnicke> #vote no
17:45:59 <LuisGomez> #vote yes
17:46:03 <adetalhouet> #vote yes
17:46:04 <edwarnicke> The fd.io TSC is at 8am PST on Thursday
17:46:04 <abhijitkumbhare> #vote yes
17:46:10 <rovarga> #vote yes
17:46:26 <edwarnicke> #vote yes
17:46:31 <colindixon> #endvote
17:46:31 <odl_meetbot> Voted on "could you make a 7:30a pacific TSC meeting on 11/10 to do a live review of the BIER project?" Results are
17:46:31 <odl_meetbot> yes (8): rovarga, adetalhouet, LuisGomez, ChrisPriceAB, dfarrell07, edwarnicke, colindixon, abhijitkumbhare
17:46:52 <colindixon> #agreed colindixon will send an invite for a 7:30-8a pacific TSC meeting to review the BIER project
17:47:14 <colindixon> #topic TSC elections
17:47:21 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006220.html
17:47:53 <colindixon> #link It looks like there were several people who added their names after the buzzer: https://wiki.opendaylight.org/index.php?title=TSC%3A2016_Election&diff=51625&oldid=51572
17:48:07 <colindixon> #link Which means the current page shows there actually being an election in every category but the Service/Protocol one. https://wiki.opendaylight.org/index.php?title=TSC:2016_Election&oldid=51625
17:48:19 <colindixon> #link The page at the buzzer didn't actually have enough candidates to fully populate the TSC: https://wiki.opendaylight.org/index.php?title=TSC:2016_Election&oldid=51572
17:49:15 <colindixon> #info colindixon says that his take is that we should take the people who have put their names in after the buzzer, given that some people might have not put their name down because they thought it was closed
17:50:25 * ChrisPriceAB is cool with that as well
17:50:26 <colindixon> #info colindixon asks if we should give more time to be fair, and if so how much
17:50:40 * adetalhouet is fine with the nomination period extended to Sunday
17:51:07 <colindixon> #info people say both 24 hours and until Sunday, consensus seems to be until Sunday
17:51:16 <ChrisPriceAB> Ack, shuffle the voting window
17:52:47 <colindixon> #startvote shall the TSC extend the election nominations to 23:59 UTC Sunday, November 6th and move voting to be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC? -1,0,+1
17:52:47 <odl_meetbot> Begin voting on: shall the TSC extend the election nominations to 23:59 UTC Sunday, November 6th and move voting to be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC? Valid vote options are -1, 0, +1.
17:52:47 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:53:00 <edwarnicke> #vote +1
17:53:00 <ChrisPriceAB> #vote +1
17:53:04 <dfarrell07> #vote +1
17:53:05 <colindixon> #vote +1
17:53:12 <LuisGomez> #vote +1
17:53:13 <adetalhouet> #vote +1
17:53:13 <abhijitkumbhare> #vote +1
17:53:14 <rovarga> #vote 0
17:53:29 <colindixon> #endvote
17:53:29 <odl_meetbot> Voted on "shall the TSC extend the election nominations to 23:59 UTC Sunday, November 6th and move voting to be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC?" Results are
17:53:29 <odl_meetbot> 0 (1): rovarga
17:53:29 <odl_meetbot> +1 (7): adetalhouet, ChrisPriceAB, LuisGomez, dfarrell07, edwarnicke, colindixon, abhijitkumbhare
17:53:56 <colindixon> #agree  election nominations will go to 23:59 UTC Sunday, November 6th an voting will be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC
17:54:16 <abhijitkumbhare> I am all for your jokes edwarnicke :)
17:54:40 <colindixon> #topic networking-odl in Ocata
17:55:10 <colindixon> #info ChrisPriceAB says that we have gaps we need to close and we have people working on it with iyamahat working as the lead
17:55:22 <ChrisPriceAB> #link https://etherpad.openstack.org/p/Keeping_ODL_in_OpenStack_Stadium etherpad on actions for the odl d-driver in ocata
17:56:16 <colindixon> #info ChrisPriceAB says that things seem to be looking up, but we're not out of the woods yet, if you can help please reach out to iyamahat
17:56:21 <colindixon> #undo
17:56:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29be0d0>
17:56:23 <iyamahat> #link https://docs.google.com/spreadsheets/d/1j9edHIQpLUA7NS9L8GugIQ8X38-LoZ5cvqsAEHdsz_0/edit#gid=220145665
17:56:25 <colindixon> #info ChrisPriceAB says that things seem to be looking up, but we're not out of the woods yet, if you can help please reach out to iyamahat (Isaku)
17:57:04 <colindixon> #info iyamahat says please, please help out and pick up tasks from the document above
17:57:25 <colindixon> #topic balance release delays short-term vs. long-term consequences
17:57:31 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-October/006205.html
17:58:07 <colindixon> #info it seems like we've accidentally created a culture of testing at the absolute last minute or after it, that results in us always shipping late by a week or two
17:58:31 <colindixon> #info that stems basically from the guidance we've had in the past that it's better to be late and good than on-time and not good
17:59:39 <colindixon> #info colindixon notes that his take is that we're likely to see this behavior until we actually ship something we'd rather not ship to make a point
18:00:28 * adetalhouet unfortunately have to drop
18:01:21 <colindixon> #info rovarga says his take is moving the requirement for blocking bugs back to RC1 or RC0 from RC2 might help by essentailly forcing testing earlier
18:01:51 <colindixon> #info colindixon notes that this is also a problem with SRs
18:01:55 <colindixon> adetalhouet: thanks!
18:02:18 <colindixon> #info rovarga notes that we should really be doing test only after M5
18:02:23 <colindixon> #Undo
18:02:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29cb790>
18:02:33 <colindixon> #info rovarga notes that we should really be doing nothing but testing after M5
18:03:00 <rovarga> well... that and planning the next release :)
18:03:43 <gkaempfer> #info gkaempfer
18:04:01 <colindixon> gkaempfer: you're an hour late :p
18:04:42 <colindixon> #action colindixon to add an agenda item around possibly sharing infrastructure with other LF projects for next week
18:05:52 <colindixon> #info colindixon notes that his take is that we've created a culture where people don't believe us when we draw lines in the sand and we can try to draw lines earlier, but if we want the lines to have meaning we'll probably have to tell people we're shipping code with bugs in it and sorry once or twice to fix that
18:05:58 <colindixon> #topic cookies
18:06:14 <colindixon> #endmeeting