15:29:35 <colindixon> #startmeeting tsc
15:29:35 <odl_meetbot> Meeting started Thu Nov 10 15:29:35 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:29:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:35 <odl_meetbot> The meeting name has been set to 'tsc'
15:29:40 <colindixon> #topic agenda bashing and roll call
15:29:41 <colindixon> #info colindixon
15:29:59 <adetalhouet> #info adetalhouet
15:30:23 <colindixon> TSC members please #info in edwarnicke, gkaempfer, abhijitkumbhare
15:31:14 <adetalhouet> I think edwarnicke has the fd.io TSC meeting so won't be there.
15:31:31 <colindixon> adetalhouet: that's not for 30 minutes
15:31:42 <adetalhouet> OK.
15:32:01 <anipbu> Are we doing just Creation Review of BIER Project or the entire TSC agenda?
15:32:23 <anipbu> okay
15:32:39 <colindixon> anipbu: I'd like to, but we also have the cluster metrics project creation review and we didn't tell them that, so I thnk we can't
15:32:50 <rovarga> #info rovarga for jmedved
15:32:52 <colindixon> also, we may not even do this meeting since we seem to not have enough TSC members #info-in in
15:33:10 <colindixon> dfarrell07
15:33:12 <abhijitkumbhare> #info abhijitkumbhare
15:33:35 <gkaempfer> #info gkaempfer
15:33:51 <colindixon> vishnoianil: please #info in
15:34:00 <vishnoianil> #info Anil Vishnoi
15:34:09 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006271.html vote on ALTO committers on the TSC list
15:34:33 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2016-November/006925.html we have TSC elections ongoing, vote if you have e-mail(s), let us know if you don't and think you should
15:35:28 <colindixon> #topic BIER creation review
15:35:47 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:BIER_Plugin
15:35:59 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-October/000551.html proposed on 10/18/2016
15:36:31 <colindixon> #link https://wiki.opendaylight.org/view/File:Presentation-bier-proposal-review.pdf presentation already on the wiki
15:37:08 <rovarga> is there a webex meeting corresponding to the review?
15:37:26 <adetalhouet> rovarga: You are scheduled to host this WebEx meeting.
15:37:26 <adetalhouet> Here are the details for your meeting. To edit the meeting or add files and comments, visit your meeting space.
15:37:26 <adetalhouet> Special TSC Meeting - Creation Review of BIER Project
15:37:26 <adetalhouet> Thu, Nov 10, 8:30 am | 1 hr
15:37:26 <adetalhouet> Denver (Mountain Standard Time, GMT-07:00)
15:37:28 <adetalhouet> Host: Phil Robb
15:37:29 <rovarga> nevermind, found it
15:37:31 <colindixon> When it's time, start the meeting from here: https://meetings.webex.com/collabs/meetings/join?uuid=M68VZJQC0YAL19U603O1YGP1WE-9VIB
15:37:32 <adetalhouet> When it's time, start the meeting from here:
15:37:34 <adetalhouet> https://meetings.webex.com/collabs/meetings/join?uuid=M68VZJQC0YAL19U603O1YGP1WE-9VIB
15:37:36 <adetalhouet> Access Information
15:37:38 <adetalhouet> Where: WebEx Online
15:37:40 <adetalhouet> Meeting number: 196 636 685
15:37:42 <adetalhouet> Meeting password: This meeting does not require a password.
15:37:44 <colindixon> #info this is work to bring the IETF draft on BIER (a new way to do multicast) with support from ZTE and China Telecom
15:37:44 <adetalhouet> Host key: 856511 (Use this key in the meeting if you have made someone else the host and then want to reclaim the host role.)
15:37:47 <adetalhouet> Audio Connection
15:37:49 <adetalhouet> +1-855-797-9485 Call-in toll-free number (US/Canada)
15:37:51 <adetalhouet> +1-415-655-0002 Call-in toll number (US/Canada)
15:37:53 <adetalhouet> Access code: 196 636 685
15:37:55 <adetalhouet> Need more numbers or information?
15:37:57 <adetalhouet> Check out toll-free calling restrictions:
15:37:59 <adetalhouet> https://www.webex.com/pdf/tollfree_restrictions.pdf
15:38:03 <adetalhouet> Best,
15:38:05 <adetalhouet> Phil.
15:38:07 <adetalhouet> View your event at https://www.google.com/calendar/event?action=VIEW&eid=NHU2NWFhMDM3dTc0dTcyOWs1YjdiNHNsNnMgZGlzY3Vzc0BsaXN0cy5vcGVuZGF5bGlnaHQub3Jn&tok=MjUjcHJvYmJAbGludXhmb3VuZGF0aW9uLm9yZzNmNjRiMjEzYTY3N2YzM2JmODY3NzMyNDM1YzcxODNlOGJlZWM5ZTA&ctz=America/Denver&hl=en.
15:38:11 <adetalhouet> sorry for that
15:38:13 <colindixon> #link https://tools.ietf.org/html/draft-ietf-bier-architecture-05 the IETF draft
15:38:55 <colindixon> #link https://datatracker.ietf.org/wg/bier/ the IETF working group
15:39:54 <dfarrell07> #info Daniel Farrell
15:40:49 <colindixon> #info BIER (Bit-Indexed Explicity Multicast Replication) assigns a unique bit position in a bitstring for each edge router, each edge router floods their bit position to ID mapping, then packets are forwarded using IGP paths looked up based on the bitstring
15:41:55 <colindixon> #info why use BIER: simpler multicast approach since the non-edge devices in the network need not have state except per-edge-device
15:42:22 <colindixon> dfarrell07: there's a link to the pdf above
15:42:57 <colindixon> rovarga: do you know if Daniel Malachovsky is raisable
15:43:02 <ChrisPriceAB> #info chris price
15:43:05 <colindixon> if so, we could maybe have this meeting be the only TSC meeting
15:43:08 <colindixon> welcome ChrisPriceAB
15:44:03 <colindixon> #info scope is basically around taking NB configuration of how the BIER should configure underlying devices and a SB plugin to reach out to devices participating in a BIER region
15:44:26 <colindixon> rovarga: since then we could do the cluster metrics creation review now as well
15:45:00 <rovarga> colindixon: messages forwarded, no response yet
15:45:33 <colindixon> #info in carbon the BIER flow manager will not be automatically calculating bit strings, but will use static configuration
15:46:01 <colindixon> #info for now the SB plugin will be over NETCONF
15:46:27 * ChrisPriceAB struggles on with webex...
15:46:38 <colindixon> #info rovarga asks if he's right in understanding that the NB interface is really a BIER topology as in OpenFlow and NETCONF today
15:49:01 <colindixon> #info the answer appears to be yes, the NB is to receive the multcast flow information to configure things
15:50:12 <dfarrell07> #info dfarrell07 rovarga notice that the set of commiters is the the same as the set of contributors, maybe not best strategy
15:50:48 <colindixon> #Info rovarga and dfarrell07 ask if the project really needs 12 committers, does the project consider this right?
15:52:32 <colindixon> #info dfarrell07 suggests maybe reducing the number of committers down to something like 3–5 might help
15:53:50 * adetalhouet is ok to vote now
15:53:54 <colindixon> #info phrobb asks if there is inbound code to review, answer seems to be no
15:53:57 <colindixon> #startvote shall the TSC approve the BIER Plugin project as an incubation project? -1,0,+1
15:53:57 <odl_meetbot> Begin voting on: shall the TSC approve the BIER Plugin project as an incubation project? Valid vote options are -1, 0, +1.
15:53:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
15:54:03 <abhijitkumbhare> #vote +1
15:54:05 <adetalhouet> #vote +1
15:54:06 <vishnoianil> #vote +1
15:54:12 <colindixon> #vote +1
15:54:14 <ChrisPriceAB> #vote +1
15:54:26 <rovarga> #vote +1
15:54:32 <dfarrell07> #vote +1
15:55:05 <colindixon> #endvote
15:55:05 <odl_meetbot> Voted on "shall the TSC approve the BIER Plugin project as an incubation project?" Results are
15:55:05 <odl_meetbot> +1 (7): rovarga, adetalhouet, ChrisPriceAB, dfarrell07, colindixon, abhijitkumbhare, vishnoianil
15:56:08 <rovarga> colindixon: I don't think we can get Daniel -- he just signed off
15:56:22 <colindixon> #info colindixon notes that while he agrees dfarrell07 and rovarga that having a smaller number of people as committers who will be actively involved in reviewing code as it comes in will make sense, if these 12 people are the right ones for that, fine, but it's worth reviewing it
15:56:23 <adetalhouet> congrats BIER team
15:56:36 <colindixon> #agree the BIER plugin project is an incubation project
15:57:20 <colindixon> #startvote shall the TSC allow the BIER project to enter the carbon release as an offset 1 or 2 project as their choice? -1,0,+1
15:57:20 <odl_meetbot> Begin voting on: shall the TSC allow the BIER project to enter the carbon release as an offset 1 or 2 project as their choice? Valid vote options are -1, 0, +1.
15:57:20 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
15:57:48 <colindixon> #vote +1
15:57:50 <rovarga> #vote +1
15:57:52 <gkaempfer> #vote +1
15:57:55 <adetalhouet> #vote +1
15:58:00 * rovarga suggests offset 2
15:58:05 <vishnoianil> #vote +1
15:58:05 <dfarrell07> #vote +1
15:58:07 <abhijitkumbhare> #vote +1
15:58:10 <ChrisPriceAB> #vote +1
15:58:14 <colindixon> #endvote
15:58:14 <odl_meetbot> Voted on "shall the TSC allow the BIER project to enter the carbon release as an offset 1 or 2 project as their choice?" Results are
15:58:14 <odl_meetbot> +1 (8): rovarga, gkaempfer, adetalhouet, dfarrell07, ChrisPriceAB, colindixon, abhijitkumbhare, vishnoianil
15:58:22 <abhijitkumbhare> +1 to offset 2
15:58:24 <colindixon> #agreed the BIER plugin can join the carbon release at either offset 1 or offset 2
15:58:31 * adetalhouet agrees with offset 2 as well
15:58:37 <vishnoianil> +1
15:58:40 <colindixon> #info abhijitkumbhare, vishnoianil, adetalhouet, colindixon, and others all suggest offset 2
15:59:10 <colindixon> #endmeeting