18:00:04 <colindixon> #startmeeting tsc
18:00:04 <odl_meetbot> Meeting started Thu Dec  1 18:00:04 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:04 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:04 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:10 <colindixon> #topic agenda bashing and roll call
18:00:17 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52052#Agenda
18:00:22 * dfarrell07 catches self about to #info in ;)
18:00:38 <edwarnicke> #info edwarnicke
18:00:40 <skitt> #info skitt
18:00:40 <anipbu> #info anipbu
18:00:42 <colindixon> #info all new and returning TSC members, please #info in
18:00:47 <edwarnicke> dfarrell07: How were you allowed to escape?
18:00:48 <colindixon> Returning: Abhijit Kumbhare, Alexis de Talhouet, Anil Vishnoi, Colin Dixon, Ed Warnicke, Luis Gomez
18:00:48 <colindixon> New: An Ho, Hideyuki Tai, Jamo Luhrsen, Robert Varga, Sam Hague, Stephen Kitt, Thanh Ha
18:00:50 <colindixon> #info colindixon
18:01:02 <adetalhouet> #info adetalhouet
18:01:12 <vishnoianil> #info Anil Vishnoi
18:01:16 * edwarnicke glares comically at colindixon as if to imply jokingly it was his fault
18:01:17 <colindixon> dfarrell07: you didn't even run!? who allowed that!?
18:01:22 <hideyuki> #info Hideyuki Tai
18:01:27 <tykeal> wasn't dfarrell07 a stand-in for ChrisW?
18:01:36 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-11-17-18.00.html last week's meeting minutes
18:01:36 <dfarrell07> ;)
18:01:47 <jamoluhrsen> do I info in yet?
18:01:57 <skitt> jamoluhrsen, ues
18:01:58 <CaseyODL> jamoluhrsen: Yes.
18:02:01 <tykeal> hehe
18:02:11 <jamoluhrsen> #info jamoluhrsen
18:02:27 <abhijitkumbhare> #info abhijitkumbhare
18:02:53 <colindixon> zxiiro: you #info ing in
18:02:55 <colindixon> LuisGomez: you #info ing in
18:02:58 <shague> #info shague
18:03:16 <colindixon> rovarga: you #info ing in
18:03:39 <colindixon> #info colindixon updated the list of ongoing mailing list discussions with OPNFV deliverables and managing projects with few/no active committers
18:03:46 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:03:47 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:03:48 <colindixon> #action colindixon to try to drive some/all of the ongoing TSC discussions to completion
18:03:49 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
18:03:50 <colindixon> #action colindixon and/or ChrisPriceAB to work on how to manage cross-release issues with ODL/OPNFV
18:04:09 <colindixon> #info we'll add a topic during updates on interns/mentors for 2017
18:04:42 <colindixon> #topic new TSC
18:04:48 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html
18:04:54 <colindixon> #info  Returning: Abhijit Kumbhare, Alexis de Talhouet, Anil Vishnoi, Colin Dixon, Ed Warnicke, Luis Gomez
18:05:08 <colindixon> #info  New: An Ho, Hideyuki Tai, Jamo Luhrsen, Robert Varga, Sam Hague, Stephen Kitt, Thanh Ha
18:05:17 <LuisGomez> #info LuisGomez
18:05:20 <rovarga> #info rovarga
18:05:21 <colindixon> #info  Departing: Chris Price, Daniel Farrell (Chris Wright), Gideon Kaempfer, Jan Medved, Uri Elzur
18:05:58 <abhijitkumbhare> +1
18:06:19 <colindixon> #info colindixon says he'd like to deeply thank those people for all their hard work on the TSC
18:06:22 <abhijitkumbhare> I mean +1 to the contributions of the previous members
18:06:34 <colindixon> #link https://www.opendaylight.org/governance/ everyone seems to be listed here (thanks CaseyODL)
18:07:11 <tykeal> random bio generator: http://www.generatorland.com/glgenerator.aspx?id=124
18:07:31 <vishnoianil> welcome An Ho, Hideyuki Tai, Jamo Luhrsen, Robert Varga, Sam Hague, Stephen Kitt, Thanh Ha
18:08:18 <abhijitkumbhare> +1: welcome  An Ho, Hideyuki Tai, Jamo Luhrsen, Robert Varga, Sam Hague, Stephen Kitt, Thanh Ha
18:09:15 <abhijitkumbhare> we don’t know you jamoluhrsen :)
18:09:44 <jamoluhrsen> i can't break ofp any more so I left you guys abhijitkumbhare
18:09:55 <dfarrell07> jamoluhrsen: lol ;)
18:10:04 <abhijitkumbhare> sob sob jamoluhrsen
18:11:03 <abhijitkumbhare> we have 5 OFP guys here - jamoluhrsen (past test contact), LuisGomez (test contact), committers vishnoianil edwarnicke & myself :)
18:11:29 <vishnoianil> skitt, you are grand-dad of ODL, --> PTL of ODL - Parent :D
18:11:40 <skitt> vishnoianil, heh heh
18:11:49 <skitt> vishnoianil, need to take good care of all the grandkids ;-)
18:11:59 <vishnoianil> skitt, yes you do :P
18:11:59 <abhijitkumbhare> yep - skitt :)
18:12:01 * adetalhouet appreciates that a lot :)
18:12:14 <colindixon> #action phrobb to send out mail calling for nominations for TSC chair and then kick of an election
18:12:53 <colindixon> #Info phrobb notes that the only people who can nominate themselves and vote in the election are TSC members
18:13:53 <zxiiro> #info Thanh
18:13:58 <CaseyODL> fail.  :)
18:14:01 <colindixon> #info colindixon says that he hopes that we could close this before the holidays, given that we're down to 13 people we could do this quickly
18:14:05 * zxiiro is not used to this yet :)
18:14:29 <shague> +1
18:14:32 <colindixon> #startvote are people OK having a 1 week nomination period and 1 week voting period back-to-back, starting now? -1,0,+1
18:14:32 <odl_meetbot> Begin voting on: are people OK having a 1 week nomination period and 1 week voting period back-to-back, starting now? Valid vote options are -1, 0, +1.
18:14:32 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:14:33 <jamoluhrsen> #vote +1
18:14:35 <skitt> #vote +1
18:14:36 <colindixon> #vote +1
18:14:38 <edwarnicke> #vote +1
18:14:38 <zxiiro> #vote +1
18:14:38 <vishnoianil> #vote +1
18:14:39 <anipbu> #vote +1
18:14:40 <LuisGomez> #vote +1
18:14:40 <rovarga> #vote +1
18:14:41 <hideyuki> #vote +1
18:14:42 <abhijitkumbhare> #vote +1
18:14:42 <shague> #vote +1
18:14:55 <adetalhouet> #vote +1
18:15:02 <colindixon> #endvote
18:15:02 <odl_meetbot> Voted on "are people OK having a 1 week nomination period and 1 week voting period back-to-back, starting now?" Results are
18:15:02 <odl_meetbot> +1 (13): rovarga, adetalhouet, skitt, anipbu, LuisGomez, edwarnicke, shague, hideyuki, colindixon, jamoluhrsen, zxiiro, vishnoianil, abhijitkumbhare
18:15:27 <rovarga> have we ever had a vote with more participants? :)
18:15:53 <skitt> rovarga, sometimes non-TSC members vote accidentally ;-)
18:15:56 <vishnoianil> why doesn't this bot automatically close the vote if everyone info'ed already voted
18:15:56 <colindixon> #agreed nominations for TSC chair open now, phrobb will post a wiki page immediately after this meeting, nominations close at 23:59 UTC on Wednesday 12/7,  voting will start on 12/8 and close at 23:59 UTC on 12/14
18:16:26 <colindixon> #topic committer-at-large representavies on the board
18:16:29 <rovarga> vishnoianil: is it cognizant of who is allowed to vote?
18:16:42 <vishnoianil> rovarga, i think based on #info?
18:16:45 <phrobb> #linkhttps://wiki.opendaylight.org/view/Committer_Members_Board_Representation Link to how the process works
18:16:46 <colindixon> vishnoianil: it is not
18:17:07 <colindixon> #link https://wiki.opendaylight.org/view/Committer_Members_Board_Representation Link to how the process works
18:17:14 <rovarga> vishnoianil: well... that is used for all sorts of things
18:17:21 <tykeal> the bot doesn't know who is allowed to vote or not. #info is just a meeting minutes status line
18:17:33 <colindixon> voting auditing is just me double checking
18:18:14 <rovarga> it would be a neat addition to the bot (I think it cares less than colindixon about the screen scrolling)
18:18:26 <phrobb> #link https://linuxfoundation.echosign.com/public/hostedForm?formid=AI3XA256U2H44Y Link to form to become a committer member
18:18:26 <vishnoianil> tykeal, good to have a enhancement
18:18:31 <vishnoianil> rovarga, exactly :)
18:18:34 <tykeal> not our project ;)
18:18:38 <colindixon> I have lots of meetbot enhancements I'd like
18:18:53 <rovarga> is there an issue tracker we can bombard? :)
18:19:12 <colindixon> https://wiki.opendaylight.org/view/Interns/Summer_2015#Improved_ODL_Meetbot
18:19:20 <tykeal> home of the bot: https://wiki.debian.org/MeetBot version we're prsently running https://github.com/openstack-infra/meetbot
18:20:03 <colindixon> #action phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
18:20:43 <colindixon> #info 2 week nominations ~12/7 to ~12/21, voting will be in the new year ~1/2 to ~1/16
18:21:14 <colindixon> #topic TSC mailing list votes and discussions
18:21:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006383.html  Vote on ALTO committers—will close after today's TSC call
18:22:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006368.html  projects with few/no active committers
18:22:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006298.html  Delivering to consumer project off-cadence (ODP & OPNFV collaboration)
18:23:12 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006392.html  escalation process we have in OpenDaylight has been added to the TSC page (object now if you want to)
18:24:13 <colindixon> #action phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
18:24:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006389.html  only allow blocking bug fixes after RCs start in Carbon
18:26:32 <colindixon> #action colindixon to remove many current discussions which are now closed, which is a lot of them
18:28:29 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006388.html  Categorizing projects (please add your project type to your project facts sidebar)
18:28:51 <colindixon> #topic 2017 OpenDaylight Interns
18:29:17 <colindixon> #link https://wiki.opendaylight.org/view/InternProjects:Main please propose projects here
18:29:33 <colindixon> #info CaseyODL wants to have things come up tomorrow
18:29:35 * ChrisPriceAB needs to pick up the de3livery thread again, apologies for letting it drop
18:29:50 <colindixon> ChrisPriceAB: no worries, maybe delegate to dfarrell07? :p
18:30:08 <colindixon> #info CaseyODL plans ot advertise it on Monday
18:30:14 <ChrisPriceAB> That is a fantastic idea colindixon!
18:30:17 <ChrisPriceAB> :)
18:30:57 <colindixon> rovarga, vishnoianil want to move the meetbot project forward to here
18:31:09 <colindixon> #info CaseyODL notes that he's been asking for projects for a month
18:31:30 <dfarrell07> It is kinda important to get them proposed early, or we miss interns to other internships
18:31:48 <colindixon> #info colindixon notes that you can add more topics after monday, but interns applying might not know about your project if they look before you list it
18:32:11 * dfarrell07 will submit one today or tomorrow
18:32:52 <colindixon> #info dfarrell07 and CaseyODL say that we need to get it advertised on Monday to try to avoid losing good candidates to other programs
18:34:13 <colindixon> #Info colindixon has listed a lot with "Mentors: ???? and Colin Dixon <colin@colindixon.com>" if you want to help do one, please please please help
18:34:24 <colindixon> #info CaseyODL notes that the LF pays for the interns, these are free interns
18:36:27 <colindixon> #Info vishnoianil asks if project-specific projects are allowed, or does it have to be cross-project, CaseyODL says that pretty much anything that benefits ODL will be allowed
18:37:34 <colindixon> #topic events
18:37:46 <colindixon> #link https://www.opendaylight.org/global-events
18:38:07 <colindixon> #link https://www.opendaylight.org/events/2016-12-05-000000-2016-12-09-000000/opnfv-plugfest  December 5, 2016 OPNFV Plugfest Durham, New Hampshire
18:38:21 <colindixon> #link  December 7, 2016 Global Network Technology Conference Beijing, China (colindixon is speaking)
18:38:48 <colindixon> #link  December 12, 2016 ODL China City Tour Nanjing, Beijing, Shenzhen and Shanghai (at least phrobb, Lisa Caywood, Neela are all going)
18:39:05 <colindixon> well, no links, but #link will work as #info
18:40:45 <colindixon> #info phrobb talks about the "Leadership Summit", which is in Tahoe in the first week of February, should we try to get some TSCs together from different LF projects
18:41:24 <colindixon> #info phrobb asks if there's interest
18:41:47 <jamoluhrsen> +1 on TSC mixer interest
18:41:59 <abhijitkumbhare> +1 on this event
18:42:10 * adetalhouet things it's a great idea
18:42:19 <adetalhouet> s/things/thinks
18:42:32 <anipbu> +1 to mixer
18:42:34 <colindixon> #Info at least jamoluhrsen, abhijitkumbhare, jamoluhrsen, colindixon, edwarnicke, dfarrell07 all say this is a good idea
18:43:09 <colindixon> #action phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
18:43:47 <colindixon> #topic boron
18:43:56 <CaseyODL> Yes, 16 C is freezing.  :)
18:44:07 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008829.html   <--- Boron SR2 Release Date: December 15; Cutoff Date on December 11 at 23:59 UTC
18:44:17 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008818.html   <--- Boron Autorelease Build Failure
18:44:27 <colindixon> CaseyODL: https://www.google.com/search?q=lake+tahoe+weather&ie=utf-8&oe=utf-8 (32F now)
18:44:31 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=---   <--- One blocker bug in openflowplugin
18:44:31 <anipbu> (6575) for Boron.  Kindly ask projects to please fix or retarget blocker bugs before the cutoff.
18:44:51 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/boron   <--- 32 patches pending for stable/boron
18:45:07 <anipbu> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR1=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-10-27   <--- 23 patches modifying yang files without API Freeze Waiver between Boron SR1 and Boron SR2
18:45:31 <colindixon> #topic carbon
18:45:46 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_yang-model-api   <--- Changes to DocumentedNode.  Method getStatus() was moved from the interface DocumentedNode into the WithStatus interface.
18:46:03 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/48246/   <--- DocumentedNode changes merged.
18:46:12 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_RpcStatement   <--- Changes to RpcStatement.  Empty input and output statements are now automatically added to every rpc statement that does not define them.
18:46:26 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/48704/   <--- RpcStatement changes pending code review.
18:46:37 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Change_in_yangtools.27s_DataTreeConfiguration   <--- Changes to DataTreeConfiguration.  Data tree configuration for operational data tree now enforces validation of mandatory nodes.
18:46:47 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/48672/   <--- DataTreeConfiguration changes pending.
18:49:36 <colindixon> #Info colindixon asks if they've run CSIT tests against 48672, rovarga says not yet, but they will befoore merging it
18:49:50 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008828.html   <--- Carbon M2 Offset 1 Status is due Today 12/1.
18:49:57 <anipbu> #info Carbon M2 IRC Working Session for new projects on Wednesday 12/7/2016 7:30AM Pacific Time Zone
18:50:20 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008827.html   <--- CENTINEL Carbon Autorelease Build Failure
18:50:30 <anipbu> #info Last Successful Carbon Autorelease Build on November 17, 2016
18:50:59 <colindixon> #topic system integration and testing
18:52:10 <colindixon> #info infrastructure resource collaboration inititiave with other projects in the LF, dfarrell07 and LuisGomez are participating
18:52:47 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features   <--- definition of top level, user facing features
18:53:15 <colindixon> #topic infrastructure
18:53:15 <colindixon> #info big outage last weekend lasted 10 hours: fixed a battery, upgraded from kilo to liberty
18:53:42 <colindixon> #Info we did run into problems now bubbling up in the last few days with lost ports, but they seem to all be resolved now
18:54:44 <colindixon> #topic  APAC time-zone TSC calls
18:55:01 <colindixon> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 poll results
18:55:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-October/006125.html
18:58:57 <colindixon> #info jamoluhrsen asks if we need quorum, colindixon says probably yes for it to be useful
18:59:15 <colindixon> #info vishnoianil asks if we get no participation, will we change it again, yeah that makes sense
19:00:02 <colindixon> #info two obvious time slots (at least to colindixon)
19:00:09 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=3&min=30&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37
19:00:15 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=7&min=0&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37
19:02:30 <colindixon> #info abhijitkumbhare notes that the times might shift for countries with daylight savings time
19:03:38 <rovarga> 0430 is going to be ... interesting :)
19:03:45 <skitt> ;-)
19:04:01 <vishnoianil> so does 3A :P
19:04:03 <colindixon> #action colindixon to start a thread to get candidate times and then we can figure out how to vote after that, at least
19:04:31 <colindixon> #topic cookies
19:04:34 <colindixon> #endmeeting