18:01:55 <colindixon> #startmeeting tsc
18:01:55 <odl_meetbot> Meeting started Thu Dec 15 18:01:55 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:01:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:55 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:59 <colindixon> #topic agenda bashing and roll call
18:02:01 <adetalhouet> #info adetalhouet
18:02:03 <zxiiro> #info Thanh
18:02:03 <colindixon> TSC members please #info in
18:02:05 <colindixon> #info colindixon
18:02:10 <skitt> #info skitt
18:02:28 <afredette> #info afredette
18:02:29 <hideyuki> #info Hideyuki
18:02:32 <jamoluhrsen> #info jamoluhrsen
18:02:40 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52306#Agenda today's agenda
18:02:51 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-12-08-18.00.html last week's meeting minutes
18:02:55 <LuisGomez> #info LuisGomez
18:02:58 <tykeal> *grr* I managed to join the integration meeting this morning but now webex doesn't want me to join the tsc again??? I hate webex
18:03:01 <anipbu> #info anipbu
18:03:01 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:03:05 <afredette> #info afredette proxy for shague
18:03:07 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:03:13 <jamoluhrsen> tykeal, works perfect with windows
18:03:17 <abhijitkumbhare> #info abhijitkumbhare
18:03:19 <colindixon> #action colindixon to try to drive some/all of the ongoing TSC discussions to completion
18:03:57 <vishnoianil> #info Anil Vishnoi
18:04:02 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
18:04:26 <rovarga> #info rovarga
18:04:32 <colindixon> #action phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
18:05:35 <edwarnicke> #info edwarnicke
18:05:53 <colindixon> #link https://wiki.opendaylight.org/view/Committer_Members_Board_Representation if you are a committer, and sign up a committer member of the OpenDaylight foundation you can nominate yourself to be a committer member of the board, and vote in the subsequent elections
18:06:15 <colindixon> #action phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
18:06:24 <colindixon> #action colindixon to remove many current discussions which are now closed, which is a lot of them
18:06:41 <colindixon> #action phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
18:09:03 <colindixon> #topic events
18:09:46 <colindixon> #link https://www.opendaylight.org/global-events
18:10:08 <colindixon> #link https://www.opendaylight.org/events/2016-12-12-000000-2016-12-16-000000/odl-china-city-tour ODL China tour ongoing now, seems like it's awesome
18:11:13 <colindixon> #info abhijitkumbhare asks about the DDF and summit
18:11:32 <colindixon> #Info CaseyODL says that the summit is held for late october
18:12:51 <colindixon> #info abhijitkumbhare asks if it will be a stand-alone summit, colindixon and CaseyODL say that's plan A for now, but not set in stone
18:13:02 <colindixon> #info afredette asks where the summit is, it's in San Jose
18:13:20 <colindixon> #action CaseyODL and/or phrobb to communicate possible dates/locations for a DDF in between the two summits
18:14:14 <colindixon> #info abhijitkumbhare asks if we're planning to have an ODL mini-summit at ONS or an ODL track, colindixon doesn't know, CaseyODL says that he's pretty sure the answer is no
18:15:30 <colindixon> #link https://www.linuxfoundation.org/announcements/linux-foundation-appoints-veteran-networking-professional-as-general-manager arpit is apparnetly trying to get the ONS set up (possibly differently) as one of his first things
18:16:21 <colindixon> #link edwarnicke asks if we're planning to have an ODL mini-sumit at the OPNFV summit in Beijing, we seem to be unsure, http://events.linuxfoundation.org/events/opnfv-summit
18:16:46 <colindixon> #action phrobb and CaseyODL to present a better idea of our summits, mini-summits, and DDFs coming up
18:17:08 <colindixon> #topic boron
18:17:11 <colindixon> #chair anipbu
18:17:11 <odl_meetbot> Current chairs: anipbu colindixon
18:17:36 <anipbu> #info We initially targeted Boron SR2 Release on 12/15, but our latest build have not been signed off by respective projects. In order to fix NETVIRT regression blocker bug, we had to respin Boron SR2 completed at Thu Dec 15 10:36:22 UTC 2016. Projects have not had time to test and sign off on Boron SR2 Build 20161215.
18:17:44 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR2/Status   <--- Status Page
18:18:45 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=7368   <--- NETVIRT Blocker Bug leading to respin yesterday.
18:19:00 <colindixon> #action anipbu to open a mailing list vote on releasing Boron-SR2 if and when we get all project buy in on test failures
18:19:09 <colindixon> #topic carbon
18:19:31 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008887.html   <--- Neutron Northbound: rename tenant-id to project-id.  Discussion on migration/upgrade process for existing setups.
18:20:03 <anipbu> https://www.irccloud.com/pastebin/lGzTbpdK/
18:20:14 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/49446/   <--- usecplugin
18:20:20 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/49429/   <--- sdninterfaceapp
18:20:42 <colindixon> is An choppy for others, or is it just me?
18:20:42 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-December/008938.html   <--- Changes to Upgrade Servlet API 3.0.1 -> 3.1.0 has broken AAA (relevant patch: https://git.opendaylight.org/gerrit/#/c/38269/)
18:20:50 * adetalhouet hears it as well
18:20:56 <colindixon> OK
18:20:58 <vishnoianil> colindixon, yeah
18:21:06 <colindixon> anipbu: you're audio is really choppy
18:21:14 <vishnoianil> looks like someone is banging on his microphone :D
18:21:48 <edwarnicke> anipbu: please do not beat your head against the desk, we love you, it will be OK, please don't hurt yourself ;)
18:21:48 <jamoluhrsen> +1 to wait on SR2
18:21:58 <hideyuki> +1 to wait
18:23:36 <colindixon> #startvote shall the TSC approve Boron-SR2 conditionally on all projects signing off on unexpected test failiures and no new blocking bugs raised? -1,0,+1
18:23:36 <odl_meetbot> Begin voting on: shall the TSC approve Boron-SR2 conditionally on all projects signing off on unexpected test failiures and no new blocking bugs raised? Valid vote options are -1, 0, +1.
18:23:36 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:23:36 <abhijitkumbhare> +1 to conditionally approve
18:23:48 <abhijitkumbhare> #vote +1
18:23:49 <skitt> #vote +1
18:23:52 <colindixon> #vote +1
18:23:54 <zxiiro> #vote +1
18:23:54 <adetalhouet> #vote +1
18:23:54 <anipbu> #vote +1
18:24:00 <jamoluhrsen> #vote +1
18:24:02 <hideyuki> #vote +1
18:24:03 <afredette> #vote +1
18:24:04 <edwarnicke> #vote +1
18:24:15 <rovarga> #vote +1
18:24:22 <colindixon> #endvote
18:24:22 <odl_meetbot> Voted on "shall the TSC approve Boron-SR2 conditionally on all projects signing off on unexpected test failiures and no new blocking bugs raised?" Results are
18:24:22 <odl_meetbot> +1 (11): rovarga, adetalhouet, afredette, skitt, zxiiro, edwarnicke, hideyuki, colindixon, abhijitkumbhare, anipbu, jamoluhrsen
18:24:29 <vishnoianil> #vote +1
18:24:36 <LuisGomez> #vote +1
18:24:50 <jamoluhrsen> LuisGomez, vishnoianil, late as usual.
18:24:53 <jamoluhrsen> :)
18:24:54 <colindixon> #agreed Boron-SR2 will be released as soon as all projects sign off on unexpected test failiures assuming no new blocking bugs are raised
18:24:58 <vishnoianil> just want to know that i support it :D
18:25:16 <colindixon> #topic system integration and testing
18:25:49 <colindixon> #info the beryllium merge job is failing, this will only matter if we have to spin a security update
18:25:58 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=7357
18:26:09 <colindixon> #info there's a carbon issue with the cardinal issue
18:26:38 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2016-December/008933.html  <--- email thread for yangtools merge job failing in beryllium
18:27:07 <colindixon> #info rovarga says that the beryllium merge job is now fixed
18:27:16 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2016-December/008916.html  <--- email thread about cardinal troubles in autorelease maybe ending up with us needing to remove cardinal from distribution
18:28:48 <colindixon> #info rovarga asks if we need to keep it working, colindixon says his take is that because we support security fixes for the two current releases, e.g., beryllium and boron, thus we might accidentally disclose that we're providing a security patch early by fixing the build only on-demand
18:29:59 <colindixon> #info vrpolak points out that Cardinal is failing and will basically have to be removed from Cabon unless they fix it
18:30:31 <colindixon> #info vrpolak says he thinks that it will be hard to fix, so it might be a pain
18:30:50 <colindixon> #info zxiiro and anipbu say that we've already removed cardinal from autorelease and they are unresponsive
18:31:21 <colindixon> #info colindixon asks if cardinal actually declared an intent to participate in carbon, if not, this is a non-issue
18:31:48 <colindixon> #topic infrastructure
18:32:56 <colindixon> #info we now have two kinds of logs on the logs server with and without timestamps
18:33:18 <colindixon> #info colindixon asks if that means we're doubling our storage requirments there, zxiiro says yes, but they're compressed, so it's probably OK
18:33:36 <colindixon> #topic TSC chair elections
18:33:43 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006454.html
18:35:11 <anipbu> #startvote Shall the TSC approve Colin Dixon as the TSC Chair for this term.
18:35:11 <odl_meetbot> Unable to parse vote topic and options.
18:35:17 <anipbu> #endvote
18:35:36 <anipbu> #startvote Shall the TSC approve Colin Dixon as the TSC Chair for this term? +1, 0, -1
18:35:36 <odl_meetbot> Begin voting on: Shall the TSC approve Colin Dixon as the TSC Chair for this term? Valid vote options are +1, 0, -1.
18:35:36 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:35:38 <skitt> #vote +1
18:35:38 <adetalhouet> #vote +1
18:35:39 <vishnoianil> #vote +1
18:35:40 <afredette> #vote +1
18:35:41 <hideyuki> #vote +1
18:35:45 <anipbu> #vote +1
18:35:45 <zxiiro> #vote +1
18:35:45 <edwarnicke> #vote +1
18:35:47 <abhijitkumbhare> #vote +1
18:35:52 <LuisGomez> #vote +1
18:35:53 <colindixon> #vote +1
18:35:53 <rovarga> #vote +1
18:36:09 <anipbu> #endvote
18:36:09 <odl_meetbot> Voted on "Shall the TSC approve Colin Dixon as the TSC Chair for this term?" Results are
18:36:09 <odl_meetbot> +1 (12): rovarga, adetalhouet, skitt, zxiiro, LuisGomez, edwarnicke, hideyuki, colindixon, afredette, anipbu, vishnoianil, abhijitkumbhare
18:36:11 <skitt> All Hail King Colin ;-)
18:36:18 <dfarrell07> colindixon: congrats! well deserved, thanks for the good work :)
18:36:21 <colindixon> skitt: I do not want to be BDFL
18:36:25 <colindixon> noooooooooooo
18:36:25 * edwarnicke watches the white smoke wafting away
18:36:26 <jamoluhrsen> #vote +1
18:36:26 <CaseyODL> colindixon: Congrats.  :)
18:36:28 <anipbu> #agreed TSC approve Colin Dixon as the TSC Chair for this term
18:36:29 <adetalhouet> colindixon: Congrats :-) and thanks for assuming the role greatly
18:36:30 <abhijitkumbhare> Congrats colindixon
18:36:36 <skitt> colindixon, I know!
18:36:36 <jamoluhrsen> awesome!
18:36:46 <edwarnicke> colindixon: There is no escape
18:36:52 <skitt> colindixon, although the B can stand for other things
18:37:12 <LuisGomez> congrats colin
18:37:16 <anipbu> congrats Colin
18:38:02 <colindixon> #topic committer members of the ODL board of directors
18:38:22 <colindixon> #info since we haven't started nominations yet, my guess nominations will run into the new year, and voting will start sometime after that
18:38:55 <colindixon> #info otherwise, find the link above to become a committer member of the nonprofit for the foundation to nominate yourself and/or vote
18:39:10 <colindixon> #topic APAC time-zone TSC calls
18:40:00 <colindixon> #startvote shall we hold the first APAC-friendly time-zone call next week at 8:30p pacific on Thursday, December 22nd? -1,0,+1
18:40:00 <odl_meetbot> Begin voting on: shall we hold the first APAC-friendly time-zone call next week at 8:30p pacific on Thursday, December 22nd? Valid vote options are -1, 0, +1.
18:40:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:40:00 <edwarnicke> go for it colindixon
18:40:10 <adetalhouet> #vote +1
18:40:12 <colindixon> #vote +1
18:40:12 <jamoluhrsen> #vote +1
18:40:13 <zxiiro> #vote +1
18:40:14 <vishnoianil> #vote +1
18:40:15 <anipbu> #vote +1
18:40:15 <abhijitkumbhare> #vote +1
18:40:16 <rovarga> #vote +1
18:40:16 <edwarnicke> #vote +1
18:40:17 <hideyuki> #vote +1
18:40:19 <afredette> #vote +1
18:40:30 <skitt> #vote +1
18:40:47 <colindixon> #endvote
18:40:47 <odl_meetbot> Voted on "shall we hold the first APAC-friendly time-zone call next week at 8:30p pacific on Thursday, December 22nd?" Results are
18:40:47 <odl_meetbot> +1 (12): rovarga, adetalhouet, afredette, skitt, zxiiro, edwarnicke, hideyuki, colindixon, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
18:40:48 * rovarga hoped it would start a bit later after the winter solstice, but this will work, too
18:41:01 * adetalhouet agrees with edwarnicke :) I live by the calendar
18:41:39 <colindixon> #agreed we will have the TSC on 12/22 at 8:30p pacific
18:43:19 <colindixon> #agreed going forward, we will have the TSC call on the fourth Thursday of every month at 8:30p pacific (which is either 10a or 9a in India)
18:43:38 <colindixon> #action CaseyODL to update the relevant calendars
18:44:22 <colindixon> #info hideyuki ask if it's PDT or PST, the answer is whatever one the west coast is currently observing
18:45:00 <colindixon> #topic RCs and blocking bugs
18:45:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006428.html
18:45:43 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-December/006463.html some options
18:45:52 <colindixon> We should make "only blocking bug fixes allowed" happen at least by RCX for offset X that is offset 0 at RC0, offset 1 at RC1 and offset 2 at RC2. This seems like a no-brainer and we should just vote on it today.
18:46:17 * edwarnicke enjoys the editorialization at the end ;)
18:47:31 <edwarnicke> #info edwarnicke notes that it is not healthy in general to revise release plans in the middle of the release
18:47:34 <edwarnicke> <end rant>
18:49:10 <colindixon> #info colindixon says his take is really that we should only be fixing blocking bugs during RCs, but others seem to worry that's too strict at least now
18:50:43 <colindixon> #info vishnoianil says he agrees, having RC2 for offset 2 meaning that we might not be reducing our risk of slipping very much
18:51:45 <colindixon> #info to be clear, both vishnoianil and colindixon don't agree with the proposal to have "only blocking bug fixes allowed" at least by RCX for offset X, but would push harder
18:52:21 <colindixon> #info rovarga restates basically the same thing that unless you start saying only blocking bugs are fixed in RCs, then they're not really RCs
18:54:03 <colindixon> the other proposal was really after RC0, we're only fixing blocking bugs
18:54:08 <colindixon> which was the original proposal
18:54:47 <colindixon> to be fair, the "not as much time" that offset 1 and offset 2 projects is really just because we have to wait for offset 2 to "catch up" before we start RCs
18:54:59 <colindixon> there's no way to fix that
18:55:14 <colindixon> vishnoianil: I muted you
18:55:40 <vishnoianil> colindixon, ack
18:55:53 <colindixon> #info abhijitkumbhare asks if the offsets are actually helping us anymore
18:57:09 <colindixon> #info rovarga notes that it really does help in his experience, colindixon notes that it was proposed based on realy painful things in previous releases
18:59:54 <colindixon> #startvote shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC0: only blocking bug fixes after RC0, or (c) only blocking bug fixes for offset X after RCX? a, b, c
18:59:54 <odl_meetbot> Begin voting on: shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC0: only blocking bug fixes after RC0, or (c) only blocking bug fixes for offset X after RCX? Valid vote options are a, b, c.
18:59:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:00:18 <colindixon> #endvote
19:00:18 <odl_meetbot> Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC0: only blocking bug fixes after RC0, or (c) only blocking bug fixes for offset X after RCX?" Results are
19:00:30 * edwarnicke has an impish desire to see the number of options require the use of greek characters... ;)
19:00:57 <colindixon> #startvote shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX? a, b, c
19:00:57 <odl_meetbot> Begin voting on: shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX? Valid vote options are a, b, c.
19:00:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:01:00 <colindixon> #endvote
19:01:00 <odl_meetbot> Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX?" Results are
19:01:03 <colindixon> #startvote shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX? a, b, c, d
19:01:03 <odl_meetbot> Begin voting on: shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX? Valid vote options are a, b, c, d.
19:01:03 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:01:16 <rovarga> #vote c
19:01:17 <adetalhouet> #vote c
19:01:23 <jamoluhrsen> #vote c
19:01:23 <skitt> #vote c
19:01:24 <colindixon> #vote c
19:01:26 <zxiiro> #vote c
19:01:27 <edwarnicke> #vote c
19:01:27 <vishnoianil> #vote b
19:01:30 <abhijitkumbhare> #vote b
19:01:35 <hideyuki> #vote d
19:01:36 <LuisGomez> #vote b
19:01:38 <anipbu> #vote c
19:01:45 <afredette> #vote c
19:01:58 <colindixon> #endvote
19:01:58 <odl_meetbot> Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX?" Results are
19:01:58 <odl_meetbot> c (9): rovarga, adetalhouet, skitt, anipbu, edwarnicke, colindixon, jamoluhrsen, zxiiro, afredette
19:01:58 <odl_meetbot> b (3): LuisGomez, vishnoianil, abhijitkumbhare
19:01:58 <odl_meetbot> d (1): hideyuki
19:02:19 <colindixon> #agreed we will only allow blocking bug fixes in all projects after RC0
19:02:31 * adetalhouet has to drop. Glad we figured that out. Thanks Colin
19:02:40 <colindixon> #topic cookies
19:02:43 <colindixon> #endmeeting