17:02:54 <abhijitkumbhare> #startmeeting TSC Meeting Oct 6, 2016
17:02:54 <odl_meetbot> Meeting started Thu Oct  6 17:02:54 2016 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:54 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:54 <odl_meetbot> The meeting name has been set to 'tsc_meeting_oct_6__2016'
17:03:19 <vishnoianil> #info Anil Vishnoi
17:03:20 <abhijitkumbhare> #chair anipbu vishnoianil edwarnicke
17:03:20 <odl_meetbot> Current chairs: abhijitkumbhare anipbu edwarnicke vishnoianil
17:03:31 <rovarga> #info rovarga for jmedved
17:03:33 <abhijitkumbhare> #chair rovarga
17:03:33 <odl_meetbot> Current chairs: abhijitkumbhare anipbu edwarnicke rovarga vishnoianil
17:03:39 <adetalhouet> #info adetalhouet
17:03:40 <abhijitkumbhare> #info abhijitkumbhare
17:03:46 <ChrisPriceAB> #info Chris Price
17:04:32 <gkaempfer> #info gkaempfer
17:04:47 <vishnoianil> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda
17:05:25 <vlavor> #info vlavor
17:05:33 <edwarnicke> #info edwarnicke
17:06:43 <vishnoianil> #topic agenda
17:07:15 <vishnoianil> #action dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
17:07:28 <vishnoianil> #action colindixon to start a thread on when projects/committers need to be approved to participate how in elections
17:07:39 <vishnoianil> #action LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
17:08:36 <vishnoianil> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:08:50 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-October/008369.html <--- email to discuss CSIT running in private and/or public cloud
17:09:14 <vishnoianil> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
17:09:27 <vishnoianil> #action phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
17:09:47 <vishnoianil> #action ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
17:10:26 <vishnoianil> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
17:10:59 <vishnoianil> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal#Election_Mechanics dfarrell07 merged vote-per-committer vs vote-per-interest corner case proposal into framework
17:11:11 <vishnoianil> #link https://lists.opendaylight.org/pipermail/tsc/2016-October/006101.html colindixon started a thread on some of the future summit structure ideas
17:11:18 <vishnoianil> #info colindixon put APAC time zone on this week's schedule
17:11:39 <vishnoianil> #link https://bugs.opendaylight.org/show_bug.cgi?id=5995 colindixon made removal of org.json a blocking issue for carbon
17:12:13 <vishnoianil> #topic events
17:13:40 <vishnoianil> #topic Boron
17:14:06 <anipbu> #info Boron-SR1 release is in three weeks on October 27
17:14:14 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=6889   <--- The Boron Autorelease job failed to build bmp-mock.  We have reached out to the BGPCEP team.
17:15:02 <vishnoianil> #topic Stable/Beryllium
17:16:31 <vishnoianil> #info distribution check is currently failing
17:16:46 <vishnoianil> #info Patch is pushed to fix it
17:19:30 <vrpolak> The revert: https://git.opendaylight.org/gerrit/46629
17:19:43 <vishnoianil> #info above patch will be reverted to bring back distribution to green state
17:20:25 <LuisGomez> #link https://git.opendaylight.org/gerrit/#/c/46629/
17:20:29 <anipbu> #info The Beryllium-SR4 is in two weeks on October 20 with a cutoff on 10/16 23:59 UTC.
17:20:47 <anipbu> #info https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/beryllium   <--- 68 patches pending for stable/beryllium
17:21:50 <vishnoianil> #topic carbon
17:21:56 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#M0:_Declare_Intent   <--- We are currently missing M0 status from 23 projects: alto, atrium, capwap, cardinal, centinel, didm, dlux,, docs, eman, iotdm, mdsal, natapp, next, nic, openflowjava, sdninterfaceapp, snbi, snmp, ttp, usecplugin, vtn, yang-push, yangide
17:22:17 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-October/008390.html   <--- odlparent which will enforce Maven 3.3.9 or later throughout the project.
17:22:25 <anipbu> #link https://git.opendaylight.org/gerrit/46220   <--- Patch for enforcing Maven 3.3.9
17:22:41 <anipbu> #info With freestyle jobs we no longer have easy accessible webview into figuring out what's failing because we're not using the maven jenkins plugin.  Logs must be parsed manually.
17:27:48 <anipbu> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-September/000525.html   <--- Project Proposals Deadline
17:28:15 <vishnoianil> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006009.html
17:28:52 <anipbu> #undo
17:28:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2b779d0>
17:28:54 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006009.html   <--- TSC consider updating and formally approving the Carbon Simultaneous Release Plan
17:29:00 <vishnoianil> #topic System Integration and Testing
17:29:52 <vishnoianil> #topic Infrastructure
17:30:52 <vishnoianil> #info odl-force is finally happening :)
17:30:58 <abhijitkumbhare> #undo
17:30:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ad4b10>
17:31:15 <abhijitkumbhare> #info odl-forge is finally happening :)
17:31:24 <vishnoianil> thanks abhijitkumbhare :)
17:31:42 <abhijitkumbhare> odl already has the force vishnoianil :)
17:35:10 <vishnoianil> #topic Creation Reviews
17:35:53 <vishnoianil> #topic TSC Elections
17:36:25 <vishnoianil> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006097.html
17:36:56 <vishnoianil> #topic APAC time-zone TSC calls
17:37:03 <vishnoianil> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7
17:37:51 <vishnoianil> #topic APAC time-zone TSC calls
17:39:52 <vishnoianil> #topic Failure to follow the process causing delays/issues in Boron
17:42:07 <vishnoianil> #topic Singularity Principle
17:42:21 <vishnoianil> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html
17:43:47 <vishnoianil> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-08-04-17.00.html
17:45:30 <gkaempfer> +1 on Ed's arguments
18:04:19 <vishnoianil> #topic beer & cookies
18:04:29 <vishnoianil> #endmeeting