17:04:45 <colindixon> #startmeeting tws
17:04:45 <odl_meetbot> Meeting started Mon Apr 18 17:04:45 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:45 <odl_meetbot> The meeting name has been set to 'tws'
17:04:49 <colindixon> #topic agenda bashing
17:05:19 <colindixon> #info zxiiro will cover the maven site infrastructure and using it to set up (among other things) javadoc
17:05:53 <colindixon> #topic maven sites in OpenDaylight
17:06:26 <zxiiro> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.odlparent/boron/maven-site.html Maven site docs
17:06:27 <zxiiro> #link https://nexus.opendaylight.org/content/sites/site/ ODL Sites location
17:07:10 <skitt> #link https://git.opendaylight.org/gerrit/37609 an example patch (with Javadoc fix)
17:07:57 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/ example of the lisp flow mapping maven site that zxiiro uses to demonstrate
17:08:41 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/checkstyle-aggregate.html you can get lots of things in maven sites, e.g., checkstyle
17:09:06 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/apidocs/index.html possibly most important thing is Javadoc
17:09:39 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.odlparent/boron/maven-site.html the maven site that documents how to enable maven sites
17:09:58 <colindixon> #info zxiiro notes that the artifactId in the deploy-site.xml doesn't matter, only the group ID
17:11:11 <colindixon> #info zxiiro notes that you need to fix the maven site URL since we don't follow the standard maven directory structure it expects for sites
17:11:36 <colindixon> #info zxiiro points out that for all pom files but the root are just copy and pasting the example from the documentation here
17:12:55 <colindixon> #Info for the root pom, you need to remove the one line for the <url>, this is the root pom.xml in the project by directory, not necessarily by the parent relationship in pom files
17:13:43 <colindixon> #info zxiiro notes that you can do lots of things here including generating AsciiDoc, markdown, or static html documentaiton
17:14:41 <colindixon> #topic enabling aggregated Javadoc is described, you just need to past the maven-site profile from the maven sites docs above, into your root pom (again by directory, not parent)
17:14:46 <colindixon> #undo
17:14:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2936f50>
17:14:51 <colindixon> #topic Javadoc
17:15:02 <colindixon> #info enabling aggregated Javadoc is described, you just need to past the maven-site profile from the maven sites docs above, into your root pom (again by directory, not parent)
17:15:22 <colindixon> #info you also have to create a site.xml under src/site/site.xml
17:16:01 <colindixon> #info you want to generate things locally, you need to do maven site:deploy -Dstream=boron, but it will be done by merge jobs and uploaded automatically
17:16:30 <colindixon> #topic other things maven sites can do
17:17:02 <colindixon> #info colindixon says he knows you can get version convergence/skew information, it's part of "reports" in maven sites
17:17:46 <colindixon> #info zxiiro notes that reporting is just like a build section, but aimed at creating reports, you can add for example dependency-convergence
17:17:53 <zxiiro> #link https://maven.apache.org/plugins/maven-site-plugin/examples/configuring-reports.html maven-site reporting
17:19:53 <colindixon> #info colindixon asks if we can enable dependency-convergence reporting on autorelease to give us an idea of when we have version skew and where in an official, supported capacity
17:20:06 <colindixon> #info zxiiro says we could, but it and several other plugins will siginficantly affect build time
17:20:38 <colindixon> #info skitt says there are lots of little gotchas, lots of projects already have a <url> field in their pom, those need to be removed
17:20:52 <skitt> #info not lots, just a couple :-)
17:21:07 <colindixon> #info skitt also says that when you enable javadoc, errors in your javadoc will break your build, so you need to fix them
17:21:54 <colindixon> #info zxiiro says he's seen random things where enabling maven sites causing checkstyle to start working, but only twice, you can either fix the problems or disable it (which is a bad idea)
17:23:18 <colindixon> #info zxiiro notes that this is all now in the archetype, so it will come for all new projects by default
17:24:24 <colindixon> #info lori asks if there's a way disable it by default, zxiiro says you need to disable maven-site generation locally, zxiiro says that you can do it by passing -P!maven-site to your local build to disable that profile
17:25:08 <colindixon> #info rovarga asks if we can have it disabled by default and then enabled in jenkins
17:26:19 <colindixon> #info zxiiro says there's no way to do that and have conditional activation by file and have it disabled by default
17:26:49 <colindixon> #action zxiiro to send an e-mail about how to disable maven-sites locally in one-time and semi-permanent ways
17:27:55 <colindixon> #info colindixon suggests either through the MAVEN_OPTS environment variable
17:29:04 <colindixon> #Info or maybe via settings.xml (but that might not override pom files)
17:29:31 <colindixon> #topic next week's TWS
17:29:49 <colindixon> #info colindixon asks if we should have a TWS next week or everyone will be at OpenStack
17:30:05 <colindixon> #startvote should we have a TWS next week? -1,0,+1
17:30:05 <odl_meetbot> Begin voting on: should we have a TWS next week? Valid vote options are -1, 0, +1.
17:30:05 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:30:11 <colindixon> #vote 0
17:30:26 <LuisGomez> #vote 0
17:30:27 <hideyuki> #vote 0
17:30:37 <skitt> #vote 0
17:30:51 <adetalhouet> #vote 0
17:30:58 <lori> #vote 0
17:31:03 <phrobb> -1 I'll be on a plane
17:31:12 <phrobb> #vote -1
17:31:12 <colindixon> phrobb: want to #vote that?
17:31:35 <colindixon> #endvote
17:31:35 <odl_meetbot> Voted on "should we have a TWS next week?" Results are
17:31:35 <odl_meetbot> 0 (6): adetalhouet, skitt, LuisGomez, hideyuki, colindixon, lori
17:31:35 <odl_meetbot> -1 (1): phrobb
17:31:44 <colindixon> #Info we are violently neutral with one conflict
17:35:38 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout current pom file best practices
17:36:08 <colindixon> #action zxiiro and/or rovarga should probably fold that into the maven sites info or vice versa
17:36:29 <colindixon> #info colindixon says probably carbon planning would be the most important thing to do next week if we have the meeting
17:36:44 <colindixon> #action colindixon to send an e-mail asking if we can get presenters for carbon planning for next week
17:37:02 <colindixon> #endmeeting