#opendaylight-meeting: tws

Meeting started by anipbu at 17:05:51 UTC (full logs).

Meeting summary

  1. NetVirt VPNService Migration (anipbu, 17:07:02)
    1. daya discuses the VPNService Components in Beryllium (anipbu, 17:09:40)
    2. https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration <--- Wiki page summarizing the migration effort (anipbu, 17:10:51)
    3. daya says there were many overlaps between netvirt and vpnservice. (anipbu, 17:11:47)
    4. daya lists the goals of the migration effort as follows: (anipbu, 17:12:25)
    5. A common service pipeline between VPN project and OVSDB - NetVirt, with shared development on a common set of services (anipbu, 17:12:38)
    6. Achieve maximum leverage of code, test, and developer resources (anipbu, 17:12:45)
    7. A modular framework of network applications and device renderers that makes addition of new functions efficient (anipbu, 17:12:53)
    8. Co-existence and cooperation between different services in running systems, with minimal design coordination and hard-coded dependencies (anipbu, 17:13:01)
    9. Current status (Jun 20 2016): all code from VPN service migrated to netvirt project/ genius project (anipbu, 17:23:18)
    10. netvirt services updated to use genius project interfaces (anipbu, 17:23:39)
    11. feature parity work in progress (anipbu, 17:23:50)
    12. daya states that VPNservice components have been removed completely. (anipbu, 17:25:27)
    13. daya states there will not be dual implementations existing (anipbu, 17:26:08)
    14. sam states perhaps unimgr will use new netvirt using genius. (anipbu, 17:38:29)
    15. sam states no projects depending on old netvirt (anipbu, 17:38:37)
    16. colin asks if we have verified that no projects are using old netvirt (anipbu, 17:39:45)
    17. sam states there were projects who were pulling in the wrong artifacts but they have been fixed. (anipbu, 17:41:02)
    18. sam states we are in touch with opnfv folks (anipbu, 17:41:53)
    19. ACTION: daya will post the slides (anipbu, 17:43:49)

  2. cookies (anipbu, 17:43:53)


Meeting ended at 17:44:02 UTC (full logs).

Action items

  1. daya will post the slides


People present (lines said)

  1. anipbu (30)
  2. odl_meetbot (7)
  3. CaseyODL (1)
  4. phrobb (0)
  5. colindixon (0)


Generated by MeetBot 0.1.4.