17:05:51 <anipbu> #startmeeting tws
17:05:51 <odl_meetbot> Meeting started Mon Jun 27 17:05:51 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:51 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:51 <odl_meetbot> The meeting name has been set to 'tws'
17:06:37 <anipbu> #chair anipbu phrobb CaseyODL colindixon
17:06:37 <odl_meetbot> Warning: Nick not in channel: colindixon
17:06:37 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon phrobb
17:07:02 <anipbu> #topic NetVirt VPNService Migration
17:09:40 <anipbu> #info daya discuses the VPNService Components in Beryllium
17:10:51 <anipbu> #link https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration   <--- Wiki page summarizing the migration effort
17:11:47 <anipbu> #info daya says there were many overlaps between netvirt and vpnservice.
17:12:25 <anipbu> #info daya lists the goals of the migration effort as follows:
17:12:38 <anipbu> #info A common service pipeline between VPN project and OVSDB - NetVirt, with shared development on a common set of services
17:12:45 <anipbu> #info Achieve maximum leverage of code, test, and developer resources
17:12:53 <anipbu> #info A modular framework of network applications and device renderers that makes addition of new functions efficient
17:13:01 <anipbu> #info Co-existence and cooperation between different services in running systems, with minimal design coordination and hard-coded dependencies
17:23:18 <anipbu> #info Current status (Jun 20 2016): all code from VPN service migrated to netvirt project/ genius project
17:23:39 <anipbu> #info netvirt services updated to use genius project interfaces
17:23:50 <anipbu> #info feature parity work in progress
17:25:27 <anipbu> #info daya states that VPNservice components have been removed completely.
17:26:08 <anipbu> #info daya states there will not be dual implementations existing
17:35:09 <anipbu> #info sam states netvirt will use genius in Boron release
17:36:57 <anipbu> #info there will be two dual implemenation of the netvirt old and new using genius, with the expectation of projects to use the new using genius.
17:37:32 <anipbu> #sam states perhaps unimgr will use new netvirt using genius.
17:38:09 <anipbu> #sam states no projects depending on old netvirt
17:38:16 <anipbu> #undo
17:38:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x232d4d0>
17:38:19 <anipbu> #undo
17:38:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24682d0>
17:38:29 <anipbu> #info sam states perhaps unimgr will use new netvirt using genius.
17:38:37 <anipbu> #info sam states no projects depending on old netvirt
17:39:45 <anipbu> #info colin asks if we have verified that no projects are using old netvirt
17:41:02 <anipbu> #info sam states there were projects who were pulling in the wrong artifacts but they have been fixed.
17:41:53 <anipbu> #info sam states we are in touch with opnfv folks
17:43:31 <CaseyODL> at some point we need to talk StackOverflow migration from AskBot
17:43:49 <anipbu> #action daya will post the slides
17:43:53 <anipbu> #topic cookies
17:44:02 <anipbu> #endmeeting