#opendaylight-meeting: tws

Meeting started by colindixon at 17:00:34 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:00:38)
    1. dfarrell07 and phrobb will talk about TSC elections today (colindixon, 17:02:03)
    2. https://wiki.opendaylight.org/view/TSC:Election_Proposal Elections Proposal wiki, main source of truth (dfarrell07, 17:04:18)

  2. TSC elections (colindixon, 17:05:12)
    1. Wiki describes: background, principles, Framework, Represented Group proposals (dfarrell07, 17:05:12)
    2. ODL didn't have community of experienced ppl to draw TSC from initially, so bootstrapped with Platinum Designates (dfarrell07, 17:07:28)
    3. Wanted to move from Platinum Designates to community-elected ppl (dfarrell07, 17:08:32)
    4. Need to change election system made more pressing by Board's refusal to give waver for bad feature of system caused by PDs (dfarrell07, 17:08:37)
    5. Representation of Constituencies: There are systemically competing groups in ODL community, they should be represented (dfarrell07, 17:09:33)
    6. Protection from Dominance by a Constituency: There should be systematic protections from dominance by a group, especially a company (dfarrell07, 17:11:01)
    7. Fairness of Exclusion: Caps, which are necessary for other properties, can cause people to be excluded. This should be fair/clear, to mitigate hard feelings (dfarrell07, 17:11:56)
    8. Modern Election Tools: Elections are complex, we should use modern best practices (dfarrell07, 17:12:35)
    9. Flexibility over Time: We need a framework that change change as ODL changes, and as we learn (dfarrell07, 17:13:22)
    10. Fixed portion stays the same election to election, RGs swapped out to allow Flexibility over Time (dfarrell07, 17:14:08)
    11. Multi-election, multi-winner - one election for each RG, no less than Min Seats winners, no more than Max Seats winners (dfarrell07, 17:14:35)
    12. Key concept: Represented Groups - group of ODL community members with similar interest, that complete with other community groups (dfarrell07, 17:14:47)
    13. RGs defined by: min seats, max seats, candidates, voters (dfarrell07, 17:14:59)
    14. abhijitkumbhare asks how represented groups work in terms of who votes, the answer is that the candidates and the electorate are the same, usually that is PTLs of the relevant projects (colindixon, 17:21:57)
    15. the exception is comitters-at-large where the electorate and the voters are both all committers of OpenDaylight (colindixon, 17:22:21)
    16. for project categories, that's one vote per project, for committer-at-large it's one vote per committer (colindixon, 17:22:44)
    17. dfarrell07 notes that isn't set in stone, but it's how it's written now (colindixon, 17:23:51)
    18. rovarga asks how things work if you're the PTL of multiple projects in the same class, e.g., mdsal and controller, the answer is they'd get two votes at least now and that would need two e-mails (colindixon, 17:24:52)
    19. ACTION: dfarrell07 to make having multiple votes in the same election more explicit (colindixon, 17:25:07)
    20. dfarrell07 goes into the election mechanics (colindixon, 17:28:14)
    21. https://wiki.opendaylight.org/view/TSC:Election_Proposal#Election_Mechanics (colindixon, 17:28:30)
    22. dfarrell07 explains over-max resolution and scaled popularity (colindixon, 17:32:03)
    23. colindixon asks how this mechanically will work if we have to trigger over-max resolution (colindixon, 17:36:18)
    24. dfarrell07 says right now, the figuring out who to drop would be done manually, that math is generally easy (colindixon, 17:37:20)
    25. after that you basically just elimnate that person and then see what happens (colindixon, 17:40:54)
    26. colindixon asks about very specific low-level details like how you get scaled-popularity to work, e.g., is i the number of people who picked that person as the first choice, or the number of people who prefered the first choice over the second choice? (colindixon, 17:41:32)
    27. colindixon asks if we even get raw votes, phrobb says that he thinks you can as one of the settings (colindixon, 17:43:20)
    28. phrobb confirms we get raw data that can be easiliy exported to google spreadsheet (colindixon, 17:47:04)
    29. abhijitkumbhare asks about mins and maxes, the basic idea is that min is the number of seats that come out of an election, max is the number of people who meet that "description" who are allowed to win seats in *any* election (colindixon, 17:48:03)
    30. abhijitkumbhare asks if we really need max caps on things other than companies, dfarrell07 and colindixon say that generally, its for fairness and edwarnicke is the biggest advocate for it (colindixon, 17:54:43)
    31. the idea is that if you're afraid of a company dominating, then you should also be afraid of other groups dominating (colindixon, 17:55:08)
    32. vishnoianil thinks he'd rather see committers vote than just PTLs, rovarga and abhijitkumbhare seem to think PTLs would be better (colindixon, 17:59:41)
    33. rovarga and abhijitkumbhare think PTLs should be better because to avoid gaming the system (abhijitkumbhare, 18:00:47)
    34. rovarga points out that we want to make sure we can't game the system with incubation projects and comitters there (colindixon, 18:00:53)
    35. colindixon notes that most RG sets we look at don't include incubation, which is probably a good thing for that reason among others (colindixon, 18:01:24)
    36. Discussion about Integration RG having value, def have different interest/needs than mature projects, good to have their voice, not always looking for most experience, also need various views on TSC (dfarrell07, 18:05:47)


Meeting ended at 18:05:50 UTC (full logs).

Action items

  1. dfarrell07 to make having multiple votes in the same election more explicit


Action items, by person

  1. dfarrell07
    1. dfarrell07 to make having multiple votes in the same election more explicit


People present (lines said)

  1. colindixon (29)
  2. dfarrell07 (20)
  3. odl_meetbot (5)
  4. abhijitkumbhare (2)
  5. phrobb (1)


Generated by MeetBot 0.1.4.