13:59:34 <anipbu> #startmeeting carbon release review
13:59:34 <odl_meetbot> Meeting started Thu May 18 13:59:34 2017 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:59:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:34 <odl_meetbot> The meeting name has been set to 'carbon_release_review'
13:59:41 <anipbu> #topic roll call
13:59:48 <anipbu> #info PTL and TSC members please #info in
13:59:56 <colindixon> #info colindixon (TSC)
13:59:58 <anipbu> #info anipbu
14:00:04 <gdavid_comp_> #info gdavid for unimgr
14:00:07 <aleckey> #info aleckey for NetIDE
14:00:10 <anipbu> #chair zxiiro colindixon
14:00:10 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
14:00:40 <zxiiro> #info Thanh
14:00:53 <anipbu> Good morning folks.
14:00:56 <anipbu> Let's begin.
14:01:07 <anipbu> #topic UNIMGR
14:01:13 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57201/   <-- Release Notes
14:01:18 <anipbu> #info David Goldberg is representing UNIMGR
14:01:24 <anipbu> Anything you would like to add?
14:01:33 <gdavid_comp_> anipbu: no
14:01:47 <anipbu> gdavid_comp_: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:01:53 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:02:17 <gdavid_comp_> i tested and no blockers were find
14:02:28 <gdavid_comp_> all of our features are expirimental
14:03:18 <colindixon> #info there are some small comments on the release notes patch, but the only ones of substance are: 1) a bunch of the CSIT tests are failing despite having passed in teh recent past, and 2.) it would be good to describe how and what was manually tested
14:03:26 <ebrjohn> #info Brady Johnson
14:03:44 <anipbu> #info UNIMGR has tested RC1 and found no blockers
14:04:09 <anipbu> #info unimgr has reviewed CSIT failures and marked them as ignore
14:04:42 <anipbu> #info all unimgr features are experimental as stated on the release notes
14:05:16 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/265/archives/docs/_build/html/getting-started-guide/project-release-notes/unimgr.html.gz html format of current release notes/review
14:05:31 <anipbu> gdavid_comp_: could you follow up on the comments on your release notes patch?  specifically the ones colindixon stated above
14:05:41 <gdavid_comp_> anipbu: yes
14:05:43 <anipbu> #action gdavid_comp_ to follow up on comments on release notes patch
14:06:48 <anipbu> gdavid_comp_: were there any major changes in this release or is your project in maintenance mode?
14:07:05 <gdavid_comp_> anipbu: most API's had changes in them
14:07:25 <anipbu> #info unimgr has major changes in API in this release
14:07:26 <gdavid_comp_> and some capabilities were added to current features
14:08:26 <anipbu> gdavid_comp_: could you add a small clarification on the API changes in the release notes?  I mean, just so end users know what might have changed
14:08:40 <gdavid_comp_> anipbu: sure
14:08:53 <anipbu> UNIMGR looks good to me
14:09:09 <anipbu> Any additional comments from folks?  colindixon, zxiiro?
14:09:40 <colindixon> no, I thnk the testing issues I pointed out above are it and if it's experimental…
14:09:51 <zxiiro> no. just my comments in the gerrit.
14:10:14 <anipbu> okay let's move on
14:10:19 <anipbu> #info UNIMGR approved for Carbon pending action items and follow up.  Congratulations!
14:10:25 <gdavid_comp_> thanks folks
14:10:26 <anipbu> #topic NETIDE
14:10:32 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57278/   <-- Release Notes
14:10:38 <anipbu> #info Alec Leckey is representing NETIDE
14:10:43 <anipbu> Anything you would like to add?
14:10:53 <aleckey> Saw colindixon's comments on the release notes in gerrit. I'll address and push a patch in next hour
14:11:00 <anipbu> aleckey: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:11:06 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:11:18 <aleckey> Tested against RC1, all good. Will update spreadsheet
14:11:27 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/262/archives/docs/_build/html/getting-started-guide/project-release-notes/netide.html.gz HTML version of the current draft release notes/review
14:12:27 <aleckey> netide features are experimental
14:12:49 <anipbu> aleckey: could you update the spreadsheet right now so we can move forward with the review?
14:13:02 <aleckey> OK
14:13:11 <colindixon> #info there are some minor comments on the patch, but the only substantive comment I have is that it's note really clear what's tested and how much
14:13:31 <anipbu> aleckey: columns C through H on this spreadsheet https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
14:14:06 <anipbu> #info All NETIDE features are experimental as stated on the release notes
14:14:34 <aleckey> We use a manual system test. Steps documented here: https://wiki.opendaylight.org/view/NetIDE:Carbon:System_Test
14:15:32 <anipbu> #info netide has tested RC1 and found no blockers
14:15:41 <aleckey> anipbu: updated spreadsheet
14:16:15 <anipbu> #info netide has no CSIT test failures on integration-distribution-test job
14:16:23 <anipbu> aleckey: thanks
14:17:11 <anipbu> aleckey: Did your project build any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:17:34 <aleckey> No new features, just maintenance
14:18:02 <anipbu> #info netide is mostly in maintenance mode this release
14:18:27 <anipbu> NETIDE looks good to me
14:18:33 <anipbu> Any additional comments from folks?
14:20:26 <anipbu> Looks like no additional comments from folks
14:20:40 <anipbu> #action aleckey to follow up on comments on the release notes patch
14:21:03 <anipbu> Okay Let's move on
14:21:06 <anipbu> #info NETIDE approved for Carbon pending action items and follow up.  Congratulations!
14:21:11 <anipbu> #topic SFC
14:21:17 <anipbu> #link https://git.opendaylight.org/gerrit/57284   <-- Release Notes
14:21:23 <anipbu> #info Brady Johnson is representing SFC
14:21:24 <ebrjohn> Hello, Brady Johnson here representing SFC
14:21:28 <anipbu> Anything you would like to add?
14:21:34 <ebrjohn> I saw colindixon's comments on the SFC Carbon release notes in gerrit. I addressed them and pushed a patch set. Waiting for verification.
14:21:43 <anipbu> ebrjohn: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:21:50 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:21:52 <ebrjohn> We tested against RC1, and everything is ok. I updated the spreadsheet.
14:22:00 <ebrjohn> I didnt get a chance yet to mark off any CSIT test failures as IGNORED.
14:22:04 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/278/archives/docs/_build/html/getting-started-guide/project-release-notes/sfc.html.gz HTML for current draft release notes/review
14:22:18 <anipbu> ebrjohn: column D is not updated
14:22:30 * ebrjohn looking now
14:23:00 <ebrjohn> I just updated it now, sorry about that
14:23:23 <colindixon> #info there are some minor comments on the release notes patch, other than the test failures I've got nothing else to really add
14:23:49 <ebrjohn> colindixon: I addressed the comments with patch set 4
14:23:49 <colindixon> #info thank you for the details about removed features and migration issues, that was really nice to see
14:23:54 <anipbu> ebrjohn: SFC has two CSIT test failures.  Could we mark it as IGNORE if you see that it is appropriate?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:24:00 <colindixon> cool haven't had a chance to look at those yet
14:24:10 <ebrjohn> anipbu: sure, I'll do that right after the review
14:24:18 <ebrjohn> colindixon: happy to provide usefull info
14:25:42 <anipbu> #action ebrjohn to follow up on the CSIT test failures  <---  This is important
14:26:09 <anipbu> #info SFC has tested RC1 and found no blockers
14:26:10 <ebrjohn> anipbu: I should have this done in about 10 minutes, how do I inform you about completion of the action point?
14:26:34 <anipbu> #info SFC has CSIT test failures which they will review and update the spreadsheet as appropriate
14:26:55 <anipbu> ebrjohn: you can just send us a message on IRC here, we'll be here until 10 AM PT
14:27:05 <ebrjohn> anipbu:  ok, will do
14:27:41 <anipbu> ebrjohn: Nice job with the quality assurance section, lots of test coverage.  =)
14:28:11 <ebrjohn> anipbu: Thanks!
14:28:12 <anipbu> #info SFC has a mixure of both experimental and nonexperimental features as stated in the release notes
14:28:31 <anipbu> ebrjohn: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:28:47 * ebrjohn thinking Cool new features is very relative...
14:29:15 <ebrjohn> anipbu: Yes, we add new features, mainly to integrate with the ODL Genius project and to add the Logicall SFF
14:29:28 <ebrjohn> anipbu: we're definitely not in maintenance mode :)
14:29:42 <anipbu> #info cool new feature for SFC in this release is integration with ODL Genius and add Logical SFF
14:30:34 <anipbu> ebrjohn: we should integrate SFC into ONAP/ECOMP (maybe discuss offline).  would love to se this feature be used by telecoms !!!
14:30:46 <anipbu> SFC looks good to me
14:31:00 <ebrjohn> anipbu: that would be awesome!! Ive had that idea rolling around in my head for a while now :)
14:31:06 <anipbu> Any additional comments from folks?
14:31:47 * ebrjohn has the jeapordy theme song on in the background while waiting for comments...
14:32:40 <anipbu> #action ebrjohn to follow up on the comments on the release notes patch
14:32:42 <anipbu> Okay let's move on
14:32:47 <anipbu> #info SFC approved for Carbon pending action items and follow up.  Congratulations!
14:32:52 <anipbu> #topic OPENFLOWJAVA
14:32:54 <ebrjohn> Thanks everybody, its been a fun release!!
14:32:56 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57356/   <-- Release Notes
14:33:02 <anipbu> #info Michal Rehak is representing OPENFLOWJAVA
14:33:07 <anipbu> Anything you would like to add?
14:33:31 <anipbu> michal_rehak: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:33:36 <michal_rehak> anipbu: nope - maintenance release
14:33:45 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:34:06 <michal_rehak> anipbu: unfortunately there are no CSIT for ofjava - relying on openflowplugin project
14:34:17 <michal_rehak> anipbu: ofPlugin is the main consumer
14:34:26 <colindixon> michal_rehak: that's fine, it would be good to put a link to their CSIT jobs
14:34:45 <anipbu> michal_rehak: could you mark the spreadsheet about your status on RC1 https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:34:50 <colindixon> I just provided feedback (mostly formatting-related) on the patch
14:34:52 <michal_rehak> ok, I will update release notes
14:35:12 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/281/archives/docs/_build/html/getting-started-guide/project-release-notes/openflowjava.html.gz HTML version of current draft release notes/review
14:36:01 <anipbu> michal_rehak: any chance you could update the spreadsheet right now so we can move forward with the review?  Only need Columns C through H?    https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
14:36:39 <colindixon> jamoluhrsen, zxiiro, anipbu: are the OFP tests stable enough that we're calling OFP/OFJ not experimental?
14:37:17 <anipbu> colindixon: openflowjava has test waiver from integration team, so i believe their do you have the same test requirements for nonexperimental
14:37:41 <zxiiro> we'll need jamoluhrsen or LuisGomez to comment as they watch the tests the most
14:37:49 <colindixon> we can come back to it, but I guess that would mean they would rely on OFP's tests
14:38:27 <anipbu> michal_rehak: will you be able to update the spreadsheet now so we can move forward?
14:38:30 <michal_rehak> anipbu: I will rahter wait for openflowplugin team and their release notes - in fact there was no change in carbon except karaf4 features
14:38:48 <anipbu> michal_rehak: okay
14:40:31 <anipbu> #action openflowjava will discuss with openflowplugin team and update the spreadsheet
14:40:52 <anipbu> #action openflowjava will follow up on testing RC1 and update the spreadsheet afterwards
14:41:07 <michal_rehak> anipbu: is it ok just to update the spread sheet or do I need to drop an email?
14:41:27 <anipbu> michal_rehak: just update the spreadsheet adn send us an IRC message or email
14:41:36 <anipbu> we'll be here until 10 AM PT
14:41:45 <michal_rehak> anipbu: ok
14:42:08 <anipbu> #info some discussion on whether openflowjava is experimental is needed
14:42:18 <anipbu> Do folks have any additional comments?
14:42:33 <colindixon> nothing more
14:42:56 <zxiiro> none from me
14:43:12 <anipbu> #info OPENFLOWJAVA requires follow up on Action Items.
14:43:18 <anipbu> Okay Let's move on
14:43:27 <Kai_> Hi, Kai here representing ALTO.
14:43:28 <anipbu> #topic ALTO
14:43:32 <anipbu> #link https://git.opendaylight.org/gerrit/57220/    <-- Release Notes
14:43:34 <ebrjohn> anipbu: I just completed my action point by updating the failing tests spreadsheet marking them as IGNORE
14:43:37 <anipbu> #info Kai Gao is representing ALTO
14:43:43 <anipbu> Anything you would like to add?
14:43:49 <Kai_> I have submitted a new patch set according to Colin's comments.
14:44:00 <anipbu> Kai_: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:44:18 <Kai_> Tested. No blocker bugs.
14:44:21 <Kai_> Will do.
14:44:43 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/250/archives/docs/_build/html/getting-started-guide/project-release-notes/alto.html.gz HTML version of the previous patch set (still useful)
14:45:10 <anipbu> Kai_: column G is missing
14:45:13 <Kai_> I use pandoc to parse the file locally and it should be fine now.
14:46:08 <Kai_> Just filled in column G
14:47:43 <colindixon> cool, I have some more feedback on the patch, but nothing critical
14:48:00 <Kai_> OK. Let's fix it offline.
14:48:12 <anipbu> #info ALTO has tested RC1 and found no blockers
14:48:25 <anipbu> #info ALTO has not CSIT failures on integration-distribution-test-job
14:48:42 <anipbu> Kai_: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:49:01 <Kai_> Unfortunately not. We failed to deliver them in time.
14:49:16 <anipbu> #info All ALTO features are experimental as stated on the release notes.
14:49:30 <anipbu> #info ALTO does not have major changes in this release
14:49:39 <Kai_> But we do have major changes by migrating the namespaces, as stated in the release notes.
14:49:47 <anipbu> #undo
14:49:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dc9690>
14:49:50 <Kai_> Sorry I should have typed faster.
14:50:09 <anipbu> #info ALTO has major changes in migrating namespaces
14:50:25 <anipbu> Kai_: could you please follow up with the comments on the release notes patch from colindixon?
14:50:32 <Kai_> Sure.
14:50:37 <anipbu> #action Kai_ to follow up on the comments on the release notes patch
14:51:04 <anipbu> #info ALTO CSIT tests are passing: https://jenkins.opendaylight.org/releng/view/alto/job/alto-csit-1node-setup-all-carbon/
14:51:16 <anipbu> ALTO looks good to me
14:51:21 <anipbu> Any additional comments from folks?
14:51:24 <Kai_> Great. Thanks.
14:51:32 <anipbu> Okay Let's move on
14:51:38 <anipbu> #info ALTO approved for Carbon pending action items and follow up.  Congratulations!
14:51:47 <anipbu> #topic CARDINAL
14:51:52 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57268/    <-- Release Notes
14:51:57 <anipbu> #info Subodh is representing CARDINAL
14:52:02 <anipbu> Anything you would like to add?
14:52:17 <anipbu> subh: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:52:49 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/249/archives/docs/_build/html/getting-started-guide/project-release-notes/cardinal.html.gz HTML version of current draft release notes/review
14:53:19 <anipbu> subh: Good morning, are you online?
14:54:04 <colindixon> #info there's a lot of feedback on the patch: major concerns: 1.) don't you run an SNMP server? on what port? secured how? 2.) is migration with data supported? 2.) more details about what was tested
14:54:16 <anipbu> So it looks like cardinal signed up for two timeslots
14:54:37 <anipbu> They seemed to ahve signed up for the 8:40 timeslot
14:54:55 <colindixon> OK
14:55:09 <anipbu> Let's take a short break until the carbon release sync at 8:00 AM
14:55:12 <anipbu> five minutes everyone
14:55:15 <colindixon> thanks anipbu
14:55:46 <jamoluhrsen> colindixon, anipbu: checking in
14:57:38 <zxiiro> welcome!
14:58:48 <subh> hello anipbu
14:58:52 <subh> good morning
15:01:56 <colindixon> anipbu: we're waiting on the zoom whenever
15:08:32 <abhijitkumbhare> Hi folks
15:08:54 <abhijitkumbhare> Wasn’t there a release meeting anipbu colindixon
15:09:11 <anipbu> abhijitkumbhare: yes, we're meeting right now
15:09:17 <abhijitkumbhare> OK
15:09:32 <anipbu> subh: your timeslot is at 8:40.  see you then.
15:09:38 <abhijitkumbhare> I had to drop the kid to school - just back
15:19:50 <anipbu> #topic DIDM
15:19:55 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57304/    <-- Release Notes
15:20:01 <anipbu> #info Subhash Kumar Singh is representing DIDM
15:20:08 <anipbu> Anything you would like to add?
15:20:27 <anipbu> subh: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:20:41 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/241/archives/docs/_build/html/getting-started-guide/project-release-notes/didm.html.gz HTML of current draft release notes/review
15:21:17 <anipbu> subh: are you online?
15:22:13 <subh> hello anipbu
15:22:16 <anipbu> Hi
15:22:21 <anipbu> Could you update the spreadsheet?
15:22:30 <jamoluhrsen> are we doing DIDM?
15:22:34 <anipbu> subh:  could you update the spreadsheet?
15:22:37 <anipbu> Yes, we are doing DIDM
15:23:01 <anipbu> subh: good morning.  do you have anuthing additional you would like to add for DIDM?
15:23:12 <subh> no
15:23:25 <anipbu> subh: could you update the spreadsheet?
15:23:26 <subh> for this release we did not added anything
15:23:40 <anipbu> subh: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:24:43 <subh> okay sure
15:25:09 <anipbu> subh: could you update the spreadsheet right now so we can move forward with the review?
15:25:33 <subh> I have update the spreadsheet
15:25:43 <colindixon> #info the only comment I have is that the CSIT is all failing…
15:26:12 <jamoluhrsen> I gave an email about CSIT last night.
15:26:30 <anipbu> subh: we need columns C though H updated
15:26:38 <jamoluhrsen> didm is 100% experimental so didn't want to block release review on it, but I suggest they attend to it.
15:26:52 <colindixon> #info for what it's worth, sonar seems to get no code coverage information
15:27:53 <subh> Yes, but functionality i had tested it is okay
15:28:17 <anipbu> subh: Why is column F no?
15:28:48 <anipbu> subh: please take a moment to review the distribution test failures
15:28:56 <subh> Sorry, but I didn't spend the time to review it
15:29:17 <anipbu> #action DIDM to update the spreadsheet on RC1 testing
15:29:25 <anipbu> #action DIDM to follow up on the CSIT test failures
15:29:46 <anipbu> #info All DIDM features are marked as experimental as stated on the release notes
15:30:02 <subh> Okay sure
15:30:11 <anipbu> subh: please follow up on the release notes patch comments and feedback
15:30:43 <subh> yes, i will address it
15:30:49 <anipbu> Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:31:10 <subh> No new features
15:31:23 <anipbu> #info DIDM has not new features, in maintence mode
15:32:01 <anipbu> #info DIDM has required action items.  Its review is PENDING.
15:32:12 <anipbu> Any other comments from folks?
15:32:17 <colindixon> nope
15:32:18 <subh> Okay
15:32:18 <anipbu> Otherwise Let's move on
15:32:37 <jamoluhrsen> +1
15:32:40 <anipbu> subh: your project is not approved unitll the action items are addressed
15:33:04 <anipbu> subh: you need to test RC1, etc as stated in the action items above
15:33:09 <anipbu> #topic GENIUS
15:33:11 <subh> okay sure .. is it required to pass all the CSIT
15:33:14 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57248/    <-- Release Notes
15:33:18 <anipbu> #info Vivek Srivastava is representing GENIUS
15:33:21 <viveks_> Hi everyone
15:33:22 <anipbu> Anything you would like to add?
15:33:30 <viveks_> nothing specific
15:33:31 <colindixon> subh: no, but it would be good to know why they're failing and if you're not going to fix them to remove it
15:33:32 <anipbu> viveks_: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:33:36 <viveks_> btw, I took the liberty of adding a new section 'New capabilities and enhancements added in Carbon' in the release note. I hope it should be okay.
15:33:45 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/260/archives/docs/_build/html/getting-started-guide/project-release-notes/genius.html.gz HTML version of the current draft release notes/review
15:33:48 <subh> okay thanks colin
15:33:53 <viveks_> yes I haev updated the sheet
15:33:55 <anipbu> <viveks_> thanks for adding the new section =)
15:34:16 <anipbu> <viveks_> What is teh ETA on fixing the Blocker Bugs?
15:34:26 <viveks_> Genius CSIT has no blockers however we have couple of blocker bugs opened by netvirt and sfc
15:34:34 <viveks_> BUG 8332 is fixed, ready to merge.
15:34:36 <colindixon> #Info I provided some feedback on the patch, but the only major part was about the CSIT, the links go to patch-test-jobs, are those CSIT jobs?
15:34:43 <viveks_> https://git.opendaylight.org/gerrit/#/c/56354/
15:34:52 <viveks_> they are not blockers
15:35:00 <viveks_> also we dont see these in local setup/manual testing.
15:35:02 <jamoluhrsen> viveks_, we need status on 7451 too, I think
15:35:08 <anipbu> <viveks_> those blocker bugs are raised against GENIUS.  Could you follow up with the other projects to ensure they are closed before today?
15:35:10 <viveks_> these could be some test script/sandbox issue. we are looking into it.
15:35:22 <viveks_> BUG 7451 has two part fix, first one is merged, 2nd one is WIP
15:35:28 <viveks_> https://git.opendaylight.org/gerrit/#/c/56736/
15:35:34 <viveks_> https://git.opendaylight.org/gerrit/#/c/55926/
15:35:35 <anipbu> <viveks_>  are they real blockers in the sense that they impact end user and regression?
15:35:49 <viveks_> anyway for 7432, we already have a workaround in place.
15:35:56 <viveks_> https://git.opendaylight.org/gerrit/#/c/54247/
15:36:17 <viveks_> and we hope it will be resolved by last patch
15:36:18 <jamoluhrsen> viveks_, if patch-test passes on 55926 are we close to +2 and merge?
15:36:38 <viveks_> netvirt csit is running currently
15:36:49 <viveks_> yes
15:37:06 <jamoluhrsen> viveks_, sweet. I'll monitor closely and ping people when it finishes
15:37:15 <viveks_> ok good
15:37:17 <viveks_> thanks
15:37:30 <viveks_> sure i will update
15:38:10 <anipbu> #action viveks_ to update on Blocker Bugs
15:38:26 <anipbu> #info GENIUS has tested RC1 and has two blocker bugs associated with it
15:38:35 <anipbu> #action viveks_ to follow up on comments from release notes patch
15:38:45 <viveks_> ok
15:39:07 <colindixon> #action viveks_ to get patches in and +2ed for blocking bugs as soon as possible
15:39:26 <colindixon> any other comments from people?
15:39:38 <anipbu> #info All GENIUS features are marked as experimental as stated on the release notes
15:39:53 <colindixon> jamoluhrsen: I assume you understand the state of genius CSIT?
15:39:53 <viveks_> not all
15:39:54 <anipbu> GENIUS looks good to me (pending blocker bugs)
15:40:02 <viveks_> first two are not
15:40:06 <anipbu> Any other comments from folks?
15:40:08 <colindixon> the links in the release notes don't point to something that I  understand
15:40:08 <jamoluhrsen> colindixon, viveks_ I gave an email about genius CSIT
15:40:23 <jamoluhrsen> there are some failures I suggest they double check.
15:40:41 <jamoluhrsen> but, genius gets some coverage from netvirt csit as well
15:40:52 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-May/010976.html genius CSIT notes from jamoluhrsen
15:40:55 <colindixon> OK
15:41:03 <colindixon> and it's experimental, so…
15:41:05 <anipbu> #action GENIUS  to follow up on the CSIT failures as described here: https://lists.opendaylight.org/pipermail/genius-dev/2017-May/001472.html
15:41:25 <viveks_> I indicate earlier they are not blocker
15:41:27 <colindixon> anything else?
15:41:32 <jamoluhrsen> weird, I gave comments on that release review patch
15:41:38 <anipbu> No, I have no other comments
15:41:39 <zxiiro> Genius links to a csit test in the sandbox. it should point to the releng production system.
15:41:43 <jamoluhrsen> #action jamoluhrsen to add comments on release review patch
15:41:45 <anipbu> Should we move on?
15:41:46 <jamoluhrsen> i'm good
15:41:54 <colindixon> #topic CARDINAL
15:41:57 <anipbu> #info GENIUS approved for Carbon pending action items and follow up.  Congratulations!
15:42:04 <viveks_> thanks!
15:42:05 <colindixon> #undo
15:42:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1deb710>
15:42:07 <colindixon> #undo
15:42:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1deb610>
15:42:13 <colindixon> #info GENIUS approved for Carbon pending action items and follow up.  Congratulations!
15:42:16 <colindixon> #topic CARDINAL
15:42:18 <colindixon> sorry
15:42:23 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/57268/    <-- Release Notes
15:42:23 <colindixon> #info Subodh is representing CARDINAL
15:42:27 <colindixon> Anything you would like to add?
15:42:35 <colindixon> Do we have subodh here?
15:43:05 <colindixon> #Link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/249/archives/docs/_build/html/getting-started-guide/project-release-notes/cardinal.html.gz HTML version of the draft release notes/review
15:44:22 <colindixon> um, I take it we don't have subodh…
15:44:49 <colindixon> #info Subodh seems to not be here, will have to reschedule cardinal to another time
15:45:02 <colindixon> #action anipbu and/or katie to reschedule Cardinal
15:45:23 <colindixon> anipbu: should be back at 8:50 and we'll pick up with VTN
15:45:37 * jamoluhrsen goes to refill coffee
15:50:29 <colindixon> OK
15:50:38 <colindixon> #topic VTN
15:50:39 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/57307/    <-- Release Notes
15:50:39 <colindixon> #info Venkatrangan Govindarajan is representing VTN
15:50:44 <colindixon> do we have Venkat?
15:50:55 <gvrangan> #info Venkat here
15:51:00 <anipbu> #topic VTN
15:51:04 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57307/    <-- Release Notes
15:51:12 <anipbu> #info Venkatrangan Govindarajan is representing VTN
15:51:18 <anipbu> Anything you would like to add?
15:51:22 <colindixon> thanks anipbu
15:51:30 <anipbu> gvrangan: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:51:47 <gvrangan> anipbu: I will update now, I tested with RC1
15:52:11 <gvrangan> anipbu: There are no blockers, known failures with 3 node
15:52:41 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/279/archives/docs/_build/html/getting-started-guide/project-release-notes/vtn.html.gz HTML version of release notes/review
15:52:48 <anipbu> #info VTN has tested RC1 and found no blocker bugs
15:53:02 <colindixon> nothing major I've called out
15:53:04 <anipbu> #info VTN has reviewed CSIT failures in RC1 and marked them as IGNORE
15:53:43 <jamoluhrsen> vtn has generally stable csit. +1
15:53:58 <anipbu> jamoluhrsen: do you concur that VTN has two features that are nonexperimental: odl-vtn-manager-rest odl-vtn-manager-neutron
15:54:22 <colindixon> there was one CSIT that went from 100% pass to 100% fail on the last run, but I assume that's just bad luck
15:54:33 <colindixon> https://jenkins.opendaylight.org/releng/view/vtn/job/vtn-csit-1node-coordinator-only-carbon/
15:54:43 <anipbu> <gvrangan> Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:54:57 <jamoluhrsen> colindixon, let me see
15:55:03 <gvrangan> anipbu: No new features for this release
15:55:11 <anipbu> gvrangan: please work with me and zxiiro to upload the VTN Coordinator to the nexus
15:55:27 <anipbu> #info VTN has no new cool feature in this release, it is in maintenance mode
15:55:29 <gvrangan> sure anipbu
15:55:35 <jamoluhrsen> colindixon, likely infra issues for that csit dump
15:55:42 <anipbu> #action gvrangan to follow up on VTN Coordinator
15:55:56 <anipbu> <jamoluhrsen> I assume you are okay with nonexperimental tag then?
15:56:04 <jamoluhrsen> yes, fine
15:56:07 <anipbu> #info VTN has two features that are nonexperimental: odl-vtn-manager-rest odl-vtn-manager-neutron
15:56:36 <anipbu> <gvrangan> Could you please follow up with colindixon on the comments on your release notes patch?
15:56:37 <colindixon> jamoluhrsen: good ot know
15:56:53 <anipbu> #action gvrangan to follow up on release notes patch comments
15:57:00 <anipbu> VTN looks good to me
15:57:05 <colindixon> jamoluhrsen: https://jenkins.opendaylight.org/releng/view/netvirt-csit/job/netvirt-csit-1node-openstack-newton-nodl-v2-upstream-stateful-carbon/ seems to had the same thing...
15:57:09 <jamoluhrsen> good to me.
15:57:16 <colindixon> I'm happy
15:57:17 <anipbu> Any additional comments from folks?
15:57:20 <anipbu> okay let's move on
15:57:33 <anipbu> #info VTN approved for Carbon pending action items and follow up.  Congratulations!
15:57:39 <jamoluhrsen> colindixon, yeah, looks like the same aprox time too. I bet rackspace had some issue.
15:57:45 <gvrangan> thanks anipbu colindixon jamoluhrsen
15:57:50 <anipbu> #topic CONTROLLER
15:57:55 <anipbu> #link https://git.opendaylight.org/gerrit/57294    <-- Release Notes
15:58:09 <anipbu> #info Robert Varga is representing CONTROLLER
15:58:29 <anipbu> rovarga: Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:59:03 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/285/archives/docs/_build/html/getting-started-guide/project-release-notes/controller.html.gz HTML version of current draft release notes/review
15:59:41 <anipbu> rovarga: Hi Good Morning/Evening.
16:01:25 <colindixon> this mostly looks good, just minor formatting rephrasing comments on the patch from me
16:01:31 <colindixon> there are no links to documenation
16:01:38 <anipbu> rovarga: ping
16:02:05 <colindixon> I'll defer to jamoluhrsen on testing
16:02:49 <jamoluhrsen> colindixon, testing is mostly in clustering and I think there may be multiple failures/bugs
16:03:27 <anipbu> rovarga: ping
16:03:42 <jamoluhrsen> colindixon, I honestly don't know how to classify controller, since it's so core and mdsal is their feature, but it's consumed by everyone
16:04:25 <colindixon> #info yeah… basically the non-clustering stuff works and the cluster stuff is kind of hit-and-miss
16:04:27 <colindixon> #undo
16:04:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cbe810>
16:04:33 <colindixon> yeah… basically the non-clustering stuff works and the cluster stuff is kind of hit-and-miss
16:04:43 <colindixon> ok we're missing rovarga or pantelis
16:05:02 <anipbu> #action rovarga and controller team to follow up on the RC1 testing and update the spreadsheet https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:05:16 <colindixon> anipbu: note that cardinal didn't show either
16:05:32 <anipbu> #action rovarga and controller team to follow up on the release notes comments such as documentation links, etc.
16:06:05 <rovarga> ugh
16:06:16 <rovarga> sorry, got lost in bug reports for a bit
16:06:20 <anipbu> YAY!  rovarga is here
16:06:33 <jamoluhrsen> rovarga you were in your happy place
16:06:39 <rovarga> (and this IRC client has annoyingly subtle notifications)
16:06:51 <rovarga> jamoluhrsen: not really, no :-(
16:07:04 <anipbu> rovarga: Okay let's get started with your review
16:08:02 <anipbu> rovarga: you have comments on the release notes patch that needs follow up
16:08:27 <anipbu> rovarga: we are still waiting on you to sign off on the RC1 status for controller: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
16:08:44 <anipbu> rovarga: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:09:21 <rovarga> we have added support for prefix-based shards, which are cool
16:09:45 <rovarga> other than that we do not have an explicit new feature, most of the cool things are happening under the hood
16:10:06 <rovarga> we have implemented transaction pipelining
16:10:25 <rovarga> and we have a new frontend/backend protocol to deal with the pesky AskTimeoutException
16:10:44 <anipbu> rovarga: 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:10:45 <rovarga> it can be test-driven, but it is not enabled by default
16:11:30 <anipbu> #info CONTROLLER has introduced the following new cool features: support for prefix-based shards, implemented transaction pipelining, frontend/backend protocol to deal with the pesky AskTimeoutException
16:11:55 <anipbu> rovarga: is there an ETA for when the blocker bugs can be fixed and resolved?
16:12:21 <rovarga> anipbu: the CSIT test suite was expanded dramatically and there are issues in both code and test suites. I'll follow-up with Vratko for review
16:12:45 <rovarga> re BBs... let me check our current situation
16:12:49 <anipbu> #action rovarga and CONTROLLER team to follow up on CSIT test failures
16:13:18 <anipbu> jamoluhrsen: do you approve the nonexperimental tag for odl-mdsal-broker?
16:13:29 <jamoluhrsen> yeah
16:13:44 <rovarga> I think we should have the final bits cleared tomorrow afternoon, depending on the CSIT run results
16:13:52 <anipbu> #info CONTROLLER has one nonexperimental features: odl-mdsal-broker
16:14:15 <anipbu> #info rovargastates that the ETA for bocker bug is tomorrow afternoon, depending on the CSIT run results
16:14:19 <anipbu> #undo
16:14:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dc2f50>
16:14:29 <anipbu> #info rovarga states that the ETA for blocker bug is tomorrow afternoon, depending on the CSIT run results
16:14:52 <rovarga> right now our biggest problem is validation turnaround :(
16:14:56 <anipbu> rovarga: could you close the bugs where the patches have already been merged?  such as  https://bugs.opendaylight.org/show_bug.cgi?id=8402
16:15:18 <rovarga> anipbu: yes, as soon as the cherry-picks to master are merged
16:15:33 <rovarga> (they are being verified now)
16:16:03 <anipbu> rovarga: then could you retarget the bug to nitrogen (ODL SR Target=nitrogen) to remove it from our radar.
16:16:29 <rovarga> that would not be accurate :(
16:16:38 <anipbu> rovarga: okay
16:16:46 <rovarga> it will clear in about an hour
16:16:55 <rovarga> not sure if that much latency hurts
16:17:47 <anipbu> rovarga: one last question form me is: are we expecting additional blocker bugs at this point from controller besides the ones already listed on the spreadsheet?
16:18:39 <anipbu> #action rovarga  and controller team to follow up on the existing blocker bugs.  8402, 8491, 8446, 8448, 8462
16:19:10 <jamoluhrsen> anipbu, 5 controller blocker bugs?
16:19:36 <jamoluhrsen> was 3 this morning, but rovarga added one just now. assuming another one is coming then.
16:19:59 <anipbu> Yes, 5 controller blocker bug, and waiting on rovarga to respond to my question if there are additional blocker bugs
16:20:05 <rovarga> anipbu: maybe one or two more :-( it all depends on CSIT, which we'll know in about .. in the morning CET
16:20:37 <rovarga> the trouble here is that there is some masking around and we do not have enough data around bug likelyhood
16:20:41 <anipbu> #info rovarga says there may be one or two mote blocker bugs, it all depends on CSIT, which we'll know in about .. in the morning CET
16:20:58 <anipbu> CONTROLLER status i have marked as RED on the spreadsheet
16:21:14 <anipbu> #info rovarga to follow up on action items stated above
16:21:22 <anipbu> Do folks have any additional comments?
16:21:41 <anipbu> colindixon, jamoluhrsen
16:21:50 <jamoluhrsen> i'm good
16:22:10 <colindixon> I'm good, it would be good to understand any new blockers, but we'll follow-up offline
16:22:13 <anipbu> #info CONTROLLER conditionally approved for Carbon pending blocker bug resolution and action items and follow up.  Congratulations!
16:22:18 <anipbu> #topic NETVIRT
16:22:19 <rovarga> jamoluhrsen: as you've seen, bugs are not my happy place :)
16:22:22 <anipbu> #link https://git.opendaylight.org/gerrit/57302    <-- Release Notes
16:22:27 <anipbu> #info Sam Hague is representing NETVIRT
16:22:32 <anipbu> Anything you would like to add?
16:22:40 <anipbu> shague: good morning
16:22:48 <shague> * hi
16:22:56 <shague> nothing to add
16:23:14 <anipbu> shague: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:23:36 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:24:14 <colindixon> I have nothing major in my feedback on the patch
16:24:18 <shague> We have updated a few to ignore and need to do another look after the latest patches ahve gone in
16:24:33 <colindixon> it seems unlikely that there were no API changes, but maybe I'm wrong
16:25:01 <shague> colindixon: yes, I added a comment in the patch that all apis are covered in teh blueprint specs
16:25:02 <anipbu> shague: what is ETA on blocker bugs?
16:25:29 <shague> would it be helpful to add that as  acomment in the release notes to go look at the specs for api changed?
16:25:45 <jamoluhrsen> anipbu, shague: as for testing status, with so many blocking bugs, I think we should not spend a ton of cycles looking at the current status.
16:25:50 <anipbu> shague: will there be any additional blocker besides the ones that listed on the spreadsheet?  7939, 8232, 8358, 8388, 8451, 8471, 8473, 8474, 8475
16:26:01 <anipbu> shague: what is ETA on blocker bugs?
16:26:03 <jamoluhrsen> current "test" status
16:26:27 <shague> ETA on blocker bugs is for today's 11:59 build, but I doubt we would make that since we have about 10  open right now. so end of week is next best estimate
16:26:46 <colindixon> shague: cool, yeah, a comment with a link would help (that could come after) we get patches for code in though
16:27:10 <colindixon> code is more important than docs until we ship
16:27:26 <colindixon> shague: how realistic do you think end of week is given how many you have?
16:28:19 <jamoluhrsen> colindixon, shague: I think we should punt that ETA
16:28:25 <shague> colindixon: 50/50.. all are being worked, couple already fixed, the generally fall into two main buckets
16:28:27 <colindixon> +1
16:28:34 <anipbu> #info shague says ETA for blocker bugs is today's 11:59 build, but I doubt we would make that since we have about 10  open right now. so end of week is next best estimate
16:28:53 <anipbu> #info NETVIRT has tested RC1 and has found blocker bugs 7939, 8232, 8358, 8388, 8451, 8471, 8473, 8474, 8475
16:28:58 <colindixon> OK, we'll follow up
16:29:10 <anipbu> shague: do you expect more blocker bugs besides 7939, 8232, 8358, 8388, 8451, 8471, 8473, 8474, 8475?
16:29:27 <anipbu> #action shague to follow up on comments on the release notes patch
16:29:28 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/277/archives/docs/_build/html/getting-started-guide/project-release-notes/netvirt.html.gz HTML version of the current draft release notes/review
16:29:29 <shague> anipbu: we are dependent on genius bugs 7451 and 8332 also
16:29:44 <jamoluhrsen> I think the main concept here is that RC1 did not uncover blocking bugs. the bugs were basically there and being worked before that. the bugs may have just been upgraded to blocker around RC1
16:30:04 <anipbu> #info NETVIRT has blocker bugs 7939, 8232, 8358, 8388, 8451, 8471, 8473, 8474, 8475 and related genius bugs 7451 and 8332
16:30:35 <michal_rehak> anipbu: as for openflowjava - I just updated the carbon rc1 status spread sheet and release-notes rst
16:30:36 <shague> jamoluhrsen: agreed. we have had generic open bugs against the csit for a ahile and we are now specifically hitting issues as we break the bugs down
16:31:50 <anipbu> jamoluhrsen, colindixon, Besides the action items discussed above, can we approve NETVIRT or should we do follow up release review on email?
16:32:03 <colindixon> I think we can approve it assuming we work out the blocking bugs
16:32:11 <jamoluhrsen> i approve
16:32:23 <zxiiro> +1
16:32:43 <anipbu> shague: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:32:48 <anipbu> Oaky let's move on
16:33:11 <anipbu> #info NETVIRT conditionally approved for Carbon pending blocker bug resolution and action items and follow up.  Congratulations!
16:33:17 <anipbu> #topic OVSDB
16:33:21 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57241/    <-- Release Notes
16:33:25 <anipbu> #info Anil Vishnoi is representing OVSDB
16:33:27 <shague> thanks!
16:33:29 <anipbu> Anything you would like to add?
16:33:45 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/239/archives/docs/_build/html/getting-started-guide/project-release-notes/ovsdb.html.gz HTML version of the current release notes/review
16:33:54 <anipbu> shague: when you get a chance coudl you send me an email on Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:34:00 <vishnoianil> anipbu, i am addressing the comment provided by comment and will push a new patch to the doc gerrit
16:34:10 <anipbu> vishnoianil: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:34:33 <vishnoianil> anipbu, sure i will update it today
16:34:53 <anipbu> vishnoianil: can you update it right now so we can move forward with the review?
16:35:14 <vishnoianil> anipbu, give me a second
16:35:18 <anipbu> vishnoianil: columns C through H https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
16:35:37 <colindixon> #Info I've given feedback on the patch, pretty much all formatting
16:36:03 <jamoluhrsen> no comments from me regarding ovsdb test. seems on the up and up
16:36:25 <anipbu> <jamoluhrsen> are you approving the nonexperimental tags?
16:36:31 <jamoluhrsen> yes
16:36:44 <vishnoianil> anipbu, updated the sheet.
16:37:06 <anipbu> #info OVSDB has mix of nonexperimental and experimental features as stated on the release notes
16:37:25 <anipbu> #info OVSDB has tested RC1 and found no blocker bugs
16:37:49 <anipbu> #info OVSDB has signed off the the CSIT test failures
16:38:01 <anipbu> <vishnoianil> Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:38:28 <vishnoianil> anipbu, Yes, we added support for SSL/TLS and did few performance improvements
16:38:37 <anipbu> #action vishnoianil to follow up on the comments on the release notes patch (mostly formatting, etc)
16:38:51 <anipbu> #info OVSDB added the following cool new features: support for SSL/TLS and did few performance improvements
16:39:02 <anipbu> OVSDB looks good to me
16:39:07 <anipbu> Any additional comments from folks?
16:39:22 <colindixon> nope
16:39:27 <vishnoianil> anipbu, And we added hardware vtep reconciliation feature as well.
16:39:35 <anipbu> #undo
16:39:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a469d0>
16:39:55 <anipbu> #info OVSDB added the following cool new features: support for SSL/TLS, performance improvements, hardware vtep reconciliation feature
16:40:08 <anipbu> Oaky let's move on
16:40:15 <anipbu> #info OVSDB approved for Carbon pending action items and follow up.  Congratulations!
16:40:21 <vishnoianil> anipbu, thanks
16:40:47 <anipbu> #topic TSDR
16:40:52 <anipbu> #link https://git.opendaylight.org/gerrit/57003    <-- Release Notes
16:40:56 <anipbu> #info yulingchen54 is representing TSDR
16:41:00 <anipbu> Anything you would like to add?
16:41:07 <anipbu> yuling: good morning
16:41:12 <yuling> good morning
16:41:27 <yuling> Not really...everything has bee added to the release note
16:41:34 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/169/archives/docs/_build/html/getting-started-guide/project-release-notes/tsdr.html.gz HTML version of current draft release notes/review
16:42:03 <anipbu> yuling: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:42:03 <yuling> Yes, we're working on the formatting and improvement of this document
16:42:04 <colindixon> #info colindixon has provided feedback on the patch, sadly the patch doesn't format really at all (see above HTML) has noticeable sections just not completed
16:42:12 <yuling> will be done by the end of this week
16:42:28 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:42:48 <colindixon> #info most concerning parts are that I can't evaluate the security concerns or known issues since they just aren't completed
16:42:57 <jamoluhrsen> yuling, there is csit trouble and your features are not marked experimental
16:43:12 <yuling> As AbdulRahman who's our testing lead, sent out email yesterday, the CSIT errors were not from TSDR tests
16:43:34 <anipbu> #info TSDR has tested RC1 and found no blocker bugs
16:43:40 <yuling> Those test cases were passed in previous releases
16:43:45 <yuling> those were not new test cases
16:43:45 <colindixon> #info I think we covered security issues in the past release and maybe had better descriptions there, clearly there are many protocols TSDR uses to talk to external databases and those should be noted and ideally provide links for how to secure them
16:44:41 <yuling> according to AbdulRahman's analysis, the CSIT failure were caused by testing infra issues
16:44:45 <anipbu> yuling: this spreadsheet needs to be updated and the test failures needs to be marked as IGNORE/OKAY/BLOCKING: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:45:03 <yuling> OK, will be marked as IGNORE
16:45:03 <jamoluhrsen> yuling, I'll reply to that email, but I don't think it's an accurate analysis
16:45:16 <colindixon> #info also I'll note that snmp was added back to carbon, so if there are patches that would be easy to revert to add back in the snmp collector, we could do that now (depending on how anipbu feels about it)
16:45:18 <jamoluhrsen> -1 on the csit going to IGNORE for now
16:45:18 <yuling> OK, we'll look into more then
16:45:21 <anipbu> yuling: could you update the spreadsheet now so we can move forward the review?
16:45:56 <anipbu> #action yuling and jamoluhrsen to follow up on the CSIT test failures as appropriate
16:46:09 <anipbu> #info TSDR has CSIT test failures that require follow up
16:46:44 <yuling> OK, just updated
16:47:08 <yuling> Regarding the security issues, like Colin said, we've addressed in previous releases
16:47:16 <anipbu> #info The INT/TEST and TSDR team will follow up on the experimental tag for the features
16:47:20 <yuling> The security level stays the same
16:47:31 <yuling> I'll update the document to make it clear
16:47:32 <colindixon> yuling: yes, but you need to copy the description over at the very least
16:47:37 <yuling> yes, will do
16:47:58 <yuling> We did test the RC1 and everything looked good
16:48:12 <anipbu> #info action yuling to follow up with colindixon on the release notes patch
16:48:23 <yuling> For the two new features, we also tested manually and provided the test repor
16:48:26 <yuling> report
16:48:43 <vina_ermagan> #info Vina Ermagan for LISP Flow Mapping
16:48:49 <anipbu> Okay, besides the uncertainty regarding the CSIT test failures, TSDR looks good to me
16:48:56 <anipbu> Any additional comments from folks?
16:49:02 <colindixon> nope
16:49:24 <colindixon> beyond what I already said above
16:49:31 <anipbu> yuling: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:49:47 <anipbu> #action yuling to follow up with colindixon on the release notes patch
16:49:54 <yuling> We have integrated with Elastic Search, as the fourth data store
16:50:00 * colindixon notes that we have a hard cutoff in 10 minutes, but lfm with vina_ermagan should be fast
16:50:05 <yuling> and RestConf activity collector
16:50:16 <colindixon> those are actually pretty cool
16:50:18 <colindixon> thanks yuling
16:50:21 <anipbu> #info TSDR cool new features : integrated with Elastic Search, RestConf activity collector
16:50:23 <yuling> sure
16:50:30 <anipbu> #info TSDR approved for Carbon pending action items and follow up.  Congratulations!
16:50:36 <yuling> Thanks very much
16:50:51 <anipbu> #topic LISPFLOWMAPPING
16:50:55 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57325/    <-- Release Notes
16:51:06 <colindixon> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/259/archives/docs/_build/html/getting-started-guide/project-release-notes/lispflowmapping.html.gz HTML version of the current draft release notes/review
16:51:08 <anipbu> #info Vina Ermagan is representing LISPFLOWMAPPING
16:51:13 <anipbu> Anything you would like to add?
16:51:37 <vina_ermagan> Nothing to add
16:51:47 <anipbu> vina_ermagan: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:52:19 <anipbu> vina_ermagan: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:52:26 <vina_ermagan> It is already updated
16:52:33 <colindixon> I looked through everything and it looked good, migration is unclear as with most projects, otherwise 3-node CSIT seems up recently but was all over the place so far
16:52:38 <colindixon> that's noted in the release notes though
16:52:40 <vina_ermagan> RC1 looks good for lispflowmapping
16:52:41 <anipbu> #info LISPFLOWMAPPING has tested RC1 and found no blockers
16:52:53 <anipbu> #info LISPFLOWMAPPING has reviewed CSIT test failures and marked them as IGNORE
16:53:25 <vina_ermagan> colindixon yes, our 3 node CSIt is not fully complete yet
16:53:26 <jamoluhrsen> lfm csit failures are in 3node, so ignoring is fine. 1node seems stable.
16:53:34 <vina_ermagan> so it is in ignore mode for now.
16:53:41 <colindixon> yup
16:53:42 <jamoluhrsen> vina_ermagan, welcome to the club. everyone in the same boat :)
16:53:44 <anipbu> #info LISPFLOWMAPPING to follow up on release notes patch comments: migration is unclear as with most projects
16:53:52 <vina_ermagan> hopefully for nitrogen we'll have it up
16:54:13 <anipbu> <jamoluhrsen>  are you okay with nonexperimental tag?
16:54:13 <colindixon> there's some minor formatting issues on the patch that I gave back, but should be fast and I could probably fix if need be
16:54:16 <jamoluhrsen> vina_ermagan, as long as -msmr has adequate csit coverage then experimental==no is ok.
16:54:55 <vina_ermagan> jamoluhrsen Thanks :) good to be in same boat :D
16:55:02 <anipbu> vina_ermagan: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:55:17 <anipbu> LISPFLOWMAPPING looks good to me
16:55:22 <colindixon> +1
16:55:30 <anipbu> Any additional comments from folks
16:55:35 <colindixon> lfm is usually the top of the pack which is really, really appreciated
16:55:52 <vina_ermagan> thanks colindixon
16:55:56 <anipbu> +1 lispflowmapping is a good project
16:56:12 <anipbu> vina_ermagan: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:56:12 <jamoluhrsen> +1 from me too
16:56:18 <anipbu> Okay, let's move on then.
16:56:23 <colindixon> 4 minute break before TSC :-)
16:56:24 * colindixon breathes
16:56:29 <anipbu> #info LISPFLOWMAPPING approved for Carbon pending action items and follow up.  Congratulations!
16:56:32 <anipbu> That's it for today.
16:56:40 <anipbu> Thanks everyone
16:56:40 <vina_ermagan> anipbu: no new cool features unfortunaltey
16:56:42 <colindixon> vina_ermagan: it would be good to know if we had cool new things before we end the meeting
16:56:43 <colindixon> ah
16:56:45 <colindixon> good to know
16:56:46 <colindixon> all good
16:56:56 <anipbu> #info LISPFLOWMAPPING has no new features
16:56:56 <zxiiro> thanks
16:57:04 <anipbu> #topic cookies
16:57:07 <anipbu> #endmeeting