16:58:35 <Sai_> #startmeeting kernel_projects
16:58:35 <odl_meetbot> Meeting started Tue Jan 17 16:58:35 2017 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:35 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:59:03 <Sai_> #chair colindixon
16:59:03 <odl_meetbot> Current chairs: Sai_ colindixon
16:59:18 <Sai_> #topic - Agenda
17:00:24 <Sai_> #info -1. Call for any topics to be add
17:00:32 <Sai_> #info 2. Review action items
17:00:45 <Sai_> #info 3. Progress on BUG-5280
17:00:58 <Sai_> #info 4. Karaf 4 Upgrade
17:01:24 <Sai_> #info 5. configure cluster script
17:01:33 <Sai_> #info 6. Review dashboards
17:01:57 <Sai_> #topic - last meeting minutes
17:02:00 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-10-17.03.html
17:04:34 <Sai_> #topic - Call for any topics
17:04:56 <Sai_> #topic - Review action items
17:05:48 <Sai_> #Action - PTLs of controller, MD-SAL, netconf to send M3 status
17:07:12 <Sai_> #Action - Figure out with TomP home for Configure cluster script and the project responsible for maintening it.
17:07:25 <Sai_> #undo
17:07:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x285ed10>
17:07:53 <Sai_> #Action - Figure out with TomP in finding out the home for Configure cluster script and the project responsible for maintaining it.
17:11:56 <Sai_> #info - Current script if using with nettytcp (not with artery) it works.
17:13:17 <Sai_> #Action - Open a bug to avoid future breakage of cluster tests wrt cluster script.
17:16:14 <Sai_> #undo
17:16:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x284d310>
17:16:26 <Sai_> #Action - Vratko to open a bug to avoid future breakage of cluster tests wrt cluster script.
17:16:50 <Sai_> #topic - Progress on BUG-5280
17:17:01 <Sai_> #link - https://bugs.opendaylight.org/show_bug.cgi?id=5280
17:17:11 <Sai_> #link - https://bugs.opendaylight.org/show_bug.cgi?id=5282
17:18:11 <Sai_> #info - colin asks community how far are we wrt Bug 5280 / 5282
17:19:10 <Sai_> #info - Robert says implementation exists for front/back end and should reasonably work, there are corner to be worked out.
17:19:26 <Sai_> #info - Robert thinks they are ready to be tested
17:21:49 <Sai_> #topic - Karaf 4 Upgrade
17:22:33 <Sai_> #info - Stephen says last week karaf 4.0.9 added to nexus
17:24:22 <Sai_> #info - the upgrade is on track
17:25:06 <Sai_> #info - Tests of karaf 4.0.9 are unstable, so there is no official release yet.
17:25:41 <Sai_> #info - Patches exists on several projects, projects can start working on migration. (ttp / nutron-flow-mapping projects are done)
17:26:23 <Sai_> #Action - Stephen to file bug in each project pertaining to karaf upgrade
17:26:47 <Sai_> #topic - Review dashboards
17:28:24 <Sai_> #info - change id 50537 - guava migration should be before karaf release
17:37:16 <Sai_> #info - Bug 6790 Michael found it while running on a desktop
17:38:25 <Sai_> #info - controller patch - Bug 5222 can be resolved using karaf 4 dependency features
17:45:21 <Sai_> #info - Bug 3128 - global rpc are being routed in cluster is being worked out.
17:47:19 <Sai_> #Action - Ryan to start generating a bug query useful to view related bugs.
17:47:36 <Sai_> #topic - RuntimeException
17:49:05 <Sai_> #link - https://lists.opendaylight.org/pipermail/mdsal-dev/2017-January/000998.html
17:50:47 <Sai_> #info - Multiple threads used in this case. we need a single executor in this case.
17:53:43 <Sai_> #info - Michael to revisit the bug by taking off some utilities and come back again.
17:55:01 <Sai_> #topic - participants
17:55:33 <Sai_> #info - Sai / Ryan / Colin / Igor / Martin / Michael / Robert / Stephen / TomP / Tomas / Viera / Vratko
17:55:39 <Sai_> #endmeeting