16:57:46 <Sai_> #startmeeting kernel_projects
16:57:46 <odl_meetbot> Meeting started Tue Jan 24 16:57:46 2017 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:46 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:57:54 <Sai_> #chair colindixon
16:57:54 <odl_meetbot> Current chairs: Sai_ colindixon
16:58:11 <Sai_> #topic - previous-meeting-minutes
16:58:27 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-17-16.58.html
16:59:09 <Sai_> #topic - Agenda
16:59:29 <Sai_> #info 1. Call for any topics to be added
16:59:37 <Sai_> #info 1. Review action items
17:00:01 <Sai_> #undo
17:00:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18619d0>
17:00:05 <Sai_> #info 2. Review action items
17:00:15 <Sai_> #info 3. NETCONF call home patch status
17:00:27 <Sai_> #info 4. Bug 7522
17:01:02 <Sai_> #info 4. FindBugs that has runtime impact
17:01:26 <Sai_> #info 5. Move from mockito-all => mockito-core
17:01:48 <Sai_> #info 6. Bug 7663 - FindBugs :jsr305
17:02:22 <Sai_> #info 7. End goals discussion
17:03:04 <Sai_> #topic - Call for any topics to be added
17:04:35 <Sai_> #info - karaf 4 update
17:05:17 <Sai_> #topic - Review action items
17:05:32 <Sai_> #info - [DONE] PTL of controller to send M3 status
17:05:41 <Sai_> #info - [DONE] Vratko to open a bug to avoid future breakage of cluster tests wrt cluster script.
17:05:52 <Sai_> #info - [DONE] Stephen to file bug in each project pertaining to karaf upgrade
17:06:20 <Sai_> #info - [DONE] Ryan to start generating a bug query useful to view related bugs.
17:07:01 <Sai_> #topic - NETCONF call home patch status
17:07:15 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/49253/
17:08:04 <Sai_> #info - colindixon expects feedback from committers for above mentioned patch
17:08:53 <Sai_> #topic - Bug 7522
17:09:00 <Sai_> #link - https://bugs.opendaylight.org/show_bug.cgi?id=7522
17:10:19 <Sai_> #info - This bug is closed as won't fix, Colin thinks Avi may start working on this.
17:11:42 <Sai_> #info - Martin says that we can start discussion through email thread, not sure about the deadlines.
17:13:43 <Sai_> #info - Robert thinks it has nothing much to do with yangtools / mdsal
17:14:15 <Sai_> #info - Robert says APIs required for this are already exposed (Eg:- NetconfSchema)
17:15:20 <Sai_> #info - Robert asks the use case underlying bug 7522
17:16:34 <colindixon> #Info the use case is basically to be able to load a model into ODL and then be able to get the access to the various tools around YANG validation and storage in ODL
17:17:24 <colindixon> #info rovarga notes that you won't get binding APIs for the model loaded this way unless it's also loaded by a jar via the normal mechanism
17:17:40 <colindixon> #Info Avi notes and rovarga confirms that REST should still work b/c it's all Binding Independent
17:19:02 <colindixon> #info rovarga notes there may be complexities for things like augmentations where another person reading/writing using the binding APIs might accidentlaly lose data from the newly loaded models
17:19:40 <colindixon> #info rovarga notes that a lot of these things will likely be augmentations to topology, which means you're likely to hit this
17:19:57 <colindixon> #action Avi to write up some simple set of use cases and constraints
17:22:09 <colindixon> #Info rovarga notes that if it's really just to get REST access to a model, but not actually to share it to the rest of the MD-SAL, one option would be to essentially build a new shard with it's own SchemaContext
17:22:19 <colindixon> #info avi asks if there's a pointer, rovarga says not off the top of his head
17:24:58 <colindixon> #action colindixon to schedule a TWS on this issue
17:25:32 <Sai_> #topic - FindBugs runtime impact
17:26:14 <Sai_> #info - Michael found jar305 is still being used
17:26:30 <Sai_> #info - Robert thinks annotations are provided by karaf
17:28:11 <Sai_> #info - Michael thinks odlparent might be the right place
17:28:18 <Sai_> #info -
17:28:29 <Sai_> #undo
17:28:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x16b9a50>
17:30:10 <Sai_> #action - Michael to create a bug in odlparent wrt FindBugs runtime impact.
17:30:18 <Sai_> #topic - mockito-all
17:30:27 <Sai_> #info - FYI mockito-all => mockito-core, see https://bugs.opendaylight.org/show_bug.cgi?id=7662 and https://git.opendaylight.org/gerrit/#/q/topic:bug/7662
17:31:27 <Sai_> #info - mockito-all is a big mistake and everyone should use mockito-core
17:31:54 <Sai_> #info - Michael has a patch that makes sure to use mockito-core
17:32:07 <Sai_> #topic - FindBugs :jsr305
17:32:16 <Sai_> #info - FYI FindBugs :jsr305 => (full) :annotation, see https://bugs.opendaylight.org/show_bug.cgi?id=7663 and https://git.opendaylight.org/gerrit/#/q/topic:bug/7663
17:33:55 <Sai_> #info - once all patches regarding findBugs & mockito-all are merged it helps in end goals and guarantees future non-regression
17:34:03 <Sai_> #topic - end goals
17:34:14 <Sai_> #info - FYI end goals, exploratory, but once everything is clean this will make sense, and guarantee future non-regression: 1. https://git.opendaylight.org/gerrit/#/c/50844/ 2. https://git.opendaylight.org/gerrit/#/c/50905/ 3. https://git.opendaylight.org/gerrit/#/c/50908/ 4. https://git.opendaylight.org/gerrit/#/c/50851/
17:40:56 <Sai_> #topic - including annotations makes sure that singleTest works, but we need to find out the reason behind it.
17:40:59 <Sai_> #undo
17:40:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x190a110>
17:41:06 <Sai_> #info - including annotations makes sure that singleTest works, but we need to find out the reason behind it.
17:45:25 <Sai_> #action - Michael to create bug wrt annotations usage
17:45:40 <Sai_> #topic - karaf 4 update
17:46:40 <Sai_> #info - Stephen started merging patches (mdsal/controller done), next phase is AAA.
17:47:12 <Sai_> #info - Stephen encountered issues with AAA (gerrit - 50304), requests help from AAA
17:48:06 <Sai_> #action - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4
17:48:27 <Sai_> #info - Stephen says controller patch might be ready by tomorrow
17:49:01 <Sai_> #info - infrautils / netconf patches are ready to go
17:49:23 <Sai_> #topic - guava upgrade
17:50:51 <Sai_> #topic - Review dashboards
17:52:04 <Sai_> #info - yangtools moving ahead with 1.1
17:54:17 <Sai_> #info - support in binding spec 2 in mdsal
17:54:29 <Sai_> #info - upgrade to netty 4.1 in netconf
17:55:41 <Sai_> #info - clean up related work in AAA
17:57:07 <Sai_> #topic - participants
17:57:49 <Sai_> #info - Sai / Ryan / An / Avi / Colin / Igor / Martin / Michael / Robert / Stephen / TomP / Vratko
17:58:03 <Sai_> #endmeeting