16:57:45 <Sai> #startmeeting kernel_projects
16:57:45 <odl_meetbot> Meeting started Tue Feb  7 16:57:45 2017 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:45 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:58:02 <Sai> #topic - last-meeting-minutes
16:58:13 <Sai> #link -  https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-31-16.58.html
16:58:21 <Sai> #topic - Agenda
16:59:36 <Sai> #info - 1.Call for any topics to be added
17:00:20 <Sai> #info - 2.Review existing action items
17:00:45 <Sai> #info - 3. AbstractConcurrentDataBrokerTest
17:01:20 <Sai> #info - 4. odlparent
17:01:52 <Sai> #info - 5. Removing projects from auto release
17:02:07 <Sai> #info - 6. Karaf 4
17:02:31 <Sai> #info - 7. netty's native e-poll mechanism
17:02:46 <Sai> #info - 8. Review the code change dashboards
17:06:37 <Sai> #topic - call for topics
17:06:43 <Sai> #topic - Review dashboards
17:07:05 <Sai> #info - [DONE] vorburger to ping anipbu to get the remaining 7662 patches get merged as much as possible
17:07:12 <Sai> #undo
17:07:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1928d10>
17:07:15 <Sai> #undo
17:07:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1928650>
17:07:27 <Sai> #topic - Review action items
17:07:39 <Sai> #info - [DONE] - vorburger to ping anipbu to get the remaining 7662 patches get merged as much as possible
17:08:37 <Sai> #Info - drop projects out of auto release if some active bug is not being addressed
17:09:49 <Sai> #info - four projects ( lacp, centinel, usecplugin, yang-push, atrium) have not responded for gerrits related to auto-release.
17:11:31 <Sai> #info - Colin / An thinks one week is reasonable amount of time to let the respective committers of project reply ( required for auto release ) .
17:11:46 <Sai> #info - [DONE] - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4
17:11:55 <Sai> #Action - Michael to open a wiki on "upgrade-ability" in odl
17:12:21 <vorburger> #action vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th
17:12:34 <Sai> #topic - AbstractConcurrentDataBrokerTest
17:12:51 <Sai> #info - controller https://git.opendaylight.org/gerrit/#/c/51486/
17:13:01 <Sai> #info - FYI for anyone interested in DataBroker testing: AbstractConcurrentDataBrokerTest @deprecate-s AbstractDataBrokerTest
17:13:39 <Sai> #info - goal is to make current inmemory data broker concurrent safe
17:19:09 <Sai> #info - test fake implementations in some cases are better than mock tests.
17:21:05 <Sai> #info - For system integration tests CDS make sense but not for unit tests
17:22:17 <Sai> #topic - odlparent
17:22:28 <Sai> #link - odlparent https://git.opendaylight.org/gerrit/#/c/47337/ merge
17:23:00 <Sai> #info -  FindBugs' full :annotation instead of :jsr305 artifact sub-set
17:24:25 <Sai> #info - This will require that all downstream projects first switch their <dependency><groupId>com.google.code.findbugs from <artifactId>jsr305 to <artifactId>annotations in all pom.xml.  They will NOT have to adapt any code, because the actual Java types are exactly the same (just from a different Maven artefact).
17:24:50 <Sai> #info - Stephen to review and merge the code
17:25:15 <Sai> #Action - Stephen to review https://git.opendaylight.org/gerrit/#/c/47337/
17:25:34 <Sai> #topic - auto release
17:25:52 <Sai> #info - discussed in action-items topic
17:25:57 <Sai> #topic - Karaf 4
17:26:47 <Sai> #info - CSS seems to be broken
17:27:42 <Sai> #Info - An asks Stephen if he is interested in bug bashing karaf4 topic.
17:29:07 <Sai> #info - Currently the process is manual, but can be automatable.
17:29:32 <Sai> #Info - Stephen to provide patches for projects wrt karaf upgrades
17:33:14 <Sai> #info - An / Michael requests Stephen to send patches for projects only that are active.
17:34:07 <Sai> #Info - Stephen confirms Archetype have not been revised yet. it is a future work.
17:35:15 <vorburger> #info https://git.opendaylight.org/gerrit/#/c/51332/ illustrates how projects which have already switched to Karaf 4 can build Karaf 4 distributions for testing
17:36:01 <Sai> #chair vorburger
17:36:01 <odl_meetbot> Current chairs: Sai vorburger
17:36:09 <Sai> #info https://git.opendaylight.org/gerrit/#/c/51332/ illustrates how projects which have already switched to Karaf 4 can build Karaf 4 distributions for testing
17:37:44 <Sai> #Action - Stephen to reach out Jamie on CSS / Netconf patches.
17:38:03 <Sai> #topic - netty's native e-poll
17:38:18 <Sai> #info - why was netty's native e-poll mechanism added between beryllium-sr2 and beryllium-sr3 ?
17:38:35 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37602/
17:38:42 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/40098/
17:39:04 <Sai> #info - both above patches added between sr2 and sr3
17:39:09 <Sai> #undo
17:39:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x179ed90>
17:39:15 <Sai> #info - both above patches were added between sr2 and sr3
17:40:59 <Sai> #info - these patches renegotiates at TLS1 level
17:41:20 <Sai> #topic - Official port for restconf
17:41:33 <Sai> #info - should we remove 8080 ?
17:42:46 <Sai> #info - There is no objection in removing 8080 port.
17:43:07 <Sai> #topic - CSS
17:44:03 <Sai> #info - Michael says since we are spending lot of energy in CSS for karaf 4 . should we consider abandoning CSS in karaf 4
17:45:54 <Sai> #info - /etc/initial directory have config sub system file
17:46:14 <Sai> #info - controller is not completely free from CSS
17:51:04 <Sai> #info - Consensus on to deprecate CSS sooner or later
17:52:32 <Sai> #info - Micheal / Ryan / Stephen / TomP supports the idea to deprecate CSS
17:55:26 <Sai> #topic - Review dashboards
17:58:58 <vorburger> #info - git.properties is being back-ported to stable/boron
17:59:36 <Sai> #topic- participants
18:00:37 <Sai> #info - Sai / An / Colin / Ryan / Casey / Igor / Martin / Michael / Stephen / TomP / Tomas / Vratko
18:00:41 <Sai> #endmeeting