#opendaylight-meeting: nitrogen release sync

Meeting started by colindixon at 15:02:52 UTC (full logs).

Meeting summary

  1. where we are (colindixon, 15:02:56)
    1. zxiiro says that migration to 1.9.0 of ODL parent is mostly done, it's only 5 leaf projects that are causing problems (colindixon, 15:03:38)
    2. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0 patches (colindixon, 15:04:09)
    3. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0+status:open 4 projects unmerged: bier, sdni, snmp4sdn, nic (colindixon, 15:04:28)
    4. colindixon and zxiiro ask skitt about odlparent 2.0.0, skitt says probably tomorrow (colindixon, 15:05:14)
    5. ACTION: skitt will send zxiiro an e-mail when we're ready to start the release (colindixon, 15:05:38)
    6. skitt basically says we're just doing the guava bump for now (colindixon, 15:06:27)
    7. Guava bump: https://git.opendaylight.org/gerrit/49820 (skitt, 15:06:55)
    8. the guava bump should mostly affect offset 0 projects, and they should mostly be ready for it (colindixon, 15:07:02)

  2. karaf 4 upstream issues (colindixon, 15:08:38)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8622 (anipbu, 15:09:04)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=8622 we're still working on this bug (which may not be correctly named) (colindixon, 15:09:09)
    3. http://karaf.922171.n3.nabble.com/template/NamlServlet.jtp?macro=user_nodes&user=497737 skitt's interactions with karaf uspstream (colindixon, 15:09:15)
    4. skitt's current understanding is that it works, we just need to figure out how to avoid refreshes, which we should be able to do, there are a few outstanding patches for netconf that fix some things there (colindixon, 15:09:47)
    5. we might need some fixes for aaa for things around beans (colindixon, 15:09:55)
    6. skitt's impression is that things are getting better in karaf 4 local distribtions, vorburger says that genius folks seem to be having success, netvirt is struggling quite a bit more (colindixon, 15:10:46)
    7. colindixon asks if there are patterns to what breaks in karaf 4 that we can look for (colindixon, 15:12:33)
    8. skitt says that there are some things which are bugs that happened to work in karaf 3, but don't work anymore (colindixon, 15:13:00)
    9. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004788.html <== this is, AFAIK, the latest on where netvirt is at (Karaf 4 is NOK; many CSIT still failing for them) (vorburger, 15:13:47)
    10. other times are when karaf 4 tracks package dependcies much more closely and refreshses things when they change those, in netconf, this seems to have happened when there are package exports that aren't really needed espcially when there are cycles (colindixon, 15:14:57)
    11. also optional dependencies now trigger refreshes if they become available (colindixon, 15:15:32)

  3. plan going forward (colindixon, 15:20:12)
    1. the plan is to basically merge odlparent-2.0.0 patch and then get people to try to test things (colindixon, 15:22:51)
    2. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004775.html (anipbu, 15:22:58)
    3. vorburger asks is the plan to go forward despite netvirt's issues (colindixon, 15:23:10)
    4. basically that's when yangtools merges patches, then everything is broken (colindixon, 15:24:42)
    5. vorburger advocates for fixing openflowplugin first (colindixon, 15:25:46)
    6. vorburger points out that people are responding and things are making progress (colindixon, 15:26:03)
    7. the cost of bumping yantools will be basically the loss in fixing openflow plugin until all it's dependencies have also migrated (colindixon, 15:30:50)
    8. that's likely to be a few days, but the question is do we want to eat those days _this_ week or next week (colindixon, 15:31:38)
    9. the consesus seems to be that if we're on a good debugging roll with openflow plugin, giving them an extra 24-48 hours to keep chugging makes sense (colindixon, 15:37:06)
    10. some combination of anipbu, skitt and vorburger will try to reach out to netvirt/ofp and see if that helps (colindixon, 15:37:28)


Meeting ended at 15:37:30 UTC (full logs).

Action items

  1. skitt will send zxiiro an e-mail when we're ready to start the release


Action items, by person

  1. skitt
    1. skitt will send zxiiro an e-mail when we're ready to start the release


People present (lines said)

  1. colindixon (34)
  2. odl_meetbot (4)
  3. anipbu (3)
  4. skitt (1)
  5. vorburger (1)


Generated by MeetBot 0.1.4.