#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:28 UTC (full logs).

Meeting summary

  1. roll call and agenda bashin (colindixon, 18:00:34)
    1. colindixon (colindixon, 18:00:37)
    2. adetalhouet (adetalhouet, 18:01:33)
    3. anipbu (anipbu, 18:01:36)
    4. skitt (skitt, 18:01:41)
    5. abhijitkumbhare (abhijitkumbhare, 18:01:45)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52852#Agenda (colindixon, 18:01:53)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-26-18.00.html last week's meeting minutes (colindixon, 18:02:00)
    8. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:02:14)
    9. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:02:15)
    10. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 18:02:16)
    11. ACTION: colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia (colindixon, 18:02:17)
    12. Thanh (zxiiro, 18:02:24)
    13. Hideyuki (hideyuki, 18:02:39)
    14. ACTION: anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking (colindixon, 18:02:52)
    15. rovarga (rovarga, 18:02:54)
    16. ACTION: jamoluhrsen CaseyODL and tykeal to look at ask.opendaylight.org and figure out why it's not generating emails (colindixon, 18:03:30)
    17. https://docs.google.com/spreadsheets/d/1kQqUroilC7v7dH9kiROlwL_exNOaMiq-isj0PYyegfs/edit?usp=sharing (CaseyODL, 18:03:33)
    18. LuisGomez (LuisGomez, 18:04:28)

  2. Katie helping anipbu with release management (colindixon, 18:04:33)
    1. jamoluhrsen (jamoluhrsen, 18:04:37)
    2. Anil Vishnoi (vishnoianil, 18:04:53)
    3. shague (shague_, 18:05:08)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-February/006563.html (colindixon, 18:05:14)

  3. local experts guide (colindixon, 18:06:05)
    1. (colindixon, 18:06:19)
    2. The Local Experts Guide is a list of experts in the OpenDaylight community who have volunteered to make themselves available to speak at ODLUG Events If you are interested in volunteering, please enter your Name, Email, Areas of Expertise, and Home Location (City / Country). You can also enter your travel dates and times if you are willing to speak at (colindixon, 18:06:30)
    3. https://docs.google.com/spreadsheets/d/1kQqUroilC7v7dH9kiROlwL_exNOaMiq-isj0PYyegfs/edit?usp=sharing you can filll out this spreadsheet (colindixon, 18:06:50)

  4. events (colindixon, 18:10:00)
    1. https://wiki.opendaylight.org/view/Events:Main (colindixon, 18:10:09)
    2. https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum we need to close on the Nitrogen dates (colindixon, 18:11:04)
    3. https://wiki.opendaylight.org/view/Events:Main#Linux_Foundation_Leadership_Summit there will be f2f board meeting and a cross-project TSC mixer at the OS LS (colindixon, 18:11:46)
    4. docs folks are planning a docsfest the Sunday before ONS and the Monday morning of ONS (4/2-4/3) (colindixon, 18:12:09)
    5. ACTION: colindixon to send mail about docfest to Open-O, OPNFV, OpenECOMP?, … (colindixon, 18:12:53)
    6. there was a question about when we expect decisions on the submissions on talks for the Open Networking Summit (colindixon, 18:14:12)
    7. phrobb says the plan is to get noices out by the end of the month (colindixon, 18:14:21)

  5. boron (colindixon, 18:14:45)
    1. nothing this week (colindixon, 18:14:55)

  6. carbon (colindixon, 18:14:57)
    1. https://lists.opendaylight.org/pipermail/release/2017-January/009111.html <--- Missing M3 Status from 1 project snmp (anipbu, 18:15:14)
    2. https://lists.opendaylight.org/pipermail/release/2017-February/009207.html <--- Carbon M3 Offset 2 Status Due Today (anipbu, 18:15:25)
    3. https://lists.opendaylight.org/pipermail/release/2017-February/009208.html <--- Carbon M4 Offset 0 Status Due Today (anipbu, 18:15:35)
    4. https://git.opendaylight.org/gerrit/#/c/26161/ <--- Controller has merged patch to move the Karaf 3 features and add matching Karaf 4 features for all the controller features. (anipbu, 18:16:01)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-February/006565.html <--- RFC 8040 for RESTCONF has been published. (anipbu, 18:16:28)
    6. https://tools.ietf.org/rfcdiff?url1=draft-ietf-netconf-restconf-18.txt&url2=rfc8040.txt <--- Diff between Draft 18 and rfc 8040 (anipbu, 18:16:36)
    7. OpenDaylight shipped draft-17 in Boron SR1, and will be backporting RFC to Boron SR3. OpenDaylight has already delivered draft-18 in Carbon, and will be adding changes from 18-to-RFC in Carbon as well. The changes 18-to-RFC are minimal and compatible. (anipbu, 18:17:15)
    8. some impact in Boron for projects (anipbu, 18:18:29)
    9. in general, most people shouldn't get hit by RESCONF unless they were using the new URLs, which very few people were using (colindixon, 18:19:46)
    10. the next project to merge Karaf 4 should be aaa (colindixon, 18:20:24)
    11. rovarga notes that we're having issues with verify vs. merge where we have different memory usages and that's making merges hard (colindixon, 18:20:58)
    12. ACTION: rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?) (colindixon, 18:22:15)
    13. zxiiro says that the issue with moving from jenkins maven to stock maven is that it publishes as it goes, rovarga suggests that we stage the artifacts in temporary directory and then publish them after the build (colindixon, 18:24:27)

  7. system integration and test (colindixon, 18:25:04)
    1. jamoluhrsen says that we're running ~500 CSIT jobs per night, 5 nights per week, they take about 11 hours (colindixon, 18:25:43)
    2. gating CSIT jobs are bumped to the front of the queue (colindixon, 18:25:53)

  8. infrsatructure (colindixon, 18:26:08)
    1. zxiiro and anil went through a bunch of patches of how we're using Heat, this will help things not time out when deploys take a bit longer, and also clean up better when things do fail despite that (colindixon, 18:26:59)
    2. new tab in jenkins to see the last 30 jobs that ran https://jenkins.opendaylight.org/releng/view/01-Recent/ (colindixon, 18:27:52)
    3. API limits increased from 5000 to 30000, so we have more room again (colindixon, 18:28:06)

  9. FPC Agent Creation Review (colindixon, 18:28:56)
    1. https://wiki.opendaylight.org/view/Project_Proposals:FpcAgent (colindixon, 18:29:04)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2017-January/000567.html proposed on 1/9/2017 (colindixon, 18:29:18)
    3. iETF draft for forwarding policy configuration (colindixon, 18:29:56)
    4. https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/ IETF draft (colindixon, 18:30:39)
    5. FPC provides a mechanism by which a FPC Client in the mobility control plane may manipulate dataplane forwarding elements (Dataplane Nodes or ‘DPNs’) via Agents. (colindixon, 18:31:37)
    6. there are two different modes: one where the agent mostly just translates a client's commads to a southbound data plane, another where the client says very few things and the agend makes most of the decisions (colindixon, 18:33:59)
    7. (note that all this content and presentation is from the wiki page with no slides, so no worries if you can't see screen sharing) (colindixon, 18:34:27)
    8. the current agent pretty much only goes to 0MQ pub/sub at the SB, but they're working to build OpenFlow as well (colindixon, 18:36:45)
    9. LuisGomez asks what DPN is using 0MQ, Lyle says that the current DPN is coming from Intel as part of M-CORD via ON.lab with code dropping mid-to-late February (colindixon, 18:39:33)
    10. Lyle says that if you're a contributor to M-CORD, you might be able to ask to see the code now (colindixon, 18:40:03)
    11. Lyle also says that ther'es a really basic stub to be able to test and play with stuff, but not a real DPN (colindixon, 18:40:21)
    12. Lyle says the goal is to make it work with lots of different places in 3GPP, 5G, with southbounds for 0MQ and eventually OFP (colindixon, 18:43:01)
    13. vishnoianil asks about FPC's offset, Lyle says offset 1 for now, but maybe offset 2 by the time they depend on OFP to get more space (colindixon, 18:43:57)
    14. anipbu asks if they want to be in Carbon, Lyle says no, not carbon (colindixon, 18:44:17)
    15. vishnoianil asks what the plans are with drafts of the IETF spec? the code supports draft 4 now, the plan is to move to the lastest draft for the next release (as well as compatibility for draft 4) (colindixon, 18:45:06)
    16. Lyle is hoping to see a final draft from the IETF by July, but we'll see (colindixon, 18:46:25)
    17. anipbu asks if IPR has gone in, Lyle says yes, phrobb says it's on his to do list (colindixon, 18:46:42)
    18. VOTE: Voted on "shall the TSC move the FPC Agent project to an incubation project?" Results are, +1: 13 (colindixon, 18:47:31)
    19. AGREED: the FPC agent project is a incubation project (colindixon, 18:47:57)

  10. new repositories integration/packaging (colindixon, 18:48:48)
    1. Some external tools expect things like ansible and puppet configuration to be their own repos (colindixon, 18:49:22)
    2. Thus, integration/packaging is asking for new repos without needing a new project (colindixon, 18:49:28)
    3. It seems like the TSC should be able to bless this as a way to solve a mundane technical detail (colindixon, 18:49:33)
    4. there are external repos (in dfarrell07's github) that we would like to move back into OpenDaylight (colindixon, 18:50:26)
    5. the interesting part here is that for technical reasons, they'd like to have multiple repos under one project to avoid more overhead (colindixon, 18:51:04)
    6. asking for the same committers for now, but dfarrell07 might argue that they drift in the future (colindixon, 18:51:47)
    7. edwarnicke points out that he'e expect that differnt packaging will have different expertise, dfarrell07 responds that there are lots of tight couplings as well (colindixon, 18:52:49)
    8. rovarga asks about switching to a top-level project, dfarrell07 says it doesn't seem like a great fit except that they look vaguely the same from a distance (colindixon, 18:53:35)
    9. edwarnicke says it sounds to him like it's really 3 projects, and that would make things different (colindixon, 18:55:23)
    10. colindixon says that to him, if there's differnt committer lists, that seems like a good sign you might need 3 different projects (colindixon, 18:56:04)
    11. anipbu asks what the overhead of having a project given that it doesn't participate in release, dfarrell07 says TSC representation doesn't quite fit, also JJB jobs, etc. (colindixon, 18:57:10)
    12. colindixon says his take is that this not be generally interpreted as a good thing to do: having multiple repos per project, but in this case since it's solving a techincal issue for a specific reason (colindixon, 18:58:10)
    13. colindixon asks if there's any infra issues, tykeal and zxiiro say no except maybe three-nesded deep names (colindixon, 18:59:37)
    14. dfarrell07 says maybe also project facts template (colindixon, 18:59:53)
    15. https://lists.opendaylight.org/pipermail/integration-dev/2017-January/009034.html Int/Pack discussion/vote mailing list thread (dfarrell07, 19:00:17)
    16. VOTE: Voted on "shall the TSC allow the integration/packaging project to get two sub-repos for puppet and ansible?" Results are, 0: 2, +1: 9 (colindixon, 19:01:39)
    17. AGREED: the integration/packaing projet can get two more repos for puppet and ansible (colindixon, 19:02:45)
    18. rovarga notes that there's potential namespace issues around nexus, feature names, project names, etc. (colindixon, 19:03:08)
    19. vrpolak_ notes that this is already broke when integration split (colindixon, 19:03:25)
    20. ACTION: colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>) (colindixon, 19:04:59)

  11. cookies (colindixon, 19:05:39)


Meeting ended at 19:05:42 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  5. anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
  6. jamoluhrsen CaseyODL and tykeal to look at ask.opendaylight.org and figure out why it's not generating emails
  7. colindixon to send mail about docfest to Open-O, OPNFV, OpenECOMP?, …
  8. rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?)
  9. colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>)


Action items, by person

  1. anipbu
    1. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
    2. anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
  2. CaseyODL
    1. jamoluhrsen CaseyODL and tykeal to look at ask.opendaylight.org and figure out why it's not generating emails
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
    4. colindixon to send mail about docfest to Open-O, OPNFV, OpenECOMP?, …
    5. colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>)
  4. edwarnicke
    1. colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>)
  5. jamoluhrsen
    1. jamoluhrsen CaseyODL and tykeal to look at ask.opendaylight.org and figure out why it's not generating emails
  6. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  7. rovarga
    1. rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?)
    2. colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>)
  8. skitt
    1. rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?)
  9. vishnoianil
    1. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  10. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?)


People present (lines said)

  1. colindixon (93)
  2. odl_meetbot (16)
  3. jamoluhrsen (13)
  4. anipbu (12)
  5. rovarga (7)
  6. vishnoianil (7)
  7. skitt (6)
  8. hideyuki (4)
  9. CaseyODL (4)
  10. dfarrell07 (3)
  11. adetalhouet (3)
  12. zxiiro (3)
  13. LuisGomez (3)
  14. abhijitkumbhare (3)
  15. edwarnicke (2)
  16. shague_ (2)
  17. vrpolak_ (1)
  18. phrobb (0)


Generated by MeetBot 0.1.4.