18:00:40 <colindixon> #startmeeting TSC
18:00:40 <odl_meetbot> Meeting started Thu Feb  9 18:00:40 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:40 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:46 <colindixon> #topic agenda bashing and roll call
18:00:50 <colindixon> TSC members please #info in
18:00:52 <colindixon> #info colindixon
18:01:05 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52940#Agenda
18:01:19 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-02-18.00.html last week's meeting minutes
18:01:33 <LuisGomez> #info LuisGomez
18:01:40 <abhijitkumbhare> #info abhijitkumbhare
18:01:42 <jamoluhrsen> #info jamoluhrsen
18:01:44 <vishnoianil> #info Anil Vishnoi
18:01:49 <rovarga> #info rovarga
18:02:03 <hideyuki> #info hideyuki
18:02:14 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:02:15 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:02:16 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
18:02:17 <colindixon> #action colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
18:02:36 <skitt> #info skitt
18:03:03 <colindixon> #action anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
18:05:12 <colindixon> #topic Katie will be the new ODL Release manager
18:05:42 <shague> #info shague
18:05:47 <colindixon> #info Katie will be replacing An as the release manager for OpenDaylight, expect the e-mails that woudl come from An to come from her instead
18:05:47 <zxiiro> #info Thanh
18:06:07 <colindixon> #info anipbu will still be a TSC member and broadly involved
18:06:52 <colindixon> #info colindixon says it would be almost impossible to overstate how important anipbu has been to OpenDayligth over the last year or so
18:07:00 <abhijitkumbhare> +1 colindixon
18:07:00 <vishnoianil> +10 to what colin said
18:07:07 <LuisGomez> +1
18:07:11 <dfarrell07> big thanks to anipbu, huge help to odl
18:07:26 <jamoluhrsen> anipbu has been huge for us. big thanks.
18:07:53 <colindixon> and to be clear anipbu isn't going anywhere
18:08:13 <jamoluhrsen> yeah, but what's he going to do with all the free time?
18:08:31 <colindixon> #topic carbon readout
18:08:35 <colindixon> #info Missing M3 Status from snmp,atrium,capwap,cardinal,centinel,didm,eman,integration/distribution,iotdm,lacp,natapp,netide,next,of-config,opflex,sdninterfaceapp,snbi,usecplugin,vpnservice,yang-push,yangide
18:08:42 <dfarrell07> jamoluhrsen: contribute to release/test automation? ;)
18:09:05 <colindixon> #Info note that snmp is the only one from offset 1 and nobody is from offset 0 has failed to send it out
18:09:14 <jamoluhrsen> dfarrell07: would be awesome :)
18:09:29 <colindixon> #info for offset 0, we only have an M4 readout from odlparent, all others are currently missing
18:09:37 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Detection_of_identifier_collisions_according_to_RFC_6020_.2F_RFC_7950   <--- Extends current detection of identifier collisions
18:10:33 <colindixon> #topic boron
18:10:36 <colindixon> #info nothing this week
18:10:52 <colindixon> #topic next week's TSC call
18:11:06 <colindixon> #info should we have one during the leadership summit
18:11:16 <colindixon> #link overlaps with two kenotes https://osleadershipsummit2017.sched.com/event/9Jzh
18:11:30 <jamoluhrsen> no tsc.
18:11:33 <colindixon> #link one keynote has Neela speaking https://osleadershipsummit2017.sched.com/event/9Jzj/keynote-collaborative-project-updates-odp-cncf-openswitch-cii
18:11:42 <zxiiro> No TSC
18:11:46 * dfarrell07 would rather not have unless pressing issues
18:11:53 * dfarrell07 will be in tahoe
18:12:00 <rovarga> dfarrell07: +1
18:12:13 <colindixon> #startvote will you be in tahoe next week? yes,no
18:12:13 <odl_meetbot> Begin voting on: will you be in tahoe next week? Valid vote options are yes, no.
18:12:13 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:12:15 <vishnoianil> #vote +1
18:12:15 <odl_meetbot> vishnoianil: +1 is not a valid option. Valid options are yes, no.
18:12:17 <jamoluhrsen> #vote: yes
18:12:17 <odl_meetbot> jamoluhrsen: : yes is not a valid option. Valid options are yes, no.
18:12:18 <colindixon> #vote yes
18:12:22 <vishnoianil> #vote yes
18:12:24 <zxiiro> #vote yes
18:12:26 <LuisGomez> #vote yes
18:12:28 <hideyuki> #vote no
18:12:28 <skitt> #vote no
18:12:28 <rovarga> #vote no
18:12:31 <shague> #vote no
18:12:36 <abhijitkumbhare> #vote yes
18:12:36 <jamoluhrsen> #vote yes
18:12:44 <vrpolak> #vote no
18:12:53 <colindixon> #endvote
18:12:53 <odl_meetbot> Voted on "will you be in tahoe next week?" Results are
18:12:53 <odl_meetbot> yes (6): LuisGomez, colindixon, jamoluhrsen, zxiiro, vishnoianil, abhijitkumbhare
18:12:53 <odl_meetbot> no (5): shague, hideyuki, rovarga, skitt, vrpolak
18:13:28 <colindixon> #starvote shall the TSC cancle next week's (2/16/17) TSC call? -1,0,+1
18:13:33 <colindixon> #startvote shall the TSC cancle next week's (2/16/17) TSC call? -1,0,+1
18:13:33 <odl_meetbot> Begin voting on: shall the TSC cancle next week's (2/16/17) TSC call? Valid vote options are -1, 0, +1.
18:13:33 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:13:43 <colindixon> #vote +1
18:13:44 <zxiiro> #vote +1
18:13:46 <vishnoianil> #vote +1
18:13:46 <rovarga> #vote +1
18:13:47 <jamoluhrsen> #vote +1
18:13:50 <hideyuki> #vote +1
18:13:53 <LuisGomez> #vote +1
18:13:54 <abhijitkumbhare> #vote +1
18:13:56 <skitt> #vote +1
18:13:59 <shague> #vote +1
18:14:16 <colindixon> #endvote
18:14:16 <odl_meetbot> Voted on "shall the TSC cancle next week's (2/16/17) TSC call?" Results are
18:14:16 <odl_meetbot> +1 (10): rovarga, skitt, LuisGomez, shague, hideyuki, colindixon, jamoluhrsen, zxiiro, vishnoianil, abhijitkumbhare
18:14:38 <colindixon> #agreed there will be no TSC meeting next week
18:14:56 <colindixon> #action phrobb to set up a phone bridge for remote participation at the TSC mixer and send that out to the TSC members
18:15:11 <colindixon> #topic TSC mailing list votes and discussions
18:15:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html  Nitrogen planning
18:15:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html Namespace management
18:16:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html  projects with few/no active committers
18:16:19 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-January/009034.html  flagship features in Carbon
18:16:30 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006579.html  dropping Carbon hackfest date/location
18:16:54 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006580.html  dropping off-cycle releases
18:17:24 <colindixon> #action colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda
18:18:09 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-February/009226.html [release] deprecate port 8080 (or 8181) so we only bring up one port?
18:18:38 <colindixon> #topic Karaf 4 upgrade
18:18:44 <colindixon> #info we've progressed as far as NETCONF
18:18:55 <colindixon> #info rovarga says that we're looking at some issues in AAA
18:19:35 <colindixon> #info most projects are blocked on dlux needing Karaf 4 features for downstreams, the patch is ready, but hasn't been merged
18:20:33 <colindixon> #action colindixon will try to scare up a dlux committer to merge the karaf 4 patch
18:20:40 <colindixon> #Info offset 1 and 2 projects should start the migration
18:21:16 <colindixon> #action katie to start tracking karaf 4 on the tracking spreadsheet with help from anipbu if needed
18:21:48 <rovarga> #link https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1
18:21:52 <skitt> #link dependency tree for the Karaf 4 migration: https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1
18:22:05 <rovarga> #link patches: https://git.opendaylight.org/gerrit/#/q/topic:karaf4
18:23:03 <colindixon> #action vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail
18:23:17 <colindixon> #topic events
18:23:25 <colindixon> #link https://www.opendaylight.org/global-events
18:23:51 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
18:24:48 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum we are locking down the Nitrogen DDF date for 5/31/17 and 6/1/17
18:25:23 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#OPNFV_Summit OPNFV summit in beijing's CFP will open next week, we're pretty sure
18:25:49 <colindixon> #info leadership summit in Tahoe next week
18:26:10 <colindixon> #info the expectation is to have notices out to all accepted ONS presenters by the end of the month
18:26:30 <colindixon> #info the OpenStack CFP has been left open until today, so please submit if you haven't
18:26:50 <colindixon> #topic system integration and test
18:27:29 <colindixon> #info now that we've moved jobs to running only 5 days a week, makes infrastructure issues more noticeable at times
18:28:04 <colindixon> #info jamoluhrsen says that they're looking into trying to debug that with rackspace
18:28:54 <colindixon> #info jamoluhrsen says they're trying to retry on failures, but LuisGomez has pointed out that's just maksing issues rackspace is having
18:29:01 <abhijitkumbhare> phrobb - who from Linux Foundation (non TSC or board) attending the Tahoe event next week? Just curious..
18:29:16 <colindixon> #topic infrastructure
18:29:58 <colindixon> #info yesterday, we noticed that rackspace was sending 503 errors to our CSIT jobs when we tried to spawn some things, rackspace says it's fixed, but jamoluhrsen says maybe not, let zxiiro and others know on the mailing list if we still see them
18:30:12 <zxiiro> #link https://git.opendaylight.org/gerrit/51096 Autorelease Auto Notify Patch
18:30:15 * jamoluhrsen thinks it would be good to have some period of time when the name RackSpace didn't really come up.
18:30:33 <colindixon> #info we're working on a patch to make autorelease notify projects when the build breaks
18:31:07 <colindixon> #topic nitrogen planning
18:31:18 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html
18:33:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005665.html previous thead on twice per year release process
18:33:17 * rovarga is just not taking the flamebait :)
18:34:04 <tykeal> now I'm wishing I was on the call just to know what flamebait rovarga is taking ;)
18:34:16 <rovarga> tykeal: version ranges :)
18:34:16 <tykeal> or not taking
18:34:22 <tykeal> heh
18:35:24 <colindixon> #info skitt points out that colindixon's naive idea of just publishing a version on each merge is the same as SNAPSHOTs
18:35:55 <colindixon> #info skitt then says what we really need is some way to actually define what semantic versioning is and then how we will do that
18:36:33 <colindixon> #info rovarga notes that yang tools has things they want to do in a v2.0 release, but doing so somewhat breaks the autorelease release model
18:38:46 <colindixon> #info rovarg and skitt seem to think that we need to be able to have multiple branches; each with a different release train; and also need to have all projects move to a release-based model
18:41:30 <phrobb> abhijitkumbhare: Who from the LF? I'm not sure what you are asking
18:41:58 <colindixon> #info skitt says that he thinks there is something good to do here, but we can start with odlparent, yangtools, and maybe mdsal, which would give a good playground
18:41:59 <abhijitkumbhare> Well - for start - are you or CaseyODL attending? :)
18:42:26 <colindixon> #info rovarga notes that we need to start with when we cut the carbon stability branches
18:42:38 <colindixon> #info skitt says that you can always fix that later
18:42:45 <phrobb> abhijitkumbhare: both myself, Casey,  as well as Andy and Thanh
18:42:47 <CaseyODL> Yes. :)
18:42:55 <abhijitkumbhare> great! :)
18:43:13 <colindixon> #action colindixon to set up some kind fo meeting (or at least thead) about semantic-versioning-ish things for nitrogen
18:44:27 <colindixon> #topic cookies
18:44:45 <colindixon> #endmeeting