#opendaylight-meeting: tsc

Meeting started by anipbu at 17:59:43 UTC (full logs).

Meeting summary

  1. Roll Call and Agenda Bashing (anipbu, 17:59:52)
    1. LuisGomez (LuisGomez, 18:01:22)
    2. skitt (skitt, 18:01:22)
    3. Hideyuki (hideyuki, 18:01:24)
    4. Anil Vishnoi (vishnoianil, 18:01:25)
    5. abhijitkumbhare (Abhijit Kumbhare) (abhijitkumbhare, 18:02:25)
    6. anipbu (anipbu, 18:02:47)
    7. https://wiki.opendaylight.org/index.php?title=TSC:Main#Agenda <--- Today's Agenda (anipbu, 18:02:56)
    8. jamoluhrsen (jamoluhrsen, 18:03:04)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-02-18.00.html <--- Last Week's Meeting Minutes (anipbu, 18:03:05)
    10. ACTION: vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer (anipbu, 18:03:20)
    11. edwarnicke_ (edwarnicke_, 18:03:26)
    12. Andre Fredette (Proxy for Sam Hague) (afredette, 18:03:30)
    13. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (anipbu, 18:03:31)
    14. https://lists.opendaylight.org/pipermail/dev/2017-March/003381.html <--- colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (anipbu, 18:04:01)
    15. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (anipbu, 18:04:14)
    16. https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html <--- colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so (anipbu, 18:04:31)
    17. ACTION: vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there (anipbu, 18:05:07)
    18. https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html <--- colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen (anipbu, 18:05:21)
    19. katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5 (See notification to respective mailing lists) (anipbu, 18:05:37)
    20. https://git.opendaylight.org/gerrit/#/c/52295/ <--- rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues (anipbu, 18:05:51)
    21. ACTION: phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing? (anipbu, 18:06:09)
    22. Thanh (zxiiro, 18:06:31)

  2. TSC Mailing List Conversations and Votes (anipbu, 18:06:51)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html <--- Nitrogen planning (anipbu, 18:07:00)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html <--- Namespace management (anipbu, 18:07:05)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html <--- projects with few/no active committers (anipbu, 18:07:10)
    4. https://lists.opendaylight.org/pipermail/release/2017-January/009034.html <--- flagship features in Carbon (anipbu, 18:07:15)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html <--- stricter enforcement of release requirements (anipbu, 18:07:20)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html <--- semantic versioning (or something like it) in Nitrogen (anipbu, 18:07:27)

  3. Events (anipbu, 18:08:25)
    1. https://www.opendaylight.org/global-events <--- Global Events Page (anipbu, 18:08:32)
    2. https://wiki.opendaylight.org/view/Events:Main <-- Events Wiki (anipbu, 18:08:39)
    3. https://www.opendaylight.org/events/2017-04-03-000000-2017-04-06-000000/open-networking-summit <--- OPEN NETWORKING SUMMIT Monday, April 3, 2017 to Thursday, April 6, 2017 (anipbu, 18:09:05)
    4. ONS has tutorials, docfest, ODL state of the union (anipbu, 18:09:25)
    5. phrobb asks did we want any meetings if we have critical mass (anipbu, 18:10:03)
    6. phrobb asks if we want to have TSC meeting in person (anipbu, 18:10:47)
    7. ACTION: CaseyODL to send email regarding topics or meetings for ONS (anipbu, 18:13:06)

  4. Boron (anipbu, 18:13:49)
    1. Boron SR3 Release on 3/23/2017 with Cutoff on 3/19/2017 at 23:59 UTC (anipbu, 18:15:40)

  5. Carbon (anipbu, 18:15:46)
    1. Missing M3:Status, capwap, cardinal, centinel, eman, next, of-config, opflex (anipbu, 18:16:54)
    2. Missing M4 Status: aaa, snmp, alto, capwap, cardinal, docs, eman, int/dist, next, of-config, opflex, packetcable, ttp (anipbu, 18:17:01)
    3. Missing M5 Status: netconf, infrautils, aaa (anipbu, 18:18:21)
    4. https://wiki.opendaylight.org/view/Weather#OpenFlowPlugin_-_Turn_Single_Layer_Serialization_on_by_default <--- OpenFlowPlugin - Turn Single Layer Serialization on by default (anipbu, 18:19:21)
    5. https://lists.opendaylight.org/pipermail/release/2017-March/009499.html <--- SFC MAC Chaining (anipbu, 18:19:27)
    6. https://lists.opendaylight.org/pipermail/release/2017-March/009409.html <--- MD-SAL Binding Generator API Change Waiver (anipbu, 18:19:34)
    7. ACTION: katiezhang to complete validation of M4 Status per project (anipbu, 18:19:57)

  6. System Integration and Test (anipbu, 18:20:23)
    1. jenkins queue is rather large (anipbu, 18:20:51)
    2. we do not have system test report, kindly request projects to add their link to the page (anipbu, 18:21:09)
    3. https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report landing page for projects to add their test reports (jamoluhrsen, 18:21:23)

  7. Infrastructure (anipbu, 18:21:48)
    1. https://git.opendaylight.org/gerrit/#/q/topic:improve-linting linting patches (zxiiro, 18:22:49)
    2. merged patches for linting (anipbu, 18:22:57)

  8. TSC Membership (anipbu, 18:23:24)
    1. https://www.opendaylight.org/membership <--- ZTE has joined OpenDaylight as a Platinum Member (anipbu, 18:23:38)
    2. https://www.opendaylight.org/governance <--- Welcome Huan Linying as new Platinum Member Designated TSC Member (anipbu, 18:23:52)
    3. Welcome Huan Linying & ZTE :) (abhijitkumbhare, 18:24:17)
    4. Welcome Huan Linying! (anipbu, 18:24:39)
    5. Welcome Huan Linying (vishnoianil, 18:24:52)

  9. MD-SAL Binding Generator (anipbu, 18:25:34)
    1. https://lists.opendaylight.org/pipermail/release/2017-March/009409.html <--- MD-SAL Binding Generator API Change Waiver (anipbu, 18:25:49)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=6859 <--- Bug Tracking (anipbu, 18:25:56)
    3. https://git.opendaylight.org/gerrit/#/q/topic:binding-gen-v1-refactoring-package-naming <--- Impacted Projects (anipbu, 18:26:05)
    4. May remove projects that are unresponsive: snmp, snbi, tsdr, capwap (anipbu, 18:26:19)

  10. Karaf 4 (anipbu, 18:27:10)
    1. https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1 <--- Tracking (anipbu, 18:27:18)
    2. skitt says he has generated patches for leaf projects. Since then, openflowplugin has been merged. Bug one we are waiting on is neutron, genius. (anipbu, 18:28:35)
    3. skitt says there are issues with SingleFeatureTest. May affect us (block us) for karaf 4 in Carbon (anipbu, 18:30:10)

  11. Nitrogen Planning: Stricter Enforcement (anipbu, 18:30:47)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html <--- stricter enforcement of release requirements (anipbu, 18:30:52)
    2. having an official timeline of when we'll remove you from the release for a late milestone (anipbu, 18:31:08)
    3. having an official timeline of when we'll remove you from the release for failing to merge patches that block others (anipbu, 18:31:21)
    4. more aggressively maybe removing all (or many) true leaves from the release and having them be "add-ons" by doing their own independent releases and then having users do a repo:add before feature:install for those projects' features (anipbu, 18:31:42)
    5. edwarnicke_ says we need to set crisp deadline and process for remediation (anipbu, 18:32:24)
    6. abhijitkumbhare asks what about nonleaf projects? how do we remove controller, mdsal (anipbu, 18:35:54)
    7. abhijitkumbhare asks would it make sense to drop projects one week after the deadline (anipbu, 18:38:15)
    8. hideyuki says one week is reasonable (anipbu, 18:38:58)
    9. edwarnicke_ suggest we rephrase to be less draconian such as "if you do not do X, then they will be dropped from autorelease" (anipbu, 18:40:05)
    10. TSC will continue this discussion on the mailing list (anipbu, 18:42:59)

  12. Nitrogen Planning: Semantic Versioning (anipbu, 18:43:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-March/006698.html <--- semantic versioning (or something like it) in Nitrogen (anipbu, 18:43:31)
    2. dependent projects switch to version ranges (as per Colin's proposal) (anipbu, 18:44:52)
    3. per-project releases are at the hands of the project (perhaps via a helpdesk ticket, this isn't about the process, it's about its existence) (anipbu, 18:44:59)
    4. projects are free to release on multiple branches (so we can have an "in-development" series of releases which isn't part of the current release, but planned for use in a future release) (anipbu, 18:45:04)
    5. we enforce the semantic constraints somehow (API breaks are reverted or cause a bump, at least if there hasn't been one in the release cycle) (anipbu, 18:45:09)
    6. we set up processes to ensure version convergence at release time (anipbu, 18:45:13)
    7. edwarnicke_ asks have to done any trial and tests? (anipbu, 18:48:04)
    8. edwarnicke_ says maven may get lowest permissible version, so we may not pick up the latest (anipbu, 18:48:41)
    9. skitt says we can start with some of the kernal projects like odlparent and yangtools, and then slowly trickle down (anipbu, 18:51:44)

  13. Nitrogen Planning: Faster Release (anipbu, 18:53:08)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html (anipbu, 18:53:21)
    2. Moving to a twice a year release process. This would help planning by not having our release dates shift randomly around each year, fall more in line with other open source projects, get us cycling a bit faster, and maybe also have some more discipline. (anipbu, 18:53:30)
    3. jamoluhrsen asks if we are making a small group to come up with a plan (anipbu, 18:54:01)
    4. abhijitkumbhare reminds us that colin had suggested we form a working group to discuss (anipbu, 18:56:38)
    5. edwarnicke_ suggests we need to figure out what is a process based plan. (anipbu, 18:56:46)
    6. edwarnicke_ suggest 1) we decide if we want to fit in a timeframe, 2) write a release plan that can happen within that timeframe (anipbu, 18:59:22)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-July/005665.html <--- previous analysis from colindixon (anipbu, 19:00:40)
    8. ACTION: jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week. (anipbu, 19:04:53)

  14. cookies (anipbu, 19:05:43)


Meeting ended at 19:05:53 UTC (full logs).

Action items

  1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer
  2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there
  5. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
  6. CaseyODL to send email regarding topics or meetings for ONS
  7. katiezhang to complete validation of M4 Status per project
  8. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.


Action items, by person

  1. abhijitkumbhare
    1. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  2. anipbu
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer
    2. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  3. CaseyODL
    1. CaseyODL to send email regarding topics or meetings for ONS
  4. edwarnicke_
    1. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  5. jamoluhrsen
    1. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  6. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    3. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
  7. vishnoianil
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer
    2. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  8. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
  9. UNASSIGNED
    1. vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there
    2. katiezhang to complete validation of M4 Status per project


People present (lines said)

  1. anipbu (98)
  2. odl_meetbot (7)
  3. abhijitkumbhare (6)
  4. vishnoianil (6)
  5. zxiiro (4)
  6. katie (4)
  7. jamoluhrsen (4)
  8. afredette (3)
  9. LuisGomez (3)
  10. hideyuki (2)
  11. edwarnicke_ (1)
  12. skitt (1)
  13. dfarrell07 (1)
  14. phrobb (0)
  15. CaseyODL (0)


Generated by MeetBot 0.1.4.