#opendaylight-meeting: tsc

Meeting started by colindixon at 03:30:45 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 03:30:50)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53341#Agenda (colindixon, 03:30:53)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-16-17.00.html last week's meeting minutes (colindixon, 03:31:05)
    3. colindixon (colindixon, 03:31:17)
    4. Hideyuki (hideyuki, 03:31:38)
    5. Thanh Ha (zxiiro, 03:31:54)
    6. Daniel Farrell (dfarrell07, 03:31:55)
    7. jamoluhrsen (jamoluhrsen, 03:33:08)
    8. LuisGomez (LuisGomez, 03:33:47)
    9. Anil Vishnoi (vishnoianil, 03:33:50)
    10. anipbu (anipbu, 03:34:35)
    11. ACTION: colindixon to try to find a time for an infromal meeting of ODL folks at ONS (colindixon, 03:35:12)
    12. lori (lori, 03:36:05)
    13. abhijitkumbhare (abhijitkumbhare, 03:36:21)
    14. https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2017-March/000230.html <--- SDNINTERFACEAPP responding to concerns (anipbu, 03:37:13)
    15. https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB (CaseyODL, 03:37:13)
    16. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 03:37:41)
    17. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 03:37:46)
    18. ACTION: phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing? (colindixon, 03:37:56)
    19. ACTION: katiezhang to follow up with validation of M4 Status per project (colindixon, 03:41:22)
    20. ACTION: rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF (colindixon, 03:41:42)

  2. TSC mailing list votes and discussions (colindixon, 03:42:57)
    1. see the agenda, but most of this stuff is either old, or come to conclusion (colindixon, 03:43:07)

  3. events (colindixon, 03:43:11)
    1. https://www.opendaylight.org/global-events (colindixon, 03:43:20)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 03:43:31)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-March/006756.html possible get together for ODL folks at ONS (colindixon, 03:43:51)
    4. https://www.surveymonkey.com/r/PGXT5PX open source community reception on Monday @ 6p RSVP (colindixon, 03:44:51)
    5. jamoluhrsen asks about trying cross-project relaase syncing, colindixon says ChrisPriceAB is trying to set something up, if you want to participate, let him know (colindixon, 03:45:54)
    6. OpenStack Boston is 2nd week of May (colindixon, 03:46:40)
    7. we will have a booth there, looking for demos (colindixon, 03:46:53)
    8. http://events.linuxfoundation.org/events/opnfv-summit/program/cfp CFP OPNFV (dfarrell07, 03:47:30)

  4. boron (colindixon, 03:48:44)
    1. Boron-SR3 is supposed to go out today, that's not going to happen (colindixon, 03:48:56)
    2. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1776065453 tracking spreadsheet (colindixon, 03:49:06)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/219/ this is the respin which literally just finished (colindixon, 03:49:46)
    4. distribution test job should start now-ish and take 8-9 hours, we should have better data tomorrow morning (colindixon, 03:50:41)
    5. it's worht noting that since we've moved a lot more tests into distribution test jobs, resulting in 113 failures vs. 11 for SR2 (colindixon, 03:51:47)
    6. shague notes that we really want to keep anipbu's basic release strategy of tracking test failures, votes on go-nogo (traditionally for major release only, SRs is only test failures), tracking blocking bugs, respins, etc. (colindixon, 03:52:59)
    7. shague wants to make sure we continue to get dist test results on the spreadsheet, actually track down projects and get them to sign-off/fix (dfarrell07, 03:54:52)
    8. jamoluhrsen says that all system tests are run as part of distribution test now vs. only opt-in before (colindixon, 03:55:23)
    9. shague wants to make sure we track bockers that will require respin, trigger re-spins quickly when needed (dfarrell07, 03:56:08)
    10. ACTION: jamoluhrsen to add a new status type for jobs that integration opted-in without project effort, so we know which ones might have no response because of that (colindixon, 03:57:01)
    11. colindixon hopes we'll have something we could release for Boron-SR3 by monday sometime, people should be ready to vote over e-mail on Monday (colindixon, 03:58:29)

  5. carbon (colindixon, 03:58:48)
    1. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 Karaf 4 progress (colindixon, 04:00:12)
    2. 28 projects have finished karaf 4, 7 projects have pending patches, and 16 projeects with no patches (colindixon, 04:00:50)
    3. that's a bit over half or projects done (colindixon, 04:01:00)
    4. anipbu notes that this puts karaf 4 migration in an unhealthy state (colindixon, 04:01:12)
    5. colindixon notes that, in his mind and others, this means we're either likely to kick a large number offset 2 projects out of carbon, or have people volunteer to help (colindixon, 04:02:18)
    6. jamoluhrsen notes that doing patches for people, might further enable bad behavior (colindixon, 04:02:44)
    7. ACTION: colindixon or katie to send out nastygrams about being removed from the release (colindixon, 04:03:57)
    8. jamoluhrsen and dfarrell07 say that one idea is to have true leaves participate in the release as a privilege, not a right, basically then show them how to do releases, repo:add, feature:install (colindixon, 04:06:07)
    9. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 04:11:18)
    10. phrobb asks if we'll host these artifacts and instructions, colindixon says for things hosted in ODL infra we should host them, for others, it's a good question, phrobb notes that if it's a wiki page there's nothing to stop others from also adding it (colindixon, 04:13:23)
    11. LuisGomez notes that some things change with testing too, and offers to help some (colindixon, 04:14:07)
    12. vishnoianil notes that he worries a bit that this may result in nobody participating in the simultaneous release (colindixon, 04:15:36)
    13. https://git.opendaylight.org/gerrit/#/c/53664/2 carbon autorelease is failing because of sal-netconf-connector, colindixon isn't sure why (colindixon, 04:17:28)

  6. system integration and test (colindixon, 04:17:42)
    1. vrpolak noteed that Karaf 4 for distribiton now has restconf, so he's working on the distribution test for that (colindixon, 04:18:09)
    2. there was a recent controller regression as far as clustering goes, there's a new patch merged which seems to have gotten things back to normal (colindixon, 04:18:38)
    3. jamoluhrsen notes that it took 2 days to get a response and it hurt our jenkins queue (colindixon, 04:19:18)
    4. ACTION: colindixon to create postmortem topics for Carbon and add the clustering breakage to it (colindixon, 04:19:34)

  7. infrastructure (colindixon, 04:19:53)
    1. nothing this week (colindixon, 04:20:02)
    2. abelur is on the call because this call is at a time that works for him (colindixon, 04:20:34)

  8. TSC membership (colindixon, 04:21:41)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-March/006813.html language for filling vacancies (colindixon, 04:21:54)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-March/006822.html 8 +1s or more (colindixon, 04:22:03)
    3. phrobb and/or colindixon will take this to the board either over e-mail or at the next meeting (colindixon, 04:22:20)
    4. the next board meeting is 4/12 (colindixon, 04:22:51)

  9. Nitrogen planning (colindixon, 04:22:53)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-March/006779.html Preliminary notes on 6-month release cadence (colindixon, 04:23:08)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-March/006849.html proposal for month-based release schedule (colindixon, 04:23:20)
    3. jamoluhrsen says he likes this, he wants to stress lining up, jamoluhrsen also asks about lining up with all or (almost all) other LF networking projects (colindixon, 04:27:33)
    4. dfarrell07 notes that OPNFV tries to line up with OpenStack, colindixon notes OpenStack has moved away from April and October (for the last 5 years), to releasing in Feb this last time and planning on Setpebmer (colindixon, 04:28:53)
    5. colindixon worries if that means they're nota good reliable clock (colindixon, 04:29:02)
    6. phrobb says lining up inside the LF seems like good goal (colindixon, 04:29:23)
    7. colindixon says the best way forward is probably to produce a clump and try to get others to join (colindixon, 04:30:04)
    8. maybe start FD.io, ODL, and OPNFV, then hope ONAP choose to align, that would be a big center of mass (colindixon, 04:30:33)

  10. cookies (colindixon, 04:30:53)


Meeting ended at 04:31:02 UTC (full logs).

Action items

  1. colindixon to try to find a time for an infromal meeting of ODL folks at ONS
  2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
  5. katiezhang to follow up with validation of M4 Status per project
  6. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  7. jamoluhrsen to add a new status type for jobs that integration opted-in without project effort, so we know which ones might have no response because of that
  8. colindixon or katie to send out nastygrams about being removed from the release
  9. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  10. colindixon to create postmortem topics for Carbon and add the clustering breakage to it


Action items, by person

  1. CaseyODL
    1. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  2. colindixon
    1. colindixon to try to find a time for an infromal meeting of ODL folks at ONS
    2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    3. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
    4. colindixon or katie to send out nastygrams about being removed from the release
    5. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    6. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
  3. jamoluhrsen
    1. jamoluhrsen to add a new status type for jobs that integration opted-in without project effort, so we know which ones might have no response because of that
  4. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  5. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
    3. katiezhang to follow up with validation of M4 Status per project


People present (lines said)

  1. colindixon (84)
  2. lori (13)
  3. jamoluhrsen (10)
  4. dfarrell07 (8)
  5. CaseyODL (5)
  6. odl_meetbot (4)
  7. anipbu (3)
  8. abhijitkumbhare (3)
  9. LuisGomez (2)
  10. zxiiro (2)
  11. vrpolak (1)
  12. hideyuki (1)
  13. abelur (1)
  14. vishnoianil (1)


Generated by MeetBot 0.1.4.