17:00:14 <colindixon> #startmeeting tsc
17:00:14 <odl_meetbot> Meeting started Thu Apr 13 17:00:14 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:22 <colindixon> #topic roll call and agenda bashing
17:00:24 <colindixon> #info colindixon
17:00:29 <colindixon> TSC members, please #info in
17:00:44 <skitt> #info skitt
17:00:56 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-24-03.30.html last meeting's minutes (2 weeks ago)
17:01:06 <anipbu> #info anipbu
17:01:09 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53881#Agenda today's agenda
17:01:26 <abhijitkumbhare> #info abhijitkumbhare
17:01:29 <hideyuki> #info Hideyuki
17:01:38 <LuisGomez> #info LuisGomez
17:01:39 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:01:39 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:02:23 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum <-- ddf
17:02:42 <skitt> #link DDF discussion: https://lists.opendaylight.org/pipermail/tsc/2017-March/006851.html
17:02:46 <lori> #info lori
17:02:51 <rovarga> #info rovarga
17:02:53 <zxiiro> #info Thanh
17:02:57 <jamoluhrsen> #info jamoluhrsen
17:03:04 <dfarrell07> the two call-in numbers on the GCal, 1-415-655-0002 and 1-855-797-9485, fail with meeting number 194 548 370 for me
17:03:14 <dfarrell07> CaseyODL^^
17:03:24 <colindixon> #action katiezhang to follow up with validation of M4 and M5 Status per project
17:04:08 <dfarrell07> 1-844-740-1264 works
17:04:15 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
17:04:16 <colindixon> #action colindixon to create postmortem topics for Carbon and add the clustering breakage to it
17:04:27 * dfarrell07 updates the gcal
17:04:33 <colindixon> thanks dfarrell07
17:05:06 <vishnoianil> #info Anil VIshnoi
17:05:31 <CaseyODL> https://www.irccloud.com/pastebin/7GlaYAWH/
17:05:31 <colindixon> #info CaseyODL would like the TSC to discussion choosing between BlueJeans and Zoom today
17:06:16 <colindixon> #action colindixon to add the security mailing list to today's meeting or next meeting if we dont' have time
17:06:28 <colindixon> #action colindixon to add BlueJeans vs. Zoom today or next week if no time
17:06:43 <colindixon> #action beryllium security release
17:06:52 <colindixon> #topic mailing list votes and discussions
17:06:58 <shague> #info shague
17:07:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-April/006980.html Michael Vorburger and Stephen Kitt as committers on controller
17:07:15 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-April/006981.html Tomas Slusny as a committer on OpenFlow plugin
17:07:38 <colindixon> #ilnk https://lists.opendaylight.org/pipermail/tsc/2017-April/007000.html Notes on moving to 6-month release cadences
17:07:56 <colindixon> #topic events
17:08:02 <colindixon> #link https://www.opendaylight.org/global-events
17:08:07 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:08:55 <colindixon> #info OPNFV summit in Beijgin in first week in June, Our DDF end of may/beginning of june in Santa Clara
17:09:29 <colindixon> #topic boron
17:09:40 <colindixon> #info Boron-SR3 was released last week
17:09:47 <colindixon> #topic Carbon
17:10:07 <colindixon> #Info chasing projects that haven't gotten their milestones in
17:10:09 <katie_> atrium capwap cardinal centinel next  yang-push
17:10:47 <colindixon> #info the following projects are still absent: atrium capwap cardinal centinel next  yang-push
17:11:42 <colindixon> #info colindixon notes that he's pretty sure atrium, capwap, centinel, and yang-push have already left the Carbon release
17:12:03 <colindixon> #action colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal
17:12:11 <katie_> dlux  faas genius lacp natapp next nic opflex ovsdb snbi snmp4sdn tsdr usecplugin yang-push
17:12:34 <colindixon> #info the following projects are still missing M5: dlux  faas genius lacp natapp next nic opflex ovsdb snbi snmp4sdn tsdr usecplugin yang-push
17:13:04 <katie_> "controller mdsal federation aaa alto BIER netconf"
17:13:52 <colindixon> #info projects having issues with karaf 4 controller mdsal federation aaa alto BIER netconf
17:14:07 <abhijitkumbhare> sorry i thought some other project had problem with openflow plugin
17:14:47 <colindixon> #undo
17:14:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b7dcd0>
17:15:06 <colindixon> #info projects having issues with karaf 4: federation alto BIER netconf
17:15:24 <colindixon> #topic Karaf 4 migration risk and status
17:15:30 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896
17:15:40 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-April/006957.html Mailing list thread on Karaf 4 risks and options
17:17:04 <colindixon> #Info during the kernel call on Tuesday, it seems as though very few projects have done very little testing of their Karaf 4 distributions, the result is that other than green verify +1s, we have very little testing of Karaf 4 itself
17:17:37 <colindixon> #info it appears as though there's still less manpower than needed to drive this forward
17:18:59 <colindixon> #info restconf was broken in Karaf 4, but then was fixed, after that the upgrade to Karaf 4.0.9, but it seems to be a feature resolution issue in Karaf
17:19:11 <anipbu> 11 Projects pending.  8 with pending patches.  3 without any patches.  3 nonleaf project cannot be dropped.
17:19:24 <colindixon> thanks anipbu
17:19:54 <colindixon> #info anipbu says that this is our current status for Karaf 4 migration patches is: 11 Projects pending.  8 with pending patches.  3 without any patches.  3 nonleaf project cannot be dropped
17:20:22 <jamoluhrsen> are we going to drop these projects. well the leaf ones?
17:20:37 <colindixon> #info skitt asks if we could roll back to 4.0.7, rovarga says that might work
17:21:38 <colindixon> #info colindixon asks if we get restconf fixed (which seems plausible), we could then have a reasonable Karaf 4 distribution which we could test
17:22:07 <skitt> rovarga, what's the odlparent bug for restconf?
17:22:10 <colindixon> #action jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
17:22:57 <jamoluhrsen> https://bugs.opendaylight.org/show_bug.cgi?id=8208
17:24:19 <skitt> this is where I'm glad I kept the -4.0.7 patches in odlparent
17:24:39 <vrpolak> #link https://git.opendaylight.org/gerrit/53797
17:24:53 <vrpolak> #info ETA to merge: 1 week.
17:25:03 <colindixon> #info jamoluhrsen and LuisGomez note that RC0 is supposed to be today and even if we were to unblock Karaf 4 distributions today, there's no way we could get all the jobs in place to meaningfully get carbon out the door
17:26:04 <abhijitkumbhare> vrpolak is at a place - he can only type not talk - maybe a bar :)
17:26:15 <colindixon> abhijitkumbhare: i can understand that
17:27:13 <colindixon> #info based on this assessment, we are 2-3 weeks behind where we would really like to be, but that's with zero system testing
17:27:38 <colindixon> #info if system testing is mostly clean, that woiuld mean that was it, otherwise, that might be off by another 1-2 weeks as we figure things out
17:28:16 <colindixon> #info rovarga says his hope is that we should have much fewer issues once we get out toward leaf projects
17:30:23 <colindixon> anipbu: the next thing I'm going to want to ask about is to ask about the projects that are likely to be dropped and the ones that can't be dropped because of Karaf 4
17:31:07 <colindixon> #info lori has been testing Karaf 4, the distribution seems to build locally and come up fine, but the integration tests don't work locally, but do work in jenkins
17:31:48 <colindixon> #info skitt and rovarga note that pax-exam issues when moving to Karaf 4 weren't trivial
17:32:32 <anipbu> colindixon: Leaf projects with Karaf 4 Pending: cardinal, didm, iotdm, lacp, nic, snmp4sdn, unimgr.  Nonleaf projects with Karaf 4 Pending: snmp, tsdr
17:32:51 <colindixon> anipbu: that's different from 3 non-leaf
17:33:02 <colindixon> progress since the beginning of the meeting
17:33:21 <anipbu> colindixon: yes, progress since the beginning of the meeting :)
17:33:46 <rovarga> anipbu: colindixon: sounds like we need way more meetings ... ;-)
17:34:35 <anipbu> colindixon: groupbasedpolicy merged their patches for karaf 4, bringing the count of nonleaf from 3 to 2.
17:34:41 <skitt> colindixon, detailed patch status is in https://lists.opendaylight.org/pipermail/tsc/2017-April/006956.html
17:34:57 <colindixon> #info colindixon notes that there is no way that we can have an RC0 today, next week would be as early as possible
17:35:44 <anipbu> colindixon: New Statistics: 9 Projects pending.  6 with pending patches.  3 without any patches.  2 nonleaf project cannot be dropped.
17:35:54 <colindixon> #info we haven't started putting features into the Karaf 4 distribution yet, in part becuase we don't have a distribution check for our Karaf 4 distribution
17:36:18 <colindixon> #info from anipbu: Leaf projects with Karaf 4 Pending: cardinal, didm, iotdm, lacp, nic, snmp4sdn, unimgr.  Nonleaf projects with Karaf 4 Pending: snmp, tsdr
17:37:06 <skitt> anipbu, where's the tsdr patch?
17:37:33 <anipbu> skitt: tsdr does not have a patch available.
17:38:05 <anipbu> skitt: 3 projects have not submitted patches for Karaf 4: didm, lacp, tsdr
17:38:08 <skitt> anipbu, ah sorry I'd misunderstood "Karaf 4 pending" as "patch pending"
17:38:21 <skitt> anipbu, but it's just "Karaf 4 unfinished" in whatever state
17:38:47 <zxiiro> should we go ahead with removing projects from autorelease if they have no karaf 4 patches?
17:38:58 <zxiiro> I know Steven has several patches to autorelease already
17:39:05 <zxiiro> Stephen* sorry
17:39:11 <anipbu> zxiiro: we cannot remove tsdr and snmp because they are nonleaf projects
17:39:16 <colindixon> #Info vishnoianil asks if we could ship Karaf 3 in Carbon and switch to Karaf 4 in Carbon SR1
17:42:30 <colindixon> #info colindixon notes that given how much trouble we've had migrating from Karaf 3 to Karaf 4 internally, it seems like downstream users would find that super jarring
17:44:52 <jamoluhrsen> https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/
17:44:56 <jamoluhrsen> all red dots
17:45:12 <skitt> my mic's gone for some reason
17:45:26 <skitt> I think inside the projects we're in better shape
17:45:39 <anipbu> Last successful build of Carbon Autorelease: Build #148 (Feb 1, 2017 12:31:55 AM)
17:45:41 <colindixon> #info colindixon asks if we have a Karaf 3 RC0 today if we wanted to do that, anipbu notes that we haven't had a succsessful carbon autorelease build since February
17:45:42 <skitt> at least the project's I'm involved with in detail are in better shape now than at Boron SR0
17:45:50 <colindixon> skitt: yeah
17:45:58 <skitt> there isn't the huge backlog of features waiting to be merged post-RC0
17:46:06 <skitt> like we had in Boron
17:46:19 <skitt> s/project's/projects/ :-/
17:46:51 <colindixon> #info skitt notes that his feeling from the projects he touches is that Carbon is in generally better shape than Boron was going into RC0 failing builds or not
17:49:41 <colindixon> #Info colindixon asks if we can get autorelease building without leaf projects to see if we can cut out some noise
17:50:13 <anipbu> colindixon: Can we get approval to remove the Karaf 4 Unfinished Leaf projects?
17:52:17 <colindixon> #agreed colindixon says that as far as he understands we have repeatedly communicated to projects that Karaf 4 is required for Carbon participation, also we have given the integration and autorelease projects permission to remove projects which are interfering with the release to make progress knowing that projects which are truly participating can quickly fix issues and re-add themselves
17:52:38 <skitt> +1
17:52:42 <jamoluhrsen> looks right
17:52:52 <rovarga> yup
17:52:58 <skitt> we need to send a friendly email to the projects being removed from autorelease to reassure them that they can get back in
17:53:05 <anipbu> projects we can remove: cardinal, didm, iotdm, lacp, nic, snmp4sdn, unimgr, tsdr (which becomes leaf once other projects are removed)
17:53:07 <skitt> because e.g. lacp is working on a patch
17:53:39 <skitt> yeah it was more re getting back in ;-)
17:53:44 <rovarga> #action colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
17:54:05 <rovarga> anipbu: iotdm is working on karaf4, battling some osgi issues
17:54:20 <colindixon> #topic zoom vs. bluejeans
17:54:36 <colindixon> #info edwarnicke says he's had trouble using bluejeans internationally, zoom doesn't seem to have those problems
17:54:45 <skitt> we use bluejeans internationally all the time at Red Hat without too many issues
17:54:52 <colindixon> #info edwarnicke says echos, latency, etc.
17:55:17 <colindixon> #info skitt notes Red Hat has had no such issues despite using internationally
17:55:36 <skitt> I'm unhappy with the Zoom Linux client
17:55:55 <skitt> Blue Jeans doesn't need a client
17:56:02 <skitt> it works with browsers with WebRTC
17:56:06 <skitt> in Chrome and Firefox
17:56:28 <skitt> and again, we use it a lot at Red Hat without the issues CaseyODL is mentioning :-)
17:56:44 <afredette> I use BlueJeans in Chrome on Fedora without issues.
17:56:49 <colindixon> #startvote (anyone, not just TSC members please also chime in) do people prefer bluejeans, zoom, or don't care? bluejeans, zoom, either
17:56:49 <odl_meetbot> Begin voting on: (anyone, not just TSC members please also chime in) do people prefer bluejeans, zoom, or don't care? Valid vote options are bluejeans, zoom, either.
17:56:49 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:56:54 <colindixon> #vote either
17:56:59 <skitt> #vote bluejeans
17:57:08 <vishnoianil> #vote bluejeans
17:57:10 <jamoluhrsen> maybe CaseyODL was using windows xp for his bjn test
17:57:16 <skitt> ROFL
17:57:21 <zxiiro> #vote either
17:57:27 <jamoluhrsen> #vote either
17:57:29 <shague> #vote bluejeans
17:57:45 <anipbu> #vote either
17:57:47 <colindixon> ALSO NOTE ANYONE CAN VOTE HERE, NOT JUST TSC MEMBERS
17:57:50 <hideyuki> #vote bluejeans
17:57:58 <afredette> #vote bluejeans
17:58:28 <skitt> to be honest I'd rather wait for a week to vote
17:58:34 <colindixon> edwarnicke, anipbu, CaseyODL, please vote here
17:58:36 <skitt> we were planning on testing Zoom in the kernel call next week
17:58:49 <colindixon> #info to be clear this is informational, not decisive in my mind
17:58:49 <edwarnicke> #vote zoom
17:58:51 <anipbu> colindixon: already voted
17:59:36 <colindixon> #endvote
17:59:36 <odl_meetbot> Voted on "(anyone, not just TSC members please also chime in) do people prefer bluejeans, zoom, or don't care?" Results are
17:59:36 <odl_meetbot> bluejeans (5): shague, skitt, vishnoianil, hideyuki, afredette
17:59:36 <odl_meetbot> either (4): colindixon, anipbu, jamoluhrsen, zxiiro
17:59:36 <odl_meetbot> zoom (1): edwarnicke
17:59:43 <colindixon> #chair anipbu
17:59:43 <odl_meetbot> Current chairs: anipbu colindixon
17:59:49 <colindixon> #chair CaseyODL
17:59:49 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon
18:00:05 <colindixon> I have to run
18:00:34 <afredette> Either would be better than WebEx
18:02:23 <colindixon> #action CaseyODL to send mail to disucss@ tsc@ saying what the time-frame
18:02:44 <afredette> Can everyone try to use it next week for meetings?
18:04:21 <anipbu> #topic cookies
18:04:31 <anipbu> #endmeeting