17:00:26 <colindixon> #startmeeting tsc
17:00:26 <odl_meetbot> Meeting started Thu May 11 17:00:26 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:31 <colindixon> #topic agenda bashing and roll call
17:00:35 <colindixon> TSC members please #info in
17:00:37 <colindixon> #info colindixon
17:00:41 <skitt> #info skitt
17:00:48 <zxiiro-away> #info Thanh
17:00:48 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54716#Agenda agenda
17:00:57 <colindixon> #linkhttps://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-05-04-17.00.html last week's meeting minutes
17:00:58 <anipbu> #info anipbu
17:01:02 <lori> #info lori
17:01:20 <rovarga> #info rovarga
17:01:21 <hideyuki> #info Hideyuki
17:02:30 <vishnoianil> #info Anil Vishnoi
17:03:08 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:03:08 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:03:09 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
17:03:13 <colindixon> #action katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
17:03:22 <LuisGomez> #info LuisGomez
17:04:02 <colindixon> #info colindixon is not planning to reach out the board/advisory group about longer delays, because shipping on Karaf 3 shoudl make it less relevant
17:04:17 <colindixon> #link new CVEs are here: https://wiki.opendaylight.org/view/Security_Advisories
17:04:24 <colindixon> #link https://lists.opendaylight.org/pipermail/security-announce/2017-May/000003.html mail to security-announce
17:04:44 <jamoluhrsen> #info jamoluhrsen
17:05:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html colindixon thinks we don't need to ship a Beryllium-SR4.1, reasons there
17:05:35 <colindixon> #action phrobb to bring the need for a security manager to the board
17:06:19 <colindixon> #topic TSC mailing list votes and discussions
17:06:30 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007181.html Viability of and using Karaf 3 for Carbon
17:06:42 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007204.html Locking the stable/carbon branch
17:07:16 <abhijitkumbhare> #info abhijitkumbhare
17:07:30 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html Need for a Beryllium-SR4.1?
17:08:03 <colindixon> #topic events
17:08:09 <colindixon> #link https://www.opendaylight.org/global-events
17:08:14 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:08:49 <colindixon> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum get your events into the Nitrogen DDF
17:09:29 <CaseyODL> I'm having really bad audio issues.  But if you could please make sure that all topics are in for the DDF.  The hotel block for special room rates has expired.  If you have not registered yet and your trying to get a hotel, please let me know.
17:09:30 <colindixon> #link http://events.linuxfoundation.org/events/opendaylight-developer-design-forum the DDF page with registration information
17:09:39 <CaseyODL> Probably best here on IRC.
17:09:50 <colindixon> #action CaseyODL to make sure that link (and how to register) is on the wiki events page
17:11:02 <colindixon> #info phrobb says that OpenStack is going well in Boston, the Nirvanah Stack day is good, there's tons of telco and SP stuff here, it seems like OpenStack is going that way, there are likely people who would be here at the TSC call, but are at the Nirvanha day instead
17:11:25 <colindixon> #topic boron
17:11:29 <colindixon> #info nothing today
17:11:43 <colindixon> #undo
17:11:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bfe810>
17:12:00 <colindixon> #Info anipbu notes that Boron-SR4 is in one month (timed to come out just after Carbon)
17:12:55 <colindixon> #info Boron-SR4 is currently scheduled for 6/15, with a cutoff of 6/11 at 23:59 UTC
17:13:34 <colindixon> #action jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
17:14:53 <colindixon> #Info rovarga asks if we should push Boron-SR4 out by some amount if we delay Carbon, which we are
17:16:22 <colindixon> #info rovarga suggests to have at least 1-2 weeks between Carbon relase and Boron-SR4, colindixon says his take is a minimum is 2 weeks
17:17:10 <jamoluhrsen> lol this is fun
17:17:26 <colindixon> #action colindixon to send out a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
17:18:38 <colindixon> #topic carbon
17:19:49 <colindixon> #info we have locked the stable/carbon branch as of a little bit less than 24 hours ago
17:20:08 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/307/ this job ran after the branch was locked, so colindixon suggest we call that RC0
17:20:17 <colindixon> #link https://nexus.opendaylight.org/content/repositories/autorelease-1802/ stagig repo here
17:20:24 <colindixon> #link https://nexus.opendaylight.org/content/repositories/autorelease-1802/org/opendaylight/integration/distribution-karaf/0.6.0-Carbon/distribution-karaf-0.6.0-Carbon.zip karaf 3 distribution
17:20:57 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 blocking bugs
17:21:37 <colindixon> #info colindixon's take is that what the TSC has voted on is that this is RC0 and we are only fixing blocking bugs from here on out
17:22:57 <colindixon> #Info colindixon asks jamoluhrsen if he has a sense of where we're at or if we need to wait for projects to look at results and manually test
17:24:12 <zxiiro-away> LuisGomez: jamoluhrsen we should check if they are back in integration/distirbution too
17:24:22 <zxiiro-away> iotdm i mean
17:24:31 <jamoluhrsen> vrpolak, any idea ^^^
17:25:32 <jamoluhrsen> #info CSIT for last carbon autorelease (307) has not started yet.
17:26:34 <anipbu> +1 to 48 hours
17:26:42 <colindixon> #info LuisGomez asks if we should try to add projects that were removed for lack of migration from Karaf 4, colindixon says his take is that projects that haven't responded shouldn't be added back if they're not paying attention
17:27:18 <colindixon> #info phrobb says at least notifying projects once and giving a timeline to respond makes sense
17:27:37 <colindixon> #startvote how long should we allow projects to join autorelease again? 1 week, 48 hours
17:27:37 <odl_meetbot> Begin voting on: how long should we allow projects to join autorelease again? Valid vote options are 1, week, 48, hours.
17:27:37 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:27:45 <skitt> #vote 1
17:27:52 <anipbu> #vote 48
17:27:53 <colindixon> #vote 48 hours
17:27:53 <odl_meetbot> colindixon: 48 hours is not a valid option. Valid options are 1, week, 48, hours.
17:27:54 <rovarga> #vote week
17:27:56 <jamoluhrsen> #vote week
17:27:56 <rovarga> :-)
17:27:59 <colindixon> #vote 48
17:28:03 <jamoluhrsen> #vote 1
17:28:09 <zxiiro-away> #vote 48
17:28:13 <hideyuki> #vote 48
17:28:13 <colindixon> #endvote
17:28:13 <odl_meetbot> Voted on "how long should we allow projects to join autorelease again?" Results are
17:28:13 <odl_meetbot> 1 (2): skitt, jamoluhrsen
17:28:13 <odl_meetbot> week (1): rovarga
17:28:13 <odl_meetbot> 48 (4): hideyuki, colindixon, zxiiro-away, anipbu
17:28:27 <colindixon> #startvote how long should we allow projects to join autorelease again? 1w, 48 h
17:28:27 <odl_meetbot> Begin voting on: how long should we allow projects to join autorelease again? Valid vote options are 1w, 48, h.
17:28:27 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:30 <skitt> #vote 1w
17:28:34 <anipbu> #vote 48
17:28:34 <colindixon> #endvote
17:28:34 <odl_meetbot> Voted on "how long should we allow projects to join autorelease again?" Results are
17:28:34 <odl_meetbot> 48 (1): anipbu
17:28:34 <odl_meetbot> 1w (1): skitt
17:28:37 <jamoluhrsen> #vote broken
17:28:38 <colindixon> #startvote how long should we allow projects to join autorelease again? 1w, 48h
17:28:38 <odl_meetbot> Begin voting on: how long should we allow projects to join autorelease again? Valid vote options are 1w, 48h.
17:28:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:41 <skitt> #vote 1w
17:28:41 <rovarga> #vote 1w
17:28:42 <lori> #vote 1w
17:28:45 <jamoluhrsen> #vote 1w
17:28:46 <anipbu> #vote 48h
17:28:46 <colindixon> #vote 48h
17:28:47 <zxiiro-away> #vote 48h
17:28:48 <hideyuki> #vote 48h
17:28:50 <abhijitkumbhare> Does 48 hours mean Monday?
17:28:53 * skitt wins the race every time
17:28:53 <LuisGomez> #vote 48h
17:29:00 <abhijitkumbhare> #vote 48h
17:29:13 <colindixon> #endvote
17:29:13 <odl_meetbot> Voted on "how long should we allow projects to join autorelease again?" Results are
17:29:13 <odl_meetbot> 1w (4): skitt, rovarga, lori, jamoluhrsen
17:29:13 <odl_meetbot> 48h (6): zxiiro-away, LuisGomez, hideyuki, colindixon, abhijitkumbhare, anipbu
17:29:42 <skitt> 15
17:29:43 <jamoluhrsen> 15th
17:29:48 <colindixon> #agree we will tell projects that they need to be in autorelease by 23:59 UTC on Monday, May 15th
17:30:59 <colindixon> #info sending a mail just to relelease is sufficient for both phrobb and anipbu, colindixon will do that
17:31:21 <colindixon> #action colindixon to notify release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate
17:32:17 <colindixon> #Info colindixon asks jamoluhrsen asks  if we're yellow, green or red, jamoluhrsen says between yellow and green
17:32:21 <vrpolak> jamoluhrsen: Idea about what, this? https://git.opendaylight.org/gerrit/56873
17:33:19 <jamoluhrsen> vrpolak, people were saying iotdm was not back in distribution yet, but was in autorelease. wondered if you knew the status
17:33:20 <anipbu> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
17:33:45 <jamoluhrsen> vrpolak, we need to merge 56873
17:34:00 <colindixon> #action anipbu to work with colindixon to send mail with pointers to RC0, post links to RC0 from the release plan wiki, add columns to the spreadsheet about the RC reported in and RC verified in
17:34:02 <vrpolak> If it verifies, yes.
17:34:13 <jamoluhrsen> kk
17:34:26 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download
17:34:42 <zxiiro-away> I can fill in the RC0 test results with my script
17:36:13 <abhijitkumbhare> I don’t think you guys can hear me - but it would be good to be before DDF
17:36:27 <colindixon> #info colindixon asks if people know if 2 weeks from today for Carbon is a crazy idea, others seem to think we should try very hard to avoid going into the DDF
17:37:37 <colindixon> #info colindixon notest that assuming we actually ship on 5/25, that leaves 3 weeks until Boron-SR4 on 6/15
17:37:49 <colindixon> #action colindixon to update the Carbon-SR dates once we release Carbon
17:38:16 <colindixon> #topic infrstructure
17:38:22 <colindixon> #Info nothing this week
17:39:23 <zxiiro-away> anipbu: looks like it will be awhile before the integration-distribution-test job for carbon #307 runs so will update it later when I see it.
17:39:42 <zxiiro-away> anipbu: I will pull it into the bottom of the RC0 Status tab if that's ok
17:39:48 <colindixon> #topic relase timeilines
17:40:05 <jamoluhrsen> anipbu, yeah, it's this job which has not started https://jenkins.opendaylight.org/releng/view/distribution/job/integration-distribution-test-carbon/120
17:40:12 <colindixon> #info we have several relaeases coming up: Boron-SR4, Carbon, Carbon-SR1, and Nitrogen milestones all coming up
17:40:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006849.html proposal for six month cadence
17:41:05 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-April/007000.html some ideas on how we might (or might not) shift to doin a march and september release
17:42:08 <colindixon> #info one idea that a lot of people have put forward is basically saying we will have a Karaf 4 release which is between now and september (call it Nitrogen) wehre the only focus is paying tech debt to get onto karaf 4 (and maybe newer versions of Guava)
17:42:28 <colindixon> #info rovarga add a bump of the scala version
17:43:23 <jamoluhrsen> stabilizing clustering? at least from csit perspectice
17:43:50 <rovarga> jamoluhrsen: yeah, that's for the controller... I think we have most of the needed bits in the pipe
17:43:53 <lori> jamoluhrsen: +1 for clustering stabilization
17:44:28 <colindixon> #info colindixon notes that during the kernel project's call we talked about kicking everyone out of the release and add things back in as they can support the never versions of karaf 4, guava and scala
17:45:16 <colindixon> #info anipbu asks if there's something tracking it
17:45:24 <colindixon> #link rovarga says looslely that's this https://bugs.opendaylight.org/show_bug.cgi?id=4219
17:45:58 <anipbu> rovarga: are you talking about this? https://bugs.opendaylight.org/show_bug.cgi?id=7183 and https://bugs.opendaylight.org/show_bug.cgi?id=7446
17:46:12 <colindixon> #info rovarga notes that we will really want to move to 4.1.x instead of 4.0.x since 4.0.x isn't getting many updates
17:47:17 <rovarga> anipbu: yes
17:47:45 <colindixon> #info carbon-SR1 is currently scheduled for 6/22, if we push out Carbon 2 weeks, that would make it 7/6, which would slip to 7/13 because we skip a week when going over July 4th normally, but I guess we don't have to
17:48:05 <colindixon> #info as stated above Boron-SR4 is scheduled for 6/15
17:48:07 <rovarga> anipbu: and then we have https://bugs.opendaylight.org/showdependencytree.cgi?id=8258&hide_resolved=1, which is the karaf-4.1.2 upgrade
17:48:36 <colindixon> 5/25 (Carbon), 6/15 (Boron-SR4), 7/6 or 7/17 (Carbon-SR1) doesn't sound too crazy
17:49:28 <jamoluhrsen> seems ok
17:49:33 <anipbu> +1 seems ok
17:51:46 <colindixon> #info colindixon notes that 5/25 (Carbon), 6/15 (Boron-SR4), 7/6 or 7/17 (Carbon-SR1) doesn't sound too crazy, jamoluhrsen and anipbu note that seems somewhat sane
17:52:39 <colindixon> #startvote should we move to a date-based six-month release cadence? -1, 0, +1
17:52:39 <odl_meetbot> Begin voting on: should we move to a date-based six-month release cadence? Valid vote options are -1, 0, +1.
17:52:39 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:52:42 <lori> #vote 1
17:52:42 <odl_meetbot> lori: 1 is not a valid option. Valid options are -1, 0, +1.
17:52:43 <jamoluhrsen> #vote +1
17:52:44 <colindixon> #vote +1
17:52:46 <skitt> #vote +1
17:52:48 <lori> #vote +1
17:52:50 <rovarga> #vote 0
17:52:53 <vishnoianil> #vote +1
17:53:02 <zxiiro-away> #vote +1
17:53:04 <LuisGomez> #vote +1
17:53:05 <abhijitkumbhare> #vote +1
17:53:05 <anipbu> #vote +1
17:53:09 <hideyuki> #vote +1
17:53:18 <colindixon> #endvote
17:53:18 <odl_meetbot> Voted on "should we move to a date-based six-month release cadence?" Results are
17:53:18 <odl_meetbot> 0 (1): rovarga
17:53:18 <odl_meetbot> +1 (10): skitt, zxiiro-away, LuisGomez, hideyuki, colindixon, lori, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
17:53:29 <colindixon> #agreed we will move to a date-based, six-month release cadence
17:54:00 <colindixon> #startvote do we want to move to a early march/early september cycle to line up with OPNFV/OpenStack? -1, 0, +1
17:54:00 <odl_meetbot> Begin voting on: do we want to move to a early march/early september cycle to line up with OPNFV/OpenStack? Valid vote options are -1, 0, +1.
17:54:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:54:02 <lori> #vote +1
17:54:03 <jamoluhrsen> #vote +1
17:54:07 <skitt> #vote +1
17:54:08 <zxiiro-away> #vote +1
17:54:09 <vishnoianil> #vote +1
17:54:10 <rovarga> #vote +1
17:54:14 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2017-April/007000.html
17:54:15 <LuisGomez> #vote +1
17:54:17 <anipbu> #vote +1
17:54:17 <hideyuki> #vote +1
17:54:43 <colindixon> #vote +1
17:55:02 <abhijitkumbhare> #vote +1
17:55:23 <colindixon> #endvote
17:55:23 <odl_meetbot> Voted on "do we want to move to a early march/early september cycle to line up with OPNFV/OpenStack?" Results are
17:55:23 <odl_meetbot> +1 (11): rovarga, skitt, zxiiro-away, LuisGomez, hideyuki, colindixon, lori, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
17:55:41 <colindixon> #agree we will shift to an early march, early september release timing
17:55:59 <skitt> a not insignificant portion of Europe shuts down in August
17:56:12 <lori> skitt: yeap
17:56:47 <colindixon> #startvote give that we are about to ship Carbon in late May, we want a short (~3 month) Nitrogen ending in early September, or long (~9 month) Nitrogen ending in early March?
17:56:47 <odl_meetbot> Begin voting on: give that we are about to ship Carbon in late May, we want a short (~3 month) Nitrogen ending in early September, or long (~9 month) Nitrogen ending in early March? Valid vote options are Yes, No.
17:56:47 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:56:52 <colindixon> #endvote
17:56:52 <odl_meetbot> Voted on "give that we are about to ship Carbon in late May, we want a short (~3 month) Nitrogen ending in early September, or long (~9 month) Nitrogen ending in early March?" Results are
18:00:27 <colindixon> #info vishnoianil asks a few questions, do we really want to offer projects 9 months vs. 3 + 6, also what happens if we slip on a 3-month release and have to cut into 6 month
18:02:00 <colindixon> #info skitt furhter notes that just doing date-based releases involves being more aggressive with deadlines and cutoffs
18:02:44 <CaseyODL> #link https://wiki.opendaylight.org/view/Events#ODL_Nitrogen_Developer_Design_Forum Registration and Topics page are linked here for the ODL DDF Later this month.
18:03:17 <colindixon> #info CaseyODL will be building out the agenda for the DDF this weekend
18:03:38 <colindixon> #Info CaseyODL says to please register and get a hotel room right now
18:05:02 <colindixon> #info vrpolak notes that he likes the idea of a short relaese to stop supporting karaf 3 sooner, colindixon notes he's not sure if we want to support it for 2 releases or 12 months (they were ostensbly the same before now)
18:05:11 <colindixon> #topic cookies
18:05:14 <colindixon> #endmeeting