17:00:08 <colindixon> #startmeeting tsc
17:00:08 <odl_meetbot> Meeting started Thu May 18 17:00:08 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:13 <colindixon> #topic roll call and agenda bashing
17:00:15 <colindixon> #info colindixon
17:00:16 <skitt> #info skitt
17:00:24 <jamoluhrsen> sometime we should do this american idol style with PTLs on a stage and us behind some seats on the floor
17:00:29 <jamoluhrsen> #info jamoluhrsen
17:00:38 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=55295#Agenda agenda
17:00:41 <skitt> jamoluhrsen++
17:00:49 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-05-11-17.00.html last week's meeting minutes
17:00:57 <rovarga> #info rovarga
17:01:06 <anipbu> #info anipbu
17:01:21 <lori> #info lori
17:01:29 <edwarnicke> #info edwarnicke
17:01:34 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:01:35 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:01:37 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
17:01:38 <colindixon> #action phrobb to bring the need for a security manager to the board
17:01:39 <colindixon> #action phrobb to bring the TSC replacment language to the board
17:01:40 <colindixon> #action colindixon to update the Carbon-SR dates once we release Carbon
17:01:49 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum CaseyODL put the link (and how to register) is on the wiki events page
17:01:50 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-May/010850.html colindixon notified release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate
17:01:51 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download anipbu got pointers to RC0 and notified people appropriately
17:02:13 <colindixon> #action colindixon to send o#ut a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
17:02:30 <abhijitkumbhare> #info abhijitkumbhare
17:02:40 <colindixon> #action jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
17:02:56 <colindixon> #undo
17:02:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1c36bd0>
17:03:31 <colindixon> #action jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
17:03:39 <vishnoianil> #info Anil Vishnoi
17:03:48 <zxiiro> #info Thanh
17:04:29 <colindixon> #topic TSC mailing list votes and discussions
17:04:41 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html Need for a Beryllium-SR4.1?
17:05:57 <rovarga> +1 to SR5 :)
17:05:59 <colindixon> #topic events
17:06:04 <colindixon> #link https://www.opendaylight.org/global-events
17:06:23 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:06:43 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum the DDF is coming up on 5/31 and 6/1
17:06:49 <shague> #info shague
17:07:21 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#Eurasia_Network_Operators_Group_ENOG13 new even in st petersburg on 5/23-24 with some major ODL content
17:07:32 <colindixon> #info agenda for DDF should be finalized soon and published
17:08:31 <colindixon> #info we only have 35 registrants for the DDF, please register if you plan to attend, the cost for the event is $225,000, we should talk about how to either make these cheaper and/or not have them if the attendance is this low
17:09:20 <colindixon> #topic boron
17:09:30 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule  <--- Boron SR4 currently scheduled for 6/15/2017
17:09:41 <colindixon> #chair anipbu zxiiro
17:09:41 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
17:10:15 <colindixon> #Info zxiiro note that the boron build has been consistently passing
17:10:28 <colindixon> #info colindixon notes that unless Carbon shifts out past the DDF, things should be fine with that date
17:10:39 <colindixon> #topic carbon
17:10:53 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968   <--- Release Review is ongoing right now: waiting on 6 projects to sign up: dlux, docs, next, sdninterfaceapp, cardinal, snmp
17:11:10 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1178576345
17:11:55 <anipbu> #link goo.gl/OaCOAG   <--- 19 Blocker Bugs in bgpcep, controller, genius, netvirt, sfc
17:12:08 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511   <--- Tracking Carbon Blocker Bugs
17:12:28 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948   <--- RC1
17:12:56 <colindixon> #info for what it's worth, we have patches in the pipe for all blocking bugs but 2 assuming the spreadsheet is up-to-date
17:14:13 <colindixon> #info remaining two are BUG-7451 and BUG-8446
17:14:56 <colindixon> #info rovarga says they're trying to get enough logs to debug BUG-8446, the claim is is that it may have been fixed (masked?) by some other fix, we should know by tomorrow morning
17:15:16 <colindixon> #info it seems like a patch was added for BUG-7451
17:17:54 <abhijitkumbhare> Much better statement colindixon (raise standard of what is blocker bug - rather than not accept blocker bugs)
17:18:36 <colindixon> #info anipbu says that we will need to push back on blocker bugs harder as we get closer to the release we will have to raise the bar of what a blocker is
17:21:31 * rovarga blushes
17:21:53 <abhijitkumbhare> good to know rovarga can blush :)
17:22:10 <colindixon> #info colindixon notes that bugs fall into 3 bins: 1.) functionality that is critical for users and was there in prior releases that is broken with no workarounds, 2.) the same thing as 1, but for functionality that is new to Carbon, 3.) things that have workarounds, are very uncommon, or otherwise aren't really blcoking
17:22:19 <colindixon> #info I think the question is what we're going to do around bin 2
17:23:37 <colindixon> #info anipbu notes that we're hoping to build RC2 today, but it looks like it might be tomorrow
17:24:16 <colindixon> #info anipbu further notes that RC3 (which should be the last one) is scheduled for Sunday and ideally we'd then go through the bureaucratic motions of final CSIT testing, and final go/nogo sign offs
17:25:39 <colindixon> #topic infrastructure
17:26:23 <colindixon> #info there are still a couple outstanding WebEx meetings out there, at the end of next week all WebEx meetings and WebEx account will be canceled
17:26:30 <colindixon> #info all recordings will be exported and uploaded to the wiki
17:26:45 <colindixon> #info ALL WEBEX ARE BELONG TO NOT US BY END OF NEXT WEEK
17:27:15 <CaseyODL> :)
17:27:50 <colindixon> #topic security response team
17:28:05 <colindixon> #info lori is interested in being part of the security response team
17:28:39 <colindixon> #startvote shall the TSC add lori as a member of the security response team? -1,0,+1
17:28:39 <odl_meetbot> Begin voting on: shall the TSC add lori as a member of the security response team? Valid vote options are -1, 0, +1.
17:28:39 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:42 <colindixon> #vote +1
17:28:44 <skitt> #vote +1
17:28:45 <jamoluhrsen> #vote +1
17:28:46 <anipbu> #vote +1
17:28:46 <shague> vote +1
17:28:47 <rovarga> #vote +1
17:28:48 <edwarnicke> #vote +1
17:28:48 <LuisGomez> #vote +1
17:28:50 <lori> #vote 0
17:28:53 <abhijitkumbhare> #vote +1
17:29:02 <colindixon> #endvote
17:29:02 <odl_meetbot> Voted on "shall the TSC add lori as a member of the security response team?" Results are
17:29:02 <odl_meetbot> 0 (1): lori
17:29:02 <odl_meetbot> +1 (8): rovarga, skitt, LuisGomez, edwarnicke, colindixon, jamoluhrsen, anipbu, abhijitkumbhare
17:29:17 <jamoluhrsen> thanks lori for taking that on
17:29:25 <colindixon> #agreed lori is a member of the security release team unanimously
17:29:49 <colindixon> #action colindixon to prepare a garbage collection vote for old security response team members after talking to them
17:30:04 <colindixon> #undo
17:30:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1dc6090>
17:30:32 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
17:32:26 <colindixon> #topic beryllium-SR4.1/SR5
17:32:42 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html
17:32:52 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007209.html
17:33:17 <colindixon> #link https://wiki.opendaylight.org/view/Security_Advisories description of CVEs here
17:35:17 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:die-xsql-die-stable/beryllium+status:open xsql patches still needed for stable/beryllium
17:37:47 <colindixon> #info vishnoianil notes that if we do this after Carbon, technically we will no longer be supporting even security updates for that
17:41:49 <zxiiro> I think if we have a workaround then we should just release note it and move on.
17:44:54 <colindixon> given that we've been told about these vulnerabilities while beryllium was still open for security updates, but have workarounds, do we 1.) just provide release notes with workarounds given that it won't be supported for security updates, 2.) fix the issues and ship the ones for which we have patches, or 3.) do nothing
17:45:44 <colindixon> #startvote given that we've been told about these vulnerabilities while beryllium was still open for security updates, but have workarounds, do we 1.) just provide release notes with workarounds given that it won't be supported for security updates, 2.) fix the issues and ship the ones for which we have patches, or 3.) do nothing? 1, 2, 3
17:45:44 <odl_meetbot> Begin voting on: given that we've been told about these vulnerabilities while beryllium was still open for security updates, but have workarounds, do we 1.) just provide release notes with workarounds given that it won't be supported for security updates, 2.) fix the issues and ship the ones for which we have patches, or 3.) do nothing? Valid vote options are 1, 2, 3.
17:45:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:45:52 <skitt> #vote 2
17:45:54 <zxiiro> #vote 1
17:45:54 <vishnoianil> #vote 1
17:45:55 <colindixon> #vote 1
17:45:59 <abhijitkumbhare> #vote 1
17:46:01 <LuisGomez> #vote 1
17:46:02 <rovarga> #vote 2
17:46:09 <jamoluhrsen> #vote 2
17:46:26 <colindixon> shague:
17:46:26 <colindixon> edwarnicke:
17:46:28 <anipbu> #vote 1
17:46:29 <edwarnicke> #vote 2
17:46:34 <shague> #vote 2
17:46:36 <lori> #vote 1
17:47:18 <colindixon> #endvote
17:47:18 <odl_meetbot> Voted on "given that we've been told about these vulnerabilities while beryllium was still open for security updates, but have workarounds, do we 1.) just provide release notes with workarounds given that it won't be supported for security updates, 2.) fix the issues and ship the ones for which we have patches, or 3.) do nothing?" Results are
17:47:18 <odl_meetbot> 1 (7): zxiiro, LuisGomez, colindixon, lori, abhijitkumbhare, anipbu, vishnoianil
17:47:18 <odl_meetbot> 2 (5): shague, skitt, rovarga, jamoluhrsen, edwarnicke
17:48:54 <colindixon> #action given the precedent this might set, colindixon to ping the last two TSC members for votes
17:52:39 <colindixon> #topic cookies
17:52:42 <colindixon> #endmeeting