03:30:35 <CaseyODL> #startmeeting tsc
03:30:35 <odl_meetbot> Meeting started Fri May 26 03:30:35 2017 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:30:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:30:35 <odl_meetbot> The meeting name has been set to 'tsc'
03:30:52 <CaseyODL> #chair phrobb
03:30:52 <odl_meetbot> Current chairs: CaseyODL phrobb
03:31:34 <CaseyODL> colindixon: The IRC meeting has been started.
03:31:52 <colindixon> CaseyODL: #chair me?
03:32:01 <CaseyODL> #chair colindixon
03:32:01 <odl_meetbot> Current chairs: CaseyODL colindixon phrobb
03:32:03 <colindixon> #topic agenda bashing and roll call
03:32:05 <dfarrell07> #info Daniel Farrell for Jamo
03:32:09 <anipbu> #info anipbu
03:32:10 <colindixon> TSC members please #info in
03:32:11 <colindixon> #Info colindixon
03:32:28 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=55975#Agenda
03:32:48 <colindixon> #info colindixon got all current TSC members to vote on how to handle CVEs in Boron and whether to release a Boron-SR5
03:32:49 <vthapar> #info Vishal for Abhijit
03:33:00 <colindixon> #info jamoluhrsen says that beyond more automation we should already have a better list of expected test failures for Boron SR4
03:33:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007236.html colindixon to sent out a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
03:33:33 <vishnoianil> #info Anil Vishnoi
03:33:49 <colindixon> #action colindixon or anipbu to update the Carbon-SR dates beyond SR1
03:34:05 <colindixon> #action phrobb to bring the need for a security manager to the board
03:34:06 <colindixon> #action phrobb to bring the TSC replacement language to the board
03:34:14 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
03:34:28 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
03:34:28 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
03:34:29 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
03:34:40 <zxiiro> #info Thanh
03:35:32 <zxiiro> odd i'm missing the zoom link for the APAC meeting
03:35:46 <colindixon> zxiiro: https://zoom.us/j/423359597
03:35:48 <CaseyODL> zxiiro: Check the TSC mailing list.
03:35:48 <vishnoianil> https://zoom.us/j/423359597
03:35:56 <LuisGomez> #info LuisGomez
03:35:58 <zxiiro> thanks
03:36:21 <colindixon> Huan is on th Zoom meeting, but not IRC, also not clear that he can hear us
03:36:51 <colindixon> hideyuki: please #info in when you get a chance
03:36:57 <hideyuki> #info Hideyuki
03:37:35 <colindixon> #info Huan is on Zoom, but not IRC (at least yet)
03:38:10 <colindixon> #topic mailing list votes and discussions
03:38:42 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007248.html Vote concluded on releasing Beryllium-SR5 (decision 8-6 is to release note the ways to mitigate the CVEs)
03:39:10 <colindixon> #action colindixon to send mail to the appropriate lists describing the CVEs and workarounds for those still using Beryllum
03:40:51 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007333.html Maybe move the APAC-time TSC call to Wed night/Thu morning
03:42:15 <colindixon> #action colindixon to send out a mailing list to vote on whether to have APAC-timed meetings on Wed night/Thu morning instead of Thu night/Fri morning
03:42:45 <colindixon> #topic events
03:42:50 <colindixon> #link https://www.opendaylight.org/global-events
03:42:55 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
03:43:14 <colindixon> #link events.linuxfoundation.org/events/opendaylight-developer-design-forum the DDF is next week, attendance is still low, please register now and attend if you plan to
03:43:23 <dfarrell07> zxiiro: are there supposed to be artifacts here? https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/distribution-karaf/0.6.0-Carbon/
03:43:26 <colindixon> #info we currently have 46 attendees
03:43:41 <colindixon> this is down from 115 from the last DDF
03:44:06 * dfarrell07 will not be at DDF due to long-standing conflicting commitment to GF :'(
03:44:25 <colindixon> #link http://events.linuxfoundation.org/events/opnfv-summit OPNFV summit in beijing 6/12-15 (with an ODL mini summit)
03:44:33 <zxiiro> dfarrell07: yes eventually
03:44:36 <zxiiro> dfarrell07: it's still copying
03:44:54 <colindixon> #topic Boron
03:45:00 <dfarrell07> zxiiro: okay, cool
03:45:20 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule   <--- Boron SR4 Scheduled for 6/15/2017 with a cutoff Sunday 6/11/2017 at 23:59 UTC
03:45:37 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/287/   <--- Boron Autorelease Build Successful
03:45:45 <vishnoianil> is there any other reason for low attendance except that it's two days events ? or it's a sign of project maturity :)
03:45:46 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046   <--- No Boron Blocker Bugs
03:45:52 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/branch:stable/boron+status:open   <--- 58 Open Boron Patches
03:46:06 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-boron/   <--- 98 Boron Distribution Test Failures
03:46:22 <anipbu> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR3=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2017-03-23   <--- 11 patches modifying yang files without API Freeze Waiver between Boron SR3 and Boron SR4
03:47:39 <colindixon> #topic Carbon
03:47:44 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/Status   <--- Carbon Release Status
03:47:52 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC_Download   <--- Carbon Download Information
03:47:56 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007337.html   <--- Carbon Approval by TSC Vote
03:48:10 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR1 scheduled for 7/6/2017 or 7/13/2017
03:50:58 <colindixon> #info it looks like SFC is using a tmp library that is GPLed, the good news is that every version after the versoin that we're using is MIT-licensed
03:51:33 <colindixon> #Info phrobb says the risk is low, but we would need an exception from the board, so respinning things may be better
03:51:49 <dfarrell07> it's too late for Carbon I think, it's already released
03:51:51 <colindixon> #info there's another GPLv3 component in controller, but it's not in the distribution
03:53:22 <colindixon> #Info colindixon asks zxiiro if we can really un-release Carbon, zxiiro says it would be possible but tedious, shipping a fast Carbon-SR1 would be easier
03:53:25 <dfarrell07> removing the git tags is the ugly part imho
03:54:18 <colindixon> #info dfarrell07 notes we also need to break the immutability of git tags
03:56:12 <colindixon> #info zxiiro asks if we need to delete the violating file, colindixon notes then we need to also need to delete the distribution, which would render the release pretty much useless
03:57:02 <colindixon> #info vishnoianil asks if we could just replace the released artifacts, zxiiro says technically yes even though it's a bad practice generally
03:58:18 <colindixon> #info the required action would be to upgrade from tmp 0.0.16 to 0.0.31, it seems like it's indirectly pulled in by Node.js for the SFC UI
03:58:27 * dfarrell07 suggests we add a carbon lesson-learned that we need to do IPR check during the normal RC process, track it as part of release milestones
03:58:28 <colindixon> #action colindixon, phrobb, and/or zxiiro to reach out to SFC to get a patch to fix this
03:58:45 <colindixon> #action colindixon to add IPR check to the normal release process
04:00:24 <colindixon> #info colindixon asks if we're opposed to violating the immutability of release artifacts and git tags, to avoid violating a license
04:01:16 <colindixon> #agreed insofar as it remains possible, we will overwrite the Carbon release artifacts and git tags with new ones after SFC fixes the issue (worst case by removing the UI)
04:04:40 <colindixon> #topic system integration testing
04:04:57 <colindixon> #info nothing really, planning for Karaf 4 migration in the next release
04:05:07 <colindixon> #topic infrastructure
04:05:11 <colindixon> #info nothing today
04:05:12 <vishnoianil> colindixon, i think we should put action item for tsc to workout a plan to avoid these situation in future
04:05:40 <colindixon> #topic commiter promotions
04:05:52 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007249.html Tim Rozet is now a committer on Int/Pack
04:06:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007266.html Jozef Bacigal is now a committer on openflowjava
04:06:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007298.html Fasella K is now a committer on infrautils
04:06:22 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007292.html Martin Dindoffer is now a committer on topoprocessing
04:06:58 <colindixon> #topic CLM reports and trying to avoid this going forward
04:07:13 <colindixon> #info colindixon notes that we run CLM weekly, we just don't have it gating
04:07:52 <colindixon> #action colindixon to maybe add reading your CLM report as part of the milestone readout? maybe at M4 or M5?
04:10:01 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-05-26-03.30.log.txt
04:10:53 <colindixon> #info zxiiro says the version of tmp in SFC UI seems to be a json file that has 0.0.23 (not what CLM reports, which is 0.0.16)
04:11:51 <colindixon> #Info zxiiro says something like the two things that are pulling in tmp 0.0.16, but they actually link to the one in the bundle which is 0.0.23 (not 0.0.16)
04:12:10 <colindixon> #info phrobb also notes that FaaS is also pulling this in
04:12:23 <colindixon> #topic Nitrogen planning
04:12:35 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-05-11-17.00.html on 5/11/2017 we agreed
04:12:41 <colindixon> #info Bullet 7.n: AGREED: we will move to a date-based, six-month release cadence
04:12:47 <colindixon> #info Bullet 7.q: AGREED: we will shift to an early march, early september release timing
04:13:24 <colindixon> #Info we notably did not agree on when we would do that or what it would look like (one long release or a short release and then normal)
04:14:00 <colindixon> #info that being said, the general feeling seemed to be in favor of a short release mainly targeting Karaf 4 migration
04:14:07 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007301.html this is one proposal that might look like tha
04:14:10 <colindixon> #undo
04:14:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1de6f90>
04:14:12 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-May/007301.html this is one proposal that might look like that
04:14:47 <colindixon> #info possible main focus areas: Karaf 4, Upgrade Guava, Finalize moving of MD-SAL APIs out of controller,  Leave leaf projects out by default (need instructions on how they can ship over ODL)
04:15:17 <colindixon> #info we also probably need some idea how to emphasize the focuses better, e.g., start with no projects in the release and add them only as they hit certain bars
04:15:54 <colindixon> #Link https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#Schedule this is reasonable draft at a Nitrogen release plan on the wiki with the above dates
04:18:46 <colindixon> #Info colindixon notes that annoying we do not have a deterministic way to validate that projects have successfully migrated to Karaf 4, e.g., SFT failures can be heisenbugs
04:19:38 <colindixon> #info vishnoianil asks if we can have two autoreleases builds one which builds everything and another which builds only karaf 4 migrated features
04:22:06 <colindixon> #info vrpolak points out that without two distribution projects, that will be hard because distribution will be the same in both and will fail the one with fewer projects
04:23:13 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#M5:_Code_Freeze   <--- Added CLM violation check to Nitrogen M5
04:25:57 <colindixon> #info the more that goes around, e.g., Guava 21 and K4 aren't compatible, it seems like we might not be able to keep the health status check part of autorelease until everyone's migration
04:30:21 <colindixon> #Info vishnoianil brings up if we're sure we can get through this in a release, e.g., in 3 months
04:31:43 <colindixon> #Info rovarga_ asks about resourcing, colindixon says the idea was to force the resource issue by saying if you don't don't staff it, you won't be in the release
04:32:26 <colindixon> #Info LuisGomez says tightly tracking projects would be another way to do this
04:32:54 <colindixon> #Info rovarga_ says if it was more than just 2 people, e.g., 1/2-1 person per project for the 3 months, he'd be confident we could do the migration
04:34:13 <colindixon> #info rovarga_ notes that it likely makes sense to get a liveness check to projects, because RTTs to projects will be criticals
04:34:15 <colindixon> #undo
04:34:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b683d0>
04:34:20 <colindixon> #info rovarga_ notes that it likely makes sense to get a liveness check to projects, because RTTs to projects will be critical
04:35:13 <colindixon> #info colindixon notes that his feeling is if we keep in touch with projects regularly that tends to keep them engaged
04:36:35 <colindixon> #info anipbu notes that this all assumes we don't have any non-leaf unresponsive projects, the only one we had in the past was SNMP
04:36:43 <colindixon> #info maybe also TSDR
04:36:57 <colindixon> #topic cookies
04:37:02 <colindixon> #endmeeting