#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:47 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:52)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=57619#Agenda agenda (colindixon, 17:01:17)
    2. rovarga (rovarga, 17:01:38)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-08-17.00.html last week's meeting minutes (colindixon, 17:01:39)
    4. anipbu (anipbu, 17:01:41)
    5. colindixon (colindixon, 17:01:43)
    6. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 17:02:07)
    7. ACTION: phrobb to float the idea of hiring a Karaf consultant to the board (colindixon, 17:02:08)
    8. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:02:09)
    9. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:02:10)
    10. ACTION: colindixon to look to see if any current security response team members would like to voluntarily step down for any reason (colindixon, 17:02:11)
    11. Hideyuki (hideyuki, 17:02:27)
    12. lori (lori, 17:02:29)
    13. https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description from anipbu and colindixon (colindixon, 17:02:48)
    14. edwarnicke (edwarnicke, 17:02:50)
    15. https://bugs.opendaylight.org/show_bug.cgi?id=8698 is a bug to track off-cycle release tools and docs (colindixon, 17:02:57)
    16. it seems like the TSC meeting invites are correct now (colindixon, 17:03:12)
    17. the board has asked for us to bering the TSC replacement language to the board again after some of the harmonization efforts have progressed (colindixon, 17:03:32)
    18. shague (shague, 17:04:55)
    19. LuisGomez (LuisGomez, 17:05:28)
    20. we will add a TCP-MD5 termination review (colindixon, 17:06:05)
    21. jamoluhrsen (jamoluhrsen, 17:06:16)

  2. TSC mailing list votes and discussions (colindixon, 17:06:20)
    1. Thanh (zxiiro, 17:06:23)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-June/007485.html Dhruv Bhardwaj and Cedric Ollivier are now commiters on transport PCE (colindixon, 17:06:34)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-June/007487.html Michal Rehak is now an ODL SXP commiter (colindixon, 17:06:50)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description (colindixon, 17:07:02)
    5. for the above, we need volunteers to take that on, so please chim in if you're interested (colindixon, 17:07:20)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-June/007507.html meetings at constant UTC offset vs. shifting with DST? (colindixon, 17:08:15)
    7. https://lists.opendaylight.org/pipermail/tsc/2017-June/007509.html (colindixon, 17:09:18)
    8. https://en.wikipedia.org/wiki/Daylight_saving_time_by_country a surprising number of countries do not care about DST (rovarga, 17:11:14)
    9. VOTE: Voted on "shall we make the APAC-time zone TSC call on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST?" Results are, +1: 9 (colindixon, 17:12:12)
    10. AGREED: the APAC-time zone TSC call wiill be on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST (colindixon, 17:12:40)

  3. events (colindixon, 17:13:29)
    1. https://www.opendaylight.org/global-events (colindixon, 17:13:50)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:13:51)
    3. OPFNV summit is going on as we speak in Beijing (or just closing down as it's 1a on Friday morning) (colindixon, 17:14:09)
    4. linuxcon china is next week also there (colindixon, 17:14:28)

  4. boron (colindixon, 17:14:52)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR4/Status <--- We initially targeted Boron SR4 Release on 6/15, but our latest build has blocker bugs in NETVIRT and we are waiting to finish respinning Boron SR4. (anipbu, 17:15:10)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=8696 <--- NETVIRT Blocker Bug (anipbu, 17:15:24)
    3. https://git.opendaylight.org/gerrit/#/c/59002/ <--- Patch Fixing NETVIRT Blocker Bug (anipbu, 17:15:30)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/306/ <--- We are respinning Boron SR4. (anipbu, 17:15:37)

  5. carbon (colindixon, 17:17:41)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- We are three weeks away from Carbon SR1 on July 6. (anipbu, 17:17:46)
    2. https://lists.opendaylight.org/pipermail/release/2017-June/011238.html <--- Autorelease carbon failed to build sal-distributed-datastore from controller (anipbu, 17:18:09)
    3. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968 <--- We are waiting on 3 projects to revise or submit Carbon Release Notes: packetable, next, dlux. (anipbu, 17:18:31)
    4. We kindly inform projects we are not running SFT in Carbon build. We plan to disable the Karaf 4 SFT in Carbon ODLPARENT. (anipbu, 17:18:58)

  6. nitrogen (colindixon, 17:22:39)
    1. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0 <--- We are bumping all Nitrogen projects to ODLPARENT version 1.9.0. Pending: sdninterfaceapp, bier, snmp4sdn, nic, bgpcep, netv (anipbu, 17:22:49)
    2. https://lists.opendaylight.org/pipermail/release/2017-June/011237.html <--- We are removing Karaf 3 from the Nitrogen Integration Distribution. (anipbu, 17:23:12)
    3. https://git.opendaylight.org/gerrit/#/c/58820/ <--- We have removed all nonoffset0 projects from the Nitrogen Integration Distribution. (anipbu, 17:23:24)
    4. https://git.opendaylight.org/gerrit/#/c/58992/ <--- We have added infrautils back into autorelease. (anipbu, 17:23:39)
    5. We plan on adding Nitrogen Integration Distribution back into autorelease this week to generate a test build. (anipbu, 17:23:46)
    6. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf <--- Nitrogen Karaf 4 Status (anipbu, 17:23:58)
    7. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <--- Nitrogen Karaf 4 Tracking (anipbu, 17:24:03)
    8. https://wiki.opendaylight.org/view/File:TWS-2017-06-12.mp4 <--- TWS Session on Monday 6/12/2017 to discuss Nitrogen Karaf 4 Project Action Items (anipbu, 17:24:10)
    9. https://lists.opendaylight.org/pipermail/release/2017-June/011221.html <--- Karaf 4 Schedule (anipbu, 17:24:27)
    10. Plan of Action This Week: all projects build and test local karaf 4 distribution and identify blocker bugs (anipbu, 17:24:36)
    11. Plan of Action Next Week: release odlparent version 2.0.0, all projects migrate to odlparent version 2.0.0, all projects add karat 4 features to integration distribution (anipbu, 17:25:01)
    12. Anil Vishnoi (vishnoianil, 17:25:34)
    13. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Nitrogen_Project_Requirements <--- 3 Nitrogen Project Requirements for Karaf 4 (anipbu, 17:25:58)
    14. NOTICE: Expected breakages expected in the next two weeks (anipbu, 17:26:29)
    15. https://bugs.opendaylight.org/show_bug.cgi?id=8638 <--- Karaf 4 Related Blocker Bugs (NETVIRT): Karaf4 specific problems seen on boot and during manual & CSIT testing of netvirt distribution (anipbu, 17:26:50)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=8694 <--- Karaf 4 Related Blocker Bugs (OPENFLOWPLUGIN): Karaf 4 openflowplugin "not working" (title to be refined as more is found out) (anipbu, 17:27:05)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=8571 <--- Karaf 4 Related Blocker Bugs (ODLPARENT): karaf4-parent does not include files from src/main/assembly. This is critical for 3 nodes system test. (anipbu, 17:27:14)
    18. https://lists.opendaylight.org/pipermail/release/2017-June/011222.html <--- Need to make a decision on featuresBoot or not featuresBoot (anipbu, 17:27:32)
    19. there is a long disussion about whether we can use feature:install or featuresBoot only and not both (colindixon, 17:35:33)
    20. they use different code paths in Karaf to load them (colindixon, 17:35:49)
    21. thus they may expose different sharp corners and possibly different bugs between ODL and Karaf (colindixon, 17:36:51)
    22. if we that to choose one to eliminate in the meantime to try to reduce testing overhead, it would be feautresBoot today (colindixon, 17:37:54)
    23. in the long run, we would really like both to work (colindixon, 17:38:06)
    24. edwarnicke says that it might make sense to take a confd-style appaoch in Karaf that would help us, maybe we should consider putting a direcotry with files that say what feautres to load as a plug-in to Karaf (colindixon, 17:39:55)
    25. then if we did this since it would be new, we could then have it use the same code path as feaure:install at the CLI (colindixon, 17:40:16)
    26. ACTION: colindixon to file an upstream bug with Karaf around featureBoot install not working if we don't have one yet (colindixon, 17:41:49)

  7. system integration and test (colindixon, 17:43:59)
    1. nothing this week other than than what's above (colindixon, 17:44:03)

  8. infrastructure (colindixon, 17:44:07)
    1. this past weekend we had jenkins outage because of a batter issue, it came back up (colindixon, 17:44:32)
    2. we had an SSL cert expiring on monday, but we have a temporary fix, we're are enabling auto-renewal for let's encrypt so it won't happen in the future (colindixon, 17:45:07)

  9. TCP-MD4 termination review (colindixon, 17:47:11)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005894.html (rovarga, 17:47:30)
    2. a million years ago, we had a termination review for TCP-MD5 in which we put it off until Carbon was released and Beryllium was thus truly EoLed becuase TCP-MD5 was in Beryllium (colindixon, 17:47:49)
    3. we're now there (colindixon, 17:47:53)
    4. https://wiki.opendaylight.org/view/TCPMD5:Termination_Proposal the proposal itself (rovarga, 17:48:41)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-08-17.00.html (colindixon, 17:49:50)
    6. VOTE: Voted on "shall the TSC archive TCP-MD5 project?" Results are, +1: 10 (colindixon, 17:50:34)
    7. AGREED: the TCP-MD5 project has been archived (colindixon, 17:50:44)

  10. other project archives (colindixon, 17:50:53)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-June/007493.html we should follow up with these archivals as well (colindixon, 17:51:21)
    2. ACTION: colindixon should reach out to projects and see if we can't archive some of them (colindixon, 17:52:01)

  11. liblldp (colindixon, 17:52:28)
    1. this is currently housed in the controller, but something like 4 other projects are using the jar directly (colindixon, 17:52:51)
    2. rovarga woudl like to take it out of the controller and put it into another project and/or make it it's own project (colindixon, 17:53:19)
    3. currently used by openflowplugin, genius, l2switch and something else (colindixon, 17:53:40)
    4. genius, netvirt and ofp each spell it out in their features. (rovarga, 17:53:41)
    5. https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001179.html (colindixon, 17:54:24)
    6. ACTION: rovarga to reach out to the project that use it and ask (colindixon, 17:55:00)

  12. merging patches on inactive proejcts (colindixon, 17:56:02)
    1. shague asking if we can auto-merge patches for things like federation (colindixon, 17:56:12)
    2. ACTION: colindixon to reach out to gidi to try to get them merged and maybe mint new committers (colindixon, 17:56:40)

  13. cookies (colindixon, 17:58:57)


Meeting ended at 17:59:02 UTC (full logs).

Action items

  1. phrobb to bring the need for a security manager to the board
  2. phrobb to float the idea of hiring a Karaf consultant to the board
  3. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
  6. colindixon to file an upstream bug with Karaf around featureBoot install not working if we don't have one yet
  7. colindixon should reach out to projects and see if we can't archive some of them
  8. rovarga to reach out to the project that use it and ask
  9. colindixon to reach out to gidi to try to get them merged and maybe mint new committers


Action items, by person

  1. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
    3. colindixon to file an upstream bug with Karaf around featureBoot install not working if we don't have one yet
    4. colindixon should reach out to projects and see if we can't archive some of them
    5. colindixon to reach out to gidi to try to get them merged and maybe mint new committers
  2. phrobb
    1. phrobb to bring the need for a security manager to the board
    2. phrobb to float the idea of hiring a Karaf consultant to the board
    3. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. rovarga
    1. rovarga to reach out to the project that use it and ask
  4. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way


People present (lines said)

  1. colindixon (72)
  2. anipbu (29)
  3. odl_meetbot (13)
  4. rovarga (8)
  5. edwarnicke (6)
  6. jamoluhrsen (6)
  7. lori (5)
  8. zxiiro (4)
  9. shague (3)
  10. hideyuki (3)
  11. LuisGomez (2)
  12. vishnoianil (2)
  13. CaseyODL (0)
  14. phrobb (0)


Generated by MeetBot 0.1.4.