03:30:18 <colindixon> #startmeeting tsc
03:30:18 <odl_meetbot> Meeting started Thu Jun 22 03:30:18 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:30:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:30:18 <odl_meetbot> The meeting name has been set to 'tsc'
03:30:23 <colindixon> #topic agenda bashing and roll call
03:30:31 <colindixon> TSC members please #info in
03:30:33 <colindixon> #info colindixon
03:30:45 <zxiiro> #info Thanh
03:30:46 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=57876#Agenda
03:30:48 <anipbu> #info anipbu
03:30:55 <huan> #info huan
03:30:58 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-15-17.00.html Last meeting's minutes
03:31:11 <jamoluhrsen> #info jamoluhrsen
03:31:38 <abhijitkumbhare> #info abhijitkumbhare
03:31:45 <colindixon> #action phrobb to bring the need for a security manager to the board
03:31:45 <colindixon> #action phrobb to float the idea of hiring a Karaf consultant to the board
03:31:47 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
03:31:48 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
03:31:48 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
03:32:32 <colindixon> #action colindixon should reach out to projects and see if we can't archive some of them
03:33:14 <colindixon> #action rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
03:33:25 <colindixon> #action colindixon to reach out to gidi to try to get them merged and maybe mint new committers
03:33:33 <hideyuki> #info Hideyuki
03:33:43 <vina_ermagan> #info vine_ermagan (proxy for lori)
03:33:50 <vishnoianil> #info Anil vishnoi
03:34:04 <vina_ermagan> #info vina_ermagan]
03:34:06 * CaseyODL waves
03:34:50 <colindixon> #topic TSC mailing list votes and discussion
03:35:17 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description and call for volunteers
03:36:08 <colindixon> #startvote shall the TSC create a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html? -1,0,+1
03:36:08 <odl_meetbot> Begin voting on: shall the TSC create a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html? Valid vote options are -1, 0, +1.
03:36:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
03:36:10 <jamoluhrsen> #vote +1
03:36:10 <zxiiro> #vote +1
03:36:11 <anipbu> #vote +1
03:36:11 <colindixon> #vote +1
03:36:18 <vina_ermagan> #vote +1
03:36:20 <huan> +1
03:36:20 <vishnoianil> #vote +1
03:36:21 <hideyuki> #vote +1
03:36:25 <abhijitkumbhare> #vote +1
03:36:34 <colindixon> huan: #vote +1, not just +1
03:36:35 <huan> #vote +1
03:36:56 <colindixon> #endvote
03:36:56 <odl_meetbot> Voted on "shall the TSC create a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html?" Results are
03:36:56 <odl_meetbot> +1 (8): zxiiro, hideyuki, vina_ermagan, colindixon, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
03:37:25 <colindixon> #agreed the TSC creates a formal (currently vacant) position for release manager with the job description linked here: https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html
03:37:31 <colindixon> welcome LuisGomez
03:37:58 <LuisGomez> #info LuisGomez
03:38:21 <colindixon> #info abhijitkumbhare asks if this is a program manager vs. release manager, anipbu says maybe
03:39:01 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future developer design forums
03:40:23 <colindixon> #action CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs
03:40:49 <colindixon> #topic events
03:40:58 <colindixon> #link https://www.opendaylight.org/global-events
03:41:04 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
03:42:23 <colindixon> #info no other major events going on, at OPNFV summit there was a live, main-stage demo of vCO with OPNFV and OpenDaylight, the OPNFV summit went well
03:43:14 <colindixon> #topic Boron
03:43:23 <colindixon> #chair anipbu CaseyODL
03:43:23 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon
03:43:39 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR4/Status   <--- We would like to present to the TSC and OpenDaylight community the final build for Boron SR4 Build 20170615.
03:43:50 <vishnoianil> #vote +1 release it as soon as possible
03:44:12 <anipbu> #info Though we will unlock the branch, please note that SR4 is the last regularly scheduled SR for Boron.
03:45:50 <colindixon> #startvote shall the TSC release Boron-SR4 per the notes above? -1,0,+1
03:45:50 <odl_meetbot> Begin voting on: shall the TSC release Boron-SR4 per the notes above? Valid vote options are -1, 0, +1.
03:45:50 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
03:45:53 <colindixon> #vote +1
03:45:57 <zxiiro> #vote +1
03:45:58 <anipbu> #vote +1
03:45:59 <jamoluhrsen> #vote +1
03:46:01 <vishnoianil> #vote +1
03:46:03 <LuisGomez> #vote +1
03:46:16 <huan> #vote +1
03:46:19 <colindixon> vina_ermagan, vrpolak
03:46:36 <abhijitkumbhare> #vote +1
03:46:45 <vina_ermagan> #vote +1
03:46:51 <colindixon> #endvote
03:46:51 <odl_meetbot> Voted on "shall the TSC release Boron-SR4 per the notes above?" Results are
03:46:51 <odl_meetbot> +1 (9): zxiiro, LuisGomez, vina_ermagan, colindixon, jamoluhrsen, anipbu, huan, vishnoianil, abhijitkumbhare
03:47:02 <colindixon> #agreed Boron-SR4 has been released
03:47:30 <colindixon> #topic Carbon
03:47:45 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR1 scheduled for 7/6/2017 with a cutoff on Sunday 7/2/2017 at 23:59 UTC
03:48:11 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511   <--- 2 Carbon SR1 Blocker in netvirt, sfc
03:48:41 <colindixon> #topic nitrogen
03:48:58 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011338.html   <--- Nitrogen M0 Offset 2 due today 6/21
03:49:15 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011306.html   <--- odlparent version 2.0.0 artifacts has been released and available on nexus
03:49:23 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011307.html   <--- Projects must migrate to odlparent version 2.0.0
03:49:32 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011299.html   <--- Karaf 4 Migration Status and Plan of Action including per project Nitrogen Karaf 4 Requirements
03:50:34 <colindixon> #link we're currently blocked on netconf migrating to odlparent-2.0.0 https://git.opendaylight.org/gerrit/#/c/59284/
03:51:15 <colindixon> #topic system integration and test
03:51:34 <colindixon> #info we will now make boron jobs run weekly, which should help queues
03:52:15 <colindixon> #info jamoluhrsen says that he's seeing some projects testing their karaf 4 distributions in CSIT and that's seeing some success
03:52:21 <colindixon> #info that's good!
03:53:21 <colindixon> #info LuisGomez says that we're currently basically ignoring integration/distribution until offset 0 projects have merged their odlparent-2.0.0 patches, currently waiting on aaa and netconf
03:53:55 <colindixon> #topic infrastructure
03:54:13 <zxiiro> #link https://access.redhat.com/security/vulnerabilities/stackguard Stack Guard
03:54:23 <colindixon> #info we did a lot of reboots of stuff yesterday to patch because of stack guard vulnerability
03:55:52 <colindixon> #topic Bier App
03:56:07 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:BIER_APP
03:56:57 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000578.html Proposed on 6/5/2017
03:57:09 <colindixon> #link https://wiki.opendaylight.org/view/File:Presentation-bierapp-proposal-review.pdf slides here
04:02:54 * vina_ermagan has the same question
04:03:07 <colindixon> #info abhijitkumbhare asks why this needs to be separate project from the bier project? vina_ermagan asks the same thing.
04:04:14 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000583.html colindixon asked the same question on the mailing list
04:04:50 <abhijitkumbhare> sorry colindixon and vina_ermagan - did not see that you asked the same question before
04:05:58 <colindixon> #info the response was: "Xiong RE: We still want to separate the BIER plugin and applications and do our best to guarantee the independence between the two projects."
04:06:25 <colindixon> I'd also like to raise the question of whether NeXt is active enough to rely on it
04:07:27 <colindixon> #Info anipbu notes the same issues above
04:07:47 <colindixon> #info vina_ermagan asks if the BIER_APP could do anything without the BIER plugin, the answer seems to be no, it can't
04:07:50 <abhijitkumbhare> +1 vina_ermagan
04:08:18 <colindixon> #info vina_ermagan notes that in LISP flow mapping they have a GUI and a plugin in the same project
04:08:22 <jamoluhrsen> vina_ermagan is making it clear
04:08:32 <hideyuki> #colindixon Thank you for the information. However, I'm still not sure why it needs to be a separate project.
04:08:41 <colindixon> hideyuki: I know
04:09:13 <hideyuki> BTW, audio is not available today. Sorry for the inconvenience.
04:10:50 <colindixon> #info colindixon suggests that even if the code is resident in the same git repository as BIER, but it the APP could be independent and be run without OpenDaylight, e.g., on another controller with same APIs
04:11:22 <vina_ermagan> +1 colindixon
04:11:58 <hideyuki> +1 colin
04:13:02 <colindixon> #info vishnoianil and colindixon point out NetVirt and OVSDB split, so this isn't without precedent
04:14:20 <colindixon> #info abhijitkumbhare and anipbu advocate for starting with one project and then splitting if need be, vishnoianil notes that splitting was harder than you might hope
04:18:44 <jamoluhrsen> dollar sign
04:19:10 <abhijitkumbhare> No dollars or any currency jamoluhrsen - we are poor :)
04:19:51 <colindixon> #info anipbu asks if we could change the git repository from bier_app to bierapp to avoid special characters
04:20:10 <colindixon> #startvote assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name? -1,0,+1
04:20:10 <odl_meetbot> Begin voting on: assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name? Valid vote options are -1, 0, +1.
04:20:10 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
04:20:41 * vina_ermagan thinks if there are no TSC guidelines/rules for creating projects with this level of dependency, and both projects prefer it this way, then it should be fine.
04:20:47 <zxiiro> #vote +1
04:20:49 <colindixon> #vote +1
04:20:50 <huan> #vote +1
04:20:56 <hideyuki> #vote +1
04:20:58 <abhijitkumbhare> #vote 0
04:20:59 <jamoluhrsen> #vote 0
04:21:02 <anipbu> #vote 0
04:21:04 <vishnoianil> #vote +1
04:21:10 <vina_ermagan> #vote +1
04:21:15 <colindixon> vrpolak: ?
04:21:21 <colindixon> LuisGomez: ?
04:22:08 <LuisGomez> #vote +1
04:22:31 <colindixon> #endvote
04:22:31 <odl_meetbot> Voted on "assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name?" Results are
04:22:31 <odl_meetbot> 0 (3): anipbu, abhijitkumbhare, jamoluhrsen
04:22:31 <odl_meetbot> +1 (7): LuisGomez, vina_ermagan, hideyuki, colindixon, zxiiro, huan, vishnoianil
04:23:03 <colindixon> #agreed assuming that they still want to have a separate project for BIER_APP in a week's time, does the TSC approve the project as an incubation project and pending a possible technically-justified git repo name
04:24:04 <colindixon> congratulations!
04:24:14 <vishnoianil> congratulations team BIER
04:24:19 <colindixon> #topic p4 plugin creation review
04:24:25 <vishnoianil> i love this project because it's sounds like BEER :D
04:24:45 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:P4_Plugin
04:25:16 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000580.html Proposed on 6/7/2017
04:27:10 <colindixon> vina_ermagan and many others, I have the same concerns, it's just that if they really want to have a separate project, I'm not ready to stand in the way and stop them
04:28:50 <anipbu> colindixon: Ding: huan: are there plans for p4 to join Nitrogen or Oxygen?
04:29:06 <colindixon> I think no
04:29:23 <vishnoianil> colindixon, i think same question for BIER project?
04:29:24 <colindixon> "we decide to participate in the Oxygen release, but we want the project to be formally approved by the TSC as soon as possible."
04:29:32 <colindixon> https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000586.html
04:29:40 <colindixon> vishnoianil: same answer
04:30:08 <colindixon> #Info colindixon notes that both BIER APP and P4 Plugin are looking to join Oxygen, not Nitrogen
04:30:32 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000586.html for P4 plugin's statement
04:30:50 <colindixon> #Undo
04:30:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2e379d0>
04:30:54 <colindixon> #Undo
04:30:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2f01bd0>
04:31:05 <colindixon> #Info colindixon notes that the P4 Plugin are looking to join Oxygen, not Nitrogen
04:31:08 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000586.html for P4 plugin's statement
04:31:30 <jamoluhrsen> Ding, good presentation
04:31:46 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-June/000587.html says that BIER_APP does plan to be in nitrogen
04:31:52 <vishnoianil> something interesting to look forward to
04:32:11 <colindixon> #link https://p4lang.github.io/p4-spec/ P4 spec
04:32:44 <colindixon> #startvote shall the TSC approve the P4 project as an incubation project? -1,0,+1
04:32:44 <odl_meetbot> Begin voting on: shall the TSC approve the P4 project as an incubation project? Valid vote options are -1, 0, +1.
04:32:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
04:32:48 <colindixon> #vote +1
04:33:18 <anipbu> #vote +1
04:33:38 <colindixon> anipbu, vina_ermagan, vishnoianil, jamoluhrsen, abhijitkumbhare, LuisGomez, hideyuki, huan
04:33:40 <colindixon> please vote
04:33:55 <huan> #vote +1
04:34:02 <vina_ermagan> #vote +1
04:34:06 <zxiiro> #vote +1
04:34:07 <abhijitkumbhare> #vote +1
04:34:14 <jamoluhrsen> #vote +1
04:34:16 <vishnoianil> #vote +1
04:34:43 <colindixon> #info abhijitkumbhare asks if there is a way to attach OpenFlow to P4 and how does OpenFlow relate to P4
04:34:53 <LuisGomez> #vote +1
04:34:58 <colindixon> #endvote
04:34:58 <odl_meetbot> Voted on "shall the TSC approve the P4 project as an incubation project?" Results are
04:34:58 <odl_meetbot> +1 (9): anipbu, LuisGomez, vina_ermagan, colindixon, abhijitkumbhare, zxiiro, huan, vishnoianil, jamoluhrsen
04:35:17 <colindixon> #agreed P4 Plugin is now an incubation project in OpenDaylight
04:35:25 <vishnoianil> Congratulations P4 team, looking forward to the project
04:35:31 <colindixon> #topic cookies
04:35:46 <colindixon> #endmeeting