17:00:22 <colindixon> #startmeeting tsc
17:00:22 <odl_meetbot> Meeting started Thu Jun 29 17:00:22 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:22 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:26 <colindixon> #chair anipbu CaseyODL
17:00:26 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon
17:00:32 <colindixon> #topic agenda bashing and roll call
17:00:37 <colindixon> TSC members please #info in
17:00:40 <anipbu> #info anipbu
17:00:52 <colindixon> I'm getting on Zoom
17:01:38 <colindixon> #info colindixon
17:01:58 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58423#Agenda
17:02:13 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-22-03.30.html last week's meeitng minutes
17:02:17 <hideyuki> #info Hideyuki
17:02:25 <colindixon> if anyone wants to add anything to the agenda, speak up now here or on voice
17:02:39 <colindixon> #action phrobb to bring the need for a security manager to the board
17:02:39 <colindixon> #action phrobb to float the idea of hiring a Karaf consultant to the board
17:02:40 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:02:41 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:02:42 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
17:03:09 <colindixon> #info colindixon says it sounds like might not actually need a Karaf consultant because karaf 4 seems to be going reasonably well
17:03:20 <abhijitkumbhare> #info abhijitkumbhare
17:03:35 <dfarrell07> vrpolak: are you proxy for Jamo or should I proxy for him?
17:03:45 <LuisGomez> #info LuisGomez
17:03:53 <vishnoianil> #info Anil Vishnoi
17:03:56 <colindixon> rovarga: do we have you?
17:04:09 <colindixon> rovarga: any status on this: rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
17:04:16 <rovarga> #info rovarga
17:04:16 <dfarrell07> #info Daniel Farrell for Sam Hague
17:04:21 <zxiiro> #info Thanh Ha
17:04:36 <vrpolak> dfarrell07: You proxy please.
17:04:42 <dfarrell07> vrpolak: ack, will do
17:04:57 <colindixon> #Info colindixon reached out to gidi to try to get federation patches merged and maybe mint new committers, but it seems like it will be inactive in nitrogen
17:04:58 <dfarrell07> #info Daniel Farrell for Sam Hague and jamoluhrsen
17:05:23 <colindixon> #action rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
17:05:32 <colindixon> #action CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs
17:06:01 <colindixon> #info if you have anythign you'd like to see in the poll and care about, please ping CaseyODL by the end of the day
17:06:04 <abhijitkumbhare> dfarrell07: will you vote twice? :)
17:06:44 <colindixon> #action colindixon or CaseyODL to send the poll to the tsc list
17:06:55 <dfarrell07> abhijitkumbhare: yeah, and I cleared it with phrobb during board discussion about charter, it's okay
17:07:16 <abhijitkumbhare> I meant the mechanics of the # vote dfarrell07
17:07:19 <colindixon> #topic mailing list votes and discussions
17:08:05 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description
17:08:20 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future dveloper design forums
17:08:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007592.html openflowjava merging into openflowplugin
17:09:54 <colindixon> #Info colindixon asks if it's doing this in nitrogen only, or also carbon and boron, rovarga says nitrogen-only
17:10:22 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007578.html Support for carbon vote
17:10:32 <colindixon> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_b61348bdd2b0c06d results from the support for carvon vote
17:11:19 <vrpolak> colindixon: I have found no evidence of me being a TSC member.
17:11:25 <colindixon> OK
17:11:52 <colindixon> vrpolak: huh, I thought you were one from support projects
17:12:36 <colindixon> #info the vote is tied, we still need votes from Huan, An, Sam and Stephen
17:12:38 <vrpolak> colindixon: Thanh and Jamo had more votes.
17:13:03 <colindixon> #action colindixon will reach out to those who didn't vote in the carbon support poll to see if we can resolve it
17:13:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007572.html Boron-SR4 released
17:13:36 <vrpolak> colindixon: (that was about TSC membership vote, not about Carbon support vote)
17:13:53 <colindixon> #vote https://lists.opendaylight.org/pipermail/tsc/2017-June/007587.html BIER APP will not be it's own project, but part of the BIER project
17:14:15 <colindixon> #info rovarga notes that ending suppport for Karaf 3 sooner rahter than later might be good
17:15:53 <colindixon> #Info colindixon notes that one tie-breaking mecahnism fo the 5 provided (minimax) gives a result
17:16:57 <colindixon> #info that supports doing date-based releases for 6-months, and 12-months of bug fixes and security fixes, respectively
17:17:18 <zxiiro> coin toss
17:17:50 <colindixon> https://www.opendaylight.org/tsc-charter
17:18:47 <abhijitkumbhare> Reasonable to wait for a couple of days
17:19:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007566.html Subodh Roy is now a committer on Cardinal
17:19:49 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007517.html APAC TSC meeting will be tied to non-DST time; Normal TSC meeting will still be tied to US DST time
17:20:35 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007613.html Archiving Discovery
17:20:44 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007614.html Archiving Armoury
17:21:17 <colindixon> #topic events
17:21:22 <colindixon> #link https://www.opendaylight.org/global-events
17:21:30 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:21:44 * dfarrell07 realizes that our product launch date will be after the carbon date by a few months, Sam should vote on 15 months of security support
17:22:13 <colindixon> #Info nothing major is coming up now, open source summit NA  would be the next thing on 9/11/2017
17:22:27 <colindixon> #topic boron
17:22:54 <colindixon> #info we are removing boron from the normal discussion here because it only receiving security updates, so it will be popped up as needed
17:22:55 <colindixon> #topic carbon
17:23:04 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR1 Cutoff this Sunday 7/2/2017 at 23:59 UTC Time.  stable/carbon branches will be locked.
17:23:16 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/carbon   <--- 81 open patches in gerri for stable/carbon branch
17:23:24 <anipbu> #link https://goo.gl/DZVjKq   <--- 2 blocker bugs in SFC and NETVIRT
17:23:32 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8501   <--- Problem with the installation of sfc, groupbasedpolicy, vbd related to vpp features
17:23:37 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8398   <--- summary: communication between two tenant network failed while using default SG (stateful mode)
17:24:16 <colindixon> #action colindixon or anipbu to ping SFC and NETVIRT after this meeting to see if those projects actually have blocking bugs
17:24:54 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011443.html   <--- Red Flag: autorelease carbon failing on odl-sfclisp from sfc
17:24:55 <colindixon> #info dfarrell07 gets the impression that these might be real bugs and thus might delay Carbon
17:25:11 <colindixon> #Info zxiiro says that's fixed as of this morning
17:25:23 <colindixon> #Undo
17:25:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c00790>
17:25:30 <colindixon> #Info zxiiro says the autorelease-carbon build is fixed as of this morning
17:25:38 <colindixon> #topic nitrogen
17:25:54 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011421.html   <--- OpenFlowJava being merged into OpenFlowPlugin	in Nitrogen
17:26:10 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011448.html   <--- Remove mechanism for mounting netconf devices via the config system in Nitrogen
17:27:01 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011420.html   <--- Pending changes to BGPCEP -Interface PCEPSession API as described in https://bugs.opendaylight.org/show_bug.cgi?id=8156
17:27:19 <anipbu> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956   <--- We are tracking Nitrogen Karaf 4 Migration
17:27:37 <anipbu> #info https://git.opendaylight.org/gerrit/#/q/topic:odlparent200   <--- As of Tuesday, we are waiting on patches from the following projects for odlparent2.0.0: bier, cardinal, didm, mean, fans, federation, iotdm, lace, lack, memo, next, of-config, pocketable, sdni, snmp4sdn, tsar, unimgr
17:27:51 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/59303/   <--- We have merged patch to add kernel projects into Nitrogen Integration Distribution
17:31:54 <colindixon> #topic system integration and testing
17:32:16 <colindixon> #Info LuisGomez says nothing really, there's a discussion around karaf 4 and the karaf 4 distribution to start doing CSIT
17:34:09 <colindixon> #Info LuisGomez says that as we upgrade to odlparent 2.0.1, we will in parallel work with getting the distribution working to not lose time, at the risk of breaking things more often
17:37:04 <colindixon> #topic LuisGomez and vrpolak would like to enoucrage projects to get their gerrit patches for int/dist up ASAP so they can help
17:37:08 <colindixon> #Undo
17:37:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2bf69d0>
17:37:14 <colindixon> #info LuisGomez and vrpolak would like to enoucrage projects to get their gerrit patches for int/dist up ASAP so they can help
17:38:39 <colindixon> #topic infrastructure
17:39:17 <colindixon> #info this past Sunday, Rackspace replaced the raid battery, that's what caused our servers to go down a few weeks ago
17:39:47 <colindixon> #info there will be some downtime Friday evening pacific time from API maintaince at Rackspace, tykeal plans to use that gap to fix our letsencrypt cert renewal stuff
17:40:52 <colindixon> #topic cookies
17:40:55 <colindixon> #endmeeting