16:59:16 <CaseyODL> #startmeeting tsc
16:59:16 <odl_meetbot> Meeting started Thu Aug  3 16:59:16 2017 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:16 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:32 <CaseyODL> #chair colindixon phrobb
16:59:32 <odl_meetbot> Current chairs: CaseyODL colindixon phrobb
16:59:45 <colindixon> thanks CaseyODL
17:00:37 <CaseyODL> Colin, did you enable "co-host" in your Zoom meeting settings?
17:00:51 <colindixon> I didn't, but will in 2 minutes
17:00:55 <colindixon> I can record today though
17:01:02 <colindixon> recording is going
17:01:06 <CaseyODL> Ok. :)
17:02:24 <colindixon> #action colindixon to add CaseyODL as a co-host for next week's TSC call
17:02:39 <colindixon> #topic roll call and agenda bashing
17:02:44 <colindixon> TSC members please #info in
17:02:46 <colindixon> #info colindixon
17:02:47 <zxiiro> #info Thanh
17:02:48 <rovarga_> #info rovarga_
17:02:49 <lori> #info lori
17:02:50 <jamoluhrsen> #info jamoluhrsen
17:02:53 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=63011#Agenda
17:02:56 <anipbu> info anipbu
17:02:56 <vishnoianil> #info Anil Vishnoi
17:02:58 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-27-03.30.html
17:03:00 <LuisGomez> #info LuisGomez
17:03:01 <anipbu> #info anipbu
17:03:03 <colindixon> anipbu: missed the #
17:03:05 <colindixon> thanks
17:03:12 <abhijitkumbhare> #info abhijitkumbhare
17:03:26 <colindixon> #action colindixon to follow up about one last non-responsive security response team members
17:03:28 <shague> #info shague
17:03:59 <colindixon> #action phrobb to bring the need for a security manager to the board and figure out if we can get a response
17:04:08 <colindixon> #link NETCONF with all of it's top-level features seems included in int/dist https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml
17:05:00 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=7891
17:05:00 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=7891
17:05:24 <colindixon> #info skitt did get it so all security mailing list members can see who the other members are
17:05:37 <colindixon> #undo
17:05:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x300eb50>
17:05:56 <colindixon> #info rovarga_ notes that ssh reloads are being seen despite the fix to 7891, so maybe it still needs some more attention
17:06:35 <vrpolak> rovarga: Is that related to https://bugs.opendaylight.org/show_bug.cgi?id=8923 ?
17:07:09 <colindixon> #info LuisGomez says that the core bug seems to be fixed, there may be other smaller issues we need to hunt down
17:07:34 <rovarga_> vrpolak: yeah, I will need to take a look at those reloads
17:07:53 <rovarga_> we do need to take care of the netty+javassist refresh
17:07:54 <colindixon> #link vrpolak points out that the bug rovarga_ talks about is here: https://bugs.opendaylight.org/show_bug.cgi?id=8923
17:07:58 <colindixon> #info skitt did get it so all security mailing list members can see who the other members are
17:08:34 <colindixon> #link the 7/28 nitrogen release sync included information about which projects were/weren't migrated to Karaf 4, in particular see 4.ac for the highest order bits https://meetings.opendaylight.org/opendaylight-meeting/2017/nitrogen_release_sync/opendaylight-meeting-nitrogen_release_sync.2017-07-28-15.06.html
17:09:34 <colindixon> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-July/007517.html It seems as though the liblldp code will live in openflowplugin
17:12:11 <colindixon> #info anipbu made sure daexim is tracked for nitrogen
17:12:52 <colindixon> #info anipbu followed up with DLUX, MDSAL and SNMP; they are all participating in nitrogen
17:13:36 <colindixon> #topic TSC mailing list votes and discussions
17:13:49 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007767.html Ryan Goulding and Tom Pantels are now SNMP committers
17:14:04 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-July/007745.html Michael Vorburger is now a daexim committer
17:14:23 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007764.html Nitrogen M5: yangtools branching/versioning	strategy
17:15:31 <colindixon> #action robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting
17:15:58 <colindixon> #topic new release manager
17:16:28 <anipbu> #info The release team would like to introduce Kit Lou from Brocade to join the OpenDaylight Release Management Team.
17:16:56 <anipbu> #info After Carbon SR2, the release team trust Kit Lou to assume the role and responsibility for OpenDaylight Release Management.
17:17:15 <anipbu> #info anipbu would like to kindly thank the community and all the countless folks in OpenDaylight for your support and contributions during the last few years to help make our release a huge success.
17:17:59 <jamoluhrsen> huge thanks to anipbu for all the awesome work as release manager
17:17:59 <dfarrell07> thanks for all your amazing release work anipbu, you've been a huge part of ODL's success
17:18:35 <dfarrell07> welcome klou, looking forward to working with you :)
17:18:37 <colindixon> anipbu's contributions to opendaylight are pretty much impossible to overstate
17:18:39 <LuisGomez> thanks anipbu for your awesome work as release mgr
17:19:17 <anipbu> Thanks folks!  Really appreciate it!
17:19:47 <rovarga_> colindixon: nobody noticed is a blanket statement :) nobody mentioned is more like it ;)
17:19:58 <colindixon> rovarga_: +1
17:20:11 <jamoluhrsen> maybe can count on LuisGomez.. not sure about vishnoianil
17:20:25 <colindixon> #topic TSC mailing list vote and discussions (part 2)
17:20:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers
17:20:44 <vishnoianil> anipbu, thanks for all of your contributions
17:21:44 <vishnoianil> anipbu, you were awesome as a release manager and super rocking with those pixalated glasses on :D
17:24:18 <colindixon> #info colindixon notes that (seemingly with the best intentions) committers on at least two key projects (netconf and bgpcep) seem to be oversubscribed and keeping a very high bar for committers resulting in it being very hard to get patches merged in a timely fashion
17:24:51 <colindixon> #info this is actively causing problems for fixing bugs to the extent that it's being noticed buy end-users
17:25:11 <colindixon> #info rovarga_ says he'll respond on the thread, but that we've seen the same thing in the past, e.g., with controller
17:26:52 <colindixon> #info LuisGomez notes and rovarga_ agrees that this time seems to be causing more problems than that time even though there were issues ( rovarga_ points out he went to revision 60+ on  patch before getting reviews )
17:27:14 <colindixon> #Info vishnoianil says, "OK, we know what the problem is and we agree it's there, but what's the solution?"
17:29:14 <colindixon> I think where rovarga_ was going is that the TSC can't force a project to add a committer, which I do think is technically true
17:29:38 <colindixon> we are explicitly charted to resolve disputes between projects
17:30:26 <colindixon> #info vishnoianil asks if a project doesn't respond and isn't merging patches, what options do contributors that need patches merged have?
17:31:33 <colindixon> #info vishnoianil points out that right now, the only recourse is to (a) ping people more and more, (b) reach out to the TSC who can then perhaps more heavily poke, and then what?
17:31:52 <phrobb> Section 5 of the TSC Charter: Section 5. Responsibilities of the TSC. Subject to such policies as may be set by the Board, the TSC is responsible for simultaneous release dates, release quality standards,  technical best practices (including the Development Process), monitoring technical progress, mediating technical conflicts between Committers and project leads, and organizing inter-project
17:31:52 <phrobb> collaboration. The TSC will define ODL’s release vehicles. The TSC will serve as ODL’s liaisons with other consortiums and groups.
17:33:29 <colindixon> #info rovarga_ claims that this is in part because contributors need to figure out how to ship patches that are easier to review
17:33:54 <rovarga_> colindixon: furthermore, I do not thing the TSC can override a committers where the project's codebase or governance is concerned. but I do not have the legal documents loaded in my brain
17:34:22 <colindixon> #info to be very clear, this isn't an attack on committers or rovarga_, this is an ask for how we can get more reasonable reviews on patches in a timely fashion
17:34:49 <colindixon> #info it's also not about asking for turnaround in hours or days, but rather (in recent times) weeks and even months
17:35:20 <colindixon> rovarga_: that is also my understanding and seems to agree with what phrobb says
17:36:59 <abhijitkumbhare> +1 colindixon
17:38:00 <colindixon> #info rovarga_ asks if we're trying to pressure committers to take code they're not sure about, colindixon says that's not the case from his view, the problem is that we can't get the RTT for reviews and discussion to find agreed-upon technical solutions is too long meet user needs
17:38:45 <vrpolak> By the way, was the Bgpcep example this one? https://git.opendaylight.org/gerrit/54331
17:39:26 <rovarga_> vrpolak: yup
17:39:28 <colindixon> vrpolak: that's one current example https://git.opendaylight.org/gerrit/#/q/message:bug-8156
17:39:47 <colindixon> #info reiterating the above statements this isn't about needing reviews in hours/days, but the RTT drifting into weeks/months is hurting things
17:40:05 <colindixon> vrpolak, rovarga_: there's a series of examples in both bgpcep and netconf
17:40:39 <colindixon> you can also see this thread: https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001177.html
17:43:01 <colindixon> #info vishnoianil points out that we've also been trying to groom new committers, but they have been told they're not ready yet
17:43:27 <colindixon> #info rovarga_ says that from his view the investment trying to help them was huge, and the return while hasn't been zero, seems as though it wasn't worth
17:44:12 <rovarga_> #info that is a personal feeling, not substantiated sufficiently to be a hard statement
17:44:31 <colindixon> #info colindixon notes that he's heard from multiple people at multiple organizations that they've tried to be involved in these projects and have been gently told they're not ready yet and eventually given up
17:46:05 <vrpolak> 54331 has not spent that many days with both Verified+1 and lack of response. 60576 similar. 60401 on the other hand is neglected since 2017-07-27. I guess Netconf might be less responsive.
17:46:51 <colindixon> #action TSC to send mail to the PTLs of these projects to ask for a plan for how to resolve these issues
17:46:54 <rovarga_> vrpolak: yup. and having multiple cherry-picks before it was completely reviewed is part of the problem. Note how it is confusing what comments are posted where
17:47:38 <colindixon> #action colindixon to try to write up what contributors and the TSC can deal with in these issues
17:49:08 <CaseyODL> Before we close today, I'd like 2 minutes to talk about the DDF, please.  :)
17:49:26 <colindixon> #info rovarga_ asks if we can actually get data, colindixon says we should go look at it
17:49:47 <colindixon> CaseyODL: working on it
17:50:16 <colindixon> #topic Oxygen DDF
17:50:35 <colindixon> if you want to start logging things here
17:50:44 <colindixon> you can, CaseyODL
17:51:40 <CaseyODL> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum Link to Oxygen DDF Topics Page.
17:52:57 <colindixon> #info please add topics
17:53:07 <colindixon> #info no registration fee, but if you register and don't show there will be a $50 fee
17:53:19 <colindixon> #topic nitrogen
17:53:30 <anipbu> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956   <--- Current status of the Nitrogen Karaf 4 Migration
17:53:48 <anipbu> #info As of Nitrogen M5 Offset 0, 22 have finished the migration (including odlparent 2, autorelease, distribution), 21 projects pending.
17:54:13 <anipbu> #info 7 nonfleaf projects: faas, gbp, vbd, l2switch, sfc, tsdr have pending/missing patches.  mdsal missing status email.
17:54:40 <anipbu> #info other leaf projects can be dropped after RC0.
17:54:58 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Project_Action_Items   <--- Project Action Items including leaf projects not in the distribution and the projects that were not leaves in carbon but have yet to make it back to the distribution
17:56:33 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-August/011823.html   <--- Yangtools branching/versioning: Nitrogen stability branch name should be 1.2.x.  Oxygen master branch should be 2.0.0 and 1.0.0.
17:57:35 <vrpolak> How up-to-date is that google sheet? Honeycomb/Vbd has been merged 2017-07-31 unless there is another patch I do not see. https://git.opendaylight.org/gerrit/59739
17:58:12 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-August/011825.html   <--- Still facing autorelease failure in NEUTRON project.  May be related to org.opendaylight.ovsdb.lib.notation and currently OVSDB and NEUTRON in conversation.
17:58:31 <colindixon> #undo
17:58:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2efc550>
17:58:38 <colindixon> #topic carbon
17:58:48 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-August/011825.html   <--- Still facing autorelease failure in NEUTRON project.  May be related to org.opendaylight.ovsdb.lib.notation and currently OVSDB and NEUTRON in conversation.
17:59:24 <colindixon> #info shague wants to know what's going on with that and AAA, colindixon says try to find ryan
18:00:04 <colindixon> #topic cookies
18:00:09 <colindixon> #endmeeting