17:02:24 <colindixon> #startmeeting tsc
17:02:24 <odl_meetbot> Meeting started Thu Aug 17 17:02:24 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:24 <odl_meetbot> The meeting name has been set to 'tsc'
17:02:26 <dfarrell07> colindixon: bot didn't talk back
17:02:28 <colindixon> #topic roll call and agenda bashing
17:02:28 <dfarrell07> ah, slow
17:02:33 <colindixon> TSC members please #info in
17:02:35 <rovarga> #info rovarga
17:02:35 <skitt> #info skitt
17:02:40 <colindixon> (no, I misspelled
17:02:42 <colindixon> #info colindixon
17:02:48 * colindixon is dialing in, give me two secs
17:03:30 <abhijitkumbhare> #info Abhijit Kumbhare
17:03:45 <LuisGomez> #info LuisGomez
17:03:46 <jamoluhrsen> #info jamoluhrsen
17:03:55 <anipbu> #info anipbu
17:05:23 <klou> #info klou
17:05:53 <colindixon> #undo
17:05:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x14cd3d0>
17:06:04 <colindixon> klou: only TSC members #info in
17:06:12 <zxiiro> #info Thanh
17:06:21 <lori> #info lori
17:06:28 <vishnoianil> #info Anil Vishnoi
17:06:30 <anipbu> klou: you do not need to #info
17:06:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-10-17.00.html last week's meeting minutes
17:07:28 <shague> #info shague
17:09:14 <colindixon> #action phrobb to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
17:09:30 <colindixon> #info CaseyODL started a thread to discuss a December meet-up
17:09:44 <colindixon> #action colindixon to follow up about one last non-responsive security response team member
17:10:08 <colindixon> #info colindixon allowed co-hosts in the Zoom meeting
17:11:11 <colindixon> #info the release engineering team ( zxiiro, anipbu, colindixon, klou ) read this and made sure that it can actually be done during nitrogen branch cutting
17:11:17 <rovarga> #info yangtools oxygen looks okay, I will check downstreams once we release Nitrogen
17:12:07 <colindixon> #action phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
17:12:48 <colindixon> #topic next week's TSC call
17:13:10 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2017&month=8&day=24&hour=3&min=30&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37  Next week's TSC meeting is at APAC time
17:13:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers
17:13:57 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007798.html Marek Ryznar is now a committer on UNIMgr
17:14:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007798.html Daniel Malachovsky is now a committer on DLUX
17:14:16 <rovarga> sorry
17:14:30 <rovarga> I would like to encourage people to comment on the commiters thread
17:14:39 * rovarga has a loud environment
17:15:07 <edwarnicke> Could we get a link to rovarga
17:15:12 <edwarnicke> 's magic doc ?
17:15:16 <jamoluhrsen> yeah it's good
17:15:31 <skitt> +1
17:15:42 <skitt> and I fixed my poorly-explained commit message ;-)
17:15:51 <skitt> (the one that's referred to in Robert's doc)
17:16:05 <rovarga> skitt: it was entirely unnecessary :)
17:16:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007773.html this is rovarga's thread on how to do reviews and how to write commits that are easy to review
17:16:28 <skitt> rovarga, I know, I just thought it would be nice to improve it
17:16:46 <skitt> rovarga, I would like everyone to write commit messages like TomP
17:17:23 <rovarga> #info for dhuge commits, it is best to socialize them -- kernel call, TWS, etc.
17:17:45 <colindixon> #topic events
17:17:54 <colindixon> #link https://www.opendaylight.org/global-events
17:17:55 <abhijitkumbhare> agree rovarga (socialize about large commits)
17:18:11 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:18:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html Oxygen DDF, please add topics
17:19:11 <colindixon> #info dfarrell07 asks what hotel to stay at, they're still working on that, in the meantime it's across the street from Hyatt Regency Santa Clara, but we're seeing if we can get a room rate
17:19:35 <colindixon> #action CaseyODL to figure out if there's a hotel for the Oxygen DDF
17:19:35 <abhijitkumbhare> Embassy Suites by Hilton Santa Clara Silicon Valley
17:19:54 <colindixon> #topic carbon
17:20:06 <abhijitkumbhare> #info Ideal location for across the street for the DDF Embassy Suites by Hilton Santa Clara Silicon Valley
17:20:11 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/SR2/Status    <--- We initially targeted Carbon SR2 Release on 8/17, but we currently have a blocker bug in controller clustering. May delay Carbon SR2.
17:20:27 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-August/012032.html   <--- Patch 61433 is believed to be impacting several projects: netvirt, vtn, etc.
17:20:36 <rovarga> sorry, I have to take this on IRC
17:20:49 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-August/012041.html   <--- Patch to revert may be fixing the tests
17:21:08 <rovarga> #info the problem with reverting that patch is that it re-introduces a memory leak, which does crash us
17:21:22 <colindixon> #link this is the likely problem patch
17:21:25 <colindixon> #undo
17:21:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1424890>
17:21:51 <rovarga> #info so the plan of record is to get debugs from the netvirt (was it) CSIT
17:21:56 <rovarga> #info find the root cause and fix it
17:22:05 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/61433/ this is the likely problem patch, but rovarga notes that undoing reintroduces a memory leak that does hurt us
17:22:23 <rovarga> shague: skitt: you guys hash out which one is more imprtant :)
17:22:30 <skitt> rovarga, yes ;-)
17:22:56 <rovarga> #info it is a Carbon -> SR1 regression
17:23:20 <rovarga> #info observed at 18M committed transactions
17:24:12 <colindixon> #info without the patch, ODL stays up long enough to pass CSIT, but crashes at some point in time, with the patch CSIT fails for other reasons
17:24:38 <colindixon> #Info anipbu says that the current plan of record is to find a better solution based on finding the real root cause of problems after the patch
17:24:53 <rovarga> #info we can revert, ship SR2, but we WILL need SR2.1 pretty much right after that
17:25:12 <rovarga> #info tell-based protocol is not affected
17:25:18 <rovarga> #info the default config is
17:25:30 <rovarga> #info tell-based is not quite ready for prime-time in SR1
17:25:43 <shague> rovarga: can you use the controller 3node jobs that started failing after the patch went in: https://jenkins.opendaylight.org/releng/job/controller-csit-3node-periodic-benchmark-all-carbon/
17:25:45 <colindixon> #action colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
17:26:15 <rovarga> shague: yeah, all they need is a tweak logging to add those debugs ... I don't know how to do that
17:26:26 <colindixon> #topic nitrogen
17:26:40 <rovarga> colindixon: shague: skitt: we really need longevity jobs here ...
17:26:47 <skitt> rovarga, +1
17:26:51 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/164 Autorelease Nitrogen in progress
17:27:00 <colindixon> #info klou our last good build was on 7/24, we're trying to a good build
17:27:09 <jamoluhrsen> vrpolak, rovarga dont we have a 23h 3node csit job in controller?
17:27:14 <vrpolak> shague, rovarga: Yes, I have seen the same symptom there. It seems that low traffic from some unrelated feature is enough to cause trouble in performance tests.
17:27:30 <rovarga> jamoluhrsen: we do, but it is not DS, IIRC
17:27:42 <vrpolak> jamoluhrsen: We have, but only of -only- type, and they are not affected.
17:27:44 <rovarga> jamoluhrsen: we could use end-user feature CSIT running over and over again
17:27:59 <colindixon> #Info at least one current issue is that not everyone is on the right odlparent version
17:28:08 <rovarga> jamoluhrsen: i.e. have netvirt repeated for 23 hours :)
17:28:15 <jamoluhrsen> rovarga, I have that in the plans for netvirt csit. maybe it needs to bump up in priority
17:28:30 <jamoluhrsen> rovarga, yeah. we need it.
17:28:39 <klou> #link https://lists.opendaylight.org/pipermail/release/2017-August/012036.html - latest email from tsdr project lead
17:29:10 <rovarga> LuisGomez: colindixon: would it make sense to talk to the user advisory group?
17:29:21 <rovarga> (about tsdr)
17:29:26 <colindixon> yeah
17:31:08 <rovarga> anipbu: colindixon: what about the branch freeze? is it still on?
17:31:26 <jamoluhrsen> i can't unmute, but why do we want to keep giving work to everyone else.
17:31:53 <colindixon> #info colindixon suggests maybe seeing if adding them to the autorelease and distribution works, they get one shot at that if there's issues, we'll give up
17:32:02 <rovarga> colindixon: anipbu: this is a prime example of a 'used project, no committers'
17:32:10 <colindixon> rovarga: yeah
17:32:18 <jamoluhrsen> the deadline is over, and this will be *work* for someone
17:32:24 <rovarga> colindixon: and, in my opinion, horrible code :)
17:32:34 <colindixon> #info LuisGomez notes that it's hard patch for int/dist because they have lots of features
17:32:58 <rovarga> #info it's not only a lot of features, it is a lot of uncleaned third-party dependencies
17:33:48 <rovarga> #info i.e. high risk of causing issues in compatible-with-all
17:34:10 <colindixon> #info consensus is we need autorelease and int/dist patches by EOD tomorrow, it seems likely that this may not go cleanly
17:34:52 <vishnoianil> rovarga and there we need early sign on these kind of project, waiting till last time is not a solution
17:34:58 <rovarga> colindixon: we were supposed to do that at RC0
17:35:32 <rovarga> anipbu: it's in the release plan says, as was approved by the TSC
17:35:38 <jamoluhrsen> rovarga, vishnoianil: i vote to move on without... it's been plenty of time... can't unmute to speak though :)
17:35:54 <colindixon> jamoluhrsen: yeah…
17:36:19 <vishnoianil> i think we should add feature in bitrega to generate notification to tsc mailing list based on project activities
17:36:49 <colindixon> #startvote shall the TSC give TSDR until EOD tomorrow (8/18) to get patches for autorelease and int/dist or drop them from nitrogen? drop, abstain, friday
17:36:49 <odl_meetbot> Begin voting on: shall the TSC give TSDR until EOD tomorrow (8/18) to get patches for autorelease and int/dist or drop them from nitrogen? Valid vote options are drop, abstain, friday.
17:36:49 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:36:51 <rovarga> #vote drop
17:36:55 <jamoluhrsen> #vote drop
17:36:58 <skitt> #vote drop
17:36:59 <anipbu> #vote drop
17:37:03 <colindixon> #vote abstain
17:37:08 <lori> #vote abstain
17:37:08 <shague> #vote drop
17:37:11 <zxiiro> #drop
17:37:14 <edwarnicke> #vote abstain
17:37:14 <zxiiro> #vote drop
17:37:15 <LuisGomez> #vote drop
17:37:18 <vishnoianil> #vote drop
17:37:22 <abhijitkumbhare> #vote friday
17:37:27 <colindixon> #endvote
17:37:27 <odl_meetbot> Voted on "shall the TSC give TSDR until EOD tomorrow (8/18) to get patches for autorelease and int/dist or drop them from nitrogen?" Results are
17:37:27 <odl_meetbot> abstain (3): colindixon, lori, edwarnicke
17:37:27 <odl_meetbot> drop (8): rovarga, skitt, anipbu, LuisGomez, shague, jamoluhrsen, zxiiro, vishnoianil
17:37:27 <odl_meetbot> friday (1): abhijitkumbhare
17:38:01 <colindixon> #agreed we will drop TSDR from Nitrogen based on the TSC assessment of risk in adding them back
17:38:07 <rovarga> colindixon: they can come back in SR1, though
17:38:11 <rovarga> I think :)
17:38:37 <rovarga> colindixon: true :)
17:39:00 <vishnoianil> rovarga colindixon or we can help them to figure out how their user can pull in their bundles from maven in the nitrogen
17:39:10 <colindixon> vishnoianil: +1
17:39:27 <rovarga> anipbu: colindixon: I really feel strongly about RC0 not being an RC without a lockdown
17:39:29 <colindixon> #info we'll lock the nitrogen branch on Monday per the verbal plan, but not the wiki
17:40:10 <colindixon> vote?
17:40:12 <rovarga> colindixon: if we don't in this release, we should commit to doing that in Oxygen
17:40:16 <vishnoianil> rovarga nitrogen probably we can take exception, given that their is no time between M5 and RC0, but in general i agree with rovarga on it
17:40:24 <rovarga> and not go back on it like we're doing now
17:40:28 <zxiiro> as it stands we don't have a successful build anyway. and we can't have an RC until at least something passes
17:40:29 <colindixon> #startvote shall we lock the nitrogen branch now or monday? now, monday
17:40:29 <odl_meetbot> Begin voting on: shall we lock the nitrogen branch now or monday? Valid vote options are now, monday.
17:40:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:40:36 <colindixon> #vote now
17:40:39 <zxiiro> #vote now
17:40:40 <rovarga> #vote now
17:40:41 <abhijitkumbhare> #vote monday
17:40:42 <anipbu> #vote monday
17:40:43 <edwarnicke> #vote monday
17:40:43 <lori> #vote monday
17:40:48 <shague> #vote monday
17:40:55 <vishnoianil> #vote monday
17:40:56 <LuisGomez> #vote monday
17:41:00 <jamoluhrsen> #vote monday
17:41:12 <vishnoianil> but we should explictly mention that it's one time exception we are taking here
17:41:12 <colindixon> #endvote
17:41:12 <odl_meetbot> Voted on "shall we lock the nitrogen branch now or monday?" Results are
17:41:12 <odl_meetbot> now (3): colindixon, rovarga, zxiiro
17:41:12 <odl_meetbot> monday (8): LuisGomez, edwarnicke, shague, lori, abhijitkumbhare, anipbu, vishnoianil, jamoluhrsen
17:41:14 <rovarga> anipbu: we have taken august vacations into account when doing the SR...
17:41:24 <rovarga> the release plan, I mean
17:41:31 <vishnoianil> given the short release cycle and M5=RC0
17:41:37 <colindixon> #agreed we will lock the nitrogen branch on Monday
17:43:24 <colindixon> #action projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)
17:43:49 <rovarga> klou: colindixon: the DLUX thing should get better when we get an active committer there (hopefully in this meeting)
17:44:08 <colindixon> #action klou and/or anipbu to follow up with dlux
17:44:13 <rovarga> sorry, missed that :)
17:44:22 <colindixon> #undo
17:44:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1320890>
17:44:58 <rovarga> skitt: colindixon: klou: I think the security team should take the action to track the security issues in DLUX and progress on them
17:45:15 <colindixon> #info it sounds like the dlux issues are false positives and it's OK
17:45:46 <colindixon> #topic system integration and test
17:45:49 <colindixon> jamoluhrsen:
17:45:50 <jamoluhrsen> nothing
17:45:56 <colindixon> #info nothing this week
17:45:57 <jamoluhrsen> zoom rocks!
17:46:03 <colindixon> #topic infra
17:46:09 <colindixon> jamoluhrsen: what's broken about it?
17:46:12 <colindixon> #Info nothing this week
17:46:24 <jamoluhrsen> colindixon, I click the mic with a red line in it and it does not work
17:46:30 <colindixon> #topic committers on int/dist
17:46:34 <rovarga> colindixon: we really should dig into history of int/dist
17:46:41 <dfarrell07> colindixon: np;)
17:46:45 <jamoluhrsen> int/dist for skitt:  https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010199.html
17:46:53 <zxiiro> colindixon: there's one for skitt too
17:46:54 <abhijitkumbhare> hash vote +1 (or +2)
17:46:55 <jamoluhrsen> int/dist for jamoluhrsen and zxiiro https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010191.html
17:46:59 <rovarga> colindixon: if my memory serves, int/dist is special in that it was made by TSC to manage the release vehicles
17:47:02 <colindixon> #link Thanh Ha for Int/Dist (votes) https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010191.html
17:47:04 <edwarnicke> #vote +1
17:47:09 <rovarga> colindixon: which would mean that it has different governance
17:47:20 <edwarnicke> rovarga: Not quite
17:47:26 <anipbu> #vote +1
17:47:26 <colindixon> #link Thanh Ha for Int/Dist (changes) https://git.opendaylight.org/gerrit/#/q/owner:thanh.ha%2540linuxfoundation.org+status:merged
17:47:27 <rovarga> colindixon: dfarrell07: like TSC maybe being able to appoint committers
17:47:31 <LuisGomez> #vote +1
17:47:32 <edwarnicke> rovarga: it broke out of the old integration project
17:47:40 <jamoluhrsen> this is not for the special int/dist committer. just full committer status
17:47:48 <vishnoianil> #vote +1
17:47:54 <rovarga> colindixon: I think somebody needs to hear the creation review recording :)
17:47:56 <colindixon> #startvote shall the TSC approve Thanh Ha as an int/dist committer? -1,0,+1
17:47:56 <odl_meetbot> Begin voting on: shall the TSC approve Thanh Ha as an int/dist committer? Valid vote options are -1, 0, +1.
17:47:56 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:47:56 <abhijitkumbhare> I think the vote has not started :)
17:47:59 <shague> #vote +1
17:48:00 <rovarga> #vote +!
17:48:00 <odl_meetbot> rovarga: +! is not a valid option. Valid options are -1, 0, +1.
17:48:03 <edwarnicke> #vote +1
17:48:03 <rovarga> #vote +1
17:48:05 <abhijitkumbhare> #vote +1
17:48:05 <colindixon> #vote +1
17:48:05 <jamoluhrsen> #vote +1
17:48:06 <lori> #vote +1
17:48:07 <skitt> #vote +1
17:48:08 <anipbu> #vote +1
17:48:09 <edwarnicke> rovarga: You might be overly excited about this vote ;)
17:48:21 <rovarga> edwarnicke: 'shift' timing :)
17:48:48 <colindixon> #endmeeting