17:48:55 <colindixon> #startmeeting tsc
17:48:55 <odl_meetbot> Meeting started Thu Aug 17 17:48:55 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:48:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:48:55 <odl_meetbot> The meeting name has been set to 'tsc'
17:49:04 <colindixon> #topic committers on int/dist
17:49:09 <colindixon> #startvote shall the TSC approve Thanh Ha as an int/dist committer? -1,0,+1
17:49:09 <odl_meetbot> Begin voting on: shall the TSC approve Thanh Ha as an int/dist committer? Valid vote options are -1, 0, +1.
17:49:09 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:49:13 <colindixon> #vote +1
17:49:14 <skitt> #vote +1
17:49:14 <edwarnicke> #vote +1
17:49:15 <anipbu> #vote +1
17:49:15 <shague> #vote +1
17:49:15 <lori> #vote +1
17:49:18 <abhijitkumbhare> rovarga: in chess a good move is indicated by “!"
17:49:21 <vishnoianil> #vote +1
17:49:22 <abhijitkumbhare> #vote +1
17:49:24 <rovarga> edwarnicke: I think there was a discussion around there ... but can't be bothered to intsall webex player and spend couple of hours to hunt for the discussion :)
17:49:25 <LuisGomez> #vote +1
17:49:28 <rovarga> #info rovarga
17:49:29 <rovarga> #vote +1
17:49:36 <colindixon> #endvote
17:49:36 <odl_meetbot> Voted on "shall the TSC approve Thanh Ha as an int/dist committer?" Results are
17:49:36 <odl_meetbot> +1 (10): rovarga, skitt, LuisGomez, edwarnicke, shague, colindixon, lori, abhijitkumbhare, anipbu, vishnoianil
17:49:46 <colindixon> #agreed Thanh Ha is a int/dist committer
17:49:56 <rovarga> abhijitkumbhare: yeah, I'll need to start playing that again :)
17:50:00 <colindixon> #link jamoluhrsen int/dist votes: https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010191.html
17:50:12 <rovarga> although I've never been good at gaining tempo :)
17:50:15 <colindixon> #link jamoluhrsen int/dist commits: https://git.opendaylight.org/gerrit/#/q/owner:jluhrsen%2540redhat.com+status:merged
17:50:20 <abhijitkumbhare> rovarga: even better move !!
17:50:29 <colindixon> #startvote shall the TSC approve jamoluhrsen as an int/dist committer? -1,0,+1
17:50:29 <odl_meetbot> Begin voting on: shall the TSC approve jamoluhrsen as an int/dist committer? Valid vote options are -1, 0, +1.
17:50:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:50:30 <skitt> #vote +1
17:50:31 <colindixon> #vote +1
17:50:32 <edwarnicke> #vote +1
17:50:33 <zxiiro> #vote +1
17:50:33 <anipbu> #vote +1
17:50:34 <rovarga> #vote +1
17:50:37 <abhijitkumbhare> #vote +1
17:50:45 <jamoluhrsen> skitt int/dist committer
17:50:51 <vishnoianil> #vote +1
17:50:59 <jamoluhrsen> https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010199.html
17:51:00 <rovarga> skitt: you are gaining a lot of hats :)
17:51:03 <colindixon> #endvote
17:51:03 <odl_meetbot> Voted on "shall the TSC approve jamoluhrsen as an int/dist committer?" Results are
17:51:03 <odl_meetbot> +1 (8): rovarga, skitt, zxiiro, edwarnicke, colindixon, abhijitkumbhare, anipbu, vishnoianil
17:51:14 <skitt> rovarga, yeah, I need to give up the SNMP hat
17:51:16 <colindixon> #agreed jamoluhrsen is an int/dist committer
17:51:22 <dfarrell07> https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010197.html
17:51:25 <dfarrell07> mail thread
17:51:26 <skitt> rovarga, not as many as you though ;-)
17:51:38 <dfarrell07> https://git.opendaylight.org/gerrit/#/q/owner:skitt%2540redhat.com+status:merged
17:51:40 <colindixon> #link skitt int/dis committer votes: https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010197.html
17:51:41 <dfarrell07> contributions
17:51:45 <rovarga> skitt: the rate is alarming, I feel threatened :-D
17:51:48 <vrpolak> zxiiro: By the way, have you ever officially agreed to become Int/Dist committer?
17:51:53 <colindixon> #link skitt int/dist commits: https://git.opendaylight.org/gerrit/#/q/owner:skitt%2540redhat.com+status:merged
17:51:57 <skitt> rovarga, ROFL
17:51:59 <jamoluhrsen> #vote +1
17:52:07 <colindixon> #startvote shall the TSC approve skitt as a committer on int/dist? -1,0,+1
17:52:07 <odl_meetbot> Begin voting on: shall the TSC approve skitt as a committer on int/dist? Valid vote options are -1, 0, +1.
17:52:07 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:52:09 <abhijitkumbhare> #vote +1
17:52:09 <colindixon> #vote +1
17:52:10 <zxiiro> #vote +1
17:52:10 <jamoluhrsen> #vote +1
17:52:10 <rovarga> #vote +1
17:52:11 <anipbu> #vote +1
17:52:11 <shague> #vote +1
17:52:16 <edwarnicke> #vote +1
17:52:28 <colindixon> #endvote
17:52:28 <odl_meetbot> Voted on "shall the TSC approve skitt as a committer on int/dist?" Results are
17:52:28 <odl_meetbot> +1 (8): rovarga, zxiiro, edwarnicke, shague, colindixon, abhijitkumbhare, anipbu, jamoluhrsen
17:52:36 <colindixon> #agree skitt is now an int/dist committer
17:52:41 <vrpolak> By 2.5 as Ed has stepped down.
17:52:54 <CaseyODL> Elections...
17:53:02 <edwarnicke> LOL
17:53:11 <colindixon> #topic odlparent version bumping
17:53:13 <vishnoianil> wow we closed teh vote in 19 seconds ;)
17:53:56 <rovarga> colindixon: actually we made it a SR requirement
17:54:13 <colindixon> rovarga: no, we explictly didn't as far as I recall
17:54:14 <rovarga> dfarrell07: colindixon: I would be okay if it was fully automated
17:54:15 <colindixon> you can opt out
17:54:35 <colindixon> #info anipbu asks is we can let projects opt-in to auto version bumping for things like odlparent
17:54:38 <rovarga> (i.e. it is a robot proposing the patches :-D)
17:54:49 <skitt> rovarga, I’ll publish my script somewhere
17:54:53 <skitt> ;-)
17:55:05 <zxiiro> someone still needs to clickc the submit button
17:55:35 <rovarga> colindixon: fair enough, my faith in my memory is rapidly dropping these days :)
17:57:00 <rovarga> colindixon: anipbu: yes, projects can opt in. strictly speaking we should have a committer vote
17:57:29 <colindixon> #info colindixon says it's certainly OK for projects to opt into this, but it's less clear for whether the prior offer of opt-out applies
17:57:31 <rovarga> colindixon: anipbu: but since each project pretty much has its own governance, PTL's word usually works well enough
17:58:08 * rovarga hears a lot about autorelease
17:58:29 <rovarga> should we socialize the idea of projects dropping out of autorelease?
17:58:32 <rovarga> :)
17:59:03 <rovarga> skitt: yes. as soon as Nitrogen is released, we are dropping out of autorelease
17:59:08 <colindixon> #info as rovarga notes, probably this technically requires a vote a committers, but in general the PTL saying yes and letting committers object later shoudl be fine
17:59:13 <rovarga> skitt: I almost submitted the patch today :)
17:59:58 <colindixon> #action CaseyODL to send mail about elections and/or make sure it's on next week's TSC agenda
18:00:06 <rovarga> skitt: sorry to rain on your parade, but I think there is a lurking problem with ranges in dependencies and compilations ... we will need to discuss it at DDF or a TWS
18:00:06 <colindixon> CaseyODL: unless you need it to be now
18:00:20 <skitt> rovarga, yeah no doubt
18:00:30 <skitt> rovarga, but it helps with remerges at least
18:00:34 <dfarrell07> so anipbu can/should start collecting opt-ins
18:00:38 <rovarga> skitt: i.e. maven-bundle-plugin deriving the *minimum* version
18:00:40 <skitt> rovarga, possibly with a constrained repo
18:00:51 <CaseyODL> It doesn't need to be now.  Just wanted to let everyone know that there will be a round of elections coming for the TSC, CAL, and TSC Chair.
18:01:05 <skitt> CaseyODL, that's November, isn't it?
18:01:31 <colindixon> #topic cookies
18:01:56 <edwarnicke> dfarrell07: Has a strong tendency to believe dfarrell07 when he says things about elections... ;)
18:02:11 <vishnoianil> edwarnicke +1 ;)
18:02:11 <rovarga> edwarnicke: :-D
18:02:20 <skitt> rovarga, let's add that for the Oxygen DDF
18:02:25 <rovarga> edwarnicke: I heard you lost a game of governance sparing :)
18:02:29 <skitt> rovarga, I'll run some experiments in the mean-time
18:02:51 <rovarga> skitt: definitely a topic for odlparent planning or offset-0 BoF
18:02:58 <skitt> rovarga, yup
18:02:59 <edwarnicke> rovarga: LOL... governance is always a collaborative effort ;)
18:03:08 <rovarga> skitt: btw. do you want to co-run the BoF?
18:03:27 <skitt> rovarga, heh, that would be cool
18:03:30 <colindixon> #action colindixon to look at the board approval of the election periods for TSC members and send a mail
18:03:41 <skitt> rovarga, I was planning on merging the odlparent planning session with that
18:03:46 <skitt> rovarga, if you don't mind
18:04:00 <skitt> rovarga, as in, not having a separate odlparent planning session
18:04:06 <rovarga> skitt: no problem ... except it may be a lot of topics
18:04:13 <rovarga> skitt: we'll play it by the ear
18:04:17 <skitt> rovarga, yes indeed
18:04:27 <colindixon> #endmeeting