#opendaylight-meeting: TSC

Meeting started by colindixon at 17:02:06 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:02:07)
    1. Anil Vishnoi (vishnoianil, 17:02:24)
    2. skitt (skitt, 17:02:28)
    3. colindixon (colindixon, 17:02:29)
    4. tykeal - Andrew Grimberg (proxy for Thanh) (tykeal, 17:02:29)
    5. lori (lori, 17:02:33)
    6. jamoluhrsen (jamoluhrsen, 17:02:35)
    7. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=65118#Agenda (colindixon, 17:02:45)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-09-07-17.00.html last week's minutes (colindixon, 17:02:59)
    9. shague (shague, 17:03:05)
    10. rovarga (is here, but not on IRC yet) (colindixon, 17:03:25)
    11. gilesheron (proxy for Ed W). (gilesheron, 17:03:35)
    12. the remaining unresponsive security resposne team member did send mail to the list, even if they didn't acknowledge the fact that we've sent them tons of other mail, so we'll leave them there for now (colindixon, 17:04:08)
    13. ACTION: colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2 (colindixon, 17:04:23)
    14. LuisGomez (LuisGomez, 17:04:42)
    15. CaseyODL added Registration link for DDF to the webpage here: https://www.opendaylight.org/events (colindixon, 17:05:39)
    16. ACTION: CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go (colindixon, 17:06:42)
    17. ACTION: phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (colindixon, 17:06:51)
    18. ACTION: projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them) (colindixon, 17:07:09)
    19. ACTION: CaseyODL to add the December OPNFV plugfest to the events pages (colindixon, 17:07:33)
    20. abhijitkumbhare (abhijitkumbhare, 17:08:12)
    21. https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan klou_ thanks for putting up the WIP Oxygne release plan (colindixon, 17:08:30)
    22. ACTION: colindixon to post instructions for record videos for tutorials (possibly vina_ermagan's links from last week's TSC meeting) (colindixon, 17:09:46)

  2. mailing list votes and discussions (colindixon, 17:10:12)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-September/007918.html TSC election timing discussion (colindixon, 17:10:24)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers (colindixon, 17:10:44)

  3. events (colindixon, 17:10:57)
    1. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum (colindixon, 17:11:06)
    2. CaseyODL says we need more registrants and topics (colindixon, 17:11:25)
    3. https://www.opendaylight.org/global-events (colindixon, 17:11:27)
    4. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:11:28)

  4. Oxygen (colindixon, 17:11:59)
    1. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=978062368 - Oxygen Project Matrix (klou_, 17:12:23)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan WIP release plan (but the release is on and based on calendar-based dates, so it's running now) (colindixon, 17:12:23)
    3. 23 projects have declared their intent to participate (colindixon, 17:13:09)
    4. ACTION: klou_ to ping projects for more participating (colindixon, 17:14:46)
    5. rovarga says yangtools will not be in autorlease, but it is planning to participate in the SR, is that OK, colindixon says yes and that's what opflex does (colindixon, 17:15:52)
    6. http://docs.opendaylight.org/en/latest/release-process/release-schedule.html (colindixon, 17:16:37)
    7. rovarga says yangtools is trying to move some code out of yangtools, when does that need to be done, colin says we've typically required restructuring to be done by M3 (which is now M2) (colindixon, 17:16:53)
    8. klou_ asks when the drop dead date for projects joining the release, colindixon says really M0, but it M1 shoudl be a harder date (colindixon, 17:18:20)
    9. rovargat asks if the M1 date for offset 0 could be moved until after the DDF for new projects joining, colindixon says that if ther'es a compelling offset 0 project that comes out of the DDF, we'll probaby allow it (colindixon, 17:18:53)
    10. ACTION: klou_ to make sure we have staggered deadlines for M1 as the release calls for (colindixon, 17:19:13)

  5. nitrogen (colindixon, 17:19:25)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1758798362 - Release Review Status (klou_, 17:19:51)
    2. many projects didn't make the release review on Monday because of late notice, klou_ is asking them to send their info over e-mail (colindixon, 17:20:50)
    3. klou_ is following up with the 8 remaining projects (colindixon, 17:21:47)
    4. cardinal, infrautils, mdsal, dlux, dluxapps, aaa, unimgr, ttp are the ones missing (colindixon, 17:22:26)
    5. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - Blocker bugs (klou_, 17:22:43)
    6. we closed all but two bugs (9034, 9038) from last week, but have 3 more from this week (9149, 9145, 9089) (colindixon, 17:23:37)
    7. 9034/9038 is the bug that has OOM in OpenFlow Plugin becaue of open transaction chains (colindixon, 17:24:32)
    8. Jozef’s update on 9038: The 9038 bug is being tested by Michael Vorburger and his colleagues I think. This is really specific bug and it is probably since Carbon release there and it is possible to get this exception only in certain cases like special test. This class haven’t been changed since long time so I am not sure it is an blocker. (colindixon, 17:24:59)
    9. Anyway I provided a patch but it is a long way to gain the tests result and to do some agile coding. After patch I need to wait a few days to get the results and have not fully debug log to continue work. So my question is it is really an blocker or it is a specific critical bug ? (colindixon, 17:25:09)
    10. rovarga says we can maybe push that into SR1 (colindixon, 17:25:22)
    11. https://git.opendaylight.org/gerrit/#/c/62674/ (vishnoianil, 17:26:59)
    12. ACTION: klou_ to follow up with vorburger et al. to see if 9034 is actually a blocker, i think only it's manifestations are blockers, e.g., 9038 (colindixon, 17:27:08)
    13. 9149 CSIT Sporadic failures - pike - instances not getting dhcp addresses: jamoluhrsen and shague say they should know what's going on by the end of tomorrow (colindixon, 17:28:52)
    14. ACTION: vorburger, shague to follow up on 9038 if the new patch fixes it (colindixon, 17:29:27)
    15. 9145 Member isolation tests fails in Carbon and Nitrogen: implementation of the signleton service has been changed to fix another bug, it breaks this test, it's harder to analyze because it wasn't entirely passing in the past, it's not entirely passing now, but it's more common to have it fail now (colindixon, 17:30:58)
    16. vrpolak says it's not clear if it's a bug in the singleton service or in the openflowplugin (colindixon, 17:31:24)
    17. vrpolak won't be able to look at it, until Monday at the earliest (colindixon, 17:31:33)
    18. colindixon says that the probability of failure changing might not be a blocker, but it's at least a release note and critical issue (colindixon, 17:33:39)
    19. LuisGomez notes that it's a regression, but maybe not enough to be a blocker (colindixon, 17:34:29)
    20. LuisGomez says that there's a single patch that seems to be causing the issue, so maybe it could be fixed (colindixon, 17:34:57)
    21. ACTION: klou_ and colindixon to follow up with whether 9145 is really a blocker, it seems likely not (colindixon, 17:36:13)
    22. 9089 Regression in Switch scalability test (carbon and nitrogen): we've lost scalability, the reason is that the patch is pretty simple (colindixon, 17:37:15)
    23. https://git.opendaylight.org/gerrit/#/c/63123/ this patch seems simple and if it fixes the issue, great (colindixon, 17:37:32)
    24. colindixon says it sounds like 9034, 9038, 9149, and 9089 are likely to have good reports back tomorrow about if they're fixed or not (colindixon, 17:38:52)
    25. if so, then it sounds like 9145 is _not_ a blocker and we could do a build and maybe release on Monday (colindixon, 17:39:11)
    26. rovarga says the issue with 9145 is probably an issue with the previous fix made some synchronous calls asychronous, the most likely thing is that openflow plugin hasn't adapted to that (colindixon, 17:40:44)
    27. vishnoianil notes that this behavior change might affect many other projects too, so it woudl be good to get into the details, rovarga is adding comments to 9145 (colindixon, 17:41:26)
    28. https://bugs.opendaylight.org/show_bug.cgi?id=9145 (vishnoianil, 17:42:13)
    29. klou_ notes that we've been seeing a lot of intermittent autorelease build failures, which could become an obstacle (colindixon, 17:42:35)
    30. ACTION: klou_ to make a new tab in the nitrogne tracking sheet with build failure explanations to see if we can't make sure to get them done (colindixon, 17:43:11)
    31. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=818416294 tab already exists to track, just never got updated (anipbu, 17:44:03)
    32. anipbu asks if there are hard reqiurements in nitrogen (colindixon, 17:44:53)
    33. ACTION: klou_ to ask if coe wants to be in nitrogen, klou_ says the they were at the release review (colindixon, 17:45:57)
    34. ACTION: klou_ to tell coe if they're in the release, and want to be listed as such, they must complete their docs (colindixon, 17:46:19)

  6. TomP as a comitter on TSDR (colindixon, 17:48:05)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-September/007899.html (colindixon, 17:48:24)
    2. colindixon notes that there are 5 patches, YuLing is the only active committer, so this is a vote (colindixon, 17:49:20)
    3. VOTE: Voted on "shall the TSC approve TomP as a committer on TSDR?" Results are, +1: 9 (colindixon, 17:49:57)
    4. AGREED: TomP is a committer on TSDR (colindixon, 17:50:04)
    5. note that rovarga voted +0 over voice (colindixon, 17:50:11)

  7. TSC elections timing (colindixon, 17:50:16)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-September/007918.html (colindixon, 17:50:24)
    2. colindixon goes on a long explanation of his email (colindixon, 17:53:33)
    3. rovarga says we could have the elections and then wait for some period of time, then have the results take effect (colindixon, 17:57:43)
    4. VOTE: Voted on "shall the TSC elections for this term (1) start today; end and be effective 10/12 or (2) start 10/25; end and be effective 11/22?" Results are, 1: 2, 0: 3, 2: 6 (colindixon, 18:00:24)
    5. AGREED: we will have the elections with a nomination period of 2 weeks and voting period of 2 weeks starting on 10/25 and ending 11/22 exactly a year after the last elections (colindixon, 18:01:26)

  8. cookies (colindixon, 18:01:34)


Meeting ended at 18:01:39 UTC (full logs).

Action items

  1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  2. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
  3. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
  4. projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)
  5. CaseyODL to add the December OPNFV plugfest to the events pages
  6. colindixon to post instructions for record videos for tutorials (possibly vina_ermagan's links from last week's TSC meeting)
  7. klou_ to ping projects for more participating
  8. klou_ to make sure we have staggered deadlines for M1 as the release calls for
  9. klou_ to follow up with vorburger et al. to see if 9034 is actually a blocker, i think only it's manifestations are blockers, e.g., 9038
  10. vorburger, shague to follow up on 9038 if the new patch fixes it
  11. klou_ and colindixon to follow up with whether 9145 is really a blocker, it seems likely not
  12. klou_ to make a new tab in the nitrogne tracking sheet with build failure explanations to see if we can't make sure to get them done
  13. klou_ to ask if coe wants to be in nitrogen, klou_ says the they were at the release review
  14. klou_ to tell coe if they're in the release, and want to be listed as such, they must complete their docs


Action items, by person

  1. CaseyODL
    1. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
    2. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
    3. CaseyODL to add the December OPNFV plugfest to the events pages
  2. colindixon
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
    2. colindixon to post instructions for record videos for tutorials (possibly vina_ermagan's links from last week's TSC meeting)
    3. klou_ and colindixon to follow up with whether 9145 is really a blocker, it seems likely not
  3. klou_
    1. klou_ to ping projects for more participating
    2. klou_ to make sure we have staggered deadlines for M1 as the release calls for
    3. klou_ to follow up with vorburger et al. to see if 9034 is actually a blocker, i think only it's manifestations are blockers, e.g., 9038
    4. klou_ and colindixon to follow up with whether 9145 is really a blocker, it seems likely not
    5. klou_ to make a new tab in the nitrogne tracking sheet with build failure explanations to see if we can't make sure to get them done
    6. klou_ to ask if coe wants to be in nitrogen, klou_ says the they were at the release review
    7. klou_ to tell coe if they're in the release, and want to be listed as such, they must complete their docs
  4. shague
    1. vorburger, shague to follow up on 9038 if the new patch fixes it
  5. skitt
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2


People present (lines said)

  1. colindixon (87)
  2. odl_meetbot (14)
  3. vishnoianil (5)
  4. abhijitkumbhare (5)
  5. skitt (4)
  6. tykeal (3)
  7. shague (3)
  8. LuisGomez (3)
  9. klou_ (3)
  10. lori (3)
  11. anipbu (3)
  12. jamoluhrsen (2)
  13. gilesher_ (2)
  14. gilesheron (1)
  15. CaseyODL (1)


Generated by MeetBot 0.1.4.