17:02:06 <colindixon> #startmeeting TSC
17:02:06 <odl_meetbot> Meeting started Thu Sep 14 17:02:06 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:06 <odl_meetbot> The meeting name has been set to 'tsc'
17:02:07 <colindixon> #topic roll call and agenda bashing
17:02:24 <vishnoianil> #info Anil Vishnoi
17:02:28 <skitt> #info skitt
17:02:29 <colindixon> #Info colindixon
17:02:29 <tykeal> #info tykeal - Andrew Grimberg (proxy for Thanh)
17:02:33 <lori> #info lori
17:02:34 <colindixon> TSC members please #info in
17:02:35 <jamoluhrsen> #info jamoluhrsen
17:02:45 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=65118#Agenda
17:02:59 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-09-07-17.00.html last week's minutes
17:03:05 <shague> #info shague
17:03:25 <colindixon> #info rovarga (is here, but not on IRC yet)
17:03:35 <gilesheron> #info gilesheron (proxy for Ed W).
17:04:08 <colindixon> #info the remaining unresponsive security resposne team member did send mail to the list, even if they didn't acknowledge the fact that we've sent them tons of other mail, so we'll leave them there for now
17:04:15 <CaseyODL> The Board agenda has a follow up to the TSCs request for a Security Manager.
17:04:23 <colindixon> #action colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
17:04:42 <LuisGomez> #info LuisGomez
17:05:39 <colindixon> #link CaseyODL added Registration link for DDF to the webpage here: https://www.opendaylight.org/events
17:06:42 <colindixon> #action CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
17:06:51 <colindixon> #action phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
17:07:09 <colindixon> #action projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)
17:07:33 <colindixon> #action CaseyODL to add the December OPNFV plugfest to the events pages
17:08:12 <abhijitkumbhare> #info abhijitkumbhare
17:08:30 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan klou_ thanks for putting up the WIP Oxygne release plan
17:09:46 <colindixon> #action colindixon to post instructions for record videos for tutorials (possibly vina_ermagan's links from last week's TSC meeting)
17:10:12 <colindixon> #topic mailing list votes and discussions
17:10:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007918.html TSC election timing discussion
17:10:44 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers
17:10:57 <colindixon> #topic events
17:11:06 <colindixon> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum
17:11:25 <colindixon> #Info CaseyODL says we need more registrants and topics
17:11:27 <colindixon> #link https://www.opendaylight.org/global-events
17:11:28 <colindixon> #Link https://wiki.opendaylight.org/view/Events:Main
17:11:59 <colindixon> #topic Oxygen
17:12:23 <klou_> #link https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=978062368 - Oxygen Project Matrix
17:12:23 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan WIP release plan (but the release is on and based on calendar-based dates, so it's running now)
17:13:09 <colindixon> #info 23 projects have declared their intent to participate
17:14:46 <colindixon> #action klou_ to ping projects for more participating
17:15:52 <colindixon> #info rovarga says yangtools will not be in autorlease, but it is planning to participate in the SR, is that OK, colindixon says yes and that's what opflex does
17:16:37 <colindixon> http://docs.opendaylight.org/en/latest/release-process/release-schedule.html
17:16:53 <colindixon> #info rovarga says yangtools is trying to move some code out of yangtools, when does that need to be done, colin says we've typically required restructuring to be done by M3 (which is now M2)
17:18:20 <colindixon> #info klou_ asks when the drop dead date for projects joining the release, colindixon says really M0, but it M1 shoudl be a harder date
17:18:53 <colindixon> #info rovargat asks if the M1 date for offset 0 could be moved until after the DDF for new projects joining, colindixon says that if ther'es a compelling offset 0 project that comes out of the DDF, we'll probaby allow it
17:19:13 <colindixon> #action klou_ to make sure we have staggered deadlines for M1 as the release calls for
17:19:16 <colindixon> #topic nitrogne
17:19:19 <colindixon> #unodo
17:19:22 <colindixon> #Undo
17:19:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x14246d0>
17:19:25 <colindixon> #topic nitrogen
17:19:51 <klou_> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1758798362 - Release Review Status
17:20:50 <colindixon> #info many projects didn't make the release review on Monday because of late notice, klou_ is asking them to send their info over e-mail
17:21:47 <colindixon> #Info klou_ is following up with the 8 remaining projects
17:22:26 <colindixon> #info cardinal, infrautils, mdsal, dlux, dluxapps, aaa, unimgr, ttp are the ones missing
17:22:43 <klou_> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - Blocker bugs
17:23:37 <colindixon> #info we closed all but two bugs (9034, 9038) from last week, but have 3 more from this week (9149, 9145, 9089)
17:24:12 <abhijitkumbhare> Jozef’s update on 9038: The 9038 bug is being tested by Michael Vorburger and his colleagues I think. This is really specific bug and it is probably since Carbon release there and it is possible to get this exception only in certain cases like special test. This class haven’t been changed since long time so I am not sure it is an blocker. Anyway I provided a patch but it is a long way to gain the tests
17:24:13 <abhijitkumbhare> result and to do some agile coding. After patch I need to wait a few days to get the results and have not fully debug log to continue work. So my question is it is really an blocker or it is a specific critical bug ?
17:24:32 <colindixon> #info 9034/9038 is the bug that has OOM in OpenFlow Plugin becaue of open transaction chains
17:24:59 <colindixon> #info Jozef’s update on 9038: The 9038 bug is being tested by Michael Vorburger and his colleagues I think. This is really specific bug and it is probably since Carbon release there and it is possible to get this exception only in certain cases like special test. This class haven’t been changed since long time so I am not sure it is an blocker.
17:25:09 <colindixon> #info Anyway I provided a patch but it is a long way to gain the tests result and to do some agile coding. After patch I need to wait a few days to get the results and have not fully debug log to continue work. So my question is it is really an blocker or it is a specific critical bug ?
17:25:22 <colindixon> #Info rovarga says we can maybe push that into SR1
17:26:59 <vishnoianil> #link https://git.opendaylight.org/gerrit/#/c/62674/
17:27:08 <colindixon> #action klou_ to follow up with vorburger et al. to see if 9034 is actually a blocker, i think only it's manifestations are blockers, e.g., 9038
17:28:52 <colindixon> #Info 9149 CSIT Sporadic failures - pike - instances not getting dhcp addresses: jamoluhrsen and shague say they should know what's going on by the end of tomorrow
17:29:27 <colindixon> #action vorburger, shague to follow up on 9038 if the new patch fixes it
17:30:58 <colindixon> #Info 9145 Member isolation tests fails in Carbon and Nitrogen: implementation of the signleton service has been changed to fix another bug, it breaks this test, it's harder to analyze because it wasn't entirely passing in the past, it's not entirely passing now, but it's more common to have it fail now
17:31:24 <colindixon> #Info vrpolak says it's not clear if it's a bug in the singleton service or in the openflowplugin
17:31:33 <colindixon> #Info vrpolak won't be able to look at it, until Monday at the earliest
17:33:39 <colindixon> #info colindixon says that the probability of failure changing might not be a blocker, but it's at least a release note and critical issue
17:34:29 <colindixon> #info LuisGomez notes that it's a regression, but maybe not enough to be a blocker
17:34:57 <colindixon> #info LuisGomez says that there's a single patch that seems to be causing the issue, so maybe it could be fixed
17:36:13 <colindixon> #action klou_ and colindixon to follow up with whether 9145 is really a blocker, it seems likely not
17:37:15 <colindixon> #info 9089 Regression in Switch scalability test (carbon and nitrogen): we've lost scalability, the reason is that the patch is pretty simple
17:37:32 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/63123/ this patch seems simple and if it fixes the issue, great
17:38:52 <colindixon> #info colindixon says it sounds like 9034, 9038, 9149, and 9089 are likely to have good reports back tomorrow about if they're fixed or not
17:39:11 <colindixon> #Info if so, then it sounds like 9145 is _not_ a blocker and we could do a build and maybe release on Monday
17:40:44 <colindixon> #info rovarga says the issue with 9145 is probably an issue with the previous fix made some synchronous calls asychronous, the most likely thing is that openflow plugin hasn't adapted to that
17:41:26 <colindixon> #info vishnoianil notes that this behavior change might affect many other projects too, so it woudl be good to get into the details, rovarga is adding comments to 9145
17:42:13 <vishnoianil> #link https://bugs.opendaylight.org/show_bug.cgi?id=9145
17:42:35 <colindixon> #info klou_ notes that we've been seeing a lot of intermittent autorelease build failures, which could become an obstacle
17:43:11 <colindixon> #action klou_ to make a new tab in the nitrogne tracking sheet with build failure explanations to see if we can't make sure to get them done
17:44:03 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=818416294 tab already exists to track, just never got updated
17:44:09 <colindixon> anipbu: thanks!
17:44:18 <LuisGomez> +1 to colindixon on autorelease test failures
17:44:53 <colindixon> #info anipbu asks if there are hard reqiurements in nitrogen
17:45:57 <colindixon> #action klou_ to ask if coe wants to be in nitrogen, klou_ says the they were at the release review
17:46:19 <colindixon> #action klou_ to tell coe if they're in the release, and want to be listed as such, they must complete their docs
17:48:05 <colindixon> #topic TomP as a comitter on TSDR
17:48:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007899.html
17:49:20 <colindixon> #Info colindixon notes that there are 5 patches, YuLing is the only active committer, so this is a vote
17:49:36 <colindixon> #startvote shall the TSC approve TomP as a committer on TSDR? -1, 0, +1
17:49:36 <odl_meetbot> Begin voting on: shall the TSC approve TomP as a committer on TSDR? Valid vote options are -1, 0, +1.
17:49:36 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:49:37 <skitt> #vote +1
17:49:38 <colindixon> #vote +1
17:49:38 <vishnoianil> #vote +1
17:49:39 <tykeal> #vote +1
17:49:39 <anipbu> #vote +1
17:49:42 <abhijitkumbhare> #vote +1
17:49:43 <shague> #vote +1
17:49:43 <gilesher_> #vote +1
17:49:45 <lori> #vote +1
17:49:57 <colindixon> #endvote
17:49:57 <odl_meetbot> Voted on "shall the TSC approve TomP as a committer on TSDR?" Results are
17:49:57 <odl_meetbot> +1 (9): tykeal, skitt, gilesher_, shague, colindixon, lori, abhijitkumbhare, anipbu, vishnoianil
17:50:04 <colindixon> #agreed TomP is a committer on TSDR
17:50:11 <colindixon> #Info note that rovarga voted +0 over voice
17:50:16 <colindixon> #topic TSC elections timing
17:50:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007918.html
17:53:33 <colindixon> #info colindixon goes on a long explanation of his email
17:55:37 <colindixon> now to 10/12, starting 10/25 to 11/22, ending 12/24
17:57:43 <colindixon> #info rovarga says we could have the elections and then wait for some period of time, then have the results take effect
17:58:52 <skitt> colindixon, go for it
17:59:31 <colindixon> #startvote shall the TSC elections for this term (1) start today; end and be effective 10/12 or (2) start 10/25; end and be effective 11/22? 0, 1, 2
17:59:31 <odl_meetbot> Begin voting on: shall the TSC elections for this term (1) start today; end and be effective 10/12 or (2) start 10/25; end and be effective 11/22? Valid vote options are 0, 1, 2.
17:59:31 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:59:47 <jamoluhrsen> #vote 2
17:59:49 <skitt> #vote 2
17:59:49 <shague> #vote 2
17:59:50 <anipbu> #vote 2
17:59:52 <vishnoianil> #vote 2
17:59:55 <lori> #vote 1
17:59:55 <tykeal> #vote 0
17:59:56 <colindixon> #vote 1
18:00:05 <gilesher_> #vote 2
18:00:10 <abhijitkumbhare> #vote 0
18:00:14 <LuisGomez> #vote 0
18:00:24 <colindixon> #endvote
18:00:24 <odl_meetbot> Voted on "shall the TSC elections for this term (1) start today; end and be effective 10/12 or (2) start 10/25; end and be effective 11/22?" Results are
18:00:24 <odl_meetbot> 1 (2): colindixon, lori
18:00:24 <odl_meetbot> 0 (3): LuisGomez, tykeal, abhijitkumbhare
18:00:24 <odl_meetbot> 2 (6): skitt, vishnoianil, shague, jamoluhrsen, anipbu, gilesher_
18:01:26 <colindixon> #agreed we will have the elections with a nomination period of 2 weeks and voting period of 2 weeks starting on 10/25 and ending 11/22 exactly a year after the last elections
18:01:34 <colindixon> #topic cookies
18:01:39 <colindixon> #endmeeting