17:01:26 <skitt> #startmeeting TSC
17:01:26 <odl_meetbot> Meeting started Thu Sep 21 17:01:26 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:26 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:32 <skitt> #topic roll call and agenda bashing
17:01:38 <skitt> TSC members please #info in
17:01:41 <skitt> #info skitt
17:01:43 <rovarga> #info rovarga
17:01:53 <skitt> #link last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-09-14-17.02.html
17:01:57 <edwarnicke> #info edwarnicke
17:01:57 <LuisGomez> #info LuisGomez
17:02:12 <jamoluhrsen> #info jamoluhrsen
17:02:19 <jamoluhrsen> #info jamoluhrsen for Sam Hague
17:02:37 <skitt> #action colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
17:02:39 <anipbu> #info anipbu
17:02:51 <skitt> #action CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
17:03:13 <vishnoianil> #info Anil Vishnoi
17:03:23 <skitt> #action phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
17:03:30 <vina_ermagan> #info Vina Ermagan proxy for Lori Jakab
17:04:06 <skitt> #action CaseyODL to advertise the OPNFV plug-fest in Portland
17:04:19 <skitt> #info CaseyODL will be inviting OPNFV participants to come to the ODL DDF
17:04:47 <skitt> #info reminder to *please* register for the DDF and submit topics
17:05:31 <abhijitkumbhare> #info abhijitkumbhare
17:05:47 <skitt> #action klou to ping projects for M0 again
17:07:07 <skitt> #link Oxygen release plan: https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan
17:07:32 <skitt> #topic mailing list votes and discussions
17:07:55 <skitt> #undo
17:07:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x142b310>
17:08:22 <skitt> #info CaseyODL and phrobb report that the board is interested in the security manager role
17:08:39 <skitt> #info phrobb mentions that the board would appreciate the TSC's participation in defining the role and job description
17:10:18 <skitt> #action CaseyODL and phrobb to write a draft of the security manager job description for discussion and approval
17:11:30 <skitt> #link TrieMap: https://lists.opendaylight.org/pipermail/tsc/2017-September/007932.html
17:11:39 <skitt> #link dependencies: https://lists.opendaylight.org/pipermail/tsc/2017-September/007937.html
17:12:38 <skitt> #info rovarga points out that the existence of infrautils, in incubation, appears to block the creation of another project with a different scope
17:13:16 <skitt> #info no point in moving the code from yangtools to infrautils since yangtools is mature
17:14:59 <skitt> #info TTP is an example of a small project which is a "happy-camper", not moving at all
17:15:10 <skitt> #info the read-out boils down to copy-pasting
17:15:16 <skitt> #info that's with TTP participating in autorelease
17:15:34 <skitt> #info projects not participating in autorelease could be even simpler
17:16:55 <skitt> #info vishnoianil points out that creating a project does have a cost
17:17:29 <skitt> #info edwarnicke says that merging unrelated projects together ends up hiding things
17:17:40 <skitt> #info it creates the illusion that there's just one thing to release manage
17:18:14 <skitt> #info the costs to create a project are minimal, the costs to run it depend on the activity in the project
17:18:31 <skitt> #info mostly moving deckchairs around
17:19:54 <skitt> #info abhijitkumbhare suggests making it a sub-project under infrautils
17:20:40 <skitt> #info rovarga reminds us that infrautils is still in incubation and probably couldn't pass graduation review currently
17:20:49 <vrpolak> LuisGomez: https://bugs.opendaylight.org/show_bug.cgi?id=9006#c32  <-- the comment I promised during Integration meeting
17:20:58 <skitt> #info infrautil's scope includes two items only
17:21:09 <LuisGomez> thanks vrpolak
17:21:20 <skitt> #info its release plan is empty as are its release notes
17:21:52 <skitt> #info yangtools can't depend on infrautils
17:24:17 <skitt> #info abhijitkumbhare points out that infrautils' name suggests it's a utility host project
17:24:50 <skitt> #info rovarga asks whether the lldp move was executed
17:25:38 <skitt> #topic events
17:25:47 <rovarga> #info lldp move has not been executed upon
17:26:11 <skitt> #topic Carbon
17:26:38 <skitt> #info klou asks when we plan to release SR2
17:27:01 <skitt> #info rovarga says we discussed releasing it two weeks or so after Nitrogen
17:27:14 <skitt> #info jamoluhrsen asks if we can start the process ASAP
17:27:26 <skitt> #info we need autorelease to run, see where we are with CSIT etc.
17:28:06 <skitt> #info anipbu asks if we're still calendar-based for Nitrogen
17:28:21 <skitt> #info rovarga has a bunch of patches for SR1
17:28:37 <skitt> #info if we don't shift the dates, do we have enough time to get feedback on Nitrogen to do anything useful in SR1
17:29:24 <skitt> #topic Nitrogen
17:29:34 <skitt> #info RC4 this week
17:29:46 <abhijitkumbhare> Just a small point - if infrautils (whose name suggests) is not really functioning as it should - perhaps we as the TSC should think about whether we can do something about that (but perhaps as edwarnicke may point out that we do not have the power to do so).
17:29:47 <skitt> #info projects have been signing off: out of 41, only 8 have signed off
17:30:06 <skitt> #info 9 release note patches need to be updated and merged
17:30:11 <edwarnicke> abhijitkumbhare: We do have limited and enumerated powers
17:30:19 <skitt> #info CSIT: out of 55, 9 issues haven't been checked off
17:30:21 <edwarnicke> abhijitkumbhare: The greatest of which is to grumble loudly :)
17:31:04 <skitt> #info how much time do we give projects to sign off?
17:31:23 <abhijitkumbhare> yes - that may be a good option edwarnicke - assuming there is someone responding on the other end :)
17:31:27 <skitt> #info vishnoianil suggests a 24h notice and TSC vote on the mailing list
17:31:55 <edwarnicke> abhijitkumbhare: If they truly fail to meet various requirements of the Simultaneous Release we can also exclude them for cause.
17:31:59 <skitt> #info it should be 48h, so by Monday
17:32:48 <skitt> #info provisionally approve?
17:33:14 <skitt> #info we've only done it for SRs
17:35:15 <skitt> #startvote how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs? email, TWS, next TSC, pre-approve
17:35:15 <odl_meetbot> Begin voting on: how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs? Valid vote options are email, TWS, next, TSC, pre-approve.
17:35:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:35:23 <skitt> #undo
17:35:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1409fd0>
17:35:26 <skitt> #endvote
17:35:26 <odl_meetbot> Voted on "how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs?" Results are
17:36:05 <vrpolak> Does that mean https://bugs.opendaylight.org/show_bug.cgi?id=9145 has to be downgraded now?
17:36:30 <vrpolak> Oh, it is already re-targeted to Carbon-SR2.
17:36:31 <rovarga> vrpolak: I don't think I will have the patch ready today, and it does need more testing :(
17:36:44 <skitt> #startvote how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs (on the Nitrogen branch)? email, TWS, TSC, pre-approve
17:36:44 <odl_meetbot> Begin voting on: how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs (on the Nitrogen branch)? Valid vote options are email, TWS, TSC, pre-approve.
17:36:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:36:50 <rovarga> #vote TWS
17:36:59 <abhijitkumbhare> #vote pre-approve
17:37:01 <anipbu> #vote TWS
17:37:03 <vishnoianil> #vote ore-approve
17:37:03 <odl_meetbot> vishnoianil: ore-approve is not a valid option. Valid options are email, TWS, TSC, pre-approve.
17:37:05 <vrpolak> rovarga: I think nobody wantd RC4.1 to test and (re)approve.
17:37:11 <vishnoianil> #vote pre-approve
17:37:17 <edwarnicke> #vote pre-approve
17:37:27 <rovarga> vrpolak: I am sure don't :)
17:37:38 <skitt> #vote pre-approve
17:37:47 <LuisGomez> #vote pre-approve
17:37:51 <rovarga> /s/ am//g :)
17:38:12 <skitt> #endvote
17:38:12 <odl_meetbot> Voted on "how shall we vote to approve the release, assuming all the projects sign off and no further blocking bugs (on the Nitrogen branch)?" Results are
17:38:12 <odl_meetbot> TWS (2): rovarga, anipbu
17:38:12 <odl_meetbot> pre-approve (5): edwarnicke, skitt, LuisGomez, abhijitkumbhare, vishnoianil
17:38:24 <skitt> #info shague and jamoluhrsen voted email
17:38:40 <skitt> #agreed we'll have a pre-approve vote
17:40:46 <skitt> #startvote Does the TSC approve RC4 as the Nitrogen release, as long as all projects sign off by Monday 25th TWS time and all blocker bugs are verified in Nitrogen, and we don't respin? -1, 0, +1
17:40:46 <odl_meetbot> Begin voting on: Does the TSC approve RC4 as the Nitrogen release, as long as all projects sign off by Monday 25th TWS time and all blocker bugs are verified in Nitrogen, and we don't respin? Valid vote options are -1, 0, +1.
17:40:46 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:41:13 <rovarga> #vote +1
17:41:15 <jamoluhrsen> #vote +1
17:41:57 <vishnoianil> #vote +1
17:42:21 <vina_ermagan> #vote +1
17:42:26 <LuisGomez> #vote +1
17:42:30 <skitt> #vote +1
17:42:36 <anipbu> #vote +1
17:42:37 <jamoluhrsen> #vote +1    -- for Sam
17:42:37 <odl_meetbot> jamoluhrsen: +1    -- for Sam is not a valid option. Valid options are -1, 0, +1.
17:42:48 <skitt> jamoluhrsen, I'll add it afterwards
17:43:07 <abhijitkumbhare> #vote +1
17:43:27 <skitt> #endvote
17:43:27 <odl_meetbot> Voted on "Does the TSC approve RC4 as the Nitrogen release, as long as all projects sign off by Monday 25th TWS time and all blocker bugs are verified in Nitrogen, and we don't respin?" Results are
17:43:27 <odl_meetbot> +1 (8): rovarga, skitt, LuisGomez, vina_ermagan, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
17:43:35 <skitt> #info shague voted +1
17:44:43 <skitt> #agreed If by Monday TWS, if all projects have signed off (blockers and release), and all blocker bugs are fixed verified in Nitrogen, and we don't respin, the TSC approves RC4 as the Nitrogen release
17:44:58 <skitt> #info anything else means a re-vote either during the TWS or by email
17:45:08 <skitt> #action klou to chase up the missing sign-offs
17:45:22 <skitt> #action klou to provide the TSC with daily updates
17:45:48 <skitt> #action klou to ask vtn/coordinator and opflex to approve their artifacts
17:46:16 <LuisGomez> vrpolak, fyi i just moved this old bug: https://bugs.opendaylight.org/show_bug.cgi?id=6755 to controller/cluster project
17:47:26 <skitt> #info we'll discuss Nitrogen SR1 and Carbon SR2 dates over email next week
17:47:43 <skitt> #info reminder that next week's TSC meeting is APAC-friendly
17:47:57 <skitt> #topic Oxygen
17:48:23 <skitt> #link Oxygen release plan: https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan
17:49:33 <vrpolak> rovarga: The next APAC TSC will still be at 05:30 Bratislava time. Summer time ends later (for both major time zones) I believe.
17:49:53 <skitt> #info no M5 for Oxygen
17:50:21 <skitt> #info M1/M2/M3 need to be split out, the merge was only for Nitrogen
17:52:00 <anipbu> http://docs.opendaylight.org/en/latest/release-process/release-schedule.html
17:52:30 <skitt> #link calendar-based release schedule: http://docs.opendaylight.org/en/latest/release-process/release-schedule.html
17:52:50 <skitt> #action klou to update the release plan
17:53:25 <rovarga> vrpolak: 0530 is still in the 'oh-bloody-early' period :)
17:53:55 <CaseyODL> Looking...
17:54:22 <vrpolak> LuisGomez: A blind workaround: https://bugs.opendaylight.org/show_bug.cgi?id=6755#c28
17:55:23 <LuisGomez> vrpolak, there is no JVM kill or isolation in the test we just send bunch of flows to1 of the instances that is not master or leader
17:55:37 <LuisGomez> anyway i will try your suggest
17:55:42 <skitt> #info rovarga suggests scheduling a session on lessons learnt from Nitrogen
17:55:46 <skitt> #info at a TWS
17:55:56 <vrpolak> rovarga: The difference is that after the 0530 meeting it is not really worth it to go back to sleep before waking up for work. :)
17:55:58 <skitt> #action rovarga to add a session to TWS page
17:56:24 <skitt> #topic system integration and testing
17:56:40 <skitt> #action rovarga asks about the reduction in test jobs
17:56:48 <skitt> #undo
17:56:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x14b4c90>
17:56:56 <skitt> #info rovarga asks about the reduction in test jobs
17:57:39 <vrpolak> LuisGomes: In that case, can you add a check (perhaps in teardown) whether leaders have moved? If yes (and they should not move), it can be Bug 8318.
17:57:47 <skitt> #info rovarga wonders whether it was widely discussed and asks why system tests are behaving in this way (the "all" jobs)
17:57:57 <skitt> #info jamoluhrsen says it was discussed, he understands the pain
17:58:19 <skitt> #info jamoluhrsen says vrpolak has ideas on how to improve the jobs (loading features, then starting the tests)
17:58:53 <skitt> #info rovarga says we need to know the state of the controller if we're testing individual features in system tests
17:59:04 <skitt> #info and what are we doing about infra not handling our release load
17:59:16 <skitt> #info jamoluhrsen says we can add "only" jobs back piecemeal starting now
17:59:40 <skitt> #info should we escalade our infra issues to the board?
18:00:02 <skitt> #info jamoluhrsen asks if there's value in having the "all" jobs
18:00:12 <skitt> #info rovarga says they have value in certain cases
18:00:24 <vina_ermagan> Sorry all, have to leave for another meeting.
18:00:39 <skitt> #info from a system perspective, validating e.g. HA is better done in "only" jobs than "all" jobs
18:01:17 <skitt> #info LuisGomez says a good practice that some jobs needs to be "only": HA, performance, longevity etc.
18:01:31 <skitt> #info projects can choose which tests they want
18:01:54 <skitt> #info vrpolak was thinking of running "only" jobs daily and "all" jobs weekly, hard to implement so dropped for now, perhaps time to revisit
18:02:12 <skitt> #info LuisGomez says the "all" doesn't need to run all the time, it can be run on demand in specific circumstances
18:02:33 <skitt> #info vrpolak says it's important for the distribution, so we know we're integrating features which do work together
18:03:53 <skitt> #info LuisGomez says cluster, performance etc. jobs only make sense for some projects, they should be opt-in
18:04:32 <skitt> #info rovarga suggests running the "all" jobs for info once a week, until we get to M4 at which point they become important
18:04:52 <skitt> #info in any case the jobs need to be fixed so the instance at least starts up, otherwise impossible to debug
18:05:50 <skitt> #action vrpolak to open a bug on releng/builder to track this
18:06:03 <skitt> #info vrpolak asks how we update integration/test requirements
18:06:36 <skitt> #info we'll discuss it on the mailing list
18:06:42 <skitt> #info rovarga says it's late in the game
18:06:46 <skitt> #topic cookies
18:06:58 <skitt> #endmeeting