18:02:15 <CaseyODL> #startmeeting tsc
18:02:15 <odl_meetbot> Meeting started Thu Nov 30 18:02:15 2017 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:02:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:15 <odl_meetbot> The meeting name has been set to 'tsc'
18:02:45 <CaseyODL> #chair skitt zxiiro
18:02:45 <odl_meetbot> Current chairs: CaseyODL skitt zxiiro
18:03:00 <vishnoianil> #info Anil Vishnoi
18:03:05 <zxiiro> #info Thanh Ha
18:03:06 <bjohnson> #info Brady Johnson
18:03:08 <anipbu> #info anipbu
18:03:08 <abhijitkumbhare> #info abhijitkumbhare
18:03:09 <skitt> #info skitt
18:03:18 <rovarga> #info rovarga
18:03:23 <shague> #info shague
18:04:35 <gzhao> #info gzhao
18:04:42 <skitt> #chair abhijitkumbhare
18:04:42 <odl_meetbot> Current chairs: CaseyODL abhijitkumbhare skitt zxiiro
18:05:11 <skitt> abhijitkumbhare, feel free to practice chairing since you’re the only declared candidate ;-)
18:05:18 <abhijitkumbhare> :)
18:07:20 <skitt> #info the TSC chair nomination period is open until January 3rd
18:07:51 <abhijitkumbhare> #undo
18:07:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29ab490>
18:08:12 <abhijitkumbhare> #info TSC chair nomination period open until Dec 13
18:08:21 <LuisGomez> #info LuisGomez
18:08:40 <skitt> #info yuling asks to talk about TSDR joining Oxygen
18:08:48 <skitt> #info rovarga asks where the project lifecycle page has gone
18:08:55 <zxiiro> rovarga: do you mean this page? http://docs.opendaylight.org/en/stable-nitrogen/release-process/project-lifecycle.html
18:09:26 <skitt> #link Nitrogen project lifecycle: http://docs.opendaylight.org/en/stable-nitrogen/release-process/project-lifecycle.html
18:09:39 <skitt> #info but that’s not the one, rovarga is thinking about the page which described stable feature requirements etc.
18:10:05 <skitt> #action rovarga to send CaseyODL his email again
18:10:39 <skitt> #topic Events
18:10:57 <skitt> #info OPNFV plugfest next week in Hillsboro
18:11:10 <skitt> #info CaseyODL and abhijitkumbhare are attending
18:11:23 <skitt> #info next big event is ONS
18:11:39 <skitt> #info no other upcoming events on the immediate horizon
18:11:45 <rovarga> zxiiro: CaseyODL: it used to be this one https://www.opendaylight.org/project-lifecycle-releases
18:12:28 <CaseyODL> #link http://events.linuxfoundation.org/events/open-networking-summit-north-america Link to ONS
18:12:43 <rovarga> and it detailed things like graduation reviews and similar
18:13:02 <bjohnson> #info ONS summit March 26-29 in downtown Las Angeles
18:13:33 <abhijitkumbhare> Yes - we used to have that rovarga - will be good to restore
18:14:11 <bjohnson> #info Open Source Leadership summit, invite only, March 6-8, 2018
18:14:11 <skitt> #info Open Source leadership summit March 6-8 in the Sonoma Valley
18:14:17 <skitt> hah
18:14:29 <rovarga> abhijitkumbhare: precisely, or at least it should exist somewhere -- otherwise we do not have grounds for managing projects :)
18:15:26 <abhijitkumbhare> agree rovarga - I am sure it should be available somewhere
18:16:12 <skitt> #topic Oxygen
18:16:16 <klou> #link https://wiki.opendaylight.org/view/Release_Dashboard
18:16:26 <rovarga> CaseyODL: I've re-sent the original email
18:17:18 <skitt> #info the TSDR team have been catching up with Oxygen
18:17:41 <skitt> #info their goal is modest for Oxygen: catch up with whatever was left out in Nitrogen and meet the requirements for Oxygen
18:17:57 <skitt> #info TSDR is quite big so some work still needs to be done, but many features already working fine
18:18:06 <skitt> #info next steps: CSIT and feature completeness
18:18:18 <skitt> #info the TSDR project has migrated to Karaf 4
18:18:30 <CaseyODL> rovarga: That link is pointing to https://www.opendaylight.org/what-we-do/odl-platform-overview.  I'm assuming that's not what you're looking for.  :(
18:19:14 <skitt> #info rovarga suspects TSDR will encounter issues migrating to odlparent 3
18:19:49 <rovarga> skitt: btw. was the status of odlparent-3 discussed on tuesday?
18:20:04 <skitt> rovarga, briefly
18:20:06 <rovarga> skitt: because we seem to be dead in the water right now
18:20:24 <skitt> rovarga, actually I was on PTO on Tuesday, getting confused
18:20:43 <skitt> rovarga, with the AAA issues?
18:21:07 <rovarga> skitt: yup, and they do go back to odlparent
18:21:12 <skitt> rovarga, I was still on “need to tweak web.xml”, did you have time to look into that?
18:21:32 <rovarga> nope, on PTO, so real life is taking precedence :)
18:21:42 <skitt> #info dfarrell07 thinks TSDR’s status is fine for Oxygen, but hopes futures releases of ODL will find a place for TSDR which doesn’t put such onerous requirements on the team
18:21:49 <skitt> rovarga, oh yes so you are, and right you are
18:21:55 <skitt> rovarga, OK I’ll look into it tomorrow
18:21:56 <klou> #link More info on TSDR request- https://lists.opendaylight.org/pipermail/tsc/2017-November/008375.html
18:22:32 <rovarga> skitt: Ryan is looking into it -- we do need to solve the jackson thing, as even if we remove it from aaa, it will resurface in offset-1/offset-2 land
18:23:01 <bjohnson> #link https://wiki.opendaylight.org/view/TSDR:Main TSDR ODL Wiki
18:23:03 <skitt> rovarga, yes
18:25:13 <CaseyODL> It's already in autorelease.  Isn't it?
18:25:26 <CaseyODL> As of yesterday.
18:27:08 <skitt> #info TSDR declared their intent to participate
18:27:56 <skitt> #info anipbu wonders if this is a precedent, or if TSDR is being singled out: fall behind, get kicked out, then have to come back to the TSC to ask to get back in
18:28:12 <skitt> #info rovarga hopes this sets a precedent: the milestones are important
18:28:34 <skitt> #info from a release engineering perspective the important thing isn’t the readout, it’s the date
18:28:52 <skitt> #info several agree we need to make this consistent, we encourage projects to be on time
18:29:12 <skitt> #info perhaps we need to formalise this before singling out TSDR
18:30:19 <skitt> #info we’d have to add something to the TSC charter describing how projects are removed and re-instated
18:30:40 <skitt> #info e.g. time limits etc.
18:30:56 <skitt> #info typically we drop projects after RC0 when they’re not effectively in the project
18:32:57 <anipbu> https://github.com/opendaylight/docs/tree/master/docs/release-process/milestone-readouts/m1
18:33:06 <skitt> #info rovarga reminds us that some releases were made on time, thanks to careful planning
18:35:13 <skitt> #action the new TSC chair to start drafting language to update the charter
18:35:22 <skitt> #info the governance documents need to be rewritten anyway
18:36:04 <skitt> #info we might want to refactor our milestones too (as discussed in the recent TWS sessions)
18:36:44 <skitt> #info fewer checkpoints with automatic metrics so we’re data-driven and objective
18:37:40 <skitt> #startvote Shall the TSC approve TSDR’s return to Oxygen? -1, 0, +1
18:37:40 <odl_meetbot> Begin voting on: Shall the TSC approve TSDR’s return to Oxygen? Valid vote options are -1, 0, +1.
18:37:40 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:37:45 <skitt> #info without setting a precedent yet
18:37:47 <anipbu> #vote +1
18:38:06 <abhijitkumbhare> #vote +1
18:38:09 <LuisGomez> #vote +1
18:38:16 <gzhao> +1
18:38:18 <zxiiro> #vote +1
18:38:22 <gzhao> #vote +1
18:38:26 <skitt> #vote 0
18:38:31 <bjohnson> #vote 0
18:38:34 <vishnoianil> #vote +1
18:38:36 <abhijitkumbhare> gzhao: you will need to actually vote
18:38:41 <rovarga> #vote 0
18:38:46 <gzhao> abhijitkumbhare: yeah
18:38:59 <abhijitkumbhare> gzhao :)
18:39:02 <shague> #vote 0
18:39:18 <skitt> #endvote
18:39:18 <odl_meetbot> Voted on "Shall the TSC approve TSDR’s return to Oxygen?" Results are
18:39:18 <odl_meetbot> 0 (4): shague, skitt, rovarga, bjohnson
18:39:18 <odl_meetbot> +1 (6): gzhao, anipbu, LuisGomez, abhijitkumbhare, zxiiro, vishnoianil
18:40:29 <skitt> #agreed TSDR rejoins Oxygen
18:42:10 <skitt> #info M2 still ongoing, half the projects have submitted
18:44:12 <skitt> #action klou to send another reminder next week
18:44:21 <skitt> #topic Nitrogen
18:44:42 <skitt> #info SR1 released on Monday
18:44:57 <bjohnson> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan Nitrogen Release Plan
18:45:03 <skitt> #info SR2 needs a revised date otherwise it will come out too close to SR1
18:45:24 <bjohnson> #link https://wiki.opendaylight.org/view/Release_Dashboard ODL Release Dashboard
18:45:43 <skitt> #info perhaps combine SR2 and SR3?
18:47:19 <skitt> #info either combine, or push back
18:47:25 <skitt> #info not much overlap with Oxygen yet
18:49:16 <skitt> #info raises the question of always pushing release back
18:50:51 <skitt> #info need to build a combined calendar with all releases
18:51:00 <skitt> #info so we can see how SRs fit in around the Oxygen release
18:55:45 <dfarrell07> we should just let klou decide and stop talking about it so much;)
18:55:49 <skitt> #action klou to combine all release dates in a single document, on a calendar of some sort
18:55:51 <skitt> dfarrell07++
18:55:57 <skitt> more power to the release team
18:56:25 <rovarga> skitt: more self-releasing projects! :)
18:56:52 <skitt> rovarga, ultimately, yes (and make everyone release managers... shudder)
18:57:05 <skitt> #info four SRs may be too many
18:57:58 <skitt> #info bjohnson says we need SRs too avoid waiting too long
18:58:06 <dfarrell07> we need to talk about this, but we need to do it in reusable way that solves it long term
18:58:09 <skitt> #info there’s a resource problem, or a process problem
18:58:25 <anipbu> We need to poll projects and end users about dropping/keeping the number of SRs to only two or three.
18:58:26 <dfarrell07> we should put this effort into writing proposal for new release system
18:59:58 <skitt> #info exceptional situation because we’re supporting Carbon *and* Nitrogen as well as developing Oxygen
19:00:14 <skitt> #info it also takes us too long to release
19:00:17 <gzhao> I need to leave now.
19:00:19 <bjohnson> Most likely since Nitrogen was a shorter release
19:00:26 <skitt> bjohnson, yes
19:00:31 <abhijitkumbhare> Agree rovarga
19:00:53 <CaseyODL> What about a once per year LTS version?  The off release wouldn't support maybe more than one SR.  Where the LTS would get the current 4 SRs?
19:01:26 <rovarga> CaseyODL: pre-declared LTSes are problematic from quality gating perspective
19:01:36 <skitt> rovarga, +1
19:01:44 <skitt> #topic Carbon
19:01:50 <skitt> #topic Nitrogen
19:01:58 <skitt> #agreed we won’t have SR2 next week
19:02:01 <rovarga> CaseyODL: e.g. you get huge influx of features, just to get them into LTS -- regardless of quality (because, hey, we'll fix it up in SRs)
19:02:02 <skitt> #topic Carbon
19:02:09 <skitt> #info SR3 is December 14
19:02:20 <skitt> #info security issue being fixed, build ready to go
19:02:28 <skitt> #info so should we release SR3 early?
19:02:30 <CaseyODL> Makes sense.
19:03:48 <skitt> #info OPNFV are seeing regressions on Carbon
19:03:55 <rovarga> CaseyODL: watch Linux Kernel -- it is dealing with that issue right now ;)
19:04:03 <zxiiro> In case we don't have time. Quick infra update, the Gerrit update last week failed and we're looking into scheduling another attempt soon once more testing is completed.
19:04:22 <skitt> zxiiro, OK, I’ll add that to the minutes in the infra section
19:04:34 <skitt> #agreed we’re not releasing SR3 early
19:04:50 <skitt> #topic Infrastructure
19:05:04 <skitt> #info the Gerrit update last week failed and we're looking into scheduling another attempt soon once more testing is completed
19:05:14 <skitt> #topic Cookies
19:05:36 <skitt> #info and congrats to all the winners, and welcome to the new TSC members
19:05:53 <skitt> #action someone to update the TSC page and update the agenda
19:06:00 <skitt> #endmeeting