17:01:02 <rgoulding> #startmeeting kernel projects
17:01:02 <odl_meetbot> Meeting started Tue Feb 27 17:01:02 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:02 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:01:05 <rgoulding> #topic agenda bashing
17:01:12 <rgoulding> #info release blockers
17:01:26 <rgoulding> #link https://jira.opendaylight.org/browse/NETCONF-516
17:01:31 <rgoulding> #link https://jira.opendaylight.org/browse/CONTROLLER-1802
17:01:38 <rgoulding> #link https://lists.opendaylight.org/pipermail/neutron-dev/2018-February/001607.html
17:01:45 <rgoulding> #link https://lists.opendaylight.org/pipermail/controller-dev/2018-February/014245.html
17:01:50 <rgoulding> #link https://jira.opendaylight.org/browse/ODLPARENT-142
17:01:57 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/61718/
17:03:16 <rgoulding> #topic agenda bashing
17:03:24 <rgoulding> #info ODLPARENT-139
17:03:35 <rgoulding> #link https://jira.opendaylight.org/browse/ODLPARENT-139
17:05:45 <rgoulding> #info NETCONF-512
17:05:49 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/68651/
17:05:55 <rgoulding> #info is there a committer paying attention to this?
17:08:42 <rgoulding> #info NETCONF-510
17:08:59 <rgoulding> #link https://jira.opendaylight.org/browse/NETCONF-510
17:09:04 <rgoulding> #info also just waiting for review
17:09:22 <rgoulding> #info NETCONF-504
17:09:29 <rgoulding> #info nobody is currently looking at this
17:09:35 <rgoulding> #info is this actually a blocker?
17:12:03 <rgoulding> #info vorburger points out sfc downloads an older version for this
17:12:07 <rgoulding> #info can we use an older version?
17:12:44 <rgoulding> #action luis to take a further look to use an older version that may not suffer same bug
17:12:55 <rgoulding> #info given that SFC is using an older one then maybe this is a stopgap
17:15:33 <rgoulding> #info ODLPARENT-142
17:15:45 <rgoulding> #info can we strip it in int/dist instead?  avoids bumping odlparent and re-releasing
17:15:56 <rgoulding> #info can we only bump karaf4-parent modules?
17:17:16 <rgoulding> #action rgoulding to look at whether we can achieve something similar in int/dist
17:18:59 <rgoulding> #topic NETCONF-516
17:19:08 <rgoulding> #link https://jira.opendaylight.org/browse/NETCONF-516
17:19:21 <rgoulding> #info tpantelis claims this was seen on stack overflow, so may be a problem in Nitrogen too?
17:19:38 <rgoulding> #info this is seen by a number of people in the community
17:19:42 <rgoulding> #info is this a blocker?
17:20:17 <rgoulding> #info reproducible 100% of the time with tsdr feature
17:22:53 <rgoulding> #info we can squash the two patches if necessary
17:24:36 <rgoulding> #action tpantelis to attempt a squash of the two patches to see if this fixes things on non-local setup
17:25:29 <rgoulding> #info those who are encountering this issue are encouraged to add the failed jobs to the jira to ensuyre that a proposed fix actually addresses the issue
17:25:35 <rgoulding> #info lets make this a blocker
17:30:24 <rgoulding> #topic CONTROLLER-1802
17:30:32 <rgoulding> #link https://jira.opendaylight.org/browse/CONTROLLER-1802
17:30:46 <rgoulding> #info this was discussed a lot earlier, and deemed too intrusive for oxygen
17:31:00 <rgoulding> #info we need to discuss next steps on how this could get into fluorine
17:31:38 <rgoulding> #info are we okay to include this in fluorine in the beginning?
17:32:01 <rgoulding> #info rovarga doesn’t know what the state of autorelease is in fluorine right now.  if it is stable we should be okay, but if not we need fix that first
17:32:14 <rgoulding> #info vorburger is asking just if its okay to put it “soon”-ish in fluroine
17:32:49 <rgoulding> #action vorburger to rebase this patch
17:33:23 <rgoulding> #info we are not talking about validate-autorelease, we are talking about autorelease
17:34:11 <rgoulding> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine/
17:34:16 <rgoulding> #info this is currently not building
17:34:24 <rgoulding> #info we also need a weather event for this
17:34:38 <rgoulding> #info otherwise projects willb e broken and not necessarily know why this is happening
17:35:10 <rgoulding> #info after this is merged, then we will promptly file and fix issues against them
17:35:16 <rgoulding> #info we need a green autorelease build first though
17:35:46 <rgoulding> #info skitt suggest ASAP after we get the autorelease green we should do this, since it often doesnt stay green long
17:36:06 <rgoulding> #action vorburger to set up weather item relating to this
17:36:23 <rgoulding> #topic elimination of web.xml
17:36:25 <rgoulding> #link https://lists.opendaylight.org/pipermail/neutron-dev/2018-February/001607.html
17:38:25 <rgoulding> #undo
17:38:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2d4fa10>
17:38:26 <rgoulding> #undo
17:38:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2d4fc10>
17:38:35 <rgoulding> #info kernel projects fitting into the new release process
17:38:39 <rgoulding> #undo
17:38:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d4fc10>
17:38:44 <rgoulding> #topic kernel projects fitting into the new release process
17:39:34 <rgoulding> #info non-SR managed projects (yangtools and odlparent currently only)— ask these projects in this new release model to deliver whatever release they want consumed at the very beginning of the release cycle (2 weeks max into the release)
17:40:05 <rgoulding> #info then dependent projects can adapt to the changes then use the rest of the time to actually do project-specific priorities
17:40:34 <rgoulding> #info we need to verbalize that we don’t need to take a release of these non-SR projects if things don’t apear to be working
17:41:01 <rgoulding> #info ask SR-managed projects to bump whatever is needed ASAP to adapt to non-SR managed dependency changes
17:43:13 <rgoulding> #info rovarga has two concerns 1) non-SR should be called “integrated” 2) going forward we want to peel more and more projects out of autorelease
17:43:21 <rgoulding> #info vorburger disagrees with #2
17:45:28 <rgoulding> #info point #2 is relevant since it affects the scale of integration
17:48:34 <rgoulding> #info time check: 10 minutes passed
17:49:31 <rgoulding> #info this seems like a reasonable timeframe for both odlparent and yangtools at this point
17:49:37 <jamoluhrsen> rovarga_: did you say you had two issues about this new model?
17:50:01 <dfarrell07> jamoluhrsen: the first was just the name
17:50:09 <rovarga_> jamoluhrsen: one is the integration window, the other one is the resource split
17:50:14 <jamoluhrsen> got it. "integrated" is a good name
17:50:47 <rgoulding> #info two issues are:  one is the integration window, the other one is the resource split
17:50:57 <rovarga_> jamoluhrsen: the third one is the appointed committers, but that is a longer topic
17:51:13 <rgoulding> #topic elimination of web.xml
17:51:21 <skitt> thanks shague_, jamoluhrsen, dfarrell07 ;-)
17:51:27 <rgoulding> #link https://lists.opendaylight.org/pipermail/neutron-dev/2018-February/001607.html
17:51:37 <dfarrell07> yep, thanks all:)
17:51:42 * dfarrell07 is off to write some rst
17:53:27 <rgoulding> #info rovarga draws parallels to CSS vs BP and protocol-framework vs netty
17:56:18 <rgoulding> #info rovarga raises point about using something else like CXF
17:56:25 <rgoulding> #info which is already bundled in Karaf
17:59:04 <rgoulding> #info vorburger isn’t necessarily talking about replacing jax-rs, but rather just using this API as a plausible alternative to existing pax-web infrastructure included in karaf
18:05:25 <rgoulding> #action TSC members on this call to bring to the TSC about our project governance Re: “project maturity
18:07:36 <dfarrell07> good point rgoulding, likely netconf should not be a mature project (there is a healthy community requirement)
18:09:02 <rgoulding> #action vorburger to propose an impl in a separate gerrit
18:09:20 <rgoulding> #info api vs impl and where this is going to actually be located
18:20:47 <rgoulding> #action vorburger to put together a AAA gerrit to show how it would use this implementation natively.   then vorburger will push the api and impl in infrautils, then switch AAA to use that.
18:26:04 <rgoulding> #topic isolation issue
18:26:06 <rgoulding> #link https://lists.opendaylight.org/pipermail/controller-dev/2018-February/014245.html
18:26:52 <rgoulding> #info first issue is akka code, not ODL
18:27:16 <rgoulding> #info second issue, if you isolate shard leader, akka sees it is unreachable, the followers don’t see heartbeat, should re-elect leader
18:28:10 <rgoulding> #info tpantelis suggest enabling debug logging on akka specific classes
18:28:27 <rgoulding> #info read through the logs to determine the specific issue
18:29:01 <rgoulding> #info geo-clustering isn’t tested in public really at all
18:29:21 <rgoulding> #info we would need full logs to be able to determine whether this is a bug or expected behavior given the circumstance
18:29:59 <rgoulding> #info this is essentially a 3-node cluster as far as voting goes since the redundant cluster nodes are not elegible to be elected leader
18:33:24 <rgoulding> #action Chethana to open a bug with enhanced logs in public
18:33:46 <rgoulding> #info and enhanced details about the config
18:36:08 <rgoulding> #info this was not tried with a 3 node cluster
18:36:19 <rgoulding> #action Chethana to test a 3 node cluster too
18:36:43 <skitt> I’ve got to drop
18:41:12 <rgoulding> #info cookies
18:41:15 <rgoulding> #endmeeting