#opendaylight-meeting: tsc

Meeting started by CaseyLF at 16:58:09 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 16:59:13)

  1. Agenda Bashing, Roll Call (abhijitkumbhare, 16:59:23)
    1. abhijitkumbhare (abhijitkumbhare, 16:59:32)
    2. Brady Johnson (bjohnson_, 16:59:39)
    3. skitt (skitt, 17:00:03)
    4. ACTION: jamoluhrsen to ping shague to get snapshot vm work put in to jira tasks (jamoluhrsen, 17:01:20)
    5. anipbu (anipbu, 17:01:47)
    6. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda (abhijitkumbhare, 17:01:52)
    7. Thanh Ha (zxiiro, 17:01:54)
    8. Claudio (cdgasparini, 17:02:14)
    9. rovarga_ (rovarga_, 17:02:50)
    10. shague (shague, 17:02:53)
    11. #project netvirt genius ovsdb coe (shague, 17:03:48)
    12. gzhao (gzhao, 17:04:07)

  2. Groups.io (abhijitkumbhare, 17:04:16)
    1. the LF is trying to migrate to Groups.io (skitt, 17:05:10)
    2. individuals can be moderators so groups can self-moderate without LF staff (skitt, 17:05:32)
    3. users have a single account across all Groups.io groups (skitt, 17:05:44)
    4. LuisGomez (LuisGomez, 17:05:49)
    5. Anil Vishnoi (vishnoianil, 17:06:35)
    6. LF will be able to delegate moderation (skitt, 17:07:27)
    7. the LF IT has decided to migrate all Mailman instances to Groups.io (skitt, 17:09:13)
    8. projects which don’t want Groups.io will have to find their own provider (skitt, 17:09:23)
    9. the deadline is end of Q2 2018 (skitt, 17:09:29)
    10. the current Mailman services we use are hosted by the LF (skitt, 17:13:39)
    11. and the LF is discontinuing these services at the end of Q2 (skitt, 17:13:52)
    12. dfarrell07 rovarga_ and others are very unhappy about being forced into this from above by LF, think it's not okay for LF to dictate to projects like this (dfarrell07, 17:14:00)
    13. many TSC memebers are voicing concerns about being forced to move. (jamoluhrsen, 17:14:02)
    14. dfarrell07 asks for people making this decision to attend this call, apparently the refused (dfarrell07, 17:14:16)
    15. no one present from the LF has context on the decision (skitt, 17:14:22)
    16. ACTION: dfarrell07 will bring this to TAC and GB (dfarrell07, 17:14:28)
    17. the people who do were asked to join the call but refused (skitt, 17:14:31)
    18. abhijitkumbhare asks whether mailman was hosted by LF? Answer is yes (abhijitkumbhare, 17:15:17)
    19. phrobb hears loud and clear the negative impact on ODL and agrees with our taking this to the TAC (skitt, 17:15:17)
    20. phrobb encourages TSC members to talk to board members (skitt, 17:15:50)
    21. abhijitkumbhare further asks whether this is a LF decision or an LFN decision? (abhijitkumbhare, 17:15:51)
    22. this should be discussed openly, after the ONS fiasco, many projects are getting very worrisome about the LF control (shague, 17:15:53)
    23. phrobb mentions that the board wasn’t involved in the decision (skitt, 17:16:00)
    24. dfarrell07 and many others are very concerned about this type of change in LF direction (dfarrell07, 17:16:26)
    25. phrobb wasn’t aware of this before the call (skitt, 17:16:51)
    26. the Q2 discontinuation was communicated to tykeal and CaseyLF only yesterday (skitt, 17:17:20)
    27. anil says LF should go to projects with ideas, talk and get buy-in, then move in a direction, not force things from above (dfarrell07, 17:17:53)
    28. ACTION: dfarrell07 to bring LF open process requirement to TAC (dfarrell07, 17:18:17)
    29. this is an LF decision, not an LFN decision (skitt, 17:18:39)
    30. phrobb suggests it might just be a misunderstanding (skitt, 17:22:24)
    31. that someone at LF IT thought it pointless to continue maintaining two similar services (skitt, 17:22:39)
    32. we don't want this precedence set where we get dictated to like this. (jamoluhrsen, 17:23:17)

  3. Neon DDF (skitt, 17:23:27)
  4. Releases (skitt, 17:23:44)
    1. Fluorine first (skitt, 17:24:01)
    2. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10303 <==== Fluorine Dashboard (anipbu, 17:24:13)
    3. dfarrell07 sent a summary out on various topics (skitt, 17:24:18)
    4. four more reviews still need to be done, hopefully in this call (skitt, 17:24:37)
    5. https://lists.opendaylight.org/pipermail/tsc/2018-April/009331.html Managed Apps & Initial Checkpoint Status (abhijitkumbhare, 17:25:03)
    6. coe, lisp, sfc, netvirt still need approval (skitt, 17:25:04)
    7. https://jira.opendaylight.org/issues/?filter=10235 (dfarrell07, 17:25:08)
    8. dfarrell07’s email: https://lists.opendaylight.org/pipermail/tsc/2018-April/009331.html (skitt, 17:25:20)
    9. https://jira.opendaylight.org/browse/TSC-66 COE Managed Application (dfarrell07, 17:25:34)
    10. the application was submitted on time but missed a field (skitt, 17:26:15)
    11. very active project (skitt, 17:26:20)
    12. dependency of netvirt (skitt, 17:26:24)
    13. small code-based (skitt, 17:26:28)
    14. high interest (skitt, 17:26:33)
    15. focused scope (skitt, 17:26:49)
    16. AGREED: The TSC approves COE as a managed project for Fluorine (skitt, 17:28:28)
    17. https://jira.opendaylight.org/browse/TSC-52 netvirt (dfarrell07, 17:28:59)
    18. AGREED: The TSC approves NetVirt as a managed project for Fluorine (skitt, 17:29:14)
    19. https://jira.opendaylight.org/browse/TSC-54 lisp (dfarrell07, 17:29:45)
    20. https://git.opendaylight.org/gerrit/#/c/70308/ Patch to cut dlux dependency (bjohnson_, 17:29:46)
    21. https://jira.opendaylight.org/browse/TSC-47 sfc (dfarrell07, 17:30:43)
    22. AGREED: The TSC approves LISP as a managed project for Fluorine (skitt, 17:30:58)
    23. AGREED: The TSC approves SFC as a managed project for Fluorine (skitt, 17:31:37)
    24. bjohnson_ asks who should update the JIRA for joining (skitt, 17:32:44)
    25. dfarrell07 says he can take care of it, or bjohnson_ can if he wishes (skitt, 17:32:55)
    26. dfarrell07 has filed grievances against projects missing their JIRA to join the release (skitt, 17:33:29)
    27. ACTION: dfarrell07 will mark all participation checkpoints and initial checkpoints to "resolved" and "closed" (anipbu, 17:33:46)
    28. we should review the grievances in the next TSC call (skitt, 17:34:09)
    29. LuisGomez points out we need to file more grievances against kernel projects with too few committers (skitt, 17:34:44)
    30. re TSDR, dfarrell07 has had lots of email discussion with yulingchen and Scott (skitt, 17:35:45)
    31. to explain that unmanaged status is a good thing for projects like TSDR (skitt, 17:36:01)
    32. and communicate the TSC’s concerns re committers (skitt, 17:37:16)
    33. yulingchen explains that there are two active TSDR committers along with tompantelis who helps out with technical migrations (skitt, 17:37:51)
    34. yulingchen feels there’s a gap between the TSC’s perception of TSDR and the reality of the project (skitt, 17:38:06)
    35. most of the recent patches were tompantelis’s patches (skitt, 17:38:40)
    36. TSDR doesn’t break ODL (skitt, 17:38:48)
    37. yulingchen asks if managed projects need to have commits every day (skitt, 17:39:15)
    38. dfarrell07 explains that managed projects need to pay close attention to the ODL ecosystem (skitt, 17:39:28)
    39. yulingchen points out that “unmanaged” itself has negative connotation (skitt, 17:41:35)
    40. managed v. unmanaged isn’t a mark of quality, it’s a mark of how well the ODL release fits a project’s specific plan and aims (skitt, 17:42:35)
    41. the management angle is only with regards to the release team (skitt, 17:43:25)
    42. “self-managed” might be a better term, v. “release-managed” (skitt, 17:43:37)
    43. TSDR fears that being unmanaged will reduce their ability to be used by other projects (skitt, 17:45:19)
    44. “managed” is more of a commitment to the ODL community in general, with contributions to other ODL projects, processes etc. (skitt, 17:46:46)
    45. ACTION: dfarrell07 to clarify in managed docs that we expect projects to work on all of ODL, contribute back, not take more cycles then they give (dfarrell07, 17:46:49)
    46. ACTION: dfarrell07 to consider renaming Managed to ~TSC Managed and Unmanaged to Self-Managed (dfarrell07, 17:47:16)
    47. yulingchen thanks the TSC for providing all this information (skitt, 17:53:17)
    48. the TSC wants to reinforce the message that TSDR isn’t doing anything bad (skitt, 17:53:49)
    49. TSDR wants to end up being managed but understands that it needs to do more (skitt, 17:54:29)

  5. SRs coming up (skitt, 17:55:30)
    1. Oxygen SR1 a week on Saturday (skitt, 17:55:40)
    2. Carbon SR4 on April 26 (skitt, 17:55:45)
    3. Oxygen autorelease is good, Carbon autorelease is a mess (skitt, 17:55:54)
    4. Happy birthday to dfarrell07 in advance for April 14! (abhijitkumbhare, 17:55:54)
    5. anipbu asks when we want to lock the branches (skitt, 17:56:34)
    6. we still need to do the version bumps for Oxygen (and Fluorine) (skitt, 17:57:03)
    7. we should bump before we lock (skitt, 17:57:11)
    8. AGREED: the version bumps will happen ASAP for Oxygen, driven by the releng team (skitt, 18:00:12)

  6. cookies (skitt, 18:01:52)


Meeting ended at 18:01:54 UTC (full logs).

Action items

  1. jamoluhrsen to ping shague to get snapshot vm work put in to jira tasks
  2. dfarrell07 will bring this to TAC and GB
  3. dfarrell07 to bring LF open process requirement to TAC
  4. dfarrell07 will mark all participation checkpoints and initial checkpoints to "resolved" and "closed"
  5. dfarrell07 to clarify in managed docs that we expect projects to work on all of ODL, contribute back, not take more cycles then they give
  6. dfarrell07 to consider renaming Managed to ~TSC Managed and Unmanaged to Self-Managed


Action items, by person

  1. dfarrell07
    1. dfarrell07 will bring this to TAC and GB
    2. dfarrell07 to bring LF open process requirement to TAC
    3. dfarrell07 will mark all participation checkpoints and initial checkpoints to "resolved" and "closed"
    4. dfarrell07 to clarify in managed docs that we expect projects to work on all of ODL, contribute back, not take more cycles then they give
    5. dfarrell07 to consider renaming Managed to ~TSC Managed and Unmanaged to Self-Managed
  2. jamoluhrsen
    1. jamoluhrsen to ping shague to get snapshot vm work put in to jira tasks
  3. shague
    1. jamoluhrsen to ping shague to get snapshot vm work put in to jira tasks


People present (lines said)

  1. skitt (76)
  2. dfarrell07 (25)
  3. abhijitkumbhare (20)
  4. jamoluhrsen (17)
  5. shague (7)
  6. odl_meetbot (7)
  7. rovarga_ (6)
  8. bjohnson_ (5)
  9. anipbu (4)
  10. vishnoianil (4)
  11. gzhao (2)
  12. cdgasparini (2)
  13. zxiiro (2)
  14. CaseyLF (2)
  15. LuisGomez (1)


Generated by MeetBot 0.1.4.