16:55:56 <CaseyLF> #startmeeting tsc
16:55:56 <odl_meetbot> Meeting started Thu Apr 12 16:55:56 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:55:56 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:55:56 <odl_meetbot> The meeting name has been set to 'tsc'
16:56:20 <CaseyLF> #chair abhijitkumbhare skitt
16:56:20 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare skitt
16:57:29 <skitt> #topic Roll call and agenda bashing
16:57:49 <abhijitkumbhare> Hi folks
16:57:55 <abhijitkumbhare> #info abhijitkumbhare
16:58:06 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:58:24 <skitt> #link Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-04-05-16.58.html
16:58:29 <skitt> #info TSC members please info in
16:58:32 <skitt> #info skitt
16:58:49 <abhijitkumbhare> #info abhijitkumbhare
16:59:47 <bjohnson_> #info Brady Johnson
17:00:27 <skitt> #info For future TSC meetings, abhijitkumbhare asks that people update the agenda (on the wiki or by email to him) before Thursday morning Pacific
17:01:03 <jamoluhrsen> #info jamoluhrsen
17:01:15 <rgoulding> #info rgoulding
17:01:45 <anipbu> #info anipbu
17:01:49 <vorburger> #info vorburger
17:01:53 <skitt> #undo
17:01:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b67650>
17:02:01 <skitt> vorburger, TSC members only please
17:02:08 <gzhao> #info gzhao
17:02:13 <zxiiro> #info Thanh Ha
17:02:18 <anipbu> #project usc
17:02:22 <bjohnson_> #project sfc
17:02:28 <skitt> #info Project representatives please #project in
17:02:31 <skitt> #project odlparent
17:02:32 <rgoulding> #project aaa
17:02:48 <vorburger> #project genius infrautils neutron daexim ...
17:03:05 <shague> #info shague
17:03:10 <jhershbe> #info
17:03:10 <skitt> vorburger, we need the exhaustive list :-P
17:03:15 <skitt> vorburger, not ...
17:03:17 <jhershbe> #info jhershbe
17:03:22 <jhershbe> #project neutron
17:03:22 <zxiiro> #info releng
17:03:22 <skitt> #undo
17:03:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b67650>
17:03:36 <jamoluhrsen> shague: do genius and netvirt
17:03:42 <zxiiro> #project releng
17:03:42 <skitt> Please use #project for projects
17:03:44 <shague> #info #project netvirt ovsdb genius
17:04:07 <skitt> #topic Federate ODL and LF JIRA
17:04:14 <cdgasparini> #info #project bgpcep
17:04:36 <jhershbe> #info #project neutron
17:04:58 <abhijitkumbhare> #topic Federate ODL Jira to LF Jira
17:05:35 <skitt> #info this will allow tickets to be linked
17:05:45 <skitt> #info as is the case with the FD.io JIRA
17:06:15 <skitt> #agreed the ODL and LF JIRAs will be federated
17:06:24 <zxiiro> thanks!
17:06:24 <skitt> #topic Neon DDF
17:06:30 <skitt> #undo
17:06:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2a4f590>
17:06:34 <skitt> #topic TAC proxy policy
17:06:36 <gzhao> FYI, FD.io TSC approved federated jira as well
17:06:50 * bjohnson_ Is Daniel off visiting another castle in Scotland?? ;)
17:07:07 <skitt> #info we’ll revisit this next time dfarrell07_pto is present
17:07:19 <skitt> #topic Neon DDF
17:07:24 <vishnoianil> #info Anil Vishnoi
17:07:40 <vishnoianil> #info #project openflowplugin
17:07:46 <vishnoianil> #info #project ovsdb
17:07:50 <skitt> #info we need to decide when and where to host the Neon DDF
17:07:59 <abhijitkumbhare> #info 3 options
17:08:06 <skitt> #info ONS will take place in Amsterdam in late September
17:08:09 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2018-April/009395.html   <--- Casey's email about Neon DDF with three options
17:08:19 <abhijitkumbhare> #info 1. We can hold the DDF at ONS.  The LF can peruse an offsite location the week before or after in Amsterdam.
17:08:31 <abhijitkumbhare> #info 2. We can pursue a hosted location in the EU near ONS.
17:08:44 <abhijitkumbhare> #info 3. We can peruse a hosted location in the Bay Area like we did for Oxygen.
17:09:56 <skitt> #info create an online poll for community members to vote
17:10:05 <skitt> #undo
17:10:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c2e490>
17:10:12 <skitt> #action CaseyLF to create an online poll for community members to vote
17:10:34 <skitt> #info the September time-frame is appropriate given our release calendar
17:10:46 <skitt> #info Fluorine is due on September 7
17:14:13 <rovarga_> #info rovarga_
17:14:52 <skitt> #info we need to decide sooner rather than later, especially if we host it in Europe
17:15:55 <Quan> #info Quan
17:18:10 <LuisGomez> #info LuisGomez
17:19:47 <skitt> #info the ONS Europe CFP is open until June 24
17:20:24 <skitt> #topic Fluorine
17:20:31 <anipbu> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400    <--- Fluorine Tracking Dashboard
17:20:38 <anipbu> #link https://jira.opendaylight.org/browse/TSC-45   <--- Weather: MDSAL Fluorine API breakage window 1 has been resolved
17:20:47 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0   <--- odlparent 3.1.0 and yangtools 2.0.3 still pending.  Version bump Checkpoint in two weeks!
17:22:51 <zxiiro> +1, I can start that effort right after the TSC
17:23:07 <jamoluhrsen> #info the version bump should have happened/finished back on 4/8
17:23:13 <skitt> #info the bump window calls for merges at the start (April 8)
17:23:21 <skitt> #info and then two weeks to settle things down
17:23:26 <skitt> #info we’ll start the bumps ASAP
17:23:32 <skitt> #topic Oxygen
17:23:38 <anipbu> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10401   <--- Oxygen Tracking Dashboard
17:23:45 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0-oxygen    <--- Oxygen version bump for odlparent 3.10 and yangtools 2.0.3 is complete
17:24:00 <anipbu> #info Oxygen SR1 on 4/14, but most likely delayed because of autorelease failure
17:24:12 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-oxygen/   <--- Oxygen SR1 Autorelease job is still failing on jsonrpc, bgpcep, controller
17:24:28 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/70816/   <--- Fix for jsonrpc autorelease failures at 2AM
17:24:50 <anipbu> #info Request that releng lock oxygen branch.
17:25:46 <jamoluhrsen> #info there is a blocker bug (jira pending from LuisGomez) in oxygen. REST is broken
17:26:12 <skitt> #agreed the branches should be locked now
17:26:15 <jamoluhrsen> #action zxiiro to lock oxygen branch
17:26:36 <skitt> #info probably 1-2 weeks delay
17:26:41 <abhijitkumbhare> that sounds pretty bad - REST is broken
17:27:00 <zxiiro> #info stable/oxygen is now locked
17:27:00 <jamoluhrsen> abhijitkumbhare: it's bad
17:27:06 <jamoluhrsen> thanks zxiiro
17:27:24 <Quan> #info Quan
17:27:30 <rovarga_> #link controller patch: https://git.opendaylight.org/gerrit/70840
17:28:43 <abhijitkumbhare> #info We will likely be delayed by a week (4/21) for Oxygen SR 1
17:29:25 <jamoluhrsen> #action zxiiro to open a jira blocker for oxy about vtn/nic issue
17:29:27 <skitt> #info cdgasparini will open a JIRA for the controller patch
17:29:35 <skitt> #topic Nitrogen
17:29:39 <anipbu> #info Last Nitrogen SR3 in one month 5/7
17:30:06 <skitt> #info autorelease is broken in Nitrogen since February 22
17:30:07 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/   <---
17:30:26 <skitt> #topic Carbon
17:30:40 <anipbu> #info Last Carbon SR4 in two weeks on 4/26
17:31:11 <jamoluhrsen> #info carbon still has the vtn/nic dependency issue
17:31:32 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/   <--- Last successful build on April 8
17:34:22 <anipbu> #link https://wiki.opendaylight.org/view/Release_Dashboard  <--- General Release Dashboard
17:34:44 <abhijitkumbhare> #topic ODL Internships
17:35:15 <skitt> #info we need project proposals for internships
17:35:22 <cdgasparini> #info controller bug opened -> https://jira.opendaylight.org/browse/CONTROLLER-1825
17:35:28 <skitt> #info several people have reached out to the LF to volunteer as interns
17:35:34 <skitt> #info but we don’t have projects for them
17:37:52 <skitt> #topic Infrastructure
17:38:05 <skitt> #info thread on the ML about limiting patches to 5MiB
17:38:23 <skitt> #info we can tune that if necessary but that should be sufficient for all sensible patches
17:38:43 <skitt> #info this will be applied at some point in the near future when Jenkins is quiet
17:44:24 <abhijitkumbhare> #topic Models Update for the models lagging standards
17:44:55 <bjohnson_> +1 to keeping ourselves up-to-date
17:48:35 <abhijitkumbhare> #info We need to balance making models up-to-date vs impact to projects
17:49:32 <abhijitkumbhare> #info Needs to continue discussion over the mailing list and get a buy-in from the projects
17:50:21 <abhijitkumbhare> #undo
17:50:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ada850>
17:50:36 <abhijitkumbhare> #info Needs to continue discussion over the mailing list
17:51:30 <abhijitkumbhare> #info Would likely be a big impact change, hence need to get a buy-in from projects
17:52:29 <abhijitkumbhare> #topic Cookies & Beer
17:52:30 <zxiiro> thanks!
17:52:38 <gzhao> thanks
17:52:38 <abhijitkumbhare> #info Thanks
17:52:44 <abhijitkumbhare> #endmeeting