16:57:45 <abhijitk> #startmeeting tsc
16:57:45 <odl_meetbot> Meeting started Thu Jan  3 16:57:45 2019 UTC.  The chair is abhijitk. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:45 <odl_meetbot> The meeting name has been set to 'tsc'
16:58:37 <abhijitk> #chair dfarrell07 LuisGomez skitt
16:58:37 <odl_meetbot> Current chairs: LuisGomez abhijitk dfarrell07 skitt
16:58:59 <abhijitk> #topic Roll Call and Agenda Bashing
16:59:09 <rovarga> #info rovarga
16:59:14 <faseelak_> #info faseelak_
16:59:29 <abhijitk> #chair faseelak_
16:59:29 <odl_meetbot> Current chairs: LuisGomez abhijitk dfarrell07 faseelak_ skitt
16:59:35 <rovarga> #project odlparent yangtools mdsal controller infrautils bgpcep coretutorials
16:59:41 <LuisGomez> #info LuisGomez
16:59:44 <skitt> #info skitt
16:59:51 <abhijitk> #info Happy New Year Everyone!
16:59:54 * skitt proxying for shague too
16:59:56 <skitt> #info shague
16:59:57 <faseelak_> #project genius coe serviceutils infrautils netvirt odltools
17:00:09 <dfarrell07> #info Daniel Farrell for Anil Belur (he asked me on IRC but I think forgot to send email)
17:00:19 <LuisGomez> #project int/dist & int/test
17:00:32 <premsankar> #info Prem
17:00:41 <premsankar> #project COE
17:00:52 <lori> #project lispflowmapping
17:01:49 <jmorvay> #info jmorvay
17:01:53 <jmorvay> #project netconf
17:02:50 <vishnoianil> #info Anil Vishnoi
17:02:58 <vishnoianil> #project openflowplugin
17:03:26 <faseelak_> #topic ODLParent Updates
17:03:34 <vishnoianil> Happy New Year Folks
17:05:14 <zxiiro> #info Thanh Ha
17:06:40 <lori> #info rovarga mentions that using odlparent 4.0.8 he was able to build netconf with Java 11
17:07:39 <faseelak_> #info bump to odlparent 4.0.5 completed
17:07:40 <skitt> #info the bump to 4.0.7 is the conclusion of the bump to 4.0.3 started before the break, which revealed a number of problems which rovarga took care of
17:07:45 <abhijitk> #topic CSIT test reduction for infra improvements
17:07:58 <rovarga> #info odlparent-4.0.5 was a christmas present, making xtend work, upgrading karaf to 4.2.2 and bringing in a bunch of additional wrapper features
17:08:23 <dfarrell07> rovarga: thanks for the christmas present :)
17:08:37 <rovarga> #info odlparent-4.0.7 fixes SFT with Java 11 to the point where yangtools/mdsal/controller pass with trivial patches (most of them already merged up)
17:08:39 <faseelak_> rovarga, thanks for helping to fix the xtend breakage, when almost everyone went on vacation :)
17:09:05 <rovarga> #info odlparent-4.0.8 will bring in fixes to BouncyCastle intregation, which fixes aaa with Java 11
17:09:30 <rovarga> faseelak_: no problem, it seems we don't get many holiday workers -- unlike previous years
17:09:48 <abhijitk> #info Some test cleanup happen as Oxygen tests will be removed
17:10:25 <rovarga> #info hence the lookahead is that odlparent-4.0.8 integration will mean core platform is Java-11 ready and we can start having a conversation about how to leap to that
17:10:34 <abhijitk> #info Some other cleanup can be done with removal of tests of inactive projects
17:11:07 <rovarga> dfarrell07: you're welcome, abelur and zxiiro where Santa's helpers, too :)
17:11:25 <dfarrell07> #info we need to reduce our infra costs very substantially as part of budget this year
17:11:42 <abhijitk> #info dfarrell07 mentions the next step should be start an intern project proposal
17:14:07 <dfarrell07> #action dfarrell07 will write intern project proposal for infra cost reductions
17:14:52 <rovarga> #info btw. we are trackign https://issues.apache.org/jira/browse/SUREFIRE-1574, which will help with verify/merge job speed
17:14:57 <dfarrell07> #info int/test/releng folks will tag-team mentoring infra reduction intern
17:15:10 <abhijitk> #topic OpenDaylight Training Content
17:19:04 <abhijitk> #info Pavan presenting the ODL Training Content document
17:21:02 <faseelak_> #info Pavan, as a first pass for January, is working on cleaning up the existing SDN training material
17:27:39 <faseelak_> #info Pavan says several portions of the document needs a rework, as there were a lot of sections talking about DLUX UI which is now deprecated and removed
17:30:50 <faseelak_> #info dfarrell07 suggests we should consider linking the training materials to docs project
17:33:29 <faseelak_> abhijitk, can we also review the answers to pavan's questions which we had added.. just to be sure that everything is correct..
17:33:57 <abhijitk> Sure faseelak_
17:35:38 <dfarrell07> #info dfarrell07 thinks we should get details about where these docs are hosted, what infra is connected to them, consider ways we can harmonize/improve
17:36:19 <dfarrell07> #info there was discussion about some training labs going out of date because of packages changing. those labs could be made into jobs and run periodically to test, show working examples to students
17:36:51 <dfarrell07> #info getting the training doc source more accessible to generally community will result in option to keep it more up-to-date
17:42:08 <abhijitk> #action Pavan to connect Abhijit/others to Coop for a TWS session
17:49:20 <abhijitk> #topic Releases
17:49:35 <abhijitk> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
17:51:26 <skitt> we love the sound deadlines make as they whizz by, to quote Douglas Adams
17:58:15 <rovarga> #action CaseyLF to follow up LF IT report about the infrastructure issues we've had at the beginning of December 2018
17:58:34 <abhijitk> #topic Cookies
17:58:45 <abhijitk> #endmeeting