#opendaylight-meeting: tsc

Meeting started by abhijitk at 15:59:22 UTC (full logs).

Meeting summary

  1. Agenda bashing and Roll Call (abhijitk, 15:59:39)
    1. abhijitk (abhijitk, 16:02:13)
    2. jamoluhrsen (jamoluhrsen, 16:02:45)
    3. Anil Vishnoi #project openflowplugin, ovsdb (vishnoianil, 16:03:18)
    4. Thanh Ha (zxiiro, 16:03:18)

  2. Neon released!! (abhijitk, 16:05:31)
    1. Prem #project coe (premsankar, 16:06:05)
    2. Press release for Neon release (abhijitk, 16:06:38)
    3. https://www.prnewswire.com/news-releases/opendaylight-most-pervasive-open-source-sdn-controller-celebrates-sixth-anniversary-with-neon-release-300818418.html (abhijitk, 16:06:41)

  3. Sodium DDF (abhijitk, 16:06:51)
    1. Everyone attending - please post your name on the attendee list (abhijitk, 16:07:23)
    2. https://wiki.opendaylight.org/view/Events:Sodium_Dev_Forum#Attendees (abhijitk, 16:07:53)
    3. CaseyLF will be preparing the schedule over the weekend (abhijitk, 16:09:43)
    4. Ling Ling from China Mobile will come for a session about what she thinks are critical needs for OpenDaylight (abhijitk, 16:10:43)
    5. shague (shague, 16:10:57)
    6. We would like to come up with the wish list on OpenDaylight - will be added as a topic (abhijitk, 16:11:38)
    7. CaseyLF asks the companies using ODL including Ericsson, Lumina, etc. to think about their wishlist for ODL (abhijitk, 16:12:58)
    8. CaseyLF will be sending a strawman schedule today (abhijitk, 16:14:57)
    9. https://www.linuxfoundation.org/projects/networking/events/ (abhijitk, 16:17:24)
    10. CaseyLF will try to frontload the schedule so that there may be chance for folks to attend any ONS events late Tuesday afternoon (abhijitk, 16:20:47)

  4. Inactive Projects Archival - Bulk Archival (abhijitk, 16:21:18)
    1. Archival proposal: (abhijitk, 16:21:51)
    2. https://wiki.opendaylight.org/view/Archive_Proposals/Archived_Sodium (abhijitk, 16:22:10)
    3. Termination proposal email was sent on March 14 Pacific time and the 2 week window is over today: (abhijitk, 16:26:04)
    4. https://lists.opendaylight.org/pipermail/tsc/2019-March/011188.html (abhijitk, 16:26:08)
    5. VOTE: Voted on "Does the TSC vote to archive the inactive projects listed in https://wiki.opendaylight.org/view/Archive_Proposals/Archived_Sodium ?" Results are, +1: 7 (abhijitk, 16:28:43)
    6. AGREED: The TSC agrees to archive the projects listed in the following archival proposal: https://wiki.opendaylight.org/view/Archive_Proposals/Archived_Sodium (abhijitk, 16:29:20)

  5. Closing the ticket TSC-74 (abhijitk, 16:31:50)
    1. AGREED: TSC agrees to close the ticket TSC-74 (abhijitk, 16:33:00)

  6. Releases (abhijitk, 16:33:14)
    1. The current release schedule: https://docs.opendaylight.org/en/latest/release-process/release-schedule.html (abhijitk, 16:34:35)
    2. Neon was released on March 26 - hence the Neon SR1 will have to be 1 month from that date i.e. April 26, 2019 (abhijitk, 16:36:20)
    3. https://docs.opendaylight.org/en/latest/release-notes/index.html (LuisGomez, 16:37:09)
    4. some projects seem to be missing here (LuisGomez, 16:37:18)
    5. ACTION: danieldelarosa to update the schedule in the docs repository so that the release schedule ( https://docs.opendaylight.org/en/latest/release-process/release-schedule.html) is updated. (abhijitk, 16:39:17)
    6. Release dashboard: https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (abhijitk, 16:39:54)
    7. All the release plans for the managed projects in Sodium have been completed (abhijitk, 16:40:30)
    8. The project plans are available in the release dashboard under "Sodium project plans" (abhijitk, 16:42:01)

  7. Removal of IdP component from AAA (abhijitk, 16:43:12)
    1. idP component will impact REST token authentication (LuisGomez, 16:45:38)
    2. There is a concern whether there is a significant impact of this change on the end user (abhijitk, 16:47:17)
    3. not everybody may be impacted as it is not mandatory but more convenient to use token vs normal authn (LuisGomez, 16:47:33)
    4. https://jenkins.opendaylight.org/releng/view/CSIT/job/aaa-csit-1node-authn-all-sodium/ (LuisGomez, 16:49:28)
    5. AAA started to fail after idP was removed (LuisGomez, 16:49:51)
    6. The link to the discussion: (abhijitk, 16:51:27)
    7. https://lists.opendaylight.org/pipermail/discuss/2019-March/008284.html (abhijitk, 16:51:29)


Meeting ended at 17:09:05 UTC (full logs).

Action items

  1. danieldelarosa to update the schedule in the docs repository so that the release schedule ( https://docs.opendaylight.org/en/latest/release-process/release-schedule.html) is updated.


Action items, by person

  1. danieldelarosa
    1. danieldelarosa to update the schedule in the docs repository so that the release schedule ( https://docs.opendaylight.org/en/latest/release-process/release-schedule.html) is updated.


People present (lines said)

  1. abhijitk (43)
  2. odl_meetbot (8)
  3. LuisGomez (7)
  4. rovarga (4)
  5. zxiiro (3)
  6. shague (2)
  7. premsankar (2)
  8. jamoluhrsen (2)
  9. vishnoianil (2)
  10. danieldelarosa (1)
  11. skitt (1)
  12. lori (1)
  13. CaseyLF (0)


Generated by MeetBot 0.1.4.