16:02:19 <abhijitk> #startmeeting tsc
16:02:20 <odl_meetbot> Meeting started Thu Apr 11 16:02:19 2019 UTC.  The chair is abhijitk. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:20 <odl_meetbot> The meeting name has been set to 'tsc'
16:02:42 <faseelak> #info faseelak
16:02:48 <skitt> #info skitt
16:02:53 <premsankar> #info premsankar
16:02:56 <abelur> #info abelur
16:02:56 <abhijitk> #topics Agenda Bashing and Roll Call
16:03:07 <faseelak> #project coe infrautils genius netvirt serviceutils
16:03:14 <Hema_> #info Hema
16:03:20 <abhijitk> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:03:23 <jamoluhrsen> #info jamoluhrsen
16:03:30 <abhijitk> #info abhijitk
16:03:40 <skitt> #project odlparent controller netvirt ovsdb integration/distribution
16:04:00 <premsankar> #project coe
16:04:01 <rovarga> #info rovarga
16:04:20 <rovarga> #project odlparent yangtools mdsal controller aaa netconf bgpcep coretutorials infrautils
16:05:04 <abhijitk> #topic DDF Recap
16:06:09 <LuisGomez> #info LuisGomez
16:08:50 <abhijitk> #link https://docs.google.com/document/d/1zHO2p3af7ABTu0d6Q-ICNrL3HxVga7H2GMXTV5vQw_g/edit?usp=sharing
16:09:22 <LuisGomez> #info DDF presentations are posted here: https://wiki.opendaylight.org/view/Presentations
16:11:42 <abhijitk> #info premsankar CaseyLF discuss the documentation person the LF is planning to hire.
16:12:26 <abhijitk> #info CaseyLF says the documentation person may need to be based to a few geographies
16:15:28 <abhijitk> #topic General
16:16:07 <abhijitk> #info LuisGomez has updated the dependency diagram on the main projects wiki
16:16:43 <abhijitk> #info Some projects still missing release notes for Neon
16:17:15 <abhijitk> #action Daniel to follow up
16:17:40 <rovarga> #info odlparent/yangtools have releases now (5.0.0 and 3.0.0)
16:19:27 <rovarga> #info mdsal-4.0.0 staging is happening now, should have the release artifacts by tomorrow morning
16:20:06 <abhijitk> #info faseelak proposes two more days (Tuesday) before MRI patches merged - everybody agrees
16:21:02 <rovarga> faseelak: what sort of UT failures are we looking at?
16:21:22 <faseelak> rovarga, some tests are failing in ofp and ovsdb, and genius as well
16:21:25 <rovarga> #link https://wiki.opendaylight.org/view/Project_list
16:21:45 <faseelak> rovarga, ovsdb one is being analyzed, and they were saying it is getting difficult to fix..
16:22:09 <faseelak> rovarga, am rerunning the genius tests now on multipatch to check if it was some local setup issue
16:23:20 <rovarga> hmm, let me look at ovsdb
16:23:29 <rovarga> those UTs are horrible
16:23:39 <abelur> rovarga: cant find the repo for releasing mdsal-3.0.8. are the repo names correct?
16:24:11 <rovarga> abelur: hmmm
16:24:24 <rovarga> https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/mdsal-maven-stage-v3.0.x/25/staging-repo.txt.gz
16:25:38 <faseelak> rovarga, looks like the genius tests are passing.. not hitting the issue whatever I sent in email.. let us wait for the run to complete
16:25:48 <rovarga> awesome :)
16:26:04 <abelur> rovarga: thanks all good, found it
16:26:05 <rovarga> abelur: both of them are loading in browser for me
16:26:49 <abelur> rovarga: looks like some delay far down here, lol ;)
16:27:22 <abhijitk> #topic Confluence
16:27:28 <rovarga> abelur: no problem. how long are you going to be around today?
16:28:09 <rovarga> abelur: I have mdsal-4.0.0 running here: https://jenkins.opendaylight.org/releng/view/yangtools/job/mdsal-maven-stage-master/228/ and should be ready in about 30 minutes
16:28:37 <abelur> rovarga: after the meeting i'll be away for a few hours to catch up on some sleep ... its getting 3am here :|
16:29:00 <abhijitk> #info CaseyLF is proposing a migration to Confluence
16:29:01 <abelur> rovarga: i'll pomote that if it goes through before that
16:29:09 <rovarga> ouch...
16:30:01 <faseelak> rovarga, any idea what this failure is : https://jenkins.opendaylight.org/sandbox/job/integration-multipatch-test-sodium/30/console
16:30:14 <faseelak> rovarga, there are no references to javax.annotation.Nonnull in genius
16:32:19 <abhijitk> #startvote Does the TSC agree for CaseyLF to migrate to Confluence from wiki  (assuming there is a transition period where both are alive)?  -1,0,+1
16:32:19 <odl_meetbot> Begin voting on: Does the TSC agree for CaseyLF to migrate to Confluence from wiki  (assuming there is a transition period where both are alive)? Valid vote options are -1, 0, +1.
16:32:19 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:32:23 <rovarga> faseelak: that's very weird
16:32:33 <rovarga> #vote +1
16:33:59 <skitt> #vote +1
16:35:51 <premsankar> #vote +1
16:35:56 <Hema_> #vote +1
16:36:01 <LuisGomez> #vote +1
16:36:06 <jamoluhrsen> #vote +1
16:36:09 <faseelak> #vote +1
16:36:13 <rovarga> CaseyLF: how is tykael
16:36:29 <rovarga> CaseyLF: how is tykeal taking the proliferation of commercial software? :)
16:36:31 <faseelak> but who will do the migration of all the existing content in wiki? abhijitk
16:36:32 <abhijitk> #vote +1
16:36:34 <abelur> #vote +1
16:36:37 <skitt> faseelak, CaseyLF will
16:36:48 <skitt> Hema_, abhijitk is wondering who you are proxying for
16:36:53 <faseelak> skitt, okaay then +2 ;)
16:37:27 <abhijitk> #endvote
16:37:27 <odl_meetbot> Voted on "Does the TSC agree for CaseyLF to migrate to Confluence from wiki  (assuming there is a transition period where both are alive)?" Results are
16:37:27 <odl_meetbot> +1 (9): rovarga, skitt, LuisGomez, faseelak, premsankar, jamoluhrsen, Hema_, abhijitk, abelur
16:37:31 <rovarga> faseelak: I looked at ovsdb ... it should not be that hard to fix
16:37:47 <faseelak> rovarga, i think they are working on it, hoping to get a patch soon..
16:37:53 <rovarga> faseelak: it's a single component, there's bunch of unneeded mocks (lenient() will help)
16:38:11 <faseelak> rovarga, okay..wil inform Som
16:38:13 <rovarga> faseelak: and the other ... 4/6 mismatches are probably soemthing around nulls :)
16:38:21 <abhijitk> #info The vote was approved by a margin of 8 to zero TSC members
16:38:44 <rovarga> so probably a mocking update neede -- those unnecessary stubbings may point towards the place
16:40:27 <abhijitk> #topic Releases
16:40:54 <abhijitk> #undo
16:40:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2d4d5d0>
16:41:20 <CaseyLF> rovarga: Some of this stuff was recommended by him.
16:42:07 <abhijitk> #info CaseyLF plans to keep the wiki around but will be pointed to by a different URL
16:42:17 <abhijitk> #topic Releases
16:42:36 <abhijitk> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
16:46:37 <abhijitk> #info rovarga requests the community to step up on the Archetype project
16:46:56 <rovarga> #info archetypes project is in dire state, it needs some initial TLC to catch up with the releases we've made
16:47:32 <rovarga> #info the scope of work is simple version bumps, branching releasing -- initial catch up should be couple of hours, maybe 2 days
16:48:18 <rovarga> #info after that it's essentially SM-level work, i.e. maybe 2-3 hours to support every Simultaneous Release
16:49:11 <abhijitk> #action abhijitk to discuss with the Neutron project with Michael, etc. regarding the committer promotions and PTL
16:51:55 <abhijitk> #info Neon SR1 is around the corner - due on April 26
16:52:51 <rovarga> #info odlparent/yangtools/mdsal have their releases for Neon SR1 done -- odlparent-4.0.10, yangtools-2.1.10 and mdsal-3.0.8
16:53:23 <faseelak> rovarga, one quick doubt
16:53:26 <faseelak> rovarga, https://jenkins.opendaylight.org/sandbox/job/integration-multipatch-test-sodium/31/console
16:53:37 <faseelak> rovarga, why does this code complain about generated code?
16:54:02 <faseelak> rovarga, here is the corresponding patch : https://git.opendaylight.org/gerrit/#/c/81529/
16:54:19 <rovarga> faseelak: looks like somethign somewhere is using the wrong code generator
16:55:00 <faseelak> #info sodium MRI patches are making good progress. Currently work on-going at sfc project
16:55:07 <rovarga> faseelak: forgot to bump bding-parent
16:55:19 <rovarga> https://git.opendaylight.org/gerrit/#/c/81529/2/sfc-model/pom.xml
16:55:24 <faseelak> #info test failures are being looked upon by Som and Karthika from ovsdb and openflowplugin
16:55:43 <faseelak> rovarga, thanks!
16:55:47 <rovarga> faseelak: binding-parent ... it's still at 3.0.6 :)
16:55:57 <rovarga> abelur: aaaalmost done :)
16:56:06 <faseelak> rovarga, am going mad! i am missing skitt :P
16:56:26 <rovarga> :)
16:56:31 <abhijitk> #topic Cookies
16:56:38 <rovarga> it's the little scripts
16:56:41 <abhijitk> #info See you next time :)
16:56:43 <skitt> faseelak, https://www.youtube.com/watch?v=Od6hY_50Dh0
16:56:46 <abhijitk> #endmeeting