16:00:01 <abhijitk> #startmeeting tsc
16:00:01 <odl_meetbot> Meeting started Thu Aug 15 16:00:01 2019 UTC.  The chair is abhijitk. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:01 <odl_meetbot> The meeting name has been set to 'tsc'
16:00:27 <abhijitk> #topic Agenda Bashing and Roll Call
16:01:03 <abhijitk> #link https://wiki.opendaylight.org/view/File:Antitrust_Slide.pptx Antitrust policy
16:01:25 <zxiiro> #info Thanh Ha
16:01:27 <LuisGomez> #info LuisGomez
16:01:28 <abhijitk> Zoom taking its own sweet time to connect
16:01:58 <jamoluhrsen> #info jamoluhrsen
16:02:35 <abhijitk> #info abhijitk
16:02:47 <abhijitk> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda
16:03:20 <vishnoianil_> #info Anil Vishnoi #project openflowplugin, ovsdb
16:03:41 <abelur> #info Anil Belur
16:04:07 <abelur> #project releng/builder, autorelease, packaging
16:04:24 <danieldelarosa> #info danieldelarosa
16:05:04 <abhijitk> #topic Releases
16:05:19 <abhijitk> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
16:06:04 <abhijitk> #info We are on Sodium Final Checkpoint today
16:07:28 <abhijitk> #info MDSAL-404 needs to be integrated into Sodium
16:08:23 <abhijitk> #undo
16:08:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ad8110>
16:08:51 <abhijitk> #info rovarga says MDSAL 4.0.4 needs to be integrated into Sodium
16:12:30 <rovarga> #info rovarga
16:13:05 <rovarga> #project odlparent yangtools mdsal controller aaa netconf infrautils
16:13:31 <rovarga> #project bgpcep (I had to forget *something*)
16:13:50 <jamoluhrsen> #link https://jira.opendaylight.org/browse/INTDIST-105 <-- blocker bug to get mdsal 4.0.4 integrated to sodium release
16:14:15 <jamoluhrsen> abhijitk: zxiiro how can I add Sodium to int/dist jira project?
16:14:43 <jamoluhrsen> LuisGomez: ^^
16:15:08 <abhijitk> abelur: ^^ ?
16:15:13 <abelur> danieldelarosa: are you an admin for ODL Jira?
16:16:48 <zxiiro> jamoluhrsen: I think someone with admin permissions to the project needs to add the "Sodium" version to the project. The downside with Jira unfortunately is that versions are per-project and there's no global way to sync versions across all projects in Jira.
16:21:52 <rovarga> #action rovarga to follow up on Jira rant/workflows
16:21:54 <jamoluhrsen> I don't know who is the admin. should I open a helpdesk?
16:23:18 <zxiiro> jamoluhrsen: abelur would be one. There's 2 level's of admin though:
16:23:18 <zxiiro> 1) project level admin, get's access to most things but not everything
16:23:18 <zxiiro> 2) site admin which has access to everything (Only LF staff are these people)
16:23:19 <abhijitk> #info Neon SR2 signoff in process
16:23:32 <zxiiro> jamoluhrsen: usually PTLs should have project admin permissions to their respective projects.
16:24:21 <jamoluhrsen> I am the "project lead" of int/test but I can't find where I  am supposed to add versions. LuisGomez is lead for int/dist
16:24:23 <abhijitk> #topic Openjdk{8,11} support for Sodium and Magnesium
16:30:01 <abhijitk> #info Group discussing suggestions from zxiiro, rovarga around job groups and verify
16:32:44 <abhijitk> #info Broad approval around zxiiro suggestions
16:32:58 <abhijitk> #info zxiiro volunteers to implement his suggestions
16:33:22 <rovarga> #info there are really two classes of jobs -- 'production' and 'verify', where 'production' affects -merge and -stage jobs (and there can only be 1 version), while verify really is about multiple versions and affects -verify and CSIT jobs
16:35:00 <rovarga> #info the idea is to hhave separate per-JDK groups, i.e. odl-maven-jobs-jdk11, with odl-maven-jobs being jdk8-implied
16:35:38 <abhijitk> #topic Self-service release process follow-up
16:35:40 <rovarga> zxiiro: okay if I action you?
16:35:48 <zxiiro> rovarga: yep
16:36:09 <abhijitk> #info abelur says all bits are in place for this - but needs some optimizations
16:36:12 <rovarga> #action zxiiro to follow up with job group refactor to support jdk11 merge/release jobs
16:36:28 <zxiiro> rovarga: I'll propose changes to add the new job-group and leave it up to the individual projects to decide when they want to switch to the new job group.
16:37:48 <abelur> #link https://docs.releng.linuxfoundation.org/projects/global-jjb/en/latest/jjb/lf-release-jobs.html
16:46:37 <rovarga> #link https://jira.linuxfoundation.org/browse/RELENG-1914
16:46:52 <rovarga> #info Casey's escalation went unheeded for two weeks
16:49:16 <zxiiro> Honestly I think what we really need is a button that let's us point to a staging repo that's been approved by the project and then Nexus releases that repo presses the "promote" button for us (in both Nexus and Maven Central).
16:49:45 <zxiiro> tagging and and pushing a tag I think is already something a committer can do.
16:53:34 <rovarga> #info rovarga is not happy (at all!) about LF engagement with projects and transparency
16:54:08 <rovarga> zxiiro: +100
16:58:44 <rovarga> zxiiro: patch going through gerrit is purely optional
16:59:01 <rovarga> #action CaseyLF to share LFN single 'get-invovled' page :)
16:59:58 <rovarga> CaseyLF: abelur: I very much appreciate the efforts, don't get me wrong, it's just we could do much better (and have been way better @ODL)
17:21:50 <abhijitk> #topic Cookies
17:22:05 <abhijitk> #endmeeting