16:04:52 <abhijitk> #startmeeting tsc
16:04:52 <odl_meetbot> Meeting started Thu Oct 17 16:04:52 2019 UTC.  The chair is abhijitk. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:52 <odl_meetbot> The meeting name has been set to 'tsc'
16:05:15 <abhijitk> #topic Agenda Bashing & Roll Call
16:05:46 <abelur> #info abelur
16:06:04 <abelur> #project releng/builder AR packaging
16:06:09 <avishnoi> #info Anil Vishnoi #project ovsdb
16:06:38 <abhijitk> #info abhijitk
16:06:57 <CaseyLF> Can someone set the agenda / chair me?
16:07:00 <abhijitk> #topic Plastic Project Creation Review
16:07:12 <LuisGomez> #info LuisGomez
16:07:23 <abhijitk> #chair CaseyLF LuisGomez abelur
16:07:23 <odl_meetbot> Current chairs: CaseyLF LuisGomez abelur abhijitk
16:07:48 <premsankar> #info premsankar
16:07:49 <CaseyLF> #info Allan Clarke discusses the Plastic Project review.
16:07:49 <abhijitk> Can someone link the Plastic proposal?
16:08:40 <CaseyLF> #link https://wiki.opendaylight.org/view/Project_Proposals:Plastic Plastic Project review page
16:08:42 <abhijitk> #link https://wiki.opendaylight.org/view/Project_Proposals:Plastic
16:08:47 <abhijitk> #undo
16:08:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2819d10>
16:09:19 <LuisGomez> #info plastic is a framework to translate data schemas, example of use is to convert standard model body like openconfig to proprietary model body and viceversa
16:09:54 <abhijitk> thanks LuisGomez
16:14:35 <LuisGomez> #info the framework is driven by template and config files so no need of java developer or to compile java code to update the translation
16:18:22 <skitt> #info skitt
16:22:58 <LuisGomez> #info this is new project (Self Managed) in OpenDaylight
16:26:09 <rovarga> #info rovarga
16:27:12 <jamoluhrsen> #info jamoluhrsen
16:27:53 <rovarga> #project odlparent yangtools mdsal controller aaa netconf bgpcep infrautils
16:30:20 <zxiiro> #info Thanh
16:30:57 <abhijitk> #startvote Does the OpenDaylight TSC approve the Plastic Project to be an "incubation" project subject to inbound code review? -1,0,+1
16:30:57 <odl_meetbot> Begin voting on: Does the OpenDaylight TSC approve the Plastic Project to be an "incubation" project subject to inbound code review? Valid vote options are -1, 0, +1.
16:30:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:31:01 <rovarga> #vote +1
16:31:04 <jamoluhrsen> #vote +1
16:31:04 <LuisGomez> #vote +1
16:31:08 <skitt> #vote +1
16:31:10 <zxiiro> #vote +1
16:31:10 <avishnoi> #vote +1
16:31:13 <premsankar> #vote +1
16:31:16 <abhijitk> #vote +1
16:31:34 <abelur> #vote +1
16:31:41 <abhijitk> #endvote
16:31:41 <odl_meetbot> Voted on "Does the OpenDaylight TSC approve the Plastic Project to be an "incubation" project subject to inbound code review?" Results are
16:31:41 <odl_meetbot> +1 (9): rovarga, skitt, zxiiro, LuisGomez, premsankar, jamoluhrsen, avishnoi, abhijitk, abelur
16:32:39 <abhijitk> #agreed OpenDaylight TSC approves the Plastic Project to be an incubation project by a vote of 9-0.
16:32:55 <abhijitk> Congrats Plastic project!
16:33:08 <abhijitk> #topic TSC Elections
16:33:29 <CaseyLF> #link https://wiki.lfnetworking.org/x/XwIiAQ TSC election mechanics.
16:33:47 <CaseyLF> #info I suggest we start the nomination period today.
16:35:45 <CaseyLF> #agree TSC agrees that the nomination period will start today
16:35:47 <abhijitk> #agreed TSC agrees that the nomination period starts today
16:36:18 <abhijitk> #topic Releases
16:36:42 <abhijitk> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard
16:45:19 <abhijitk> ##info Overall missing some release plans - but otherwise on track
16:45:26 <abhijitk> #info Overall missing some release plans - but otherwise on track
16:45:55 <rovarga> #link https://wiki.opendaylight.org/view/Project_list
16:45:56 <abhijitk> #info CoE is planning to move as a self managed project
16:46:24 <rovarga> netvirt/coe/ ->
16:46:40 <rovarga> ./features/odl-netvirt-api/pom.xml:            <artifactId>coe-api</artifactId>
16:47:05 <skitt> rovarga, yes, that means netvirt depends on coe
16:48:52 <abhijitk> #topic JSON-RPC as a managed project
16:50:54 <abhijitk> #info JSON-RPC proposes to be managed project for a few perceived benefits
16:51:35 <abhijitk> #info One perceived benefit is to remove the release overheads - but rovarga says this is automated
16:52:25 <abhijitk> #info LuisGomez feels managed is a good idea as the project has been stable
16:53:54 <abhijitk> #info No planned new features, only bug fixes
16:53:56 <rovarga> skitt: anything you'd like to see in odlparent-6.0.1? :)
16:54:22 <skitt> rovarga, nothing particularly realistic ;-)
16:54:31 <rovarga> :-)
16:55:01 <abhijitk> #startvote Does the TSC approve JSON-RPC to be a managed project for the Magnesium release? -1,0,+1
16:55:01 <odl_meetbot> Begin voting on: Does the TSC approve JSON-RPC to be a managed project for the Magnesium release? Valid vote options are -1, 0, +1.
16:55:01 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:55:02 <premsankar> #vote +1
16:55:05 <avishnoi> #vote +1
16:55:06 <abhijitk> #vote +1
16:55:07 <zxiiro> #vote +1
16:55:09 <rovarga> #vote +1
16:55:12 <abelur> #vote +1
16:55:13 <abhijitk> #vote +1
16:55:15 <skitt> #vote +1
16:55:36 <rovarga> jamoluhrsen: are you subscribed to netconf-dev? a message approval just appeared in my mailbox ...
16:55:53 <rovarga> A message was sent to the group https://lists.opendaylight.org/g/netconf-dev from jluhrsen@gmail.com that needs to be approved.
16:56:09 <abhijitk> #endvote
16:56:09 <odl_meetbot> Voted on "Does the TSC approve JSON-RPC to be a managed project for the Magnesium release?" Results are
16:56:09 <odl_meetbot> +1 (7): rovarga, skitt, avishnoi, premsankar, zxiiro, abhijitk, abelur
16:57:17 <abhijitk> #agreed JSON-RPC will be a managed project for the Magnesium release
16:58:49 <skitt> #endmeeting
16:58:56 <abhijitk> dang
16:59:05 <abhijitk> I was just adding a few notes :)
16:59:11 <skitt> sorry
16:59:15 <skitt> it didn’t work though ;-)
16:59:18 <skitt> so you can add notes
16:59:20 <abhijitk> no prroblem :)
16:59:30 <abhijitk> great :)
16:59:57 <rovarga> skitt: so I'll spin 6.0.1 once the notes are in and the same for 5.0.x and 4.0.x
17:00:01 <abhijitk> Just about the 2 self managed projects and the security team member
17:00:23 <rovarga> kinda missed the train for getting 5.0.whatever into Sodium SR1, but that's fine
17:00:49 <abhijitk> #info Emails about CoE and SFC to be a self managed projects need to be sent to the release mailing list
17:00:56 <rovarga> it's probably better this way, because the yangtools releases stacked on top of these will wreck bpcep at the very least
17:01:38 <skitt> rovarga, a lot of plates to keep spinning ;-)
17:02:09 <abhijitk> #action abhijitk to forward the email from Jaime to the release mailing list agreeing it makes sense for SFC to be a self managed project
17:02:51 <abhijitk> #action premsankar to send an email to the release mailing list asking for CoE to be made a self managed project
17:03:11 <abhijitk> #topic Security Mailing List New Member addition
17:03:42 <abhijitk> #info KKS from Lumina is volunteering to be added to the security mailing list
17:04:13 <abhijitk> #info The TSC will vote on his candidacy
17:05:10 <abhijitk> #action abhijitk to send KKS information to the TSC mailing list and initiate a vote for KKS to be added to the security team
17:05:35 <jamoluhrsen> #endmeeting