#opendaylight-netvirt: NetVirt Weekly 12/05/17

Meeting started by shague at 16:01:44 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:01:54)
  2. Review existing action items (shague, 16:01:55)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_11_28_17/opendaylight-netvirt-netvirt_weekly_11_28_17.2017-11-28-16.03.html (shague, 16:02:12)
    2. vpickard (vpickard, 16:04:27)

  3. [DONE] shague run gate also with https://git.opendaylight.org/gerrit/#/q/I65644f32551124c61e30c02831ac4193d12471d2 - [60259](https://git.opendaylight.org/gerrit/#/c/60259/) - new patches pushed so need another run (shague, 16:04:28)
    1. Vishal (vthapar, 16:04:32)
    2. ACTION: vthapar to review impl and spec again (shague, 16:06:32)
    3. jamoluhrsen (jamoluhrsen, 16:06:57)
    4. ACTION: shague run gate again once patches build (shague, 16:07:28)
    5. gate was requested to verify the spec (shague, 16:07:53)

  4. genius auto-tz changes - Vic's testing looks good, need to update installers like devstack and OOO (shague, 16:08:28)
    1. vpickard testign looks good (shague, 16:08:47)
    2. need changes for the installers (shague, 16:08:57)
    3. questions about tep ip (shague, 16:09:42)
    4. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-December/005922.html (shague, 16:09:45)
    5. vpickard likely reuse local_ip (shague, 16:10:01)
    6. ACTION: vpickard look at OOO variables, can local_ip be used? differentiate between data, mgmt or control ip (shague, 16:14:48)
    7. https://github.com/openstack/puppet-neutron/blob/master/manifests/plugins/ovs/opendaylight.pp#L7 (shague, 16:15:21)
    8. vthapar, vpickard looks like local_ip can be used (shague, 16:19:56)
    9. daya mentions there are similar variables in the hostconfig (shague, 16:20:45)
    10. ACTION: vpickard to work on genius patch to use lcoal_ip (shague, 16:24:07)

  5. CSIT VM DHCP IP Failure [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-December/005893.html) - [csit job](https://logs.opendaylight.org/releng/jenkins092/netvirt-csit-1node-openstack-ocata-upstream-stateful-carbon/214/log_02_l3.html.gz#s1-t11-k9) (shague, 16:24:24)
    1. Aswhin : table 51 has same src mac (shague, 16:28:30)
    2. Ashwin : table 51 has same src mac (shague, 16:28:40)
    3. Ashwin : table 51 has same src mac on both computes (shague, 16:29:58)
    4. ashwin looking further (shague, 16:30:10)
    5. Ashwin : correction, table 50 rather than table 51 (shague, 16:31:26)

  6. [weather for neutron changes to uuid and tenant id](https://wiki.opendaylight.org/view/Weather#Neutron_Northbound:_Yang_Model_changes.28UUID.2FTenantID_consolidation.29) - [53438](https://git.opendaylight.org/gerrit/53438) - is there an impact to netvirt or genius? (shague, 16:33:46)
    1. vthapar tenant-id is not being used by netvirt so likely no changes in netvirt (shague, 16:36:24)
    2. ACTION: vthapar to take a closer look if there are impacts (shague, 16:37:05)

  7. neutron change to move port status to operational - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-February/003141.html) - [51981](https://git.opendaylight.org/gerrit/#/c/51981/) (shague, 16:37:18)
    1. daya asks if the prot status being in operational will be lost on reboots. Yes it will (shague, 16:38:11)
    2. josh will look at impacts (shague, 16:38:47)

  8. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 16:39:22)
    1. sunil posted another patch (shague, 16:40:20)
    2. sunil groupids stored in local cache before stats collected (shague, 16:41:04)
    3. sunil discrepancy in how cache is handle during delete (shague, 16:41:32)
    4. original patch cherry-picked to nitrogen and master (shague, 16:42:05)

  9. https://jira.opendaylight.org/browse/OPNFLWPLUG-917 deserialization (shague, 16:43:11)
    1. patches under review (shague, 16:43:22)

  10. https://jira.opendaylight.org/browse/NETVIRT-993 (shague, 16:43:57)
    1. hanamant to update last debugging patch (shague, 16:44:38)
    2. vorburger mentions the retyr patchs in genius might have helped with other exceptions (shague, 16:45:32)

  11. genius retry patches (shague, 16:46:54)
    1. vorburger to work with philippe on adding to ipv6 code (shague, 16:47:10)

  12. vinh spec https://git.opendaylight.org/gerrit/#/c/65948/ (shague, 16:51:38)
    1. need to review spec (shague, 16:51:43)
    2. ACTION: daya, vthapar, shague, vivek to review spec (shague, 16:52:08)

  13. specs (shague, 16:52:59)
    1. need specs in and review by m3 date, 12/21/17 (shague, 16:53:16)

  14. test spec (shague, 16:53:24)
    1. vthapar pushed new template, needs review (shague, 16:53:35)
    2. https://git.opendaylight.org/gerrit/#/c/65081/ (shague, 16:53:57)
    3. ACTION: shague, jamoluhrsen to review spec (shague, 16:54:08)
    4. vthapar removed robot code sections, better to not have duplicated in spec and actual test code (shague, 16:54:49)

  15. https://git.opendaylight.org/gerrit/#/c/65880/ elan circular dependencies (shague, 16:56:58)
    1. link to bug for vm dhcp ip failure: https://jira.opendaylight.org/browse/NETVIRT-889 (shague, 16:59:49)
    2. tom and vorburger reviewing patch in detail (shague, 17:00:27)
    3. vthapar action to look at neutron weather item for aggregating tenantid and uuid. change should not have an impact in netvirt (shague, 17:12:20)


Meeting ended at 17:12:24 UTC (full logs).

Action items

  1. vthapar to review impl and spec again
  2. shague run gate again once patches build
  3. vpickard look at OOO variables, can local_ip be used? differentiate between data, mgmt or control ip
  4. vpickard to work on genius patch to use lcoal_ip
  5. vthapar to take a closer look if there are impacts
  6. daya, vthapar, shague, vivek to review spec
  7. shague, jamoluhrsen to review spec


Action items, by person

  1. jamoluhrsen
    1. shague, jamoluhrsen to review spec
  2. shague
    1. shague run gate again once patches build
    2. daya, vthapar, shague, vivek to review spec
    3. shague, jamoluhrsen to review spec
  3. vpickard
    1. vpickard look at OOO variables, can local_ip be used? differentiate between data, mgmt or control ip
    2. vpickard to work on genius patch to use lcoal_ip
  4. vthapar
    1. vthapar to review impl and spec again
    2. vthapar to take a closer look if there are impacts
    3. daya, vthapar, shague, vivek to review spec


People present (lines said)

  1. shague (58)
  2. odl_meetbot (3)
  3. vpickard (2)
  4. vthapar (1)
  5. jamoluhrsen (1)


Generated by MeetBot 0.1.4.