15:02:43 <shague> #startmeeting NetVirt Weekly 06/12/18
15:02:43 <odl_meetbot> Meeting started Tue Jun 12 15:02:43 2018 UTC. The chair is shague. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:43 <odl_meetbot> The meeting name has been set to 'netvirt_weekly_06_12_18'
15:02:54 <shague> #topic Roll call and agenda bashing (please #info <your-nick>)
15:02:56 <vpickard> #info vpickard
15:03:13 <shague> #link https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_05_18/opendaylight-netvirt-netvirt_weekly_06_05_18.2018-06-05-15.03.html
15:04:30 <shague> #topic [WIP] jamoluhrsen will look to add the code permanently for SnD in CSIT - [71598](https://git.opendaylight.org/gerrit/#/c/71598/)
15:04:59 <vthapar_> #info Vishal
15:05:00 <shague> #info still issues with the SnD so can't enable
15:05:26 <shague> #action: jamoluhrsento work on patch
15:05:39 <shague> #topic https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400)
15:07:08 <shague> #topic specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#)
15:07:56 <shague> #topic Error and exception handling: [72813](https://git.opendaylight.org/gerrit/#/c/72813/), [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-June/007027.html)
15:08:28 <shague> #info need to revisit exception handling
15:09:15 <shague> #info utils wrap read exceptions and swallow exceptions making it difficult to know what is happening
15:14:47 <shague> #info thsi handling will also help with the improved transaction handling ideas to ensure transactions are opened and closed properly
15:17:36 <shague> #info skitt: we can starts with listeners and rpc to follow trail and fix along the way
15:18:22 <shague> #action skitt: create a jira and subtasks for tracking the fixes
15:19:20 <skitt> #info suneelu mentions that we need to consider recovery aspects too
15:21:12 <skitt> #info we should perhaps add retries for every job
15:21:53 <skitt> #info need to think about how this all fits in with the job coordinator
15:23:02 <shague> #topic 3node and sharding - [CONTROLLER-1836](https://jira.opendaylight.org/browse/CONTROLLER-1836) - looking at switching to single shard
15:24:43 <shague> #info daya mentions need 3 shards at minimum: operational, config, eos
15:24:56 <shague> #info skitt also mentions a fourth shard
15:26:36 <shague> #info default adds: inventory and operational
15:26:48 <shague> #info skitt: rh ds uses default
15:27:12 <skitt> #info default controller setup is default/topology/inventory, all with config/operational
15:27:23 <skitt> #info default puppet-opendaylight is default only, with config/operational
15:28:33 <shague> #topic bundles based resync
15:28:52 <shague> #info daya_k troubleshooting found that nat had stale flows when enabled
15:29:37 <shague> #info arun and gobinath will update the ofp code to handle missing resources
15:29:58 <shague> #info chetan is looking at netvirt side fixes
15:31:23 <shague> #topic CSIT for new features
15:35:21 <shague> #topic csit test suite upstreaming
15:38:49 <shague> #action shague send copy-logs instructions
15:42:14 <shague> #endmeeting