17:01:43 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting March 7 2016
17:01:44 <odl_meetbot> Meeting started Mon Mar  7 17:01:43 2016 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:44 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_march_7_2016'
17:02:12 <abhijitkumbhare> #topic Agenda
17:03:00 <abhijitkumbhare> #info Lithium Design Migration & blocking issues for the migration
17:03:20 <abhijitkumbhare> #info DDF
17:03:40 <abhijitkumbhare> #info Boron planning
17:03:59 <abhijitkumbhare> #info Top issues
17:04:46 <abhijitkumbhare> #info Committer Promotion
17:07:00 <abhijitkumbhare> #chair LuisGomez jbacigal vishnoianil kamalr
17:07:00 <odl_meetbot> Current chairs: LuisGomez abhijitkumbhare jbacigal kamalr vishnoianil
17:07:36 <abhijitkumbhare> #topic Top issues
17:07:57 <abhijitkumbhare> #info Group Delete
17:09:09 <abhijitkumbhare> #info Group Delete behavior has changed in OpenFlow 1.3.5
17:09:36 <abhijitkumbhare> #info ODL behavior is as per 1.3.1
17:10:09 <abhijitkumbhare> #info OVS spec may be following 1.3.5
17:11:44 <abhijitkumbhare> #info vishnoianil thinks OVS should be backward compatible to 1.3.1 even if OVS is following 1.3.5
17:12:34 <abhijitkumbhare> #info More investigation needed
17:13:52 <abhijitkumbhare> #info Muthu / Shuva  will try with the ID based delete and check if that works across the different versions of OVS
17:14:28 <LuisGomez> #info Luis will try a candidate patch with HW switches in Brocade
17:15:32 <abhijitkumbhare> #topic Blockers for Lithium migration
17:16:58 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5328 OpenFlow 1.0
17:17:16 <abhijitkumbhare> #info The OpenFlow 1.0 issue has been fixed
17:18:19 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5388 Cluster issue: Flow push does not work after owner instance is killed
17:18:34 <abhijitkumbhare> #info This has been fixed
17:19:05 <abhijitkumbhare> #action jbacigal to add gerritt ID in the bug
17:19:23 <abhijitkumbhare> #undo
17:19:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2bfec50>
17:19:50 <abhijitkumbhare> #action jbacigal to add gerritt ID in the bug - OR mark it as duplicate of 5075
17:20:28 <abhijitkumbhare> #info https://bugs.opendaylight.org/show_bug.cgi?id=5271 Stability issue: Longevity test
17:20:42 <abhijitkumbhare> #info This fix is needed but not a blocker
17:21:42 <abhijitkumbhare> #info This issue is intermittent
17:22:16 <abhijitkumbhare> #action LuisGomez to observe 5271 and update
17:23:26 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=4925 Clustering: OpenFlow connections unstable
17:24:23 <abhijitkumbhare> #action Muthu To have 4925 tested with the latest stable/beryllium & master builds and report back
17:25:10 <abhijitkumbhare> #topic Lithium Design Migration
17:28:47 <abhijitkumbhare> #info The migration to happen for Boron (but we need to get the projects migrated as soon as possible on the master); Beryllium Service Releases will keep the default as the Helium design
17:30:24 <abhijitkumbhare> #info Flip the default to Lithium design - strategy?
17:43:41 <hideyuki> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan
17:50:07 <abhijitkumbhare> #agreed OFP will create an unmerged patch to flip the default
17:51:00 <abhijitkumbhare> #agreed The dependent projects should use this patch to fix issues by M1 offset 2 (March 24)
17:51:38 <abhijitkumbhare> #agreed If no outstanding issues - the patch will be merged to make the Li design as the default
17:52:06 <abhijitkumbhare> #agreed OFP will issue a weather report for this by March 9
17:54:49 <abhijitkumbhare> #topic Committer Promotion
17:57:18 <abhijitkumbhare> #info Abhijit will first discuss with the committers & interested folks (Jozef) over email the process before starting a vote on the mailing lists
17:58:24 <abhijitkumbhare> #topic Bugs raised by projects during Lithium migration
17:58:46 <abhijitkumbhare> #agreed Should be marked blockers and fixed with a priority
17:59:24 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=5432
18:00:18 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=4671
18:00:31 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=5432 Li: Enable "get-flow-statistics-from-flow-table" RPC by default
18:02:57 <abhijitkumbhare> #info Anna will work with Michal and jbacigal
18:03:57 <abhijitkumbhare> #topic Boron Planning
18:10:22 <abhijitkumbhare> #action jbacigal vishnoianil kamalr Muthu everyone - please come up with your contribution ideas for Boron for next meeting
18:11:13 <abhijitkumbhare> #info The Boron planning may need 2-3 meetings
18:11:22 <abhijitkumbhare> #undo
18:11:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2aa0c50>
18:11:34 <abhijitkumbhare> #info The Boron planning may need 2-3 meetings more
18:11:40 <abhijitkumbhare> #endmeeting