15:03:36 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting April 27, 2017
15:03:36 <odl_meetbot> Meeting started Thu Apr 27 15:03:36 2017 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:36 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_april_27__2017'
15:04:14 <abhijitkumbhare> #topic Agenda
15:06:08 <abhijitkumbhare> #info Karaf 3, Karaf 4 and OpenFlow Plugin status
15:07:02 <abhijitkumbhare> #info Issues
15:08:11 <abhijitkumbhare> #topic Issues: Bug 6459
15:11:02 <abhijitkumbhare> #info jbacigal wanting to know how to delete the node once the Karaf instance killed
15:16:45 <abhijitkumbhare> #info vishnoianil provided suggestion on how to handle this
15:18:09 <abhijitkumbhare> #topic Performance and stability
15:25:21 <abhijitkumbhare> #undo
15:25:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x18ff510>
15:25:38 <abhijitkumbhare> #topic Plug & play frameworks / features
15:28:03 <abhijitkumbhare> #info Sometimes different use cases need different optimizations - whether for performance or for stability or some other metric
15:28:30 <abhijitkumbhare> #info Suggestion is to have different possible plug & play components for select features
15:29:03 <abhijitkumbhare> #info Needs more discussion for Nitrogen, etc.
15:37:00 <abhijitkumbhare> #topic Bugs
15:37:06 <abhijitkumbhare> #undo
15:37:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x194c310>
15:37:41 <abhijitkumbhare> #topic Karaf3, Karaf4 & OpenFlow Plugin
15:38:22 <abhijitkumbhare> #info Some issues but not in OFP
15:38:33 <abhijitkumbhare> #info Issues in RESTCONF
15:40:17 <abhijitkumbhare> #info Not sure we have Karaf 4 issues - as there are issues in other projects - we cannot even run OFP in Karaf 4
15:41:24 <abhijitkumbhare> #info Not able to run Plugin in Karaf4 - feature install being restarted from RESTCONF or MDSAL
15:43:42 <abhijitkumbhare> #topic Bugs
15:44:37 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=6755
15:45:23 <abhijitkumbhare> #info Bug 6755: Perf test 100K flow installation does not not work in Cluster
15:46:10 <abhijitkumbhare> #info Possible performance regression - Jozef will take a look at it next week
15:46:49 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=6908 Bug 6908 - failed to update port status - all new OVS ports fail from this point
15:46:56 <abhijitkumbhare> #info Bug 6908 - failed to update port status - all new OVS ports fail from this point
15:47:45 <abhijitkumbhare> #info tomasslusny has a patch for this - vishnoianil reviewing this
15:48:25 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=7184
15:48:29 <abhijitkumbhare> #info Bug 7184 - [Boron] Switch connection sometimes bounces on non-owner node when OWNER is shut down
15:49:18 <abhijitkumbhare> #info Luis thinks this is better with Carbon - maybe related split connection handler
15:49:31 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=7763
15:49:48 <abhijitkumbhare> #info Bug 7763 - Openflow plugin deletes switch from topology while changing mastership from one controller to another
15:51:42 <abhijitkumbhare> #action jbacigal to update the bug status for bug 7763  https://bugs.opendaylight.org/show_bug.cgi?id=7763
15:51:55 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=7948
15:52:09 <abhijitkumbhare> #info Bug 7948 - br-sfc become slave and disconnect from ODL
15:54:19 <abhijitkumbhare> #info Bug 7948 is somewhere in MD-SAL
15:54:34 <abhijitkumbhare> #action jbacigal to check with the MD-SAL folks
15:55:35 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=7957
15:55:48 <abhijitkumbhare> #info Bug 7957 - OF channel fail/recover does not work when FRM config is modified
15:56:02 <abhijitkumbhare> #info Apparently fixed with split connection
15:57:01 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=8057
15:57:17 <abhijitkumbhare> #info Bug 8057 - Missing rules after OVS restart - even though they exist in config/inventory-nodes
15:59:21 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=8103
15:59:33 <abhijitkumbhare> #info Bug 8103 - Switch scalability regression due to missing table miss flows
16:03:21 <abhijitkumbhare> #info Assigned to Arun for now - but cc’ed to vishnoianil . If Arun is stuck - we can have vishnoianil take a look
16:04:54 <abhijitkumbhare> #link https://bugs.opendaylight.org/show_bug.cgi?id=8245
16:05:06 <abhijitkumbhare> #info Bug 8245 - No OF rules after ODL sync
16:05:29 <abhijitkumbhare> #info Most likely: working as designed
16:06:12 <abhijitkumbhare> #endmeeting