15:37:06 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting Aug 7, 2017
15:37:06 <odl_meetbot> Meeting started Mon Aug  7 15:37:06 2017 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:37:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:37:06 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_aug_7__2017'
15:38:03 <abhijitkumbhare> #topic LLDP code moving from Controller to OFP
15:40:13 <abhijitkumbhare> #info Hema thinks the lib LLDP can be moved into the “common” directory
15:53:05 <abhijitkumbhare> #agreed Since the code freeze is done, we can do the LLDP movement in Oxygen. While moving also cleanup the directory structure for the libraries including OpenFlow Java.
15:53:46 <abhijitkumbhare> #topic Reconciliation framework and bundles based resync
15:55:50 <abhijitkumbhare> #undo
15:55:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2d78650>
15:55:54 <abhijitkumbhare> #undo
15:55:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2f201d0>
15:56:34 <abhijitkumbhare> #agreed Since we are at M5 (code freeze), we can do the LLDP movement in Oxygen. While moving also cleanup the directory structure for the libraries including OpenFlow Java.
15:56:47 <abhijitkumbhare> #topic Reconciliation framework and bundles based resync
15:57:13 <abhijitkumbhare> #info Anil has reviewed the patches - and will be merging them today or tomorrow
16:02:50 <abhijitkumbhare> #topic Bugs
16:03:26 <abhijitkumbhare> #info Bug 8913 - Redesign of statistics manager and statistics context
16:04:15 <abhijitkumbhare> #info Bug 8913 fix: To simplify statistics context and statistics manager code, have better control over statistics polling and to remove referencing of statistics manager from statistics context, remove current method of statistics scheduling and replace it with Guava scheduled service that will handle starting, periodic gathering and stopping of statistics
16:14:08 <abhijitkumbhare> #info Add RoleManager and RoleContext - Move device role management logic from DeviceContext and ContextChain to separate context and manager. - InReview
16:14:27 <abhijitkumbhare> #info Guard lifecycle of contexts - Add wrapper for OpenFlowPlugin contexts that will curate lifecycle of each context. - InReview
16:15:01 <abhijitkumbhare> #info All the above were part of bug 8913
16:16:46 <abhijitkumbhare> #info Feedback: the “Add RoleManager and RoleContext” is a good change; “Guard lifecycle of contexts” is a higher risk change and needs to be tested well
16:17:27 <abhijitkumbhare> #info Bug 8607 - Update unit tests - For now, coverage of openflowplugin-impl increased from ~70% to 85% - In Progress
16:18:22 <abhijitkumbhare> #info Bug8924 - Remove deprecated EOS - In Progress
16:20:10 <abhijitkumbhare> #info Feedback - this is actually removing deprecated EOS from controller project and replacing with EOS from MD-SAL project
16:29:02 <abhijitkumbhare> #endmeeting