16:06:47 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting Jan 12, 2017
16:06:47 <odl_meetbot> Meeting started Thu Jan 12 16:06:47 2017 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:06:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:47 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_jan_12__2017'
16:07:02 <abhijitkumbhare> #topic Agenda
16:07:42 <abhijitkumbhare> #info M3 status
16:08:16 <abhijitkumbhare> #info Documentation & wiki
16:12:52 <abhijitkumbhare> #info Config knobs
16:13:21 <abhijitkumbhare> #info Direct RPC stats
16:13:52 <abhijitkumbhare> #info Code Reviews & bugs
16:14:11 <abhijitkumbhare> #topic M3 status
16:28:47 <abhijitkumbhare> #info Discussion about what functionality freeze means - the definition available on the ODL Carbon release plan
16:29:53 <abhijitkumbhare> #info “Split connection layer from core” status - mostly done & being tested. Couple of patches may be needed. Code review needs to be done for this by vishnoianil & shuva.
16:30:39 <abhijitkumbhare> #action jbacigal1 needs to add vishnoianil & shuva to the code reviewer list for his patches for “Split connection layer from core"
16:31:40 <abhijitkumbhare> #info “Southbound Manager” status - shuva will send an email about the functionality of this and request for code review
16:32:16 <abhijitkumbhare> #action shuva to send an email about the functionality of this and request for code review about “Southbound Manager"
16:33:01 <abhijitkumbhare> #info Usability improvements - will be discussed under the config knobs
16:33:20 <abhijitkumbhare> #topic Config knobs
16:34:10 <abhijitkumbhare> #info Currently config options in yang files as well as in the cfg file - which do not map one to one
16:35:45 <abhijitkumbhare> #info Also this hybrid approach can cause some race conditions
16:41:34 <shuva> https://git.opendaylight.org/gerrit/#/c/44386/
16:41:57 <shuva> i think the
16:41:57 <shuva> Configurable update-strategy is already in..
16:50:57 <abhijitkumbhare> #action shuva to initiate a discussion on the relative merits of the config knob approaches as well as how to resolve this. This needs to be resolved before M4.
16:51:27 <abhijitkumbhare> #topic Documentation & wiki
16:52:39 <abhijitkumbhare> #info shuva suggests removing the wiki references/info to be changed to the Lithium design and keep the archived documentation accessible
16:53:49 <abhijitkumbhare> #topic Direct RPC stats
16:54:52 <abhijitkumbhare> #info Tomas says needs some augmentations
16:57:14 <hideyuki> #link https://git.opendaylight.org/gerrit/#/c/40817/
16:57:27 <abhijitkumbhare> #undo
16:57:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x281a710>
16:57:40 <abhijitkumbhare> #topic Other topics
16:57:55 <abhijitkumbhare> #info Review the patch 40817
16:58:05 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/40817/
17:02:29 <abhijitkumbhare> #endmeeting