15:03:09 <abhijitkumbhare> #startmeeting OpenFlow Plugin Meeting March 30, 2017
15:03:09 <odl_meetbot> Meeting started Thu Mar 30 15:03:09 2017 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:09 <odl_meetbot> The meeting name has been set to 'openflow_plugin_meeting_march_30__2017'
15:03:33 <abhijitkumbhare> #chair jbacigal shuva
15:03:33 <odl_meetbot> Current chairs: abhijitkumbhare jbacigal shuva
15:03:46 <abhijitkumbhare> #chair Hema__
15:03:46 <odl_meetbot> Current chairs: Hema__ abhijitkumbhare jbacigal shuva
15:03:59 <shuva> thanks
15:04:00 <abhijitkumbhare> #topic Agenda
15:04:47 <abhijitkumbhare> #info High Priority Issues
15:05:26 <abhijitkumbhare> #info Status of feature merges
15:06:04 <abhijitkumbhare> #topic High Priority Issues
15:07:15 <abhijitkumbhare> #undo
15:07:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a2a450>
15:07:41 <abhijitkumbhare> #topic Status of feature merges
15:08:35 <abhijitkumbhare> #info Unmerged features are:Split Connect Handler,
15:08:39 <abhijitkumbhare> #undo
15:08:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18336d0>
15:08:50 <abhijitkumbhare> #info Unmerged features are:
15:09:11 <abhijitkumbhare> #info * Split Connection Handler
15:09:15 <shuva> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:openflowplugin+branch:master+topic:%22Split+connection+layer+...%22
15:09:25 <abhijitkumbhare> #info * Bundles
15:09:45 <abhijitkumbhare> #info * Mastership service
15:10:30 <abhijitkumbhare> #info Aligning the config knobs yang & config file
15:11:13 <shuva> #link https://git.opendaylight.org/gerrit/#/c/53862/
15:11:56 <tomasslusny> https://bugs.opendaylight.org/show_bug.cgi?id=7218
15:13:04 <shuva> #link https://git.opendaylight.org/gerrit/#/c/53630/
15:16:18 <abhijitkumbhare> #action shuva to review & merge bug 7218 changes from Hema & Tomas after the build succeeds
15:17:31 <abhijitkumbhare> #info shuva reviewing the split connection layer patches
15:20:30 <abhijitkumbhare> #info Higher priority to get the split connection handler patches merged
15:21:21 <abhijitkumbhare> #info Mastership service merge should be lower priority - and of course make sure all the clustering is stable - otherwise move it to Nitrogen
15:26:33 <abhijitkumbhare> #info We will merge bundles after the branch cutoff
15:27:04 <abhijitkumbhare> #topic High Priority issues
15:27:15 <abhijitkumbhare> #undo
15:27:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1913190>
15:27:43 <abhijitkumbhare> #topic High Priority issues: needed by NetVirt
15:28:45 <abhijitkumbhare> #info Issue 1:   https://bugs.opendaylight.org/show_bug.cgi?id=8025 - group+flow installation dependency missing API, similar for flow+packet_out - this forces us to add sleeps which are problematic and will not scale well
15:28:58 <abhijitkumbhare> #undo
15:28:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x16b2290>
15:29:22 <abhijitkumbhare> #info Issue 1:  https://bugs.opendaylight.org/show_bug.cgi?id=8025
15:29:35 <abhijitkumbhare> #info  - group+flow installation dependency missing API, similar for flow+packet_out - this forces us to add sleeps which are problematic and will not scale well
15:31:22 <abhijitkumbhare> #info shuva lists a few options for this:
15:31:45 <abhijitkumbhare> #info FRS could be used - but FRS may not be stable
15:31:52 <abhijitkumbhare> #undo
15:31:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1919bd0>
15:32:08 <abhijitkumbhare> #info FRS could be used - but FRS not well tested
15:32:47 <abhijitkumbhare> #info Southbound Manager by shuva
15:33:31 <abhijitkumbhare> #action shuva will respond on the bug on the different options including working around
15:33:45 <abhijitkumbhare> #undo
15:33:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ab8590>
15:34:05 <abhijitkumbhare> #action shuva will respond on the bug 8025 on the different options including working around
15:35:44 <abhijitkumbhare> #action Hema__ will also discuss with the NetVirt folks about 8025
15:36:25 <abhijitkumbhare> #info Issue 2: https://bugs.opendaylight.org/show_bug.cgi?id=8057
15:36:30 <abhijitkumbhare> #info - some flows missing after OVS restart - critical for OVS failure recovery
15:38:22 <abhijitkumbhare> #action jbacigal looking at bug 8057 with the split connection layer handling
15:38:50 <abhijitkumbhare> #info Issue 3:     https://bugs.opendaylight.org/show_bug.cgi?id=8087 (dup https://bugs.opendaylight.org/show_bug.cgi?id=7948 ?)
15:39:08 <abhijitkumbhare> #info  - The bug seen in CSIT (total failure, OVS does not connect to ODL)
15:40:23 <abhijitkumbhare> #info jbacigal thinks bug 8087 will be solved by the split connection handler - and does not see it with the split connection handler
15:41:00 <abhijitkumbhare> #action jbacigal to follow up on bug 8087
15:41:38 <abhijitkumbhare> #info Issue 4:     https://bugs.opendaylight.org/show_bug.cgi?id=6908 - finally under review so not sure it's worth bringing up https://git.opendaylight.org/gerrit/#/c/53905/
15:43:07 <abhijitkumbhare> #info Waiting for a response from NetVirt whether the patch by tomasslusny is working or not
15:44:16 <abhijitkumbhare> #info Fix for 6908 (https://git.opendaylight.org/gerrit/#/c/53905/) will be merged after NetVirt has tested it
15:45:27 <abhijitkumbhare> #topic Critical issues
15:47:21 <abhijitkumbhare> #info jbacigal says some critical bugs fixes by Robert Varga merged:
15:47:25 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/52965/
15:47:37 <abhijitkumbhare> #undo
15:47:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1ab7110>
15:47:52 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/52965/ Bug 7901
15:48:55 <abhijitkumbhare> #undo
15:48:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1ab7110>
15:49:18 <abhijitkumbhare> #link https://git.opendaylight.org/gerrit/#/c/52965/ Bug 7901 & 8060 fixed by this patch
15:50:14 <abhijitkumbhare> #topic CSIT failures
15:50:33 <abhijitkumbhare> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-March/006973.html Email by LuisGomez about CSIT failures
15:52:04 <abhijitkumbhare> #info Boron only issue: Reconciliation with 10 switches and 1K flows/groups is not stable (new)
15:52:44 <abhijitkumbhare> #info Bug: https://bugs.opendaylight.org/show_bug.cgi?id=8102 - needs to be reworked
15:54:34 <abhijitkumbhare> #info Table Miss Flow feature - seems to have some issue
15:55:46 <abhijitkumbhare> #info https://bugs.opendaylight.org/show_bug.cgi?id=7770 & https://bugs.opendaylight.org/show_bug.cgi?id=8103
15:57:51 <tomasslusny> #link https://git.opendaylight.org/gerrit/#/c/53557/3 Table Miss gerrit patch
15:58:39 <abhijitkumbhare> #action LuisGomez will test https://git.opendaylight.org/gerrit/#/c/53557
16:04:45 <abhijitkumbhare> #endmeeting