19:08:14 <Madhu> #startmeeting OVSDB weekly call
19:08:14 <odl_meetbot> Meeting started Tue Jun 10 19:08:14 2014 UTC.  The chair is Madhu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:08:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:08:14 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
19:08:26 <Madhu> #chair tbachman dave_tucker networkstatic
19:08:26 <odl_meetbot> Current chairs: Madhu dave_tucker networkstatic tbachman
19:08:40 <dave_tucker> #info 🐱
19:08:43 <Madhu> #topic emoji exploration ;)
19:08:55 <tbachman> >:)
19:09:07 <dave_tucker> #info bro hugging = 👬
19:09:24 <Madhu> #info : PartyPoopers : 🎉💩
19:09:41 <dave_tucker> #info devstack = 💩
19:12:21 <tbachman> #info floating IP work is done
19:12:44 <dave_tucker> #topic Trello Updates
19:13:00 <dave_tucker> #info Floating IP's are tested to work - thanks tbachman
19:13:19 <tbachman> #info Ashwin posted code gerrit for schema change — not complete, but getting closer
19:13:48 <tbachman> #info PAX-exam patch submitted, but not merged yet.
19:13:54 <tbachman> #action networkstatic to merge
19:14:29 <dave_tucker> #link https://git.opendaylight.org/gerrit/#/c/7773/
19:17:51 <Madhu> #info ofplugin switch proposal : https://git.opendaylight.org/gerrit/#/c/7841/
19:20:40 <tbachman> #info gerrit was proposed to remove OF1.0 plugin. If this is the case, there will need to be changes for OVSDB to adapt.
19:20:47 <dave_tucker> #info networkstatic to talk about NXM extensions
19:21:24 <tbachman> #info OVS allows NXMs and OXMs to be used interchangably.
19:22:38 <dave_tucker> did we need an action for somebody to look at splitting flow programming logic from the OF10 and OF13 providers?
19:26:05 <dave_tucker> #info networkstatic ragequits 😡
19:26:09 <tbachman> #info stable/hydrogen is done
19:27:15 <dave_tucker> #info LBaaS support. shague_ is looking at how the existing LB works in OpenStack
19:27:50 <dave_tucker> #info current implementation uses HAProxy (software LB)
19:28:42 <dave_tucker> #info we can use OVS to load-balance instead of HAProxy
19:29:27 <dave_tucker> #info chris is looking at how to create a load-balancer using flows in ovs
19:31:59 <dave_tucker> #info we are trying to create a distributed load-balancer
19:34:42 <odp-gerritbot> A change was merged to ovsdb: Adding Pax-Exam infra with a basic IT for plugin  https://git.opendaylight.org/gerrit/7773
19:36:14 <tbachman> #info dave_tucker asks whether we can leverage more sophisticated metrics other than just heartbeat for load balancing
19:36:42 <dave_tucker> #info flaviof has been working on L3 supprot
19:36:59 <dave_tucker> s/supprot/support/
19:38:37 <dave_tucker> #topic Release Plan
19:39:08 <tbachman> #info Ryan O’Hara joined the call — HAProxy guru
19:39:42 <dave_tucker> #info M2 milestone is today
19:40:10 <Madhu> #info Release plan : https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Helium_Release_Plan
19:40:27 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Helium_Release_Plan Release plan
19:41:18 <tbachman> #topic Release Plan
19:41:41 <tbachman> #topic HAProxy/Load Balancer
19:42:38 <tbachman> #info goal is to implement as natively as possible using OVSDB and OpenFlow
19:43:39 <tbachman> #info goal is to remove the middlebox from the network.
19:44:09 <tbachman> #info HAProxy is a reverse proxy
19:45:32 <tbachman> #info In IPVS, you have to set up the NAT-ing rules yourself
19:45:42 <tbachman> #info HAProxy does the NAT-ing for you, in user-space
19:46:20 <tbachman> #info HAProxy maintains its own table of connections.
19:46:41 <tbachman> #info The back end (i.e. links being load balanced across) will see all traffic coming from HAProxy’s IP address
19:47:31 <tbachman> #info HAProxy is stateful in the sense that traffic proxied thru HAProxy has state about those TCP connections and how they’re mapped through the proxy
19:48:01 <tbachman> #info Madhu asks what if we have to remove HAProxy completely, and have OVS do the load balancing.
19:55:52 <tbachman> #info cdub notes that advanced health metrics probably won’t be doable in OVS
20:01:50 <tbachman> #endmeeting