19:00:08 <tbachman> #startmeeting ovsdb_weekly_call
19:00:08 <odl_meetbot> Meeting started Tue Oct 28 19:00:08 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:08 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
19:00:14 <tbachman> #chair shague
19:00:14 <odl_meetbot> Current chairs: shague tbachman
19:00:32 <tbachman> #topic Agenda
19:01:06 <dfarrell07> tbachman: yes, sorry, one sec
19:02:32 <tbachman> #info Trello: update on Trello cards; add new cards; Other: discuss some of the test coverage for OVSDB that we need to add for Lithium; Sonar tool coverage; code walk thru
19:02:57 * dfarrell07 just joined
19:03:09 <tbachman> dfarrell07: welcome! :)
19:04:25 <shague> https://trello.com/b/ddIvDQE0/ovs-openstack
19:05:14 <flaviof> #link https://trello.com/b/ddIvDQE0/ovs-openstack
19:05:50 <tbachman> flaviof: shague thx!
19:06:00 <tbachman> #link https://wiki.opendaylight.org/view/Simultaneous_Release:DRAFT_Lithium_Release_Plan_ckd Lithium Release Plan
19:06:18 <tbachman> #link https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB Trello Board
19:11:02 <tbachman> #topic Trello Board
19:11:44 <tbachman> #info karaf distribution is working now on stable/helium and master
19:14:10 <tbachman> #info Issue had to do with bundle dependency/ordering
19:14:57 <tbachman> #info flaviof has been working on the L3 forwarding, and is down to one bug (floating IPs)
19:15:15 <tbachman> #info flaviof is working with shague on why the sonar reporting isn’t working
19:16:55 * dfarrell07 is working on Integration team stuff, no OVSDB updates
19:18:20 <tbachman> #info dfarrell07 is working on Integration Team stuff — no OVSDB updates for this meeting
19:18:31 <tbachman> dfarrell07: thx! :)
19:18:55 <dfarrell07> tbachman: of course, np and thx right back @ you ;)
19:19:03 <tbachman> lol
19:19:21 <tbachman> #topic sonar reporting
19:19:44 <tbachman> #info Every time you submit or merge code, jenkins jobs are run.
19:20:03 <flaviof> #link http://sonar.opendaylight.org/
19:20:10 <tbachman> #info Jenkins jobs do various things, but one of the functions is to collect test status and report it to sonar
19:20:12 <tbachman> flaviof: thx! :)
19:23:47 <tbachman> #info the current sonar reporting has been broken since Sept. 4th — flaviof and shague are working to fix this
19:30:49 <tbachman> #action shague to figure out how to get sonar reporting information on local builds
19:31:58 <tbachman> #info shague recommends creating a single unit test for every bundle so that all the bundles show up in sonar
19:34:34 <tbachman> #action tbachman to see if unit test coverage can exclude getters/setters
19:38:33 <tbachman> #info People interested in contributing should put their name on the appropriate trello card
19:41:22 <tbachman> #topic code walk through
19:41:31 <tbachman> #link https://www.youtube.com/watch?v=vACyoKdefRs youtube video created by srini
19:41:55 <tbachman> #undo
19:41:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x272e1d0>
19:42:17 <tbachman> #link https://www.youtube.com/watch?v=vACyoKdefRs YouTube video created by Srini on the plugin part of the OVSDB code
19:44:30 <tbachman> #info The majority of the integration tests are in their own bundle
19:45:29 <tbachman> #info There are two distribution builds — karaf, and the legacy OSGI build
19:50:58 <tbachman> #info the library package uses the OVS schemas (vswitchd and vtep), and contains the code that uses the tables with this schema
19:51:21 <tbachman> #info The northbound package contains the v2 and v3 northbound APIs
19:51:38 <tbachman> #info The  of-extension package has the nicira extensions used by OVS
19:53:40 <tbachman> #info The team is looking into restructuring the code (e.g. move nicira extensions and openstack into separate things)
19:57:24 <tbachman> #info The net-virt-provider contains the OpenFlow pipeline
19:58:17 <tbachman> #info The net-virt package is the insfrastructure under the net-virt-provider package
19:59:05 <tbachman> #info the plugin-mdsal-adapter adds the node to the MD-SAL
20:01:00 <tbachman> #endmeeting