#opendaylight-ovsdb: ovsdb_weekly_call

Meeting started by tbachman at 20:03:44 UTC (full logs).

Meeting summary

  1. Helium SR1 version bumps (tbachman, 20:04:42)
    1. zxiiro has been working on the Helium SR1 patches the version bump patch. (tbachman, 20:05:37)
    2. Helium SR1 patches need to be merged then the version bump patch. (tbachman, 20:05:43)
    3. odlparent has merged their patches (tbachman, 20:06:42)
    4. flaviof asks if something can be merged to stable/helium now, or must that wait until the bumping is merged (tbachman, 20:07:34)
    5. colindixon says its better if you can wait (technically possible, but a lot more messy) (tbachman, 20:08:06)
    6. flaviof asks how projects will know when the dependent projects have merged (tbachman, 20:09:46)
    7. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=213157244 Spreadsheet that zxiiro is using to track these merges (tbachman, 20:10:41)
    8. colindixon says you should consult the spreadsheet to know when your dependent projects have merged. (tbachman, 20:11:07)
    9. flaviof asks what other things have to happen to push the tag (tbachman, 20:11:26)
    10. colindixon says you can do this if you’ve done the merge (tbachman, 20:11:35)
    11. colindixon asks if the versionbump.sh should be moved to releng project? (tbachman, 20:14:25)
    12. zxiiro recommends the future odl-autobuilder project (tbachman, 20:14:35)
    13. ACTION: colindixon to bug gzhao and edwarnicke to get an autorelease project (tbachman, 20:14:49)

  2. Trello Board (tbachman, 20:15:42)
    1. https://trello.com/b/ddIvDQE0/ovs-openstack (shague, 20:16:18)
    2. https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB Trello board (tbachman, 20:16:31)
    3. shague finished the sonar reporting trello card, and flaviof wrote instructions on how to bring up the sonar locally (tbachman, 20:16:57)
    4. http://potofjoy.com/flavioBlog/work/how-to-run-sonar-locally.html flaviof’s link on how to run SONAR locally (tbachman, 20:18:06)
    5. shague got Eclipse to load correctly, and listed the steps in the trello card (tbachman, 20:19:08)
    6. sharad is still working through some issues with importing using eclipse (tbachman, 20:19:49)
    7. Marcus Koontz said that they’re setting up sonar using shague’s instructions, and will provide feedback on the Eclipse instructions (tbachman, 20:20:21)
    8. shague says sometimes Eclipse gets out of sync, especially with the yang pieces (tbachman, 20:20:35)
    9. colindixon says that his experience is that it’s best to build from the CLI and do an update to the project in Eclipse afterwards (tbachman, 20:20:59)
    10. colindixon recommends right-click and refresh and right-click and update maven project (tbachman, 20:21:46)
    11. colindixon says there’s a way to create working sets in eclipse which is helpful here as well (tbachman, 20:22:20)
    12. shague says he creates working sets by default (makes it easier) (tbachman, 20:22:56)
    13. shague is trying to separate all the integration tests out, as it’s tough to identify which bundles have ITs (tbachman, 20:25:35)
    14. Right now unit tests and integration tests are combined in the same bundle, and the ITs that are with UTs are currently not using PAX-EXAM (tbachman, 20:26:10)
    15. flaviof asks if there’s a difference between using PAX-EXAM with karaf and PAX-EXAM using OSGI (tbachman, 20:26:52)
    16. shague says we don’t have any PAX-EXAM using karaf (tbachman, 20:27:03)
    17. flaviof is working bug 2021, but is having a hard time understanding how to come up with a fix that’s amenable to the controller commiters (tbachman, 20:29:50)
    18. https://git.opendaylight.org/gerrit/#/c/12568/ proposed gerrit to fix BUG 2021 (tbachman, 20:30:38)
    19. flaviof said that srini084 also has another gerrit to fix this (tbachman, 20:30:58)
    20. sharad is trying to integrate Juno with Helium, and is hitting bug 2257, and asks if there’s any progress on this (tbachman, 20:33:13)
    21. https://bugs.opendaylight.org/show_bug.cgi?id=2257 BUG that sharad is hitting when using Juno and Helium (tbachman, 20:33:55)
    22. flaviof asks if sharad has tried SR1 (tbachman, 20:34:44)
    23. sharad hasn’t tried yet - he’s downloaded it, but will try it out. (tbachman, 20:35:02)
    24. sharad asks who they should be adding as reviewers (tbachman, 20:36:07)
    25. shague says it should be flaviof and shague for now (tbachman, 20:36:20)

  3. walk through of submitting a patch (tbachman, 20:38:21)
    1. step 1) make sure master is current, by doing a git pull while on the master branch (tbachman, 20:38:49)
    2. step 2) create a local branch: git checkout -b <branch name> (tbachman, 20:39:05)
    3. step 3) make edits (tbachman, 20:39:27)
    4. step 4) do git add to stage all your changes (tbachman, 20:40:28)
    5. step 5) commit changes locally, using signoff (-s) (tbachman, 20:40:42)
    6. Add a message to the commit, provide BUG ID for any commits that are patches for BUGs (tbachman, 20:41:44)
    7. commit message should be 70 characters or less on first line, with BUG ID # if needed (tbachman, 20:42:05)
    8. step 6) git push origin test:refs/for/master (tbachman, 20:43:32)
    9. step 7) go into gerrit, using the URL that’s sent to you in email (tbachman, 20:45:20)
    10. step 8) Add reviewers to your gerrit (tbachman, 20:45:52)
    11. make sure you have gerrit user, etc and that when you cloned repo, you added the hook that insert 'signed-off-by' (flaviof, 20:46:44)
    12. The jenkins verify job is run for every patch (tbachman, 20:46:58)
    13. https://wiki.opendaylight.org/view/GettingStarted:Pulling,_Hacking,_and_Pushing_All_the_Code_from_the_CLI link for cloning/etc (flaviof, 20:47:06)
    14. on link above look for "add the signoff to the commit message on your every commit without the need to specify..." (flaviof, 20:47:41)
    15. if your verify job doesn’t run, contact a committer to retrigger your job (tbachman, 20:48:26)
    16. reviewers can put a -1 on a patch if there’s an issue (tbachman, 20:49:45)
    17. committers can provide the +2 to a patch, contributers can provide a +1 to a patch as a reviewer (tbachman, 20:50:26)
    18. sharad asks whether reviewers should use “no score” or “-1” if there’s something they don’t like (tbachman, 20:52:11)
    19. colindixon says we tend to leave this to individual project, with -1 used to indicate that it shouldn’t be merged, and 0 to indicate that you’d be okay if it merged (tbachman, 20:52:58)
    20. Use git commit —amend to provide changes requested on an existing commit (tbachman, 20:55:38)
    21. colindixon says you can copy the change ID from a gerrit (tbachman, 20:56:04)
    22. colindixon recommends using gitreview (tbachman, 21:00:50)
    23. https://wiki.opendaylight.org/view/Git-review_Workflow Link to how to use git review (tbachman, 21:01:39)
    24. Use git review -d <gerrit #> to get the most recent patch for that gerrit ID (tbachman, 21:02:26)
    25. do git commit -asm “commit message” to commit your changes (tbachman, 21:03:49)
    26. do git review to push the commit (tbachman, 21:05:20)
    27. use git review -D to create a draft (tbachman, 21:05:51)
    28. drafts are only visible to you and any reviewers you add to it (tbachman, 21:06:03)
    29. If you have a patch that you don’t want merge, make the first line of the commit message say “DO NOT MERGE” (tbachman, 21:08:28)
    30. drafts will not trigger a jenkins build. (flaviof, 21:08:50)
    31. colindixon recommends testing behavior, not an implementation (tbachman, 21:12:22)
    32. https://en.wikipedia.org/wiki/Test-driven_development TDD (flaviof, 21:13:06)


Meeting ended at 21:15:53 UTC (full logs).

Action items

  1. colindixon to bug gzhao and edwarnicke to get an autorelease project


Action items, by person

  1. colindixon
    1. colindixon to bug gzhao and edwarnicke to get an autorelease project


People present (lines said)

  1. tbachman (88)
  2. flaviof (12)
  3. odl_meetbot (6)
  4. odp-gerritbot (2)
  5. shague (1)
  6. colindixon (1)


Generated by MeetBot 0.1.4.